Excel change links from absolute to relative path when saving as XLSX after KB2597166


  • Hi,

    I have a problem with an Excel 2010 file, after installing update KB2597166 :

    My file has some reference to other files, located on my network.

    Example : My main file master.xlsx is located at \\FileServer\Share_Name1\master.xlsx

    In this file, I have reference to others file, say for example : \\FileServer\Share_Name2\child.xlsx

    If I save the file (With, or without doing any changes), next time I open my master.xlsx, all references are changed to Share_Name1\child.xlsx instead of staying at \\FileServer\Share_Name2\child.xlsx (Basically, it's changing all absolute path to relative).

    If I uninstall KB2597166, the problem doesn't occur.

    With KB2597166 installed, this bug is not happening if I'm saving my file as XLS. But saving the same file as XLSX change all path.

    Any workaround ? I removed the KB, but it's installed over 100 Computers of my network, and I don't want to uninstall it on all my computers....

    Mittwoch, 16. Mai 2012 11:45


Alle Antworten

  • Microsoft is aware of the serious problems with this update and is investigating it, but there is currently (16-May-2012) no solution yet, except uninstalling the update.

    Regards, Hans Vogelaar

    Mittwoch, 16. Mai 2012 14:12
  • Hi Adrien,

    The workaround solution is to uninstall the patch. This can done Silently (or from SCCM) with the solution given below. I have tested it from cmd prompt and from SCCM, its working. Thanks to Kevin.

    Silent Uninstall
    msiexec /I {90140000-0011-0000-0000-0000000FF1CE} MSIPATCHREMOVE={B76D8C6D-1F13-42A7-9931-D7504CB89D6D} /qn


    scorpITs |

    Donnerstag, 24. Mai 2012 06:25
  • Hi,

    Just checking in to see if the suggestion of ucrajee was helpful. Please let us know if you would like further assistance.

    Jaynet Zhang

    TechNet Community Support

    Freitag, 25. Mai 2012 02:25
  • We are seeing unwanted changes to the hyperlink paths (from absolute to relative) also. I tried uninstalling the KB listed in the OP, but that had no effect on Excel's changes to the hyperlink path. I have checked the XML in the Excel file and have found no reason for this change.

    Has anyone been able to find a reason for the change? I understand that using the formula version of the hyperlink (=HYPERLINK(\\Sharename\directory\ does not have this issue.

    Freitag, 25. Mai 2012 16:23
  • Hi,

    Just checking in.  Was this issue ever resolved?

    Alerts from Forums

    Montag, 18. Juni 2012 22:49
  • Hi,

    Please try the “Silent Uninstall“ in ucrajee’s reply.

    Jaynet Zhang

    TechNet Community Support

    Dienstag, 19. Juni 2012 01:20
  • Another option/workaround is to adjust these settings in Excel and make the document Read Only except for those who are required to make changes to the document this way it doesn't get updated on accident.

    Excel 2010:
    Un-check Update Links To Other Documents->
    Save Changes
    Excel 2003:
    On the Tools menu, click Options ->
    Click the General tab ->
    Click Web options ->
    Click Files tab ->
    Un-check Update Links on Save->
    Save Changes

    Freitag, 18. Januar 2013 17:26
  • Dear Hans,

    I am experiencing this problem now ( a year later). Is there an update available in the meantime that solves the problem?


    Freitag, 14. Juni 2013 12:39
  • Dear Hans,

    I am experiencing this problem now ( a year later). Is there an update available in the meantime that solves the problem?


    Freitag, 14. Juni 2013 12:39
  • Hi Bart,

    Its already mentioned in the Ref. Link i shared in my earlier reply post.

    This issue has been fixed as part of Microsoft's June 2012 Cumulative Update.

    Rajeesh M | My Tech Blog: ScorpITs | LinkedIn Please take a moment to “Mark as Answer” and/or “Vote as Helpful” on the post that helps you. This helps other community members reading the thread and recognises useful contributions. Thanks!

    Freitag, 14. Juni 2013 12:47
  • To stop Excel from changing absolute hyperlinks to relative hyperlinks, in Excel click:

    File, Options, Advanced.  Under the "General" section, click on Web Options.  Click on Files tab.  Uncheck "Update Links on Save".  

    It is a mystery to me why Microsoft feels the need to change your file by default when you close it.

    Montag, 8. August 2016 20:55