locked
IIS WebDAV service required for SharePoint webdav?

    Question

  • Does the IIS WebDAV service need to be enabled (Allowed) in order for WSS V3/MOSS 2007 to provide client access to a team site via WebDAV?

     

    Thursday, May 10, 2007 5:29 PM

Answers

  • Ok, I've finally figured out how to get the MOSS/WSS Explorer View to work correctly in Windows Server 2008!

    Firstly if you installed the WebDav service for IIS7 you'll need to uninstall it from Programs and Features.

    Secondly you'll need to add the "Desktop Experience" feature on Win2008
    To enable this go to the Server Manager
    Click Add Features
    Select the Desktop Experience check box and click next to install this feature

    You will need to restart the server for this feature to be installed.

    Hope this will also help you sort out this error.



    Wesley
    • Edited by Wesley Steele Thursday, October 30, 2008 7:41 AM
    • Proposed as answer by jos_ Tuesday, July 7, 2009 12:30 PM
    • Marked as answer by Mike Walsh FIN Saturday, March 20, 2010 4:52 AM
    • Marked as answer by Mike Walsh FIN Saturday, March 20, 2010 4:52 AM
    Thursday, October 30, 2008 7:41 AM

All replies

  • No

    • Proposed as answer by Bill.Wang Friday, November 28, 2008 1:23 PM
    • Unproposed as answer by Mike Walsh FIN Sunday, December 7, 2008 3:06 PM
    Monday, October 22, 2007 6:32 PM
  •  

    Yes. To access doc lists via widows explorer as a file share you need webdav allowed in IIS.  Otherwise it is similar to FTP/Dir browsing.

     

     

    Tuesday, May 20, 2008 7:20 PM
  • Hiya,

     

    no, WebDAV does not need to be enabled. Microsoft published a White Paper explaining how it works. Allow me to quote from page 22:

    WebDAV, IIS, and SharePoint

    Many people are under the misconception that SharePoint uses the WebDAV functionality provided by IIS 6.0. Actually, SharePoint provides its own WebDAV implementation using the Stsfilt.dll ISAPI filter that is installed with both Windows SharePoint Services and SharePoint Portal Server. Enabling or disabling the WebDAV extension in IIS 6.0 has no effect on SharePoint functionality.

     

    Cheers,

    Christian

    Tuesday, May 20, 2008 8:40 PM
  •  

    Christian,

    You left out the next line...

     

    WebDAV, IIS, and SharePoint

    Many people are under the misconception that SharePoint uses the WebDAV functionality provided by IIS 6.0. Actually, SharePoint provides its own WebDAV implementation using the Stsfilt.dll ISAPI filter that is installed with both Windows SharePoint Services and SharePoint Portal Server. Enabling or disabling the WebDAV extension in IIS 6.0 has no effect on SharePoint functionality.

    You only need to enable WebDAV on IIS if you want to use the Web Sharing feature.

    Correct.  Sharepoint does not requied webdav at all, however if you want to use advance features of widnows explorer with sharepoint you need webdav enabled.

     

    You can try yourself.  

    •  With webdav disabled,   Select a Document library with documents and open it in explorer view. called  FPRPC in the white paper.
    •  Now enabled webdav (may need to reset IIS) and open the same library again and you will notice the left explorer sidebar has additional functionallity (Webdav). 
    • Also the site address will may change in win explorer.  Without webdav it may be similiar to http://yoursite and with it enabled it wil be mapped as a file share \\Yoursite
    • There is a client service called (webclient) that needs to be running on client machines (not the iis server) to use webdav. It is on by default on xp and off in win2003/win2008 (don't know about vista).   If some users work and others don;t this may be the issue.

     

    Note that this is windows explorer view and not sharepoint explorer view available on some doc lib types.

     

     

    On Win2003 the webdav is enable at the IIS level and is turned on for all server applications.

     

    ---------------  Update/Wrong - Do Not Do This !! ------------------------

    On Win2008 you will need to download and install the webdav http://www.iis.net/downloads/default.aspx?tabid=34&g=6&i=1621 librarys and enabled in the "webdav authoring rules" for each application in IIS. 

    Again,

    Not required in SPS/MOSS but available if required by your users or if you have processes where you want to treat a library like a standard file share for loads and extracts. (We ftp download files from a supplier and xcopy them to a doc library like it is a file share)

     

     

    If is off by default due to security conisderations.  My network guys do not like it and exposing it on the intranet is a bad  idea.  Turn on only if you need it and you have a secure environment.  

     

    ------------------------------------------------------------

    UPDATE:

    If the WebDav http://www.iis.net/downloads/default.aspx?tabid=34&g=6&i=1621 librarys  is installed on Win2008 x64  it will break Sharepoint / MOSS Explorer view and cause security prompts on XP and possiably Vista clients.   This will occur even if Win2008 webdav is not enabled for the for the Moss Web Application.  Do not install if you want to use WSS 3.0 explorer view.  

     

     

    With much chagrin Christian, I stand corrected.  

     

    On the flip side if you wish to diable Sharepoint/Moss WebDav, install it...

     

     

     

    Hope this helps..

     

    Bruce

     

     

     

    • Proposed as answer by NaveenNair Wednesday, October 20, 2010 7:31 PM
    Wednesday, May 21, 2008 1:47 PM
  • Hi,

     

    I also have a litte problem with MOSS 2007 SP1 on Windows Server 2008.

    From WindowsXP-Client the Explorer View is working fine (after I applied the BasicAuthLevel-Registry-Hotfix [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters] BasicAuthLevel->2 )

     

    But from Vista the Explorer View is not working at all:

     - if I select 'Document-Library / Action / Open with Windows Explorer' simply nothing happens

     - if I make Explorer View to default view (or open WebFldr.aspx), in iframe it show me the known "Internet Explorer cannot display the webpage"

     - if I try to add a new network location within Windows Explorer and enter the url (I also tried about 20 permutations) it tells me 'The folder you entered does not appear to be valid. Please choose another.'

     - if I try to map a network drive it get system error 67 or 53, depending on which permutation of the path I tried

     

    As I mentioned, with XP it works fine!

    Therefore I suspect it could be a Vista-Bug.

     

    I also want to mention that what MOSS 2007 SP1 was running on Windows Server 2003 R2 that problem with Explorer View and Vista didn't exist.

     

    Has anyone got this problem too? Does anyone has a solution or workaround?

    Thanks in advance.

     

    Peter

    Friday, June 6, 2008 5:16 PM
  •  

    mmmm...

    I do not have Vista but you can experience the same problem in xp if the WebClient service is not turned on. You probably have already checked but (on second thought) if vista explores fine with SPS on Win2003  and but not with Win2008 then that is probably not it. 

     

    I did stumble across this that applies to configuring the web client on win2008,  The settings should also apply to Vista.   

    http://blogs.msdn.com/robert_mcmurray/archive/2008/01/17/webdav-redirector-registry-settings.aspx

     

     

    Sorry I could not be much help

     

     

     

    Monday, June 9, 2008 12:55 PM
  • Let's say I want to disable WebDav for all on SharePoint. How can I do that. Can I do that on individual appliation or that's a farm feature. Thanks.

     

     

    Wednesday, July 2, 2008 6:12 PM
  •  

    You can't disable WebDAV on the server itself, it's a client side request. You can disable the service on the server, should already be so by default anyway, but it won't make any difference to what you are trying to to.

     

    When a client accesses SharePoint in Explorer View, it'll try the WebClient (WebDAV) service first of all, if that's not running and you have Office 2003 or above installed on the client then it'll use WebFldr's (Codename: Rosebud) which will generate the view for you.

     

    The benefit of the WebClient service is that you can connect to SharePoint sites via UNC paths and have third party utils who are not DAV aware utilise this feature.

     

    Have a read of this doco for some enlightened views;

    http://www.microsoft.com/downloads/details.aspx?familyid=C523AC7A-5724-48BE-B973-641E805588F4&displaylang=en

     

    Cheers,

    Thursday, July 10, 2008 9:12 PM
  • So did anyone decide if there is a way to fix this problem with MOSSS on Win2008?  We can't get it to work on a new portal we're setting up and we use Vista/IE 7/Office 2007.  I have read literally hundreds of posts and do not see how to make Explorer View work other than installing the Web Folders Update on my machine and mapping a network drive to the library.  Then it works for me in that library only... but who has time to map this for every user to every library on their portal? 

    On a side note we also have the infamous issues with log in prompts and errors opening, editing, and trying Explorer View on our current SP2003 portal but don't even get me started on how many fixes I have tried for that!

    Looking for any tips out there for those who unfortunately switched to Vista...

    Patrice
    Tuesday, October 7, 2008 6:58 PM
  • Ok, I've finally figured out how to get the MOSS/WSS Explorer View to work correctly in Windows Server 2008!

    Firstly if you installed the WebDav service for IIS7 you'll need to uninstall it from Programs and Features.

    Secondly you'll need to add the "Desktop Experience" feature on Win2008
    To enable this go to the Server Manager
    Click Add Features
    Select the Desktop Experience check box and click next to install this feature

    You will need to restart the server for this feature to be installed.

    Hope this will also help you sort out this error.



    Wesley
    • Edited by Wesley Steele Thursday, October 30, 2008 7:41 AM
    • Proposed as answer by jos_ Tuesday, July 7, 2009 12:30 PM
    • Marked as answer by Mike Walsh FIN Saturday, March 20, 2010 4:52 AM
    • Marked as answer by Mike Walsh FIN Saturday, March 20, 2010 4:52 AM
    Thursday, October 30, 2008 7:41 AM
  • Bruce, 
     
    I don't think that the WebSharing feature has anything to do with WebDAV and SharePoint. It is an NT 4 feature which lets you access filing system shared folders through an HTTP url. This almost the oposite of WebDAV which makes virtual HTTP folders (EG SharePoint document libraries) appear as file system shared folders.

    Enabling IIS WebDAV certainly doesn't make the SharePoint Explorer View any richer.

    Simon Jones
    MillStream Designs Limited
    Sunday, December 7, 2008 2:57 PM
  • >> If the WebDav http://www.iis.net/downloads/default.aspx?tabid=34&g=6&i=1621 librarys  is installed on Win2008 x64  it will 
    >> break Sharepoint / MOSS Explorer view and cause security prompts on XP and possiably Vista clients.   This will occur even if >> Win2008 webdav is not enabled for the for the Moss Web Application.  Do not install if you want to use WSS 3.0 explorer view.  
    Bruce,

    i have installed WebDav on Win2008 x64 with WSS 3.0. What can I do to make WSS Explorer View working again.

    Thank You,

    Oliver
    Tuesday, December 30, 2008 6:16 AM
  •  KB907306 fixed the issue on our machines.
    (client side hotfix -- running Vista with Office 2007)
    Wednesday, February 11, 2009 3:47 PM
  • Thank you very much for this TIP

    I could not get my integration with Office to Work until i uninstall the WEBDav on my Windows 2008 R2 x64 BIT server

    After installation everything work perfect

    Friday, March 19, 2010 10:40 PM
  • Kudos... I unistalled WebDav only and that actually resolved the problem. I didnt have to install Desktop Experience on the server to make the Folder View work.. just the removal of WebDav from Web Server IIS. Thanks.
    Jawad
    Wednesday, May 12, 2010 3:01 PM
  • We do not have WebDav installed on our Windows 2008 server running MOSS 2007 but still could not use Open with Exploror. We were finally able to resolve the issue by changing IE settings.

    Tools/Internet Options/Security/Local Intranet/Custom Level/Binary and Script behaviors set to enable.  This resolved the issue on XP and Windows 7 machines.

    Friday, June 11, 2010 2:16 PM
  • Thanks to all the posts in this thread!

    Thursday, July 8, 2010 6:07 AM