none
OCS and Outlook Intergration - Presence Unknown RRS feed

  • Question

  • Hello All,

    I am hoping you can shed some light on an issue with are having with interaction between our OCS client and Microsoft Outlook 2007 running on both Windows XP and Windows 7.

    When we hover over a username on an email, the odd one will show as presence unknown. This does not occur on our sharepoint site (presence works as expected). After a couple of weeks searching the internet, I have tried the following:

    I have installed the new update at:

    http://support.microsoft.com/kb/978564

     

     

    Office Communicator Presence does not display in Office Outlook or SharePoint

    ISSUE:   Office Communicator presence is not displayed in Office Outlook or Office SharePoint.
    RESOLUTION:   Set the following registry keys to make Communicator the default application for Presence within Office applications.
    "REG_DWORD HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\PersonaMenu\RTCApplication=3"
    "REG_DWORD HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\PersonaMenu\RTCApplication=3"

    Stale Presence in Office Outlook

    ISSUE:   When a user signs out of Office Communicator, contacts in the Communicator Contact List could show presence information that is out-of-date.
    RESOLUTION:   Restart Office Communicator or restart Office Outlook.

    No Presence in Office Outlook

    ISSUE:   When a user signs out of Office Communicator, contacts in the Communicator Contact List could show presence information that is out-of-date.
    RESOLUTION:   If a user shuts down Office Communicator and navigates between e-mails within Outlook while Communicator is shutting down, Outlook may disconnect from Communicator and show no presence, even if Communicator is restarted.

    Presence Unknown for certain contacts in Office Outlook

    ISSUE:   If a user’s e-mail address, as entered into an Outlook e-mail, cannot be resolved to a SIP address in the Outlook Address Book or through Office Communicator, then presence cannot be retrieved for that user.
    RESOLUTION:   Set the SetOnlineStatusLevel registry key to allow Outlook to make a call to Microsoft Exchange to help resolve the SIP address for users. Setting this key can help particularly when the user’s Exchange address (x400/X500) is in the e-mail.
    "HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Outlook\IM] "SetOnlineStatusLevel"=dword:00000003"

    The issue is still there. Any ideas?

    Thanks in advance,

    Paul Sanders

    Saturday, April 17, 2010 8:13 AM

All replies

  • I was wondering if any one can explain the below registry key and why it would work?

    [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\PersonaMenu]
    "QueryServiceForStatus"=dword:00000003

    After looking on the Microsoft website, there should only be 3 options available, 0, 1 and 2. However I accidently added 3 and now the presence works. My only worry is this is a debug mode that may be causing other issues with other applications?

    Thanks

    Saturday, April 17, 2010 8:14 AM
  • Hi
    Sure the "QueryServiceForStatus" have three vlaue to configured, there is no 3 according to the DOC, and have you try set it as "2".
    There is a looked same issue as yours, you could refer to below:
    http://social.technet.microsoft.com/Forums/en-US/ocspresenceim/thread/d527e0ec-bf30-447d-a9ef-efc0e74962aa
    So you'd better change it to "2".

    Regards!
    gavin
     
    Tuesday, April 20, 2010 10:27 AM
    Moderator
  • Hi Gavin,

    When we change it to 2, the OCS 'Blob' stops working, and reverts back to Presence Unknown. As soon as I revert back to 3, all is working ok.

    Has any one else had sucess with setting this value to 2? If so, please can you let me know exactly what keys were changed. Our reg fix has been tested on around 30 machines and all are working as expected without any other issues.

    Thanks

    Paul

    Thursday, April 22, 2010 12:29 PM
  • Hi Paul,

    Sure it is an odd issue, thanks for your confirm, and I will do more research about it, then I will gave you some information.

    Regards!
    gavin
    Friday, April 23, 2010 2:32 AM
    Moderator
  • Thanks Gavin. If you need any trace logs or testing, please let me know.

    Regards,

    Paul

    Friday, April 23, 2010 10:59 AM
  • Hi Gavin,

    Have you had any luck with finding out what this registry key does?

    Thanks,

    Paul

    Friday, April 30, 2010 10:09 AM
  • Hi Paul,

    I have sent an email to the escalation  team, and I will give you the information i get.


    Best regards!
    gavin

    Tuesday, May 4, 2010 1:25 AM
    Moderator
  • Hi Paul,

    Kinkdly suggest that you open a ticket from MS. It sounds an odd issue.
    Maybe would need retrieve more log to analyze the issue.

    Regards!
    gavin
    Wednesday, May 5, 2010 7:28 AM
    Moderator