none
SharePoint problem with permission RRS feed

  • Question

  • I'm currently working on migration WSS 3.0 to SharePoint 2013.
    On WSS 3.0 I use the list to record important documents.
    On the WSS 3.0 users who have read right, they see only the lists that they have read right.
    When I do this on SharePoint 2013, all users see all the lists.
    The list must include:
    Title - pressing the text opens this list.
    It must be able to insert more attachments.

    How to do it? I want to some users see only the documents they have read permission.
    Tuesday, September 26, 2017 7:41 PM

Answers

  • Hi,

    It is a by design feature of SharePoint, you need to break the inheritance of the list and add those users to whom you want to show the list. If I understood your question you want to set the unique permission on list where only some users can have read access.

    1. Go to the list and open it.
    2. Go to the Permissions page using the steps in the section above.
    3. To break permissions inheritance from the parent, click Stop Inheriting Permissions. Top of Page.
    4. After breaking the parent permission you need to remove the domain group and all groups/users from here and then grant only the users read access to whom you want to show this list.

    https://social.technet.microsoft.com/wiki/contents/articles/18203.sharepoint-2013-break-document-library-permissions-inheritance.aspx


    KRISHANA KUMAR

    SharePoint Architect

    Mosstechnet-kk.com

     

    Please click "Mark As Answer" if this post solves your problem or "Vote As Helpful" if it was useful

    • Marked as answer by Maty M Friday, September 29, 2017 10:36 AM
    Tuesday, September 26, 2017 7:48 PM

All replies

  • Hi,

    It is a by design feature of SharePoint, you need to break the inheritance of the list and add those users to whom you want to show the list. If I understood your question you want to set the unique permission on list where only some users can have read access.

    1. Go to the list and open it.
    2. Go to the Permissions page using the steps in the section above.
    3. To break permissions inheritance from the parent, click Stop Inheriting Permissions. Top of Page.
    4. After breaking the parent permission you need to remove the domain group and all groups/users from here and then grant only the users read access to whom you want to show this list.

    https://social.technet.microsoft.com/wiki/contents/articles/18203.sharepoint-2013-break-document-library-permissions-inheritance.aspx


    KRISHANA KUMAR

    SharePoint Architect

    Mosstechnet-kk.com

     

    Please click "Mark As Answer" if this post solves your problem or "Vote As Helpful" if it was useful

    • Marked as answer by Maty M Friday, September 29, 2017 10:36 AM
    Tuesday, September 26, 2017 7:48 PM
  • Hi Maty, 

    To make some users see only the lists they have read permission, make sure the user have no permission on the list and activate Limited-access user permission lockdown mode feature:

    Navigate to site settings->site collection features->activate Limited-access user permission lockdown mode feature:

    Best Regards, 

    Lisa Chen


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, September 27, 2017 10:26 AM
    Moderator
  • Also, if this is a migration, how are you actually doing this?  The specifics of permission inheritance may be manageable via a tool that you're using?

    Steven Andrews
    SharePoint Business Analyst: LiveNation Entertainment
    Blog: baron72.wordpress.com
    Twitter: Follow @backpackerd00d
    My Wiki Articles: CodePlex Corner Series
    Please remember to mark your question as "answered" if this solves (or helps) your problem.

    Wednesday, September 27, 2017 10:34 AM
    Answerer
  • I do migration manual, without any tool.
    Thursday, September 28, 2017 10:40 AM
  • Hi Maty, 

    Have you tried the method I offered?

    Navigate to site settings->site collection features->activate Limited-access user permission lockdown mode feature:

    Best Regards, 

    Lisa Chen


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, September 29, 2017 10:16 AM
    Moderator
  • Hi Maty, 

    Have you tried the method I offered?

    Navigate to site settings->site collection features->activate Limited-access user permission lockdown mode feature:

    Best Regards, 

    Lisa Chen


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Thank you for your solution, but I didn't try, because first answer work for me.
    Friday, September 29, 2017 10:36 AM