none
MS Word open document readonly with WEBDAV

    Question

  • Hi,

    I'm testing a custom webdav-module which is working fine on some clients and some others not. I hope someone can help me figure out why.

    The situation:
    I notice difference in behaviour when a client opens the document trough the url in IE. The document is opened read-only after opening a document trough the browser. Open the same url using Word and the document is editable.
    This is not the case for all clients, but some of them.

    Futher details:
    - The WEBDAV-module is hosted on a stand-alone server (W2K8R2 with IIS7.5), eventually it will be but in a domain. Maybe this could make a difference?
    - Also the WEBDAV-module is hosted in the root-website on port 82, with a binding on port 80 (put in the DNS which is used by the clients). I read somewhere webdav should be hosted in the root using port 80, but now I placed it under 82 in combination with the binding. No difference in behaviour noticed here, so I guess this is not causing any harm?
    - The url to the document is added to the trusted locations in Office Word and also added in IE to the trusted locations.
    - Anonymous access to the website, the WEBDAV-module handles the authentication and returns the WEBDAV-verbs necessary for editing.
    - No difference detected in behaviour when the document is openend using http://server:82/mydocument.docx or http://dnsalias:80/mydocument.docx
    - The url to the word-document ends with doc or docx as extension and the returned content-type is application/msword (is determined by the documentmanagement system which is used by the module.
    - The clients used for testing are in a similar domain, these are Windows 7 machines with Office 2010.

    Any advice, hints and tips are most welcome. Thanks in advance.

    Chris

    Monday, April 2, 2012 10:08 AM

Answers

  • Hi,

    Please follow these steps test if it helps:

    1. Click Start, click Run, type regedit in the Start search box, and then click OK.
    2. Locate and then right-click the following registry subkey:

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet

    3. Point to New, and then click DWORD Value.
    4. Type OpenDocumentsReadWriteWhileBrowsing, and then press ENTER.
    5. Right-click OpenDocumentsReadWriteWhileBrowsing, and then click Modify.
    6. In the Value data box, type 1, and then click OK.
    7. On the File menu, click Exit to quit Registry Editor.

    If the problem still persists, please try to open document in common shared folder, if it works, the problem is more WEBDAV or IE related, it recommend to post a new thread to there for further discussion.

    Best regards.


    William Zhou

    TechNet Community Support

    Monday, April 9, 2012 1:41 AM