locked
The Managed Metadata Service or Connection is currently not available. The Application Pool or Managed Metadata Web Service may not have been started. Please Contact your Administrator. RRS feed

  • Question

  • When I tried to access the managed metadata service  from -> central administration-> managed service application -> my metadata service I get the following error:-

    The Managed Metadata Service or Connection is currently not available. The Application Pool or Managed Metadata Web Service may not have been started. Please Contact your Administrator.
    Now I check all the application pools and all of them are running, and have their security as integrated , with the admin username and password.

    I also check the permission for the managed meta data , central administration-> Manage service applications->select the metadata service->permission-> I gave the administrator a full permission.

    So I cannot figure out where is the problem ? the metadata was working well , but this problem happens after I restarted the SharePoint 2013 server?

    Thanks


     
    Wednesday, June 4, 2014 11:16 AM

Answers

  • Just check your ULS logs and see you had the below lines in it or something similar to it.

    Failed to get term store for proxy ‘Managed Metadata Service Application Proxy’. Exception: System.Security.SecurityException: Requested registry access is not allowed

    If so its due to lack of permission in registry key for WSS_WPG and WSS_ADMIN_WPG. You have to provide an access for it and reboot your server which is running with it.

    Likewise executing below PS command will do the work for you.

    Initialize-SPResourceSecurity

    Likewise its worth to have a glimpse of permission for your application pool account in MMS service application is set with Read access to Term store. By the way did you installed any CU/Patches in recent time, I have noted this missing permission behavior after that for couple of times.

    /Veeramani.S

    PS : Kindly mark this as an answer if it fix your issue.


    Veeramani.S

    • Marked as answer by JasonGuo Monday, June 16, 2014 6:14 AM
    Friday, June 6, 2014 7:05 AM

All replies