SharePoint Logs Showing Unexpected Error Related to CMS/Cached Values?


  • I just took a peek at my SharePoint logs and noticed a very large number of entries similar to the following:

    08/30/2011 08:23:11.47  w3wp.exe (0x276C)                        0x1BF0 CMS                            Publishing                     0 Unexpected Cached Value found.  Value is False 
    08/30/2011 08:23:11.47  w3wp.exe (0x276C)                        0x1BF0 CMS                            Publishing                     0 Unexpected XXX / is a descendent of / - False)

    By the looks of it I see one of these for each site/subsite in the site collection, as well as individual pages, but I am unsure of what process would be going through the entire site like this.  While we have the Publishing Infrastructure site collection feature enabled (in order to make use of the enhanced navigation options), we do not use any other publishing-related features and do not have the site-level Publishing feature enabled.  The last update of any significance to the site was the June CU which I installed on 7/29.  Considering the number and type of changes in that updated, could this be related to that?

    I do not recall having seen these errors before, and after searching I have not found any related information online or here in the forums.  My logs go back to 8/26 and the errors appear to go back that far as well, so I am not sure exactly when they first occurred.  There are no related entries in the Event Log.  We are using MOSS 2007 SP2.

    Thanks in advance!

    Tuesday, August 30, 2011 1:13 PM

All replies

  • Hi Chanda,


    Did you find more other error info like “The security validation for this page is invalid. ...” ?

    If yes, it is a known issue mostly caused by June 2011 CU, it should be fixed in Aug 2011 CU(released).

    You can patch it and check again.


    Regards, Daniel
    Thursday, September 01, 2011 8:24 AM
  • I have exactly the same issue.  It definitely came in after the June 2011 CU for me.  Until July we were running SP1, then I put in SP2 and the latest CU together; so I can't be sure it was the CU specifically.  We're sometimes getting over 3Gb log file sizes (in half an hour) full of these entries, although obviously it depends on site usage.   Ours is a full publishing site, with CMS and approval, extended into the Internet zone for a public (anonymous) site.

    The August CU has not fixed this.  I have raised it with Microsoft, but the suggestion so far has been to disable logging for the "Publishing" category as that's what has been suggested in other similar cases (for example "While initializing navigation, found Page placeholder but object was not found at: /xxx/xxx/xxx.aspx"; which is a problem we also have but which has always been there!). 

    I'll post an update if I get back anything more useful!


    Monday, September 12, 2011 1:29 PM
  • We have the exact same issue. During the weekend we upgraded our SharePoint servers from SP2 to the Aug 2011 CU. Before this upgrade we did not have this error in our logs. We are seeing the same log entries, only sometimes it also says True instead of False:

    09/19/2011 10:15:02.23  w3wp.exe (0x09E8)  0x125C CMS    Publishing      0 Unexpected XXX /../Pages/...aspx is a descendent of /Pages/...aspx - True) 
    09/19/2011 10:15:02.23  w3wp.exe (0x09E8)  0x125C CMS    Publishing      0 Unexpected Cached Value found.  Value is True 

    When our search crawler was started up again after the upgrade it started flooding the log and I had to set the Diagnostic logging to None for Publishing to avoid that.

    But bottomline is that this issue is not solved by the Aug 2011 CU.
    I'll raise this with Microsoft aswell.

    Regards, Jesper

    Monday, September 19, 2011 8:40 AM
  • Ok, I got an answer back from Microsoft Support and it goes like this:

    "As discussed earlier today, This issue is a bug. A bug request is filed for this to the product group and we are waiting for an outcome. This may however take some time. In the meantime the workaround is to go into the Diagnostic Logging section and set the option to NONE for the Publishing category. I have also checked around to see if there are other way to work around this but there does not seem to be any for the moment."

    The hope was that this bug would be solved with the October 2011 CU, but no guarantees where given.


    Tuesday, September 20, 2011 11:56 AM
  • The bug reference number is 52078 in case this helps with tracking!



    Friday, September 23, 2011 9:12 AM
  • Did this ever get resolved?  I still see the issue on one of my clients installations running SP2007 SP3



    Friday, January 27, 2012 2:25 PM
  • I am also seeing this issue on a 2007 SP3 box as well...hoping someone has a fix for this?
    Thursday, March 01, 2012 3:23 PM
  • Same here... SharePoint 2007 SP3 with Feb 2012 CU updates installed version and I am still seeing this error? does anyone have any idea what causes it?
    Monday, March 19, 2012 2:42 PM
  • yeap me too with 2007 SP3 Box with same issues.

    Thursday, August 02, 2012 6:25 AM