none
Exchange 2013 sending winmail.dat RRS feed

  • Question

  • Greetings all,

    I've got a new Exchange 2013 setup and external internet users have been reporting that attachments they receive from internal users are showing only as winmail.dat (why does this problem still exist?!?)

    In Exchange 2010 I had a transport rule that sent *everything* to the internet as plain-text to stop this happening, but I can't seem to find any info on how to do this in Exchange 2013. There's no obvious options in the ECP, so I'm guessing it's a powershell command?


    Friday, February 22, 2013 11:30 AM

Answers

  • Set-RemoteDomain -Identity <Name of Domain> -TNEFEnabled $false

    Details here:

    http://support.microsoft.com/kb/2487954?wa=wsignin1.0


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Saturday, February 23, 2013 12:01 AM
  • (Sorry, busy weekend)

    That powershell was the way to do it. I had found the article about Set-RemoteDomain but with many other options, but it wasn't as clear to which one of those options was the same as "send as plain text". I assume settings like this will be added to the ECP over time.

    For the record, I just set it for all external email. I might take some time to tweak to work out just the right format that works, but for the time being plain text is better than winmail.dat

    Set-RemoteDomain -Identity * -TNEFEnabled $false

    Monday, February 25, 2013 8:03 AM

All replies

  • Set-RemoteDomain -Identity <Name of Domain> -TNEFEnabled $false

    Details here:

    http://support.microsoft.com/kb/2487954?wa=wsignin1.0


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Saturday, February 23, 2013 12:01 AM
  • Hi Scott,

    Any updates?

    If you have any feedback on our support, please click here


    Frank Wang
    TechNet Community Support

    Monday, February 25, 2013 7:47 AM
  • (Sorry, busy weekend)

    That powershell was the way to do it. I had found the article about Set-RemoteDomain but with many other options, but it wasn't as clear to which one of those options was the same as "send as plain text". I assume settings like this will be added to the ECP over time.

    For the record, I just set it for all external email. I might take some time to tweak to work out just the right format that works, but for the time being plain text is better than winmail.dat

    Set-RemoteDomain -Identity * -TNEFEnabled $false

    Monday, February 25, 2013 8:03 AM
  • We too have experienced same issue, Server 2012 running exchange 2013. I have been working with Microsoft support and they had me run this command "Set-RemoteDomain -Identity * -TNEFEnabled $false" which is referenced above. I can confirm this did resolve my issue with the winmail.dat sending with attachments. However, once this was enabled we were having delivery failure notifications and having large number of emails (going to external users) that would get stuck in the submission que. The error on them would be "A Storage Transient Failure Has Occurred during content Conversion". Once again I started working with Microsoft and received a different support person. He had me run the following command "Set-RemoteDomain -Identity * -TNEFEnabled $true", and after that had me restart the transport services. Immediately I thought to myself, darn, I don't know which issue I would rather have. It is consistent in our environment that enabling or disabling the TNEF has side effects which impact our end users greatly. I am again putting in a support request with Microsoft, I just thought I would share my experience with running (or seeing) this command ran.
    Monday, March 18, 2013 2:09 PM
  • I have had the same issue.

     

    lots of failed messages in the mail queue and I had to set Set-RemoteDomain -Identity * -TNEFEnabled $true to resolve this problem.

     

    however once the issue is resolved some internet recipients receive winmail.dat files  this can be resolved with

    Set-RemoteDomain -Identity * -TNEFEnabled $false

    but then back to messages stuck in queue.

    I will update is CU1 fixes issue with having TNEF set to false.

    Tuesday, April 23, 2013 10:35 AM
  • Solved the issue,

    Default Frontend Connector was main cause of issue.

    Disabled the connector 

    created new Frontend connector.

    Disabled Exchange anti Spam

    Only enabled 3rd party Anti Spam Software.

    No errors, or issues since i did this 3 weeks ago.!

    If you have queries please contact me.


    Monday, July 15, 2013 9:34 AM
  • Hi,

    I have the same problem on Windows 2012/Exchange 2013 for a customer, I just want to confirm with you the working solution, is that:

    Set-RemoteDomain -Identity * -TNEFEnabled $false??

    Default Frontend Connector, how do you recreate it??

    Thanks

    Yann

    Friday, February 14, 2014 3:21 AM
  • Hi,

    I have the same problem on Windows 2012/Exchange 2013 for a customer, I just want to confirm with you the working solution, is that:

    Set-RemoteDomain -Identity * -TNEFEnabled $false??

    Default Frontend Connector, how do you recreate it??

    Thanks

    Yann

    im having the exact same issues... server 2012 with exchange 2013 how the hell can this be fixed!?
    Friday, June 13, 2014 2:14 PM
  • Have you tried the powershell command mentioned in the answer,or in my follow up post?


    Friday, June 13, 2014 2:24 PM
  • Have you tried the powershell command mentioned in the answer,or in my follow up post?



    I dont want people to send plain text because they will complain about it and maybe the logo in signature wont even be visible... So is there a way to set it to send html!? Also if i understad it right disabling tnef will disable the ability to send/recieve meeting request!? Wtf :/ Maybe theres another way...
    Friday, June 13, 2014 2:38 PM
  • We too have experienced same issue, Server 2012 running exchange 2013. I have been working with Microsoft support and they had me run this command "Set-RemoteDomain -Identity * -TNEFEnabled $false" which is referenced above. I can confirm this did resolve my issue with the winmail.dat sending with attachments. However, once this was enabled we were having delivery failure notifications and having large number of emails (going to external users) that would get stuck in the submission que. The error on them would be "A Storage Transient Failure Has Occurred during content Conversion". Once again I started working with Microsoft and received a different support person. He had me run the following command "Set-RemoteDomain -Identity * -TNEFEnabled $true", and after that had me restart the transport services. Immediately I thought to myself, darn, I don't know which issue I would rather have. It is consistent in our environment that enabling or disabling the TNEF has side effects which impact our end users greatly. I am again putting in a support request with Microsoft, I just thought I would share my experience with running (or seeing) this command ran.

    Hello Jacop,

    Have you found any solution? I have exactly same problem.

    Kind regards.


    Monday, April 4, 2016 11:29 AM
  • Hello All,

    I'm just here for an update. Anybody resolve this without creating the delivery issues?  Or, at least fix both?

    Thanks!


    Tuesday, January 31, 2017 9:18 PM