none
Active sync issue

    Question

  • Hello

    We have 2 Exchange 2013 CU7 servers.

    Sometime I get an error message on phones that says it cannot log in.

    I can see from event log that

    [Eas] The number of outstanding requests for guard TargetBackend("exch01.top.domain.no") has exceeded the max limit 150. Current request will be rejected.

    Anyone know what limit its refering to? And should it be set higher?

    Regards

    Friday, January 02, 2015 1:16 PM

All replies

  • Hi , don't know for sure ,  but i guess you can find it somewhere in the throttling policy. 

    You might wanna have look into that one : From Exchange Powershell : Get-Throttling-Policy

    And see if there is something with a maximum of 150 which you can refer to EAS.

    Friday, January 02, 2015 2:02 PM
  • You can check the following things

    Please check for any errors logged in RPC logs for the same in all the cas servers

    Also look for any additional events triggered for activesync in APP log
    Possibly set the event log level to expert for activesync and look for any errors
    get-eventloglevel “MSExchange ActiveSync\Requests” | set-eventloglevel -level 5

    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.That will encourage me - and others - to take time out to help you Check out my latest blog posts on http://exchangequery.com Thanks Sathish (MVP)

    Friday, January 02, 2015 2:04 PM
  • Hi Kristinansen,

    I agree with Wint.

    Please verify whether this caused by Throttling Policy. I find some related parameters for your reference:

    1. EasMaxConcurrency : It specifies how many concurrent connections an Exchange ActiveSync user can have against a server running Exchange 2013 at one time.

    2. EasMaxDevices : It specifies a limit to the number of Exchange ActiveSync partnerships that a user can have at one time.

    More details to see: http://technet.microsoft.com/en-us/library/dd351045(v=exchg.150).aspx

    If it is the Throttling Policy issue, please run following command example to re-set the limit.

    Set-ThrottlingPolicy <ThrottlingPolicyName> -EasMaxConcurrency 300

    More details to see: http://technet.microsoft.com/en-us/library/dd298094(v=exchg.150).aspx

     

    Thanks


    Mavis Huang
    TechNet Community Support


    Tuesday, January 06, 2015 8:17 AM
    Moderator
  • Hi Mavis,

    I have the same Problem (new Exchange 2013 Installation CU7). The value at the DefaultThrottlingPolicy and GlobalThrottlingPolicyis as follows: EASMaxConcurrency: 10 / EASMaxDevices: 100 I found nowhere a default value of 150. Where does the value 150? Under EASMaxConcurrency the value is 10, not 150. What do you recommend?

    Thanks for your Support.

    Marco

    Tuesday, January 06, 2015 1:24 PM
  • This is the same for mee, EASMaxConcurrency is 10 on both throttlig policys, the number 150 I cant find anywhere.
    Friday, January 09, 2015 3:46 PM
  • Getting the same. Also an Exchange 2013 CU7 Environment.

    Same Default Throttling for Concurrent Devices and Devices. 10 and 100.

    Doing a Get-ThrottlingPolicy | fl No mention of 150.


    James Hogg BSc, MCP, MCTS, A&amp;amp;#43;, MBCS


    • Edited by -Hoggle- Thursday, January 15, 2015 3:40 PM
    Thursday, January 15, 2015 3:38 PM
  • I'm seeing the same on a CU7 environment. The load did not increase and users do not report actual issues.

    Did my post help? Please use "Vote As Helpful", "Mark as answer" or "Propose as answer". Thank you!

    Monday, February 02, 2015 8:21 AM
  • We are also seeing the same issue. CU7, no reference in ThrottlingPolicy to 150. 

    I am seeing this error on the Microsoft Web Application Proxy

    The HTTP response from the backend server was not received within the expected interval. Expected interval: 300 seconds.

    Details:
    Transaction ID: {f4be1653-43e9-0000-02d0-bef4e943d001}
    Session ID: {f4be1653-43e9-0000-02d0-bef4e943d001}
    Published Application Name: Exchange Microsoft-Server-ActiveSync
    Published Application ID: 9ad23d25-1d98-7a66-3671-6cd7aabcab29
    Published Application External URL: https://mailserver.address.com/Microsoft-Server-ActiveSync/
    Published Backend URL: https://mailserver.address.com/Microsoft-Server-ActiveSync/
    User: <Unknown>
    User-Agent: Apple-iPhone5C2/1104.257
    Device ID: <Not Applicable>
    Token State: NotFound
    Cookie State: NotFound
    Client Request URL: https://mailserver.address.com/Microsoft-Server-ActiveSync?User=user@address.com&DeviceId=ApplF2LL1VVXDTWF&DeviceType=iPhone&Cmd=Ping
    Backend Request URL: https://mailserver.address.com/Microsoft-Server-ActiveSync?User=user@address.com&DeviceId=ApplF2LL1VVXDTWF&DeviceType=iPhone&Cmd=Ping
    Preauthentication Flow: PassThrough
    Backend Server Authentication Mode: PassThrough
    State Machine State: BEBodyWriting
    Response Code to Client: <Not Applicable>
    Response Message to Client: <Not Applicable>
    Client Certificate Issuer: <Not Found>

    have anyone fixed this?

    Thanks Edd

    Monday, February 09, 2015 11:23 AM
  • We had this exact same problem, and after a supportcase with Microsoft, we got a solution that worked for us:

    On all CAS servers:

    In \Exchange Server\V15\FrontEnd\HttpProxy\sync\web.config, add this key in the <appSettings> node.

        <add key="HttpProxy.ConcurrencyGuards.TargetBackendLimit" value="5000" />

    In \Exchange Server\V15\FrontEnd\HttpProxy\rpc\web.config, add this key in the <appSettings> node.

        <add key="HttpProxy.ConcurrencyGuards.TargetBackendLimit" value="5000" />

    After this change recycle the MSExchangeSyncAppPool and MSExchangeRPCProxyAppPool in IIS manager.

    After this, we stopped getting Event ID 2002, and all Connection_Dropped_Event_List_Full stopped appearing in Httperror logs.

    This was a "new find", and the technician that had worked this out was going to inform the developers. He recommended a minimum of 2000 (default: 150), but in our case he instructed 5000. (for 25000 users)

    Hopefully this will work for more people.

    • Proposed as answer by kjetilnor Friday, February 20, 2015 1:23 AM
    Friday, February 20, 2015 1:23 AM
  • It Works! Thank you for your helpful contribution. Best regards Marco
    Tuesday, February 24, 2015 2:49 PM
  • Thank you Kjetilnor,

    I just updated to CU7 this past weekend and your post has cleared up my error logs. I do appreciate you sharing the fix before it filtered its way through the Microsoft channels. 

    John

    Thursday, March 12, 2015 5:38 AM
  • Just an FYI,

    This issue is also present in CU8.

    Thursday, June 18, 2015 3:21 PM
  • Confirmed that this issue still exists in CU9.
    Friday, July 24, 2015 1:34 AM
  • Does anyone know if there are associated perfmon counters that can be monitored that correspond to these settings?

        <add key="HttpProxy.ConcurrencyGuards.TargetBackendLimit" value="5000" />

        <add key="HttpProxy.ConcurrencyGuards.TargetBackendLimit" value="5000" />

    Thanks!!  Tom

    Monday, August 10, 2015 9:36 PM
  • ... and also confirmed in CU10.
    Monday, November 09, 2015 10:17 AM
  • Two questions...

    1. Does anyone know if the regedit fix is just for Exchange on Windows Server 2012?  The registry path mentioned doesn't exist on our Windows 2008 R2 server, but we are seeing the same MSExchange Front End HTTP Proxy Event ID 2002 warning.  (We upgraded from Exchange 2013 CU5 to CU9 recently.) 
    2. Why is the existing limit being exceeded?  Is that something that should be investigated before increasing?

    Thanks in advance

    Thursday, December 03, 2015 6:46 PM
  • 1) It's not a registy setting. it's a setting in the web.config files of those proxying protocols on each Exchange server.

    2) More connections are being proxied than the current limit.

    Note that I've create a script allowing you to perform these changes locally or remotely, see:
    http://eightwone.com/2015/12/22/http-proxy-targetbackend-limits/


    Michel de Rooij | Exchange Server MVP
    B:http://eightwone.com | T:twitter.com/mderooij
    This posting is provided 'AS IS' with no warranties.


    Tuesday, December 22, 2015 5:43 PM
  • This is still an issue with CU12. Updating from CU11 even overwrited the fixed values and re-created the problem.

    Friday, June 17, 2016 8:48 AM
  • problem still exists  in CU 13  (come on MS)

    after 2or 3 years this Problem suddenly popped up.

    The Suggested changes to the web.conf fixed the Problem.

    thanks kjetilnor<abbr class="affil"></abbr>

    regards

    Stefan

    Tuesday, October 25, 2016 8:13 AM
  • UPDATE:

    It seem's that in our Case it was not the fault of the Exchange 2013. The Problem returned yesterday.

    There where only around 450 Connections on TMG (wich is used as reverse Proxy) nothing special there.

    But looking at the Client Access Server IIS Manager -> click on Servername -> Worker Process -> doubleclick MSExchangeSyncAppPool - > expand the Url column -> there you can see the Username

    i saw that one Samsung phone had opend just around 4500 Connections.

    I disabled  Active Sync for that User and blocked the Device, AND Recycled MSExchangeSyncAppPool IIS Application Pool  on Client Access and Mailbox Server.

    After that Active Sync was working normal again.

    regards

    Stefan


    • Edited by steven_85 Friday, October 28, 2016 6:35 AM
    Friday, October 28, 2016 6:34 AM
  • Just upgraded to CU15 and this issue still exists!
    Monday, February 13, 2017 9:13 AM
  • Same here ungraded to CU15  and the issue still exists ?!

    On multi_roles and also separated MBXs and CASs environment.

    tried the above resolution and the server went down the server components went inactive?!

    What's wrong MS?!

    Wednesday, March 08, 2017 7:21 PM