SharePoint Designer 2007 on Windows 7; cannot open or edit .aspx pages


  • Hello all...I'm running SharePoint Designer 2007 on Windows 7 (also have Office 2010 and SharePoint Designer 2010 installed); I cannot open or edit .aspx pages.  If I open the client and navigate to the site/list, then try to open the .aspx page by double-clicking, it simply does nothing.  If I use the toolbar and click file/open and navigate to the page, it opens the list but not the page.  Oddly, when I right click on .aspx pages in Designer, it doesn't give any choice to open or edit (see below). 

    It is NOT a permissions issue; I am a site collection admin, and I can get on a server (Windows Server 2003) that has designer and open these pages with no trouble (Designer runs horribly slow on the server so it's not a viable alternative).  Anyone seen this issue before?  The only other relevant piece of information is that I was having issues with SharePoint 2007 after installing office 2010 and reinstalling designer 2007, so I made the registry change described here:

    paul truland

    Friday, March 09, 2012 2:44 PM

All replies

  • This might be a silly question, but have you run Office Diagnostics?
    Friday, March 09, 2012 6:38 PM
  • I did run diagnostics, and I tried repairing the program; neither helped. 

    paul truland

    Friday, March 09, 2012 6:49 PM
  • Hi paul,

    I tried to reproduce your issue, but the SharePoint .aspx page can be opened and edited from SharePoint Designer 2007 installed on my Windows 7 client (I intalled Office 2010 too).

    You need to check and make sure you access SharePoint site in your SharePoint Designer using user account with web designer permission (e.g. you used site collection admin) from Windows 7 Manage your Credentials, and uninstall and re-install the SharePoint Desinger 2007 on your Windows 7 client, then check result again.  You can also check whether it is related to 32-bit or 64-bit versions of SharePoint Desinger 2007.


    Daniel Yang

    TechNet Community Support

    Tuesday, March 13, 2012 10:10 AM
  • Thanks Daniel...I'll try the re-install.  Regarding managed credentials, it's been disabled by our system admin.  Is that going to be problematic?

    paul truland

    Tuesday, March 13, 2012 1:31 PM
  • Re-install didn't fix...neither did service pack 3. 

    paul truland

    Tuesday, March 13, 2012 2:52 PM