none
Send to mail recipient not working in Outlook 2010

    Question

  • Hi, I have just noticed that when I right click on a file to send to mail
    recipient nothing happens. I am running Windows 7 x64 and would like someone to
    help me fix this please?
    Microsoft Outlook is set as default mail client

    Thanks
    Friday, May 28, 2010 10:00 AM

Answers

  • Hi,

    This issue may be caused by the default mail client is not set.

    To work around this issue, try the steps as follow to set outlook 2010 as default mail client:

  • Click Start.
  • Type "default programs" in the Start Search box.
  • Click Default Programs under Programs in the search results.
  • Now click Set your default programs.
  • Highlight Microsoft Office Outlook or Microsoft Outlook on the left.
  • Click Set this program as default.
  • Click OK.
Monday, May 31, 2010 5:27 AM
Moderator

All replies

  • Hi,

    This issue may be caused by the default mail client is not set.

    To work around this issue, try the steps as follow to set outlook 2010 as default mail client:

  • Click Start.
  • Type "default programs" in the Start Search box.
  • Click Default Programs under Programs in the search results.
  • Now click Set your default programs.
  • Highlight Microsoft Office Outlook or Microsoft Outlook on the left.
  • Click Set this program as default.
  • Click OK.
Monday, May 31, 2010 5:27 AM
Moderator
  • I am just setting up a new install of win7 and office 2010 and the send to "mail recipient" is also not working right.  Outlook did need to be set as default for email to get other things working but it still doesn't fix this send to issue.  A work around I discovered is that once a mailto weblink is clicked, a new email window comes up and then right clicking on a file to send to email does work until the next reboot.  Is this an issue with office 2010?  How can I make the function stick?

    edit: I have resolved the issue by uninstalling and reinstalling office

    • Proposed as answer by cuffhill Thursday, April 11, 2013 5:20 AM
    Friday, August 20, 2010 12:42 PM
  • I have Windows XP with Office 2010 and facing the same issue. If I right click the files and send to mail recipient, nothing happens. And if I try to use the file menu from Excel/Word/Powerpoint to send as email, I recieve error message.

    Error on Excel - "General mail failure. Quit Microsoft Excel, restart the mail system, and try again"

    Error on Word - "Word could'nt send mail because of MAPI failure" "Operation not Supported"."

    Show help on this Word error - "

    This error can occur if you attempt to send a Word document as an e-mail attachment in Word and the MAPI session was closed and Word is no longer able to connect to that MAPI session. It can also occur if there is a problem with the fax configuration.

    To correct a MAPI related error: restart the MAPI e-mail program (for example,Outlook) or save and close the document, and then restart Word after restarting your MAPI e-mail application. Word will establish a new MAPI session, allowing the document to be sent.

    To correct a problem with the fax configuration, review the configuration settings for your fax software and make the appropriate changes."

     

    Error on Powerpoint - An error occurred while sending the presentation

     

    Background:

     

    1. Initially I upgraded from Office 2007 to Office 2010 ( I had uninstalled MS Project 2003 as upgrade was no happening without removing this)

    2. Started getting above errors and have tried uninstall and a fresh installation

     

    Please help, I am not able to get a solution anywhere.

    Thanks,
    Anwer

    Thursday, November 25, 2010 5:04 AM
  • I just noticed an you stated "Outlook not set as default may be the issue" although the person above clearly states "Outlook is set as default"
    Tuesday, March 29, 2011 11:42 PM
  • I have the same issue. I am using office 2010 and some users can not send from excel or work as attachement. If they use outlook and attach the file it works fine. By the way OUTLOOK IS THE DEFUALT CLIENT so that is not the solutions.
    Thursday, June 02, 2011 7:23 PM
  • I was having the same problem with a client.

    Outlook 2010 was set as the default client and all attempts at sending emails resulted in Outlook opening except for Send To > Mail Recipient.

    To resolve the problem I ran fixmapi. To run fixmapi:

    • go to Start
    • Click on Run
    • type fixmapi
    • Click OK
    • Wait a few moments, then attempt to use Send To > Mail Recipient again.
    Tuesday, June 14, 2011 5:19 AM
  • I have the identical problem: Windows 7 Professional SP1 64-bit, Outlook 2010 from Office Home and Business, Version 14.0.6023.1000 (32-bit) on a brand new machine (delivered one week ago). Send to mail recipient does not work from the Windows Explorer window (nothing happens) or from within Adobe Reader X (clicking the "attach" button launches Windows Explorer).

    Outlook is set as the default email handler from within Outlook and from the Control Panel default programs window. There is a profile for the user in the Control Panel / User Accounts area, which refers properly to Outlook.

    The one possibly unusual factor is that the user has four email accounts, two POP3 and two IMAP. One of the POP3 accounts is clearly set as the default. However, as I said, nothing happens when the Send To Email Recipient function is invoked.

    I have tried FIXMAPI as the previous poster suggests, with no effect.

    Any further suggestions?

    Friday, August 05, 2011 8:54 PM
  • Same problem here Outlook is the default mail client I have used the a/m mailto trick didn't work I have used the fiximapi didn't work as well appreciate to find a solution here soon Best regards to everyone
    • Proposed as answer by marvels362 Tuesday, January 17, 2012 4:36 PM
    • Unproposed as answer by marvels362 Tuesday, January 17, 2012 4:36 PM
    Tuesday, November 22, 2011 1:26 PM
  • Hey everyone,

    I just was combing the internet trying to find a solution.  I tried the FIXMAPI and set as default as described above with no luck.  What worked for me:

    1) go to control panel

    2) go to programs and features

    3) right click on Microsoft Office Professional 2010 and choose change

    4) a new window for Microsoft Office Professional 2010 will come up 

    5) choose "Repair" (add or remove features is selected by default)

    6) click "continue" and follow the dialogs through 

    Upon completion I had to reboot my machine.  After rebooting, I went into windows explorer to right click on a file and clicked send to -> mail recipient and it worked the way it is supposed to.

    I hope this helps as I was also getting pretty frustrated.  

    You would think "Microsoft" windows 7 and "Microsoft" Office 2010 would work together and if they didn't, you would think that "Microsoft" would have fixed the problem by now...

    • Proposed as answer by baughan Thursday, January 26, 2012 1:48 PM
    Tuesday, January 17, 2012 4:43 PM
  • I tried all what is proposed here. No luck. I cannot slide pictures to the email either. If I attached pictures using insert, I cannot resize the pictures either. Upgrade to Outlook 2010 does not seem to be a great idea.

    Any more suggestions ?

     

    Friday, January 27, 2012 7:51 PM
  • My case is similar: Windows XP SP3. Upgraded from Office 2007 to 2010. Default Mail Client is Outlook.

    "Sent To Mail Recipient" works for Office Documents, but not for images or videos. No issue attaching them from within Outlook. When I select a file in an Explorer Window and select the option nothing noticable happens.

    Thursday, March 22, 2012 1:25 PM
  • YES this WORKED to me too, thanks
    Wednesday, April 18, 2012 12:49 PM
  • Nope - nothing there my friend. Any other ideas? 64bit Windows 7 and Office 2010 - been at it all day
    Monday, June 18, 2012 4:20 PM
  • Sorry this did not work for me either. I am using brank new 64 bit PC with newly purchased Office 2010 Home and Business all on 64bit. Some investment. After a whole irritating day, I think this is something that Microsoft did not think about. At least I get the mapi error report in Word. I get no report trying to mail on Excel files. 
    Monday, June 18, 2012 4:37 PM
  • Hi, I have just noticed that when I right click on a file to send to mail
    recipient nothing happens. I am running Windows 7 x64 and would like someone to
    help me fix this please?
    Microsoft Outlook is set as default mail client

    Thanks

    I have tried almost everything. I reinstalled Office 2010. I also used FIXMAPI, or change/repair but no success.

    I am tired of Outlook 2010 now. It doesn't work for mail merge, send to email recipient and the best thing is

    whenever I launch outlook 2010, user account setting pops up. Help me with this crap please.


    Anuj

    Saturday, June 30, 2012 7:36 AM
  • If you type outlook.exe in the start search field of windows explorer, what happens?



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Monday, July 02, 2012 2:27 AM
  • Its opens Outlook directly.

    Also I get user account control pop up, and every time I open outlook I have to click yes.


    Anuj

    Monday, July 02, 2012 5:28 AM
  • It looks like the problem is with the shortcut and with your UAC settings. Is Outlook.exe configured to run as administrator?



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Monday, July 02, 2012 2:15 PM
  • I am running MS office trail version 64bit on my win7 64x system. Other Ms office programs runs smoothly and UAC doesn't shows up. Issue is only with Outlook. How do I know if its configured to run as administrator?


    Anuj

    Tuesday, July 03, 2012 4:28 AM
  • Guys Finally I got the answer for this..

    Please trail below:-

    To stop getting the prompt again while we open Outlook, follow the following steps:

    Method1:

    Run Outlook as an Administrator:

    1>     Go to My Computer\Local Disk C\Program Files\Microsoft Office\Office 12\Outlook.exe

    2>     Right Click on Outlook.exe and click on Run as Administrator

    (If you are using a 64 bit OS, look in to My Computer\Local Disk C\Program files(X86)\Microsoft Office\Office 12\Outlook.exe)

    3>     Once Outlook opens, try to close it and open it again. This should resolve the problem.

    In case if Method 1 does not resolve the issue, check if Outlook is in “compatibility mode”.

    Method 2:

    Check if Outlook is in a compatibility mode:

                     1>     Open My Computer>Local Disk C>Program Files>Microsoft Office>Office 12>Outlook.exe.

                     2>     Right click on Outlook.exe and click on Properties and then click on Compatibility tab. Check if you have any check mark in any of the compatibility mode options. Make sure you also click on the option "change settings for all users" tab at the bottom of the same screen and look for similar check boxes in the window.

                    3>     If you see any check boxes in the compatibility mode options, uncheck all the boxes and click on Apply and OK.

                    4>    
    Try to close outlook and open outlook again to confirm if the prompt still pops up.


    Anuj

    • Proposed as answer by Anujjoc Tuesday, July 03, 2012 4:42 AM
    Tuesday, July 03, 2012 4:42 AM
  • That's brilliant - I hope the many other people who have had this problem find this.

    Followed all as in above post (except Office14)

    Worked like a dream.

    For me it was a case of right click on pic - send to - mail recipient - chose size - then woooosh all disappeared into the ether. Lost track of how many times I checked default email was outlook.......

    Anyway a million thanks Anujjoc.

    Tuesday, July 03, 2012 9:02 AM
  • You are welcome!!

    Anuj

    Friday, July 06, 2012 5:15 AM
  • Thanks a lot Anujjoc, it was amazing. I was waiting for a solution since last few months.

    Regards,

    KritiRani

    Friday, July 06, 2012 5:18 AM
  • This is awesome, thanks!
    Monday, July 16, 2012 3:48 PM
  • Guys Finally I got the answer for this..

    Please trail below:-

    To stop getting the prompt again while we open Outlook, follow the following steps:

    Method1:

    Run Outlook as an Administrator:

    1>     Go to My Computer\Local Disk C\Program Files\Microsoft Office\Office 12\Outlook.exe

    2>     Right Click on Outlook.exe and click on Run as Administrator

    (If you are using a 64 bit OS, look in to My Computer\Local Disk C\Program files(X86)\Microsoft Office\Office 12\Outlook.exe)

    3>     Once Outlook opens, try to close it and open it again. This should resolve the problem.

    In case if Method 1 does not resolve the issue, check if Outlook is in “compatibility mode”.

    Method 2:

    Check if Outlook is in a compatibility mode:

                     1>     Open My Computer>Local Disk C>Program Files>Microsoft Office>Office 12>Outlook.exe.

                     2>     Right click on Outlook.exe and click on Properties and then click on Compatibility tab. Check if you have any check mark in any of the compatibility mode options. Make sure you also click on the option "change settings for all users" tab at the bottom of the same screen and look for similar check boxes in the window.

                    3>     If you see any check boxes in the compatibility mode options, uncheck all the boxes and click on Apply and OK.

                    4>    
    Try to close outlook and open outlook again to confirm if the prompt still pops up.


    Anuj

    An easier/faster solution is to:

    • Click Start, type the following and press Enter:

                      C:\Users\Default\AppData\Roaming\Microsoft\Windows\SendTo

    • Right-click the Mail Recipient icon and choose Copy (Keyboard: CTRL+C)
    • Click Start, type the following and press Enter:

                      shell:sendto

    • Right-click an empty area in the folder, and choose Paste (CTRL+V)

    • Proposed as answer by mikie_m Wednesday, August 22, 2012 5:02 PM
    Wednesday, August 22, 2012 5:02 PM
  • I've tried everything on this page and still doesn't work for me :(
    Thursday, September 20, 2012 2:33 PM
  • I have also tried everything on this page until I used the suggestion of Mikie_M and Hey Presto it works

    Running Win7 and Office 2010

    Strange thing was that it was working fine and then for some inexplicable reason 'Send to mail Recipient' stopped being available.

    I can only assume that it somehow got corrupted.

    It now works fine complete with functionality of choosing picture size.

    Many thanks

    Why don't Microsoft suggest this as the solution or one to check out?

    • Proposed as answer by Preymantas1 Friday, November 02, 2012 12:05 AM
    Monday, October 22, 2012 12:14 PM
  • Hi, I have just noticed that when I right click on a file to send to mail
    recipient nothing happens. I am running Windows 7 x64 and would like someone to
    help me fix this please?
    Microsoft Outlook is set as default mail client

    Thanks

    FIXED and oh so simple!

    I too was having this issue on my win7 x64 with Office 2010 startup UAC annoyance and the Send To Mail issues. What I found was that I was experiencing exactly the same issues as everyone else here, why?

    After going through several threads which included replacing registry entries with someone elses custom entries which is nuts, I started looking at the proprties of ALL the other Office 2010 shortcuts & .exe's which all worked as expected to see commonalities and what was different about Outlook before getting into remove/reinstall and registry hacking.

    All other Office proggies opened without the UAC annoyance and NONE of them had RUN AS ADMINISTRATOR set in thier properties, either the shorcuts or the .exe's themselves! What? I thought. Everyone is saying to set that... That was the only difference I could find in all of the Office shortcut properties. So I changed Outlook.exe's in the (x86) programs folder properties to NOT RUN AS ADMINISTRATOR and Vwa-La! It worked without the UAC and the Send To Mail Recipient is working once again!

    Why Outlook was the only Office 2010 program to have run as administror for all used enabled is a mystery, but removing that fixed it here! Try it!

    • Proposed as answer by Preymantas1 Friday, November 02, 2012 12:20 AM
    Friday, November 02, 2012 12:19 AM
  • this final worked for me.  Shell:sendto and paste the mail receipient icon.
    Thursday, December 13, 2012 6:34 AM
  • I tried everything on every possible forum.   This worked for me

    1. Click Start, and then click Run.
    2. In the Open box, type regedit, and then press ENTER.
    3. In Registry Editor, locate the following subkey in the registry:

    HKEY_LOCAL_MACHINE\Software\Clients\Mail\Microsoft Outlook

    1. Select the subkey, and then press DELETE.
    2. Click Yes.
    3. Quit Registry Editor.
    4. Start Outlook.
    5. For Outlook 2000 and Outlook 2002, click the Help menu, and then click Detect and Repair .
      For Outlook 2007, click the 
      Help menu, and then click Office Diagnostics . 
      For Office 2010, Click
       Start, click Control Panel, click Programs and Features, select Microsoft Office 2010 and then click the Change button. Next, click Repair, and then click Continue.
    6. Follow the instructions on the screen to complete the repair.
    Thursday, August 01, 2013 6:47 AM
    1. Click Start, and then click Run.
    2. In the Open box, type regedit, and then press ENTER.
    3. In Registry Editor, locate the following subkey in the registry:

    HKEY_LOCAL_MACHINE\Software\Clients\Mail\Microsoft Outlook

    1. Select the subkey, and then press DELETE.
    2. Click Yes.
    3. Quit Registry Editor.
    4. Start Outlook.
    5. For Outlook 2000 and Outlook 2002, click the Help menu, and then click Detect and Repair .
      For Outlook 2007, click the 
      Help menu, and then click Office Diagnostics . 
      For Office 2010, Click
       Start, click Control Panel, click Programs and Features, select Microsoft Office 2010 and then click the Change button. Next, click Repair, and then click Continue.
    6. Follow the instructions on the screen to complete the repair.
    Thursday, August 01, 2013 6:49 AM
  • THANK YOU!!!!  This solved my problem with Windows 8.  You're my hero.
    Saturday, August 24, 2013 10:10 PM