none
Cannot install "SMB 1.0/CIFS File Sharing Support" role on server 2019 data center. RRS feed

  • Question

  • Hi Guys

    I have a server 2019 data center on azure and I cannot seem to be able to install the SMB 1.0 to be able to connect to my on-prem AD.

    I have downloaded the 2019 data center image and mounted it on this server and further added the source path for installing the role. And it didnt fix the issue.

    I further tried to install it using Powershell wiht below commands:

    Get-WindowsOptionalFeature -Online -FeatureName "SMB1Protocol"

    FeatureName      : SMB1Protocol
    DisplayName      : SMB 1.0/CIFS File Sharing Support
    Description      : Support for the SMB 1.0/CIFS file sharing protocol, and the Computer Browser protocol.
    RestartRequired  : Possible
    State            : DisabledWithPayloadRemoved
    CustomProperties :
                       ServerComponent\Description : Support for the SMB 1.0/CIFS file sharing protocol, and the Computer Browser protocol.
                       ServerComponent\DisplayName : SMB 1.0/CIFS File Sharing Support
                       ServerComponent\Id : 487
                       ServerComponent\Type : Feature
                       ServerComponent\UniqueName : FS-SMB1
                       ServerComponent\Deploys\Update\Name : SMB1Protocol

    When I try to enable it I get the following error that says source file could not be found.

     C:\Users\myserver> Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol -source e:\sources\install.wim:4
    Enable-WindowsOptionalFeature : The source files could not be found.
    Use the "Source" option to specify the location of the files that are required to restore the feature. For more information on specifying
    a source location, see http://go.microsoft.com/fwlink/?LinkId=243077.
    At line:1 char:1
    + Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol -sour ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Enable-WindowsOptionalFeature], COMException
        + FullyQualifiedErrorId : Microsoft.Dism.Commands.EnableWindowsOptionalFeatureCommand

    I also tried installing it and that didnt work either.

     C:\Users\myserver> install-windowsfeature SMB1Protocol -Source wim:E:\sources\install.wim:4
    install-windowsfeature : ArgumentNotValid: The role, role service, or feature name is not valid: 'SMB1Protocol'. The name was not found.
    At line:1 char:1
    + install-windowsfeature SMB1Protocol -Source wim:E:\sources\install.wi ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidArgument: (SMB1Protocol:String) [Install-WindowsFeature], Exception
        + FullyQualifiedErrorId : NameDoesNotExist,Microsoft.Windows.ServerManager.Commands.AddWindowsFeatureCommand

    Success Restart Needed Exit Code      Feature Result
    ------- -------------- ---------      --------------
    False   No             InvalidArgs    {}

    I am really stuck.. I would appericiate if someone could guide me.

    Monday, July 29, 2019 4:16 AM

Answers

  • I ended up fixing the issue by using the following command: 

    Install-WindowsFeature FS-SMB1 -Source wim:e:\sources\install.wim:4

    e:\ being the mounted drive that contain a copy of windows image.

    ensure that you run the wim command to find out what index you should use.

    In my case I  had to use 4 since the version of windows that I have was datacenter with Desktop environment.

    I believe my problem was the fact that I was using the wrong name "smb1protocol" instead of "FS-SMB1"

    if you are reading this thread but you are trying to install a different service run a the below in powershell to get the correct service name:

    Get-WindowsFeature

    NOTE: It takes some time for it to execute

    IMPORTANT NOTE: the service names are case sensitive!

    • Marked as answer by MRWayne_09 Tuesday, July 30, 2019 3:56 AM
    Tuesday, July 30, 2019 3:54 AM

All replies

  • Hi Armin,

    Can you try using dism to install the feature? Also, can you point to /sources/sxs in your source path?

    Refer below links which may help you.

    https://social.technet.microsoft.com/Forums/en-US/4cd766d0-1089-40ca-8d97-a07d3c121fd7/installwindowsfeature-failing-to-find-source?forum=ws2016

    https://powershell.org/2014/01/using-install-windowsfeature-with-offline-source/

    - Umesh.S.K

    Monday, July 29, 2019 5:20 AM
  • Thanks for replying Umesh S K

    yes, I have tried both methods that you have posted.

    and in either case I get 

    enable-windowsoptionalfeature : The source files could not be found.
    Use the "Source" option to specify the location of the files that are required to restore the feature. For more
    information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077.
    At line:1 char:1
    + enable-windowsoptionalfeature -online –featurename smb1protocol -sour ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Enable-WindowsOptionalFeature], COMException
        + FullyQualifiedErrorId : Microsoft.Dism.Commands.EnableWindowsOptionalFeatureCommand

    I have tried 

    enable-windowsoptionalfeature -online -featurename smb1protocol -source wim:e:\sources\install.wim:4

    enable-windowsoptionalfeature -online -featurename smb1protocol -source e:\sources\install.wim:4

    notice that :4 is for the version that iam using which is 2019 data center

    One other thing that I noticed is that when i run  get-windowsfeature I get 

    [ ] SMB 1.0/CIFS File Sharing Support                   FS-SMB1                          Removed
        [ ] SMB 1.0/CIFS Client                             FS-SMB1-CLIENT                   Removed
        [ ] SMB 1.0/CIFS Server                             FS-SMB1-SERVER                   Removed

    as shown in my original question, when I query windows feature it says that the state  is 

    State            : DisabledWithPayloadRemoved

    • Edited by MRWayne_09 Monday, July 29, 2019 6:14 AM
    Monday, July 29, 2019 6:10 AM
  • I ended up fixing the issue by using the following command: 

    Install-WindowsFeature FS-SMB1 -Source wim:e:\sources\install.wim:4

    e:\ being the mounted drive that contain a copy of windows image.

    ensure that you run the wim command to find out what index you should use.

    In my case I  had to use 4 since the version of windows that I have was datacenter with Desktop environment.

    I believe my problem was the fact that I was using the wrong name "smb1protocol" instead of "FS-SMB1"

    if you are reading this thread but you are trying to install a different service run a the below in powershell to get the correct service name:

    Get-WindowsFeature

    NOTE: It takes some time for it to execute

    IMPORTANT NOTE: the service names are case sensitive!

    • Marked as answer by MRWayne_09 Tuesday, July 30, 2019 3:56 AM
    Tuesday, July 30, 2019 3:54 AM
  • Hi ,

    Good to hear that you have solved this issue by yourself. In addition, thanks for sharing your solution in the forum as it would be helpful to anyone who encounters similar issues.

    If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Tuesday, July 30, 2019 6:17 AM
  • I found I did not need to use a mounted windows image. I am at an administrative powershell session on a Win2019 server and was able to run:

    install-windowsfeature FS-SMB1

    It installed, and asked for a restart. I restarted, then ran

    get-smbserverconfiguration

    In the stdout, I see "EnableSMB1Protocol" is now set to True.
    Thursday, September 26, 2019 6:16 PM