locked
Remove Web Application Proxy from ADFS 3.0 RRS feed

  • Question

  • We have two Web Application Proxies deployed with ADFS 3.0, however we'd like to remove one. We uninstalled the role from the server, however on the other Web Application Proxy it still shows the uninstalled server under Clustered Servers on the Remote Management mmc. How can I get this completely removed from ADFS?
    Wednesday, April 9, 2014 12:32 PM

Answers

  • Hi,

    you have to overwrite the connected servers list there is a powershell command with example on this link ConnectedServersName

    Best Regards,

    Steve


    • Edited by thasteve Monday, April 14, 2014 1:21 PM
    • Marked as answer by jviggiano2042 Thursday, April 17, 2014 4:45 PM
    Monday, April 14, 2014 1:19 PM

All replies

  • Hi,

    According to your description, are these two web application proxy servers clustered?

    By “on the other Web Application Proxy it still shows the uninstalled server under Clustered Servers”, do you mean that the uninstalled proxy server still shows as a node of cluster?

    If that’s the case, then it is normal, because uninstalling web application proxy role doesn’t remove its role as a node of cluster.

    More information for you:

    How to Evict a Node from a Windows Server 2008 Failover Cluster

    http://technet.microsoft.com/en-us/library/bb676524(v=EXCHG.80).aspx

    Best Regards,

    Amy Wang
    • Edited by Amy Wang_ Friday, April 11, 2014 7:13 AM
    Friday, April 11, 2014 7:11 AM
  • It's a Web Application Proxy, it doesn't use MSCS. Basically we've registered two servers with ADFS as a Web Application Proxy. We decommissioned one of them, yet it still shows as being active in the Remote Access console of the new Web Application Proxy server.
    Friday, April 11, 2014 3:00 PM
  • Hi,

    you have to overwrite the connected servers list there is a powershell command with example on this link ConnectedServersName

    Best Regards,

    Steve


    • Edited by thasteve Monday, April 14, 2014 1:21 PM
    • Marked as answer by jviggiano2042 Thursday, April 17, 2014 4:45 PM
    Monday, April 14, 2014 1:19 PM
  • That worked for me.

    Thank you so much Steve!

    BAHADURI

    Tuesday, July 22, 2014 8:51 AM
  • Thanks, worked for me.
    Wednesday, April 6, 2016 5:30 PM
  • I think this command is to add a WAP.  I'm trying to remove a WAP. I have upgraded my ADFS environment to 2016 both ADFS and WAP. I removed all 2012 from the environment but I have the name of the 2012 WAP in the RAMGui as a non-operational node. I've already decommissioned the server.

    Will this make any difference in the operation of 2016 WAP?  If not, then leaving it alone will work as well.

    Stan


    Stanley E. Noel Jr

    Monday, November 20, 2017 12:20 PM
  • Hi,

    here is simple power shell script to remove WAP proxy from Console and from ADFS.

    to check the list of the servers 

    Get-WebApplicationProxyConfiguration

    to remove  one server

    Set-WebApplicationProxyConfiguration –ConnectedServersName ((gwpc).ConnectedServersName -ne ‘servername’)

    Friday, January 5, 2018 8:47 AM
  • Appears, in a load balanced configuration not MSCS, the older units must be upgraded using the '-UpgradeConfigurationVersion' switch.

    PS C:\Windows\system32> Set-WebApplicationProxyConfiguration -ConnectedServersName ((gwpc).connectedserversname -ne 'old-server-name.domain')
    Set-WebApplicationProxyConfiguration : You cannot change the existing Web Application Proxy configuration from a server running a new version if there are servers running an older version on the cluster. Make your configuration changes from a Web Application Proxy server that is running the older version. After all Web Application Proxy servers are running the new version, upgrade the configuration by running the ‘Set-WebApplicationProxyConfiguration’ with the ‘-UpgradeConfigurationVersion’ switch.
    At line:1 char:1
    + Set-WebApplicationProxyConfiguration -ConnectedServersName ((gwpc).co ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (WmiPSProvider:root/Microsoft/...xyConfiguration) [Set-WebApplicationProxyConfiguration], CimException
        + FullyQualifiedErrorId : WIN32 5904,Set-WebApplicationProxyConfiguration


    Stan Noel


    Tuesday, February 20, 2018 2:31 PM
  • I replaced my old 2012 R2 WAP servers with 2016 servers. The 2012 R2 servers are gone, and now I can't remove them from the Cluster configuration because according to the error I'm getting (same as joCo Sys Admin), I'm supposed to run the "Set-WebApplicationProxyConfiguration" command from the 2012 servers, but they don't exist anymore, so how can I get rid of them from one of my 2016 servers?
    Saturday, May 12, 2018 5:31 AM
  • update proxy configuration by running below command

    Set-WebApplicationProxyConfiguration -UpgradeConfigurationVersion

    and run Set-WebApplicationProxyConfiguration -ConnectedServersName < WAP Server 1,  WAP Server 2>

    check http://www.mrchiyo.com/migrating-mixed-mode-ad-fs-full-windows-server-2016-ad-fs-farm/

    Wednesday, July 4, 2018 1:47 PM