locked
Problem exporting Exchange 2007 certificate - Certificate not listed in "Personal" folder RRS feed

  • Question

  • We bought a new SSL for our Exchange 2007 server from Godaddy. They walked be through installed the certificate and everything is working fine. Now I need to export that certificate so that I can import it on our other Exchange 2007 server.

    I'm following a process that's almost exact to this:

    http://www.entrust.net/knowledge-base/technote.cfm?tn=6004

    Now, when I go to Certificates and I expand the folder named "Personal", there is nothing listed in that folder. Godaddy support stated that on their end they can see that the certificate is installed properly. They could not tell me why the certificate is not being listed in the Personal folder.

    Any ideas?

    Monday, June 18, 2012 4:03 PM

Answers

  • and that's the problem I have been pointing out. You MUST select Local Computer. Your user account does NOT have the certificate. Those 3 choices all have different certificate stores. Once you select local computer you will see the certificate and can export. Do the same for the import. Select local computer and import.

    Chris Morgan

    Thursday, June 28, 2012 1:54 PM

All replies

  • Hello,

    Please verify whether you select “Automatically select the certificate store based on the type of certificate”. If so, the issue may happen. Please choose “Place all certificate in the following store” and check the result.

    Best Regards,

    Lisa

    Tuesday, June 19, 2012 6:05 AM
    Moderator
  • Hello,

    Please verify whether you select “Automatically select the certificate store based on the type of certificate”. If so, the issue may happen. Please choose “Place all certificate in the following store” and check the result.

    Best Regards,

    Lisa

    Where do I go to verify that?
    Wednesday, June 20, 2012 3:57 PM
  • If things are working fine. Does that mean you installed the cert on the new server and can't see it or can't see it on the old server?

    Make sure you open an MMC first.

    Add/Remove snapin

    Add certificates

    Select local computer

    Then ok twice (I think...doing this off the top of my head)

    then check to see if the cert shows up. That is also the location you want use when importing.


    Chris Morgan

    Friday, June 22, 2012 9:07 PM
  • If things are working fine. Does that mean you installed the cert on the new server and can't see it or can't see it on the old server?

    Make sure you open an MMC first.

    Add/Remove snapin

    Add certificates

    Select local computer

    Then ok twice (I think...doing this off the top of my head)

    then check to see if the cert shows up. That is also the location you want use when importing.


    Chris Morgan

    The certificate just isn't showing up. When I look in the "Personal" folder, nothing is there.
    Monday, June 25, 2012 8:26 PM
  • Hello,

    According to the link: http://www.entrust.net/knowledge-base/technote.cfm?tn=6004

    In “Part 2 - Importing a certificate”, please refer to step 15 and make sure you select “Automatically select the certificate store based on the type of certificate” or “Place all certificate in the following store”.

    Best Regards,

    Lisa

    Tuesday, June 26, 2012 6:01 AM
    Moderator
  • how are you logged on? How did you do the import? Can you provide the steps you took in detail of what you clicked on and what you opened up?

    Chris Morgan

    Tuesday, June 26, 2012 12:14 PM
  • Hello,

    According to the link: http://www.entrust.net/knowledge-base/technote.cfm?tn=6004

    In “Part 2 - Importing a certificate”, please refer to step 15 and make sure you select “Automatically select the certificate store based on the type of certificate” or “Place all certificate in the following store”.

    Best Regards,

    Lisa

    I am not even at the import phase of the process yet. I am first trying to Export from our primary server. The issue is that when I open the mmc snapin Certificates, the certificate is not listed in the folder named "Personal". That folder is completely empty. Godaddy stated that they see that the certificate is installed properly, but they do not know why it's not showing in the "Personal" folder.
    Wednesday, June 27, 2012 2:44 PM
  • how are you logged on? How did you do the import? Can you provide the steps you took in detail of what you clicked on and what you opened up?

    Chris Morgan

    I am not even at the import phase of the process yet. I am first trying to Export from our primary server. The issue is that when I open the mmc snapin Certificates, the certificate is not listed in the folder named "Personal". That folder is completely empty. Godaddy stated that they see that the certificate is installed properly, but they do not know why it's not showing in the "Personal" folder.
    Wednesday, June 27, 2012 2:45 PM
  • Ok, how are you logged on? can you provide the steps you are taking to get to the Personal folder in the mmc? Are you opening a new mmc and doing an add/remove snapin of the certificates snapin? Then what are you selecting? Can you provide a screen shot?


    Chris Morgan


    Wednesday, June 27, 2012 2:47 PM
  • Ok, how are you logged on? can you provide the steps you are taking to get to the Personal folder in the mmc? Are you opening a new mmc and doing an add/remove snapin of the certificates snapin? Then what are you selecting? Can you provide a screen shot?


    Chris Morgan


    The steps that I am taking to get to Certificates are:

    Start -> Run

    Type MMC press Enter

    File -> Add/Remove Snap-in

    Add Certificates, Select My user account, Click Finish, Then Click OK.

    According to GoDaddy, the certificate should be located in a subfolder inside "Personal". However when I select that folder, it's empty. I tried checking all other folders and I tried doing a search for the certificate and was not able to find it.

    Thursday, June 28, 2012 1:41 PM
  • and that's the problem I have been pointing out. You MUST select Local Computer. Your user account does NOT have the certificate. Those 3 choices all have different certificate stores. Once you select local computer you will see the certificate and can export. Do the same for the import. Select local computer and import.

    Chris Morgan

    Thursday, June 28, 2012 1:54 PM
  • and that's the problem I have been pointing out. You MUST select Local Computer. Your user account does NOT have the certificate. Those 3 choices all have different certificate stores. Once you select local computer you will see the certificate and can export. Do the same for the import. Select local computer and import.

    Chris Morgan

    Wow you're right!!!! Thanks Chris. I'm an idiot sometimes.
    Thursday, June 28, 2012 2:51 PM
  • It's a common mistake. Just remember certificates for Exchange will ALWAYS be in the computer store. So importing and exporting operations should all take place in that store.

    Chris Morgan

    Thursday, June 28, 2012 3:01 PM
  • It's a common mistake. Just remember certificates for Exchange will ALWAYS be in the computer store. So importing and exporting operations should all take place in that store.

    Chris Morgan

    Cool. In the export wizard, should I select the option for "Export all extended properties"?

    The instructions were kind of vague about that section.

    Thursday, June 28, 2012 3:10 PM
  • I dont believe that will matter for this. However make sure:

    • Export the private key (if it's greyed out then the option to make the private exportable was not set when the certificate was issued and you need to get it reissued by GoDaddy)
    • Make sure you export all certificates in the path (this ensures the GoDaddy trusted CA and intermediate CA's certs are exported. They are required to be installed on the new machine as well to avoid issues)

    That should do it.


    Chris Morgan

    Thursday, June 28, 2012 3:14 PM