locked
The expected version of the product was not found on the system - SharePoint 2013 RRS feed

  • Question

  • Hi Guys,
    I have a SharePoint 2013 farm with SP1 installed. The baseline as you see below:
    DisplayName    : Microsoft SharePoint Server 2013
    DisplayVersion : 15.0.4571.1502

    DisplayName    : Language Pack for SharePoint and Project Server 2013  - Danish/dansk
    DisplayVersion : 15.0.4571.1502

    DisplayName    : Language Pack for SharePoint and Project Server 2013  - English
    DisplayVersion : 15.0.4571.1502

    DisplayName    : Language Pack for SharePoint and Project Server 2013  - Finnish/suomi
    DisplayVersion : 15.0.4571.1502

    DisplayName    : Language Pack for SharePoint and Project Server 2013  - Norwegian/norsk
    DisplayVersion : 15.0.4571.1502

    DisplayName    : Language Pack for SharePoint and Project Server 2013  - Swedish/svenska
    DisplayVersion : 15.0.4571.1502

    I have installed all the patches released after SP1 until the CU April 2015 KB2965266 there I got my problem. When I try to install it I get  the message "The expected version of the product was not found on the system". Even though I try to install later patch for example KB3054937 or any later patch I get the same error message.
    The BuildVersion is 15.0.4701.1000.

    Have you guys any idea plz? I have exhausted all my ideas but could not solve the problem.

    Best regards
    //Ashraf


    Sunday, December 6, 2015 9:40 PM

Answers

  • Hi Trevor,

    Thank you for your input and suggestion. Now I have resolved it by uninstalling and reinstalling the all the language packs I had installed on the farm (4 language packs) with their SP1 as follow:

    Uninstalling the language packs one by one, ran config wizard between them, checked if there were any issue and fixed it. Reinstalled  the language packs one by one, ran config wizard between the installation of each language pack and checked if there were any issue.

    Still I got the same error message with version. I ran reparation of the language pack which took almost 3 hours. The reparation was failed but I ran config wizard anyway. The config wizard failed as well with missing all the language packs on the other machine. 
    Finally I ran cmdlet:

    psconfig -cmd upgrade -inplace b2b -wait -force 

    which could not fix all of the problems but I could then run the config wizard successful.

    After that I ran the installation of  CU April 2015 KB2965266 without getting the version mismatch anymore.

    Thanks for all of you who tried to help me :)

    Best regards
    //Ashraf

    Friday, December 18, 2015 2:58 PM

All replies

  • 4701 is March 2015. You cannot install April 2014, of course. For the July 2015 CU, you may want to try installing each individual MSI one by one.

    Trevor Seward

            

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Sunday, December 6, 2015 10:37 PM
  • Hi,

    After install SP1, I can install CU April 2015 KB2965266.

    For your issue, try to restart the server and install the CU April 2015 KB2965266 again.

    Download cu from here:

    http://www.microsoft.com/en-us/download/details.aspx?id=46574

    Best Regards,

    Lisa Chen


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, December 8, 2015 10:48 AM
  • Hi Ashraf,

    Have a look at the similar scenario I faced have blogged here -

    https://manojviduranga.wordpress.com/?s=The+expected+version+of+the+product+was+not+found+on+the+system+

    -------------------------------------------------------------------

    please do not forget to mark this as answer if it was helpful

    Tuesday, December 8, 2015 11:11 AM
  • Hi Manoj,

    Thank you for your reply but if I want to do what you suggest in your blog then I have to uninstall the service pack 1 (SP1) since SharePoint doesn't accept an older CU than SP1 when SP1 it already installed.

    Any idea?

    Best regards
    //Ashraf

    Monday, December 14, 2015 9:17 PM
  • As I'm sure you're aware, you cannot uninstall SharePoint patches once they're applied to the system. You can only update to a newer patch. It might be helpful if you provided the entire output of Central Admin -> Upgrade and Migration -> Check product and patch installation status.

    Trevor Seward

            

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Monday, December 14, 2015 9:20 PM
  • Hi Trevor,

    Thank you for your input and suggestion. Now I have resolved it by uninstalling and reinstalling the all the language packs I had installed on the farm (4 language packs) with their SP1 as follow:

    Uninstalling the language packs one by one, ran config wizard between them, checked if there were any issue and fixed it. Reinstalled  the language packs one by one, ran config wizard between the installation of each language pack and checked if there were any issue.

    Still I got the same error message with version. I ran reparation of the language pack which took almost 3 hours. The reparation was failed but I ran config wizard anyway. The config wizard failed as well with missing all the language packs on the other machine. 
    Finally I ran cmdlet:

    psconfig -cmd upgrade -inplace b2b -wait -force 

    which could not fix all of the problems but I could then run the config wizard successful.

    After that I ran the installation of  CU April 2015 KB2965266 without getting the version mismatch anymore.

    Thanks for all of you who tried to help me :)

    Best regards
    //Ashraf

    Friday, December 18, 2015 2:58 PM