none
slow online mode "browsing"

    Question

  • Hi there,

    Currently my configuration is exchange 2013 CU3 with windows 2012 server (fully patched and up to date)

    my issue is with internal network slow outlook clients working with online mode (long delays when going from one message to another)

    OWA mail browse is very fast though with no delays what so ever (IE8/9/10/11/Chrome)

    I know that Microsoft recommend working with cache mode, but sometimes cache mode is not applicable like Terminal servers environment.

    is there any way to improve online mode speeds? (exchange 2010/7 has not delays with outlook internal clients)

    any ideas??

    Thanks Ahead


    Tuesday, February 25, 2014 5:40 PM

Answers

  • I believe we found a solution. We noticed that some of the client machines were having this issue but not all. Using Wireshark, we noticed that the Exchange 2013 Server would send info to the Outlook client, but the client would delay by 200ms before ACKing, which over many packets would create big delays in message previewing. After some research, we found that this is a long standing issue. Changing this registry entry on the client machines and rebooting solved this, and now the Outlook preview pane is as fast as OWA. My best guess is that Exchange 2013 is handling these very small packet transmits differently than Exchange 2007/2010. We didn't need to change anything on the Exchange servers.

    http://support.microsoft.com/kb/2020559/en-us

    1. Start Registry Editor (Regedit.exe).
    2. Locate and then click the following registry subkey:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces

      the interfaces will be listed underneath by automatically generated GUIDs like {064A622F-850B-4C97-96B3-0F0E99162E56}
    3. Click each of the interface GUIDs and perform the following steps:

      a.  On the Edit menu, point to New, and then click DWORD value.

      b.  Name the new value TcpAckFrequency, and assign it a value of 1.
    4. Exit the Registry Editor.
    5. Restart Windows for this change to take effect.


    Thursday, July 24, 2014 6:32 PM

All replies

  • Hi,

    As we know,Online Mode works by using information directly from the server, and, as the name implies, it requires a connection. If you have a lot of folders, Outlook will try to synchronize each one of them, so even if there is nothing to synchronize Outlook can take a long time to step through all of them.

    In addition,mailbox data is only cached in memory and never written to disk when using online mode.

    So,if you want to improve online mode speed,there are two ways for your reference:

    1.Less create folders.

    2.Increased memory for users.

    Hope this helps!

    Thanks.


    Niko Cheng
    TechNet Community Support

    Wednesday, February 26, 2014 9:12 AM
    Moderator
  • To improve online mode speed, you will have to have strong network.
    What kind of network you have? Is it on CAT5 or 6? Or Optical Fiber?

    Cheers,

    Gulab Prasad

    Technology Consultant

    Blog: http://www.exchangeranger.com    Twitter:   LinkedIn:
       Check out CodeTwo’s tools for Exchange admins

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Wednesday, February 26, 2014 9:45 AM
  • Thanks for the tips i will try to apply.

    Exchange 2007\2010 didnt had those "problems".

    Wednesday, February 26, 2014 2:12 PM
  • the exchange is 10GBE speed, Client are CAT6 1GBE.

    i guess thats not the problem, transfer speed from clients to server are fast also backups etc

    Wednesday, February 26, 2014 2:14 PM
  • Hi Dani.

    We are experiencing the same on our Exchange setup. We have both 2010 and 2013 servers. Users with mailboxes on the 2010 server browse fast in online mode while users on 2013 usually a 1 second delay when scrolling to a new message.

    Haven't found out yet :(

    Did you find out what caused the delays on your system?

    Friday, July 18, 2014 8:24 AM
  • Count us in, we're experiencing exactly the same thing. Lightning fast Exchange 2013 OWA, very slow and delayed Outlook preview panes while in Online mode. 2007 server accounts run at full speed. Our management isn't very happy with us and we've overturned every setting in Outlook 2013 with no help. How can we migrate to the latest version of Exchange and it's massively slower for the client than the 5 year old server?
    Wednesday, July 23, 2014 7:34 PM
  • Hi Festivalman,

    About this problem, i guess you can try to disabled IPv6 on the network adapters for the CAS and Mailbox servers.

    Thursday, July 24, 2014 8:31 AM
  • Eric.YK, we've been hesitant to do something like that seeing that it's core to the OS at this point. Microsoft has said from all angles not to do it. If that's the solution, there's no telling if everything's going to break upon the next Cumulative Update. We've noticed that Windows 8 users aren't experiencing this slowdown anywhere near as much as Windows 7 users.
    • Proposed as answer by Festivalman Thursday, July 24, 2014 6:27 PM
    • Unproposed as answer by Festivalman Thursday, July 24, 2014 6:27 PM
    Thursday, July 24, 2014 12:20 PM
  • I believe we found a solution. We noticed that some of the client machines were having this issue but not all. Using Wireshark, we noticed that the Exchange 2013 Server would send info to the Outlook client, but the client would delay by 200ms before ACKing, which over many packets would create big delays in message previewing. After some research, we found that this is a long standing issue. Changing this registry entry on the client machines and rebooting solved this, and now the Outlook preview pane is as fast as OWA. My best guess is that Exchange 2013 is handling these very small packet transmits differently than Exchange 2007/2010. We didn't need to change anything on the Exchange servers.

    http://support.microsoft.com/kb/2020559/en-us

    1. Start Registry Editor (Regedit.exe).
    2. Locate and then click the following registry subkey:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces

      the interfaces will be listed underneath by automatically generated GUIDs like {064A622F-850B-4C97-96B3-0F0E99162E56}
    3. Click each of the interface GUIDs and perform the following steps:

      a.  On the Edit menu, point to New, and then click DWORD value.

      b.  Name the new value TcpAckFrequency, and assign it a value of 1.
    4. Exit the Registry Editor.
    5. Restart Windows for this change to take effect.


    Thursday, July 24, 2014 6:32 PM
  • Festivalman - You are.....so beautiful..... tooooo meeeee.

    Many thanks for sharing that solution, I owe you a dance or perhaps just a beer :)

    Thursday, July 24, 2014 8:36 PM
  • Festivalman!! My man !! Thank you very much for sharing this.

     

    We have Exchange 2013 and installed CU6.

    Our Windows 7 computers with Outlook 2010 become slugish/slow for all users, but most for the users working in Online mode.

    Also our Cirtix servers (Windows 2008) with Outlook 2010 responded slow.

     

    As a test we added the registry key on a couple machines and the Outlook response become fast again. Did not have this issues on Windows 8.1 computers.

     

    Many thanks :))))))


    • Edited by OPePePe Friday, September 05, 2014 1:05 PM
    Friday, September 05, 2014 1:04 PM
  • I believe we found a solution. We noticed that some of the client machines were having this issue but not all. Using Wireshark, we noticed that the Exchange 2013 Server would send info to the Outlook client, but the client would delay by 200ms before ACKing, which over many packets would create big delays in message previewing. After some research, we found that this is a long standing issue. Changing this registry entry on the client machines and rebooting solved this, and now the Outlook preview pane is as fast as OWA. My best guess is that Exchange 2013 is handling these very small packet transmits differently than Exchange 2007/2010. We didn't need to change anything on the Exchange servers.

    http://support.microsoft.com/kb/2020559/en-us

    1. Start Registry Editor (Regedit.exe).
    2. Locate and then click the following registry subkey:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces

      the interfaces will be listed underneath by automatically generated GUIDs like {064A622F-850B-4C97-96B3-0F0E99162E56}
    3. Click each of the interface GUIDs and perform the following steps:

      a.  On the Edit menu, point to New, and then click DWORD value.

      b.  Name the new value TcpAckFrequency, and assign it a value of 1.
    4. Exit the Registry Editor.
    5. Restart Windows for this change to take effect.


    I have win2k12 r2 with Exchange 2013 SP1.
    Outlook 2010 SP2 on Windows 7 SP1.
    I just tested this on the windows 7 and it works.

    How can I make this change for 100 pcs without manually editing the registry key on each PC?

    Thanks

    • Edited by kungpow112 Monday, September 29, 2014 4:21 AM
    Monday, September 29, 2014 4:20 AM
  • With a vbs script? ;)

    Dim strComputer   
    Dim strID   
    Dim strKeyPath   
    Dim strValueName   
    Dim strDWValue   
      
    Const HKEY_LOCAL_MACHINE = &H80000002   
    Const DEFAULT_TcpAckFrequency = 1
      
    strDWValue = DEFAULT_TcpAckFrequency
    
    strComputer = "."  
    Set oReg=GetObject("winmgmts:{impersonationLevel=impersonate}!\\" & _   
             strComputer & "\root\default:StdRegProv")   
      
    Set objWMIService = GetObject("winmgmts:" _
        & "{impersonationLevel=impersonate}!\\" & strComputer & "\root\cimv2")
      
    Set colAdapters = objWMIService.ExecQuery _   
        ("SELECT * FROM Win32_NetworkAdapterConfiguration")   
      
    For each objAdapter in colAdapters     
           strID = objAdapter.SettingID   
           strKeyPath = "SYSTEM\CurrentControlSet\Services\TCPIP\Parameters\Interfaces\" & strID   
           strValueName = "TcpAckFrequency"  
           oReg.SetDWORDValue HKEY_LOCAL_MACHINE,strKeyPath,strValueName,strDWValue
    Next


    Wednesday, October 01, 2014 4:13 PM
  • Will this work on RDP-FARM ?

    will it have to be set on each RDP server or...?

    brgds

    Marco

    Saturday, January 10, 2015 6:36 AM
  • I am having a different issue over here with Exchange server 2013.

    My OWA itself is working really slow, If I send a mail from OWA some times it sends out immediately & some times it get stuck over tre for hrs...Can some one suggest a fix for this please..

    Wednesday, January 14, 2015 10:38 PM
  • Hi,

    Did you figure out a way to make this work on Citrix . We use Online mode for Outlook in Citrix and all our users complain about Performance issues.

    Any special consideration for Citrix servers.

    Wednesday, March 18, 2015 12:28 PM
  • Our problem was on also Citrix servers. On all Citrix servers I just added the TcpAckFrequency, and assign it a value of 1. Restarted the servers and the problem was gone :)
    Wednesday, March 18, 2015 12:38 PM
  • Does Roaming profile and AppData redirection make a difference.

    We use roaming profile in citrix .

    Our Outlook Performance is awful even after making the registry changes and reboot

    Thursday, April 16, 2015 7:57 AM
  • We needed to upgrade to Office 2010 SP2 to solve the issue
    Thursday, April 16, 2015 10:16 AM
  • Although this works, I'm wondering if the actual cause is something else. We have the exact same issue.  Our Exchange servers are on VMware.  When you run the servers with VMware Tools 5.1 U1 or earlier, everything works great and you do not have to change this setting.  If you update just the Tools to 5.1 U2 or later, including any version of 5.5, you run into this problem.

    Why would MS make a main line product that would force everyone to make an oddball registry change on every single client?  I think the answer is "they wouldn't."

    So I'm wondering what everyone is running their Exchange on?  I still have not found the root cause of this problem, and I do not think disabling Delayed Ack at the client is the real answer.

    Friday, May 22, 2015 8:09 PM