none
Custom watermarks in Word 2010 not obeying Section Breaks

    Question

  • Hello,

    I've stepped through the process of separating a document into 2 sections using Section Breaks.  I then removed the Link to Previous option so the second section is no longer using the Section 1 header.  I then click in the body of the first section which is where I want a watermark to appear.

    Now, if I apply one of Word's built in text watermarks, it only appears in Section 1...as it should.  But, if I select Custom Watermark, then choose either a Picture or Text watermark (including leaving the built in watermark's text in the custom text field)...it appears in both sections of the document when I click Apply or OK.  If I remove it, then add one of the built in watermarks...only appears in Section 1.

    Any ideas as to why Custom Watermarks are not being restricted to Section 1 as the built in watermarks are?  Are others having this same thing happen?

    Thanks for any help.

    Using Office 2010 Professional Plus on Windows 7.

    Saturday, July 10, 2010 2:17 AM

Answers

  • Hello George,

    I was reviewing this post and the other post and I wanted to chime in from a Microsoft prospective.

    I have tested this behavior in Word 2007 and Word 2010 and in both, the same process works where if you insert a watermark, go to section 2's header and de-select "Link to Previous", then delete the watermark on that section, the watermark is removed.

    I then inserted a custom watermark to only section 1 and in both Word 2007 and 2010, it showed up on all pages.    I also went back to Word 2003 and it did the same thing.

    I also tested using a built-in watermark instead of using Custom Watermark and I can confirm it only puts it in that section.

    This behavior is by design of Word to only 1 watermark per document.  However, the behavior of custom vs. built-in watermarks, while consistent among Word versions, I agree is not very intuitive.  I can submit this to our product group for review of future versions of Word.

    • Marked as answer by GeoPro Tuesday, July 13, 2010 6:14 PM
    Monday, July 12, 2010 8:46 PM
    Moderator

All replies

  • See response to your other post in http://social.answers.microsoft.com/Forums/en-US/wordcreate/thread/cd0a4a11-88c4-4b1c-a065-1bb3124b2a4b

    -- Hope this helps.

    Doug Robbins - Word MVP,
    dkr[atsymbol]mvps[dot]org
    Posted via the Community Bridge

    "GeoPro" wrote in message news:0dad349d-4290-40ed-bb7d-364883fff88d@communitybridge.codeplex.com...

    Hello,

    I've stepped through the process of separating a document into 2 sections using Section Breaks.  I then removed the Link to Previous option so the second section is no longer using the Section 1 header.  I then click in the body of the first section which is where I want a watermark to appear.

    Now, if I apply one of Word's built in text watermarks, it only appears in Section 1...as it should.  But, if I select Custom Watermark, then choose either a Picture or Text watermark (including leaving the built in watermark's text in the custom text field)...it appears in both sections of the document when I click Apply or OK.  If I remove it, then add one of the built in watermarks...only appears in Section 1.

    Any ideas as to why Custom Watermarks are not being restricted to Section 1 as the built in watermarks are?  Are others having this same thing happen?

    Thanks for any help.

    Using Office 2010 Professional Plus on Windows 7.


    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org
    Saturday, July 10, 2010 5:17 AM
  • Thanks Doug,

    The answer in my other post is helpful, but I still would like to know if this behavior of Custom Watermarks and Section Breaks in Word 2010 is by design or a bug that needs to be fixed...since it's different than 2007, requires extra steps to get the watermark to only exist where I want it to be, and it's not documented to work this way in the 2010 Help files which indicate that 2010 should work as 2007 did.

    Other than what appears at this point to be the workaround you suggest, any additiional information you can find out about the issue would be helpful.  It doesn't seem Microsoft would want to have make it more difficult to use Custom Watermarks...certainly without documenting the extra steps necessary to get them properly placed.

    Thanks for you time, I appreciate it.

    Saturday, July 10, 2010 3:26 PM
  • Hello George,

    I was reviewing this post and the other post and I wanted to chime in from a Microsoft prospective.

    I have tested this behavior in Word 2007 and Word 2010 and in both, the same process works where if you insert a watermark, go to section 2's header and de-select "Link to Previous", then delete the watermark on that section, the watermark is removed.

    I then inserted a custom watermark to only section 1 and in both Word 2007 and 2010, it showed up on all pages.    I also went back to Word 2003 and it did the same thing.

    I also tested using a built-in watermark instead of using Custom Watermark and I can confirm it only puts it in that section.

    This behavior is by design of Word to only 1 watermark per document.  However, the behavior of custom vs. built-in watermarks, while consistent among Word versions, I agree is not very intuitive.  I can submit this to our product group for review of future versions of Word.

    • Marked as answer by GeoPro Tuesday, July 13, 2010 6:14 PM
    Monday, July 12, 2010 8:46 PM
    Moderator
  • Thanks Adrian.

    I checked my '03 and '07 versions and see that it does function the same way as you indicated.  I appreciate that you will submit this to the product group.  My hope is that they will make Custom Watermarks function as the built-in ones do...but at a minimum, maybe they'll add a line or two to the Help file mentioning the need to manually delete Custom Watermarks from undesired sections after Word places them there even though no Link To Previous is active.

    Thanks again!

     

    Tuesday, July 13, 2010 6:14 PM
  • Hey George,

    I think I might have a work around. First post your custom watermark on one page.
    Then:
    1. Select the header
    2. Select Page Layout
    3. Select Watermark and then select "Save selection to Watermark Gallery"
    4. Select Watermark and then select "Remove Watermark"
    5. Select Watermark and then go to the general heading and select your custom water mark

    This will only add it to one page. If you want to add it to multiple pages. You can go back to the watermark general heading and right click your custom watermark and select Edit Properties. Then you can copy, paste, and move your watermark to multiple pages. I don't think you have to be in the header, but you can try it either way. When I did this I head all my pages with breaks in-between each break and they were all unlinked.

    Hope this helps.

    Jon Geiger

    P.S. This is my first form post ever...that I can remember at least.
    Monday, April 09, 2012 6:53 PM
  • That's a good solution and I have also found another work around.  Watermarks are actually embedded WordArt elements that can be edited and this solved the problem for me.  Follow these steps:

    1. Follow the process as you did before to add a watermark to select pages by creating multiple sections in your document.
    2. Go to the page where you want to add the watermark, open the header, and add aSTANDARD watermark (such as "confidential").
    3. With the header still open, mouse over the watermark until the pointer arrow turns into a crosshair when it "finds" the WordArt element and click to select.
    4. From the WordArt ribbion, click "edit text" (first button, far left of ribbon) and a dialog box will appear.  (Alternately, right click on the element when the cursor changes and select "edit text" from the pop-up menu.)
    5. Change the text to whatever you want and click "OK."

    The "standard" watermark is still there but with your new custom text and it should still only be on the pages in that section.  This requires a few extra steps from simply using the custom option on the watermark drop-down, but it should do the trick.

    Thursday, May 10, 2012 8:09 PM
  • Thank you, Fightin. Your solution worked great. I will pass this onto my co-workers also!
    Wednesday, June 13, 2012 3:23 PM