none
Office 2010 Installation Problem osetup.dll

    Question

  • While trying to install Office 2010 Pro I receive the following error immediately after running setup.exe "OSETUP.DLL digital signature does not validate or is not present".  I have done several internet searches and see this problem has been around since Office 2007.  Apparently tons of people have this problem, but very few resolutions all of which do not work for me.  I have tried the following:

    • Re-downloaded from Microsoft (even tried the x64 version)
    • Burned several discs
    • Tried in 5 different Computers comprising of Vista, XP, and W7
    • Copied files to network and to local PC
    • Ran from command prompt
    • Ran as local admin
    • Created a clean unpatched W7 install - failed
    • Created a clean unpatched XP wSP2 install - failed
    • Patched clean install of W7 - failed

    I have tried downloading the individual apps from our Volume Licensing website to try and pull the osetup.dll from their file set, this also fails.  At the moment the only thing I can get to work is Office Standard, trying to pull the osetup.dll from that file set resolves the error but causes the setup.exe app to immediately crash.  I also tried downloading the Office 2010 Pro trial and pull the file from that file set, same crash result not the .dll error.  I can install the trial successfully though.  I have tried on PC's with Office 2003 installed, no Office installed, Office 2007 installed, nothing works.  PCs off the domain, on the domain, PCs completely off the network that are fresh installs. Again all same results.

    Please help as I have run out of ideas.  The install log contains the following: (Certain items removed)

     

    Verify file signature in "\ProPlus.WW\OSETUP.DLL"

    Error:  \ProPlus.WW\OSETUP.DLL is not trusted.

    Log level changed from: Standard to: Verbose

    Failed to verify file signature from the selected setup controller dll in location "\ProPlus.WW\OSETUP.DLL"

    \ProPlus.WW\OSETUP.DLL digital signature does not validate or is not present.

     

    • Edited by Sean H-SC Wednesday, May 12, 2010 12:29 PM Removed hidden text from cut/paste
    Wednesday, May 12, 2010 12:28 PM

All replies

  • To better understand the problem, I would like to confirm the exact situation with you:

    1.       Please let me know the exact link where you downloaded the Office 2010 Professional software. Is it from: http://www.microsoft.com/office/2010/en/download-office-professional-plus/default.aspx?

    2.       Is the downloaded file an .ISO file?

     

    If the downloaded file is an .ISO file, I suggest using a tool to extract the .ISO file, such as winrar, and then run the setup.exe again.

    Thursday, May 13, 2010 3:59 AM
  • I downloaded it from our Volume Licensing website

    https://www.microsoft.com/licensing/servicecenter/Downloads/CatalogHome.aspx

    Correct, it was downloaded as an ISO.  I have tried mounting the ISO as a virtual drive with no luck either.  Two of the tests I did were done on a Hyper-V installation using the ISO mounted as a drive, additionally I also mounted it as a virtual ISO in a standard PC.

    Let me know if that does not answer your questions.

    Thursday, May 13, 2010 11:49 AM
  • Hi Sean,

     

    Thank you for your reply. Please try to use WinRAR to extract the ISO. Then, run setup.exe directly from the extracted folder.

     

    Best Regards,

     

    Sally Tang

    • Proposed as answer by rebar kaka Tuesday, April 26, 2011 9:49 AM
    • Unproposed as answer by rebar kaka Tuesday, April 26, 2011 9:50 AM
    Friday, May 14, 2010 8:35 AM
  • Hi

     

    Same problem here, downloaded Office 2010 Professional Plus EN 64-Bit from MSDN as ISO file. Extracting with WinRAR dosn't help.

    The signature on file osetup.dll is missing.

     

    Other Office 2010 ISO files like 32-Bit or German are working.

     

    Regards,

    Patrick

     

    Friday, May 14, 2010 12:14 PM
  • Extracting via WinRAR made no difference for me either.  Same error.
    Friday, May 14, 2010 12:19 PM
  • We also get the same problem. We have tried re-downloading the .iso from the Microsoft Partners page from 3 different machines to avoid any caching, and the same results occur.

    We have also tried on 4 machines, 1 of these machines being a clean installation of Windows 7.

    We have also burnt to a CD, DVD, Mounted using Virtual Disk Clone, extracted the .iso to a network share and desktop. All giving the same error.

    We were trying the 32-bti version.

    Kind Regards,

    Craig

    Monday, May 17, 2010 10:03 AM
  • I too seem to have the same issue and am looking for a solution. Tried re downloading and extracting the ISO using winrar. No luck.

     

    Thanks,

    Brenda

    Monday, May 17, 2010 9:20 PM
  • Hi,

     

    If we are still unable to install the Office program by clicking the setup.exe file directly, the osetup.dll in the folder may be corrupted.

     

    You can check if others can download the Office program from the website and install. If they can, you can try to copy a good copy of the osetup.dll file from them and replace the corrupted one. Then, click the setup.exe file to install the Office program again.

     

    However, if all the downloaded files from the website cannot be installed, the media might have problems and you need to contact the administrator.

     

    Best Regards,

     

    Sally Tang

    Tuesday, May 18, 2010 8:47 AM
  • We have 3 other individuals that have posted here in less then a week, along with the numerous web search results from Google all the way back to Office 2007 installs, with this same exact install problem.  I have tried my software on numerous differant disks, not extracted to a disks, redownloading several times, and on numerous differant computers and OS's.

    I can't understand why you would think it is something that has corrupted itself in each and every one of those test cases.  As soon as one person says it works fine that almost proves the file is not corrupted.  Whatever check the setup.exe is executing to confirm the digital signature of the file is obviously not working correctly on a vast range of scenarios.

    And we are not having problems with every download from the VLA website, only the Office 2010 Pro suite and related apps.  I contacted VLA support and they referred me to the generic Microsoft support which subsequently led me here.  I mean, you all are the admins, where else do you suggest I get the downloads from?  "gouldinguk" said he downloaded from the Partner page, assuming that is different from my VLA page, I can't believe it is "corrupt" in both locations.

    Where do you recommend I get a working osetup.dll file?  People aren't posting that it works, people only complain when its broken.  What if replace it with a known working osetup.dll and it still doesn't work?  What then?  I already posted that I took the osetup.dll from the Office Standard install, again that install does work, and replaced the osetup.dll in the Pro files and, instead of the above mentioned error, setup.exe just crashes.

    Tuesday, May 18, 2010 12:49 PM
  • Tried the same ... downloaded 2010 office from VLK website 32bit edition and gave the same error. My system is Win 7 Enterprise. tried the same on colleages vista & a windows 7 home premium .. the same.

    For all i can see it looks like a corrupt release. Does Microsoft have a patch \ bugfix or link of a clean dll ??

    Wednesday, May 19, 2010 12:14 PM
  • It's really difficult to download Office 2010 from an other source... I only have one source available. So where should I get an "other" copy of osetup.dll...? Seems I have to buy an original dvd... :-) Taking osetup.dll from an other version doesn't work.

    Google gives a lot of hits back, all for Office 2007. Seems there are lot more people having the same issue than in this thread involved... No hit for Office 2010 and osetup.dll.

    I think I have to stop my project "Office 2010" and install OpenOffice instead...

     

    Regards

    Patrick

     

    Wednesday, May 19, 2010 12:38 PM
  • Yep have the same problem. I have the dutch 32 bit version downloaded from our microsoft member partner side. Itried alse Windows 7 and Vista. All the same problem
    Saturday, May 22, 2010 6:10 PM
  • we have the same problem.

    fresh german x32 win7 installation and office 2010 std. from the https://www.microsoft.com/licensing/servicecenter/Downloads/CatalogHome.aspx page.

    If I watch the properties of the osetup.dll there ist no tab for "digital Signature". So it's really missing.
    But when I do it with our own Office Prof. version it works and there I can see the "digital Signature" tab in the .dll properties.
    I replaced the "original dll" with the "working dll" but this crashes the setup.

    I also posted in the german Certified Partner Support Portal 10 days ago, but no answer. The customer gets angry because it is not possible to simply install Office!? That's really embarrassing!

    Please make a Fix or a working download available asap!

     

    • Edited by Bechtle AG Monday, June 07, 2010 4:38 PM news
    Tuesday, May 25, 2010 2:05 PM
  • Same problem here - is this another Microsoft screw-up - because this is allot of people with the same issue - we need a resolution not excuses.
    Tuesday, May 25, 2010 2:36 PM
  • Same problem as per everyone above... Come on MS - time to pull finger and fix this silly issue ASAP... please!! At least just add the fixed osetup.dll in the VL download section

    Extremely frustrated

    Reg

    Friday, May 28, 2010 8:29 AM
  • In case anyone is still checking this thread.  I received my actual VLA discs from Microsoft today with "Microsoft Office Professional Pluss 2010" included.  These discs worked, on the exact same system(s) that the downloaded ISO did not work on.

    That doesn't solve any problems unfortunately, but maybe that will help anyone.

    Wednesday, June 09, 2010 11:57 AM
  • Hello Sally,

     

    This is probably the wrong place to make this request, however, I have no idea where would be the proper location.  The Office 2010 Professional install is flaky/fragile/untested "whatever."  While I can maybe understand this with a beta install.  Now that the official release has been out there for a while, numerous problems across many areas still exist.  A simple search on "Office 2010 Install Problems" on the Internet yields thousands of replies--with many of them since the official release date.  This is, clearly, unacceptable.  Even more so, when one has to spend several hundred dollars, and up with software that won't install.

     

    What happened to the reliable and solid installs of Office 2003 and Office 2007?

     

    With the present erratic install, I can hardly even consider moving from Office 2007 to Office 2010.

    Kindly forward this request to the applicable department/person.  Thank you.

    Bob

    Thursday, July 08, 2010 5:58 PM
  • I've checked manually the pro 2010 en-us iso and it is fine. If you think there is a faulty iso image on the download site please reference the entire file name (e.g. SW_DVD5_Office_Professional_Plus_2010_W32_English_MLF_X16-52536.ISO). There are thousands of iso images on the VLA site for 2010 alone.

    Thanks!

    Michael Reynolds


    • Edited by micrey Thursday, February 14, 2013 7:18 PM
    Wednesday, December 22, 2010 7:08 PM
  • Good afternoon,

    I had the same issues are reported above. I re-downloaded the ISO image from Microsoft licensing website and indeed the official ISO and its OSETUP.DLL was extracted without the Digital signature check and the installation cannot go further. Either from the ISO onto DVD or extracted to a folder(using ISO Extract tool), same issue.

    To fix it, I had to search on my local computer for an existing OSETUP.DLL. I had one from Office 2007 setup. I found many versions on my computer in cache folders or installed version or temp files. Possibly some of them might do the job.

    I had installed the temporary Certificate from Microsoft. Now, funny enough, each OSETUP.DLL file I check is "Signed". Would it be linked to a missed file association/version check  that fails without the certificate installed (valid until march 2011)?

     

    Digital signature of the file that works :

    System Windows XP SP3.

    Anti-virus Symantec V10 Corporate edition.

    Name: osetup.dll

    Thursday, 11 th of March 2010 08:46:08.

    Size :5'789'544 bytes

    File version :14.0.4755.1000

    file Description : Office Setup Engine

    Product name : Microsoft Office 2010

    Product Version : 14.0.4755.1000

     

    I hope this helps.

    Kr

    FO.

    • Proposed as answer by Charl100 Thursday, February 17, 2011 9:26 PM
    Wednesday, January 05, 2011 2:52 PM
  • I had the same problem using Windows7.  My Kaspersky AV was corrupting the download.  I turned off the Kaspersky AV, downloaded a new copy of the ISO image and unzipped it with WinRAR.
    • Proposed as answer by Cyborgx372 Saturday, March 08, 2014 2:43 PM
    Thursday, February 17, 2011 9:29 PM
  • Same problem again, VLK Office 2010 Pro downloaded. osetup.dll is missing. Microsoft, please find the installer!!!!
    Sincerely, Alexander Schmidt, MCPD Enterprise
    Tuesday, July 05, 2011 1:00 PM
  • I might have a solution: I had the same type of problems / errors when downloading Office 2010 64 Bit from the MS Volume License site. The mistake I made was that a 32 bit system was used to actually download the software. I then used 7-Zip (32 bit version) to 'unarchive' the ISO. I believed that I could do this because I was simply copying the resulting Office 2010 64 Bit folders over to a network share and did not think it would be a problem.

    It opened it up but, a) generated various errors, b) finished, but then generated a "failed to verify file signature..." type of error message. So it was not usable.

    I even deleted the original .ISO and re-downloaded, with same results. The first failure was on my 32 bit Windows 7 Pro; the 2nd failure was on a 32 bit Server 2003. The fix for me was stunningly simple:

    I eliminated any trace of a 32 bit Operating System intermediary completely. I logged into the MS Volume Licensing site on a 64 Bit Windows 7 Pro, then unarchived it and voila, the 64 Bit 2010 Office software works as advertised!


    SF Dave
    • Proposed as answer by WillowtreeBear Friday, August 19, 2011 1:44 PM
    • Unproposed as answer by WillowtreeBear Friday, August 19, 2011 1:46 PM
    Wednesday, July 27, 2011 9:55 PM
  • I am using win 7 professional upgraded from vista. I too had the same problem. I was using chrome and downloading through the browser. Download was successful and i was able to burn successfully to disc. Error msg came up straight away when first installing.

    Re-downloaded using internet explorer as browser and also using the download manager option. Extracted files using winrar onto the computer. installed using the .exe file and no problems at all.

    Hope this helps.

    Friday, August 19, 2011 1:55 PM
  • Hey everyone, 

    I was trying to install Microsoft Office 2011 Professional on a Windows XP Home Edition system. It is a computer that I have recently rebooted due to a fried motherboard. I like everyone else in this forum was confronted with the same error message. I tried various tips and tricks that I have found on the internet but to no great avail.

     

    However I managed to fix the problem!!!!!!

     

    This may be very simple and a lot of you may have already done this but I hadnt and was subsequently kicking myself after I realised.

    Check what service pack you are running, and update to the most recent one... in my case... up to Service Pack 3. After installing this SP.... the error message was no more, and I was able to install MO2011 with no problems.

     

    Hope this helps!!!!

    • Proposed as answer by TheBeesknees Saturday, December 31, 2011 10:30 PM
    Saturday, December 31, 2011 10:29 PM
  • Try this

    http://go.microsoft.com/?linkid=9737366

    Reboot and the againg try installing


    Shashwat Shriparv


    Wednesday, February 08, 2012 7:28 AM
  • Same problem

    standard.ww\osetup.dll digital signature does not validate or is not present

    Tuesday, April 17, 2012 7:39 AM
  • Still no permanent/recommended fix?
    Wednesday, April 18, 2012 2:16 AM
  • A solution:

    I have had this problem a BUNCH of times, never figured this would be the problem, until the hints in here..

    Downloaded from Volume Licensing I got this error no matter what version I tried..
    Used direct browser download through Internet Explorer..

    And the fix is, Installing and using the Download Manager instead...
    worked right away !!!!!!!!

    Annoying to have wasted so much time on it..  the reason for using direct download is to avoid spending time on installing download manager, and popup-stuff...  so the penalty is to waste our time with non working downloads instead...
    Sunday, October 14, 2012 5:24 AM
  • Same Problem here.Technet Standard Abo -> downloaded the Pro .iso

    getting the error message no matter what i do. (yeah i wasted the time like Sean H-SC did)

    i mean... wth? wasted 3 days of my abo-time to install office??? come on, this isnt Linux, it should W O R K out of box...

    i just HOPE that all the other installations for my future test cenarios arent that complicated

    (looking forward to test system center & exchange on a hyper V enviroment with several client systems)

    btw still NO official solution for this problem posted, whats wrong here?

    disappointed by now yours,

    humongous

    Tuesday, May 07, 2013 5:09 AM
  • Hi I solved a similar problem. I could not install Project 2010. The same failure notice. I solved it so that I found gdiplus.dll and copied to the directory C: \ windows.
    Wednesday, May 29, 2013 9:15 PM
  • download manager is the fix for it, ive seen this before somewhere when you download MS ISOs mount them using something like Daemon Tools or Magic ISO. Dont touch them with winrar extracting them can work fine but can also corrupt the iso. 
    Saturday, October 19, 2013 4:31 PM
  • Even though this is an old thread, it is highly ranked on google so I want to add my two cents where it might be seen.  I am having this issue on a new computer using a disc that has work since office 2010 came out.  I downloaded the office 2010 opk when it became available and burned the dvd and that dvd has worked for years until today.  the iso was downloaded and the dvd burned on x86 xp system; but I have never had any issues with installing from this disc on any system 32 or 64 bit xp/vista/7/8.  That is until today.  I burned another dvd and the same issue occurs on any system I put the discs into.  I tried extracting the contents of the iso and I get the same error.  FWIW the last time I installed office 2010 was over six months ago, but it went off without a hitch.  I wish I had a solution, other than libreoffice, but there is none that I can find.
    Thursday, February 27, 2014 4:01 PM
  • Thank you!!! After over an hour of searching, this was exactly the issue. I disabled my Kaspersky AV and re-downloaded the ISO. It works perfectly now.
    Saturday, March 08, 2014 2:44 PM