locked
Unable to mount PF database. RRS feed

  • Question

  • Hi,

    I was running Exchange 2003 and 2007 in our enviorment, Recently i migrated all the Mailboxes,public folders and Free/Busy  information to EX2007, and remove EX2003 server. It was running fine until recently i started getting this error and PF doesn't mount any more

    Event ID 8197 "Error  0x80040111" is logged in the Application log

    Error initializing session for virtual machine uts-MS01. The error number is 0x80040111. Make sure Microsoft Exchange Store is running. Also, make sure that there is a valid public folder database on the Exchange server

     

    when I try to mount the PF database in Exchange Server 2007
    --------------------------------------------------------
    Microsoft Exchange Error
    --------------------------------------------------------
    Failed to mount database 'Public Folder Database'.

     

     

    Public Folder Database
    Failed
    Error:
    Exchange is unable to mount the database that you specified. Specified database: uts-MS01\Second Storage Group\Public Folder Database; Error code: MapiExceptionADPropertyError: Unable to mount database. (hr=0x80004005, ec=2418)


    .

    Can any one help?

    Thanks,

    Heymish

     

    Friday, June 5, 2009 4:56 AM

Answers

  •  
    When I did the migration I couldn’t remove ex2003 properly, even though all mailboxes and PF and FREE/BUSY information were transferred I couldn’t uninstall EX2003 server, so I used adsiedit.msc to remove left over AD attribute. Then I was able to uninstall EX2003. Exchange 2007 worked fine until recently PF stop working.

    While searching in the forum, I found a solution,

    I’m sure I didn’t remove “Folder Hierarchies” with adsiedit, not sure what happened there?

    BY Sonny1

    Open adsiedit.msc.

     

    Select Configuration-Configuration-Services-Microsoft Exchange-Orgname-Administrative Groups-Exchange Administrative Group.

     

    Now we were missing the 'Folder Hierarchies' folder - how I still am unsure of. All we had to do was recreate it as follows:

     

    Create the "Folder Hierarchies" under the Exchange Administrative Group

     

    1. Right click on Exchange Administrative Group

    2. Select New Object

    3. Select msExchPublicFolderTreeContainer for the class and click Next

    4. Enter the following for the value: Folder Hierarchies, click Next

    5. Click Finish

     

    Create Public Folder Tree Object

     

    1. Right click CN=Folder Hierarchies -> New Object

    2. Selected msExchPFTree for the class

    3. For the value we entered, "Public Folders" and clicked next

    4. Clicked on the "More Attributes" button, selected msExchPFTreeType and set the

    value to 1. Note: This is very important that this value is set to a value of 1 as

    this tells Exchange that this is a MAPI Tree

    5. Click Ok and then finish

     

    Populate msExchOwningPFTreeBL attribute object of the PF Stores in the organization

    (Since this attribute is not directly editable, you have to follow the below steps

    to do this for each PF store)

     

    1. Get properties of the newly created "Public Folders" Tree object in ADSIEdit.

    2. Copy the distinguishedname value to the clipboard and then click cancel.

    3. Navigate to the Storage group that contains the Public Folder Store for this

    server and get properties of the server.

    4. Locate the msExchOwningPFTree attribute and paste in the value that was copied

    to the clipboard in step 2. Click OK.

    5. Restart the Information Store Service

    6. Now try to  mount the PF store and see if we can access it fine now.

     

    After recreating  'Folder Hierarchies' PF working fine.

    Thanks, Milind and Mike for quick respond. and special thanks for Sonny1.


     

     

    • Marked as answer by Heymish Saturday, June 6, 2009 2:26 AM
    Saturday, June 6, 2009 2:26 AM

All replies

  • using err.exe you can see more information:

    C:\ToolShed\Utilities\Err>Err.exe , 0x80040111
    # NOT FOUND: ,
    # for hex 0x80040111 / decimal -2147221231 :
      ecLoginFailure                                                ec.h
      MAPI_E_LOGON_FAILED                                           mapicode.h
      CLASS_E_CLASSNOTAVAILABLE                                     winerror.h
    # ClassFactory cannot supply requested class
    # 3 matches found for "0x80040111"

    more here: http://support.microsoft.com/default.aspx/kb/222066, http://support.microsoft.com/kb/918006

    What else have you changed as part of your migration process?  Have you adjusted x400 addresses, or deleted exchange groups yet?
    Mike Crowley: MCT, MCSE, MCTS, MCITP: Enterprise Administrator / Messaging Administrator
    Friday, June 5, 2009 12:48 PM
  • In addition to Mike's suggestion I would check to see the permissions for the server object on Public folder database as well. Error code 0x80004005 suggests a permissions issue on database uts-MS01\Second Storage Group\Public Folder Database. You can check to see if the exchange servers group or the exchange server object itself has correct permissions on it.

    M
    Milind Naphade | MCTS:M | http://www.msexchangegeek.com RSS Feed
    Friday, June 5, 2009 3:36 PM
  •  
    When I did the migration I couldn’t remove ex2003 properly, even though all mailboxes and PF and FREE/BUSY information were transferred I couldn’t uninstall EX2003 server, so I used adsiedit.msc to remove left over AD attribute. Then I was able to uninstall EX2003. Exchange 2007 worked fine until recently PF stop working.

    While searching in the forum, I found a solution,

    I’m sure I didn’t remove “Folder Hierarchies” with adsiedit, not sure what happened there?

    BY Sonny1

    Open adsiedit.msc.

     

    Select Configuration-Configuration-Services-Microsoft Exchange-Orgname-Administrative Groups-Exchange Administrative Group.

     

    Now we were missing the 'Folder Hierarchies' folder - how I still am unsure of. All we had to do was recreate it as follows:

     

    Create the "Folder Hierarchies" under the Exchange Administrative Group

     

    1. Right click on Exchange Administrative Group

    2. Select New Object

    3. Select msExchPublicFolderTreeContainer for the class and click Next

    4. Enter the following for the value: Folder Hierarchies, click Next

    5. Click Finish

     

    Create Public Folder Tree Object

     

    1. Right click CN=Folder Hierarchies -> New Object

    2. Selected msExchPFTree for the class

    3. For the value we entered, "Public Folders" and clicked next

    4. Clicked on the "More Attributes" button, selected msExchPFTreeType and set the

    value to 1. Note: This is very important that this value is set to a value of 1 as

    this tells Exchange that this is a MAPI Tree

    5. Click Ok and then finish

     

    Populate msExchOwningPFTreeBL attribute object of the PF Stores in the organization

    (Since this attribute is not directly editable, you have to follow the below steps

    to do this for each PF store)

     

    1. Get properties of the newly created "Public Folders" Tree object in ADSIEdit.

    2. Copy the distinguishedname value to the clipboard and then click cancel.

    3. Navigate to the Storage group that contains the Public Folder Store for this

    server and get properties of the server.

    4. Locate the msExchOwningPFTree attribute and paste in the value that was copied

    to the clipboard in step 2. Click OK.

    5. Restart the Information Store Service

    6. Now try to  mount the PF store and see if we can access it fine now.

     

    After recreating  'Folder Hierarchies' PF working fine.

    Thanks, Milind and Mike for quick respond. and special thanks for Sonny1.


     

     

    • Marked as answer by Heymish Saturday, June 6, 2009 2:26 AM
    Saturday, June 6, 2009 2:26 AM
  •  
    When I did the migration I couldn’t remove ex2003 properly, even though all mailboxes and PF and FREE/BUSY information were transferred I couldn’t uninstall EX2003 server, so I used adsiedit.msc to remove left over AD attribute. Then I was able to uninstall EX2003. Exchange 2007 worked fine until recently PF stop working.

    While searching in the forum, I found a solution,

    I’m sure I didn’t remove “Folder Hierarchies” with adsiedit, not sure what happened there?

    BY Sonny1

     

    Open adsiedit.msc.

     

    Select Configuration-Configuration-Services-Microsoft Exchange-Orgname-Administrative Groups-Exchange Administrative Group.

     

    Now we were missing the 'Folder Hierarchies' folder - how I still am unsure of. All we had to do was recreate it as follows:

     

    Create the "Folder Hierarchies" under the Exchange Administrative Group

     

    1. Right click on Exchange Administrative Group

    2. Select New Object

    3. Select msExchPublicFolderTreeContainer for the class and click Next

    4. Enter the following for the value: Folder Hierarchies, click Next

    5. Click Finish

     

    Create Public Folder Tree Object

     

    1. Right click CN=Folder Hierarchies -> New Object

    2. Selected msExchPFTree for the class

    3. For the value we entered, "Public Folders" and clicked next

    4. Clicked on the "More Attributes" button, selected msExchPFTreeType and set the

    value to 1. Note: This is very important that this value is set to a value of 1 as

    this tells Exchange that this is a MAPI Tree

    5. Click Ok and then finish

     

    Populate msExchOwningPFTreeBL attribute object of the PF Stores in the organization

    (Since this attribute is not directly editable, you have to follow the below steps

    to do this for each PF store)

     

    1. Get properties of the newly created "Public Folders" Tree object in ADSIEdit.

    2. Copy the distinguishedname value to the clipboard and then click cancel.

    3. Navigate to the Storage group that contains the Public Folder Store for this

    server and get properties of the server.

    4. Locate the msExchOwningPFTree attribute and paste in the value that was copied

    to the clipboard in step 2. Click OK.

    5. Restart the Information Store Service

    6. Now try to  mount the PF store and see if we can access it fine now.

     

    After recreating  'Folder Hierarchies' PF working fine.

    Thanks, Milind and Mike for quick respond. and special thanks for Sonny1.


     

     


    Fantastic Post - After a few hours of trawling through various postings this one worked a treat !! many thanks, much appreciated.  I deleted and recreated...took me a little while to locate the group that contained the PFS, otherwise perfect !!
    Tuesday, June 16, 2009 11:42 AM
  • Just install a new Exchange and Remove the old.

    When I open the new Exchange, I got a "PublicFolderHierarchy is mandatory" error

    Try to update the Hierarchy in the Tools and got another error
    "No MAPI public tree was not found" <- search that on Google & got only 2 hits

    Did the steps above and a few minutes later...
    Got it working!! I can access the PF.

    Thanks guys!!!!

    Wednesday, July 8, 2009 6:19 PM
  • I upgraded from Exchange 2003 to 2007. First of all, Microsoft needs to put MORE INFO for that procedure.

    In case you are planning to upgrade from 2003 to 2007 you should read this first: 

    http://technet.microsoft.com/en-us/library/bb288905.aspx 
    How to remove the last Legacy Exchange Server from Organization

    In fact, there you will find the proper procedure yo MOVE the Public Folders from 2003 to 2007, step that must be done BEFORE killing the Exchange 2003 server. 

    By the way, this procedure here indicated to recreate the PF hierachy works perfectly. Got my PF working and everything is smooth again.
    Monday, August 17, 2009 2:06 PM
  • FYI - This also works for Exchange 2010. I had the same problems after a shoddy Exchange 2003 decommission.

    Here's some tags to toss in here for other people that are searching:

    Exchange 2010 Public Folder Corrupt

    Exchange 2010 Public Folder missing attributes

    Exchange 2010 Public Folder invalid data

    Exchange 2010 Public you must provide a value for this property

    Thanks!

    Brad

    Thursday, March 25, 2010 3:27 PM
  • FYI - This also works for Exchange 2010. I had the same problems after a shoddy Exchange 2003 decommission.

    Here's some tags to toss in here for other people that are searching:

    Exchange 2010 Public Folder Corrupt

    Exchange 2010 Public Folder missing attributes

    Exchange 2010 Public Folder invalid data

    Exchange 2010 Public you must provide a value for this property

    Thanks!

    Brad

    Thursday, March 25, 2010 3:28 PM
  • Hello all,

    Tried the solution also and i got the PF store mounted again. And the warning tht says that the PF store is corrupted is gone, but it still doesnt work. Outlook 2003 clients are still getting the message that the system administrator has disabled their version of Outlook. When I open PF management tool of Exchange 2010 i get the error 'Couldn't find a MAPI public folder tree'.

    Anybody idea's???

    One thing I am uncertain about is the the following:

    3. Navigate to the Storage group that contains the Public Folder Store for this

    server and get properties of the server.

    4. Locate the msExchOwningPFTree attribute and paste in the value that was copied

    to the clipboard in step 2. Click OK.

    I am not sure i found the right "server properties" Is this

    Configuration-Configuration-Services-Microsoft Exchange-Orgname-Administrative Groups-Exchange Administrative Group-CN=Exchange Administrative Group (FYDIBOHF23SPDLT)-CN=Databases-CN=Public Folder Database 1506563856 and then the object in the right pane (wich is the server name). ?

    • Edited by Mark Meelhuysen Monday, March 29, 2010 7:51 PM Forgotten information
    Monday, March 29, 2010 7:47 PM
  • I finally managd to locate the msExchOwningPFTree object.

    The clients are able to connect again, so that problem is solved.

    I only still get the error "Couldn't find a MAPI public folder tree" in the Public Folder Management console.

    Anyone any idea's on that?

    Monday, March 29, 2010 8:46 PM
  • I had a botched 2003SBS to 2008SBS install where the decommissioned server would not uninstall exchange.  This worked like a champ!

    For what it's worth, I found the msExchOwningPFTree in the following location.

    Configuration-Configuration-Services-Microsoft Exchange-Orgname-Administrative Groups-Exchange Administrative Group - Servers - Server Name - InformationStore - Second Storage Group.  Goto Properties of Public Folder Database and paste the distinguished name in the msExchOwningPFTree field.

    Tuesday, August 10, 2010 10:21 PM
  •  

    where exactly did you find this - I cant find it either

     

    stuck here:

     

    3. Navigate to the Storage group that contains the Public Folder Store for this

    server and get properties of the server.

    4. Locate the msExchOwningPFTree attribute and paste in the value that was copied

    to the clipboard in step 2. Click OK.

    thanks

    Wednesday, October 6, 2010 2:32 PM
  •  

    You go back to ADSIEdit. Administrative Groups | Exchange Administrative Group | Servers | Your Server | Information Store | Second Storage Group (most likely). Select this, and on the right pane, right-click on the object that appears. Search for the attribute as indicated and click on edit. Follow the rest of the instructions.

    Thursday, October 14, 2010 2:14 PM
  • Sonny1's solution worked for me also when my Public Folders stopped working when I deleted the AdminGroup containing an old decommisioned Exchange Server 2003 in ADSIEdit. I was sweating bullets but recreating a vaild Public Folders Heirarchy for Exchange 2007 was exactly what I needed to do to fix the issue. No restoring AD trees needed, thank goodness.
    Wednesday, September 28, 2011 11:10 PM