locked
Exception Error 0x80020009 when trying to Activate "Office Sharepoint Server Publishing Infrastructure"

    Question

  • Hello,

     

    when trying to activate "Office Sharepoint Server Publishing Infrastructure" on the site collection features page, I end up with the following error :

     

    Exception occurred. (Exception from HRESULT: 0x80020009 (DISP_E_EXCEPTION))

     

    Browsing through the logs I found some additional infos : but here I'm stuck :

     

    The element of type 'ContentTypeBinding' for feature 'PublishingResources' (id: aebc918d-b20f-4a11-a1db-9ed84d79c87e) threw an exception during activation: Exception occurred. (Exception from HRESULT: 0x80020009 (DISP_E_EXCEPTION)) 

     

    Feature Activation: Threw an exception, attempting to roll back.  Feature 'PublishingResources' (ID: 'aebc918d-b20f-4a11-a1db-9ed84d79c87e').  Exception: Microsoft.SharePoint.SPException: Exception occurred. (Exception from HRESULT: 0x80020009 (DISP_E_EXCEPTION)) ---> System.Runtime.InteropServices.COMException (0x80020009): Exception occurred. (Exception from HRESULT: 0x80020009 (DISP_E_EXCEPTION))     at Microsoft.SharePoint.Library.SPRequestInternalClass.GetMetadataForUrl(String bstrUrl, Int32 METADATAFLAGS, Guid& pgListId, Int32& plItemId, Int32& plType, Object& pvarFileOrFolder)     at Microsoft.SharePoint.Library.SPRequest.GetMetadataForUrl(String bstrUrl, Int32 METADATAFLAGS, Guid& pgListId, Int32& plItemId, Int32& plType, Object& pvarFileOrFolder)  

     

    I tried to activate the feature with STSADM, without success (it gives a success but still doesn't works).

    I also tried the solution of changing app pool, resetting IIS, enabling, reverting pool, resetting IIS, without success.

     

    Thanks in advance for your help!

    Max

     

    Tuesday, June 24, 2008 1:09 PM

Answers

  • I followed Chris Winebarger method and it worked. But...

    But unfortunately, I could not create pages under the top-level site (the error message is "The site is invalid. The 'Pages' document library cannot be found", sth like that).
    Furthermore, the menu item "Modify Navigation" was disabled (grayed out) under Site Actions-->Site Settings, although I could access it by typing in the URL in the browser.

    The following is what I did to solve my problem:

    1. Deleted the site collection
    2. Recreated the site collection
    3. Using STSADM command line tool, activated the following:
        - "PublishingPrerequisites" (stsadm -o activatefeature -filename PublishingPrerequisites\feature.xml -url http://MyUrl)
        - "PublishingSite" (stsadm -o activatefeature -filename PublishingSite\feature.xml -url http://MyUrl)
        - "PublishingWeb" (stsadm -o activatefeature -filename PublishingWeb\feature.xml -url http://myurl/)

    After that, I could create pages under the top-level site, and the "Modify Navigation" link worked again.



    Wednesday, December 03, 2008 8:40 AM
  • I was getting the exact same error.  Microsoft WILL be publishing an article about this in the near future because it has affected countless customers.  These STSADM commands allowed me to enable the publishing infrastructure on a particular site collection that was generating the error when I tried to activate.

     

    stsadm -o activatefeature -filename publishing\feature.xml -url http://URL -force

    stsadm -o activatefeature -filename publishingresources\feature.xml -url http://URL  -force

    stsadm -o activatefeature -filename publishingSite\feature.xml -url http://URL -force

    stsadm -o activatefeature -filename publishingweb\feature.xml -url http://URL -force

    stsadm -o activatefeature -filename publishinglayouts\feature.xml -url http://URL -force

    stsadm -o activatefeature -filename navigation\feature.xml -url http://URL -force

    (Obviously, replace the URL above with the URL of the site collection)

    Friday, July 18, 2008 7:34 PM

All replies

  • *bump* has anyone encoutered the same problem yet?
    thnx
    max
    Thursday, June 26, 2008 8:50 AM
  • Maybe check the elements file in the PublishingResources feature to see what the ContentTypeBinding is pointing to? Maybe the item that it's trying to bind to no longer exists.
    Thursday, June 26, 2008 8:51 PM
  • Hi Lawrence, thanks for the hint. I was able to track down the following line in the PublishingContentTypes.xml located in C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\TEMPLATE\FEATURES\PublishingResources\



    <ContentTypeBinding ContentTypeId="0x01010007FF3E057FA8AB4AA42FCB67B453FFC100E214EEE741181F4E9F7ACC43278EE811" ListUrl="_catalogs/masterpage" />

    This is the last line of the file, it's followed by the ending tag </Elements>

    Tracking the contentTypeID, it seems to report to the master page, but I can't put my finger on what's buggy yet...
    Friday, June 27, 2008 7:32 AM
  • Hi,

     

    I've done a bit of research but also can't really find much. ContentTypeId '0x01010007FF3E057FA8AB4AA42FCB67B453FFC100E214EEE741181F4E9F7ACC43278EE811' is the Page Layout content type (see), so it might be that the Page Layout content type is missing or that there's something wrong with it?

     

    Also, maybe some of these suggestions will help:

    • Try accessing the Page Layout content type via the interface to see if it exists and is working correctly
    • Run the SharePoint Products and Technologies Configuration Wizard (suggestion from here)
    • Go to Site Central Admin, User Permissions for Web Application and enable "Use Client Integration Features" and "Use Remote Interfaces" (suggestion from here)
    • Reinstall SharePoint?
    Friday, June 27, 2008 9:00 AM
  • Hello Lawrence,

    I've run into all these sites unfortunately without any further success.

    • Try accessing the Page Layout content type via the interface to see if it exists and is working correctly
    If the page is http://portal/_catalogs/masterpage/DefaultLayout.aspx then yes I can access it
    • [DONE - NO SUCCESS] Run the SharePoint Products and Technologies Configuration Wizard (suggestion from here)
    • [ALREADY ENABLED] Go to Site Central Admin, User Permissions for Web
      Application and enable "Use Client Integration Features" and "Use
      Remote Interfaces" (suggestion from here)
    • [OUCH !!!!!] Reinstall SharePoint?
    I'm certain now that the problem is related to some kind of feature listed in the Navigation element
    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\TEMPLATE\FEATURES\Navigation\NavigationSiteSettings.xml ... the logs indicate that it's where the exception is thrown.

    The ContentTypeBinding element is now 0x0101000F1C8B9E0EB4BE489F09807B2C53288F0054AD6EF48B9F7B45A142F8173F171BD1
    (Publishing Master Page)

    Would you happen to know which file it is ?

    Thanks very much,
    Max
    Friday, June 27, 2008 11:24 AM
  • Max, unfortunately I just encountered the same issue as you.  Not sure what changes have occurred that would have brought about such an error.  My SharePoint trace logs are producing a very similar error to the one you posted everytime I attempt to activate Office Publishing. 

    The error occurs on all new site collections that I create. 

    Let me know if you have found a fix. 

    Matt
    Monday, July 07, 2008 1:54 PM
  • Hi Matt,

    I will certainly update this post if I find a solution. Can you tell me a bit more about how your Sharepoint is set up ?

    I was never able to activate Office Publishing as of now. This is our first Sharepoint implementation and besides that it works pretty well, so I'm reluctant to start again from the beginning.

    Good luck to you as well,
    Max
    Monday, July 07, 2008 2:41 PM

  • I will be swamped for a couple of days; however, I figured I would post my gameplan to resolve this problem. You might want to give it a try as well....it won't affect anything you have in production.

    In summary, I will be backup up my existing SharePoint web application, creating a new (temporary) web application, and then performing a restore on that temp web app. Once the temp web app is up and running, I will create a new site collection and attempt to Activate the publishing feature.

    If you haven't done this test already, I would encourage you to do so. If it works for you, I can tell you how to turn that "temporary" web application into your "production" web application.

    Here are the steps in detail (sorry, I'm not sure of your SharePoint experience so I'm being exhaustive.....)

    1. Backup of the problematic web application
    stsadm.exe -o backup -url http://sharepointname -filename c:\backup

    2. Create a new web application
    Use Central Admin to do this. Accept the defaults. Be sure to create a new database to host it.

    3. Restore the backup to the new web application
    stsadm.exe -o restore -url http://newwebapplication -filename c:\backup

    Anyway, when I get a chance, I'll try this out myself.

    -- Matt



    Tuesday, July 08, 2008 12:16 PM
  • Max,  I forgot one thing........

    Step 4.  Create a new site collection and attempt to Activate the publishing feature.

    The reason I stress "new site collection" is because that often does the trick. 

    -- Matt
    Tuesday, July 08, 2008 12:19 PM
  • Hi Matt, thanks for your hints. I've tested it however I had exactly the same error. The only thing I see would be now to do a fresh Sharepoint installation on another machine and have a look at it again.

    Let's hope we'll find a workaround for that.

    Best Regards,
    Max
    Wednesday, July 09, 2008 11:02 AM
  • I was getting the exact same error.  Microsoft WILL be publishing an article about this in the near future because it has affected countless customers.  These STSADM commands allowed me to enable the publishing infrastructure on a particular site collection that was generating the error when I tried to activate.

     

    stsadm -o activatefeature -filename publishing\feature.xml -url http://URL -force

    stsadm -o activatefeature -filename publishingresources\feature.xml -url http://URL  -force

    stsadm -o activatefeature -filename publishingSite\feature.xml -url http://URL -force

    stsadm -o activatefeature -filename publishingweb\feature.xml -url http://URL -force

    stsadm -o activatefeature -filename publishinglayouts\feature.xml -url http://URL -force

    stsadm -o activatefeature -filename navigation\feature.xml -url http://URL -force

    (Obviously, replace the URL above with the URL of the site collection)

    Friday, July 18, 2008 7:34 PM
  • Hi Chris,

    thank you so much, you helped me enable this feature, I had lost hope to make it work! It just caused me to shout, to run out shouting and having some good nervous laugh, and having people clap their hands when I got back in office Big Smile Big Smile
    Monday, July 21, 2008 8:13 AM
  • Works for me as well!!!  Thank you so much!

    Matt
    Monday, July 21, 2008 12:27 PM
  • wow, glad that it works for you too!

    I've made a little post about it on my blog : http://ntoskrnl.wordpress.com Smile

    Many thanks again to Chris! Big Smile
    Monday, July 21, 2008 2:49 PM
  • Glad I could help!  I can't take the credit for coming up with the solution... but I'll take the credit for sharing it.  

     

    Monday, July 21, 2008 5:25 PM
  • Thanks you Chris. I've been trying to solve this problem for 8 hours when I came across your posting. Thank you!
    Friday, September 12, 2008 9:43 AM
  • I followed Chris Winebarger method and it worked. But...

    But unfortunately, I could not create pages under the top-level site (the error message is "The site is invalid. The 'Pages' document library cannot be found", sth like that).
    Furthermore, the menu item "Modify Navigation" was disabled (grayed out) under Site Actions-->Site Settings, although I could access it by typing in the URL in the browser.

    The following is what I did to solve my problem:

    1. Deleted the site collection
    2. Recreated the site collection
    3. Using STSADM command line tool, activated the following:
        - "PublishingPrerequisites" (stsadm -o activatefeature -filename PublishingPrerequisites\feature.xml -url http://MyUrl)
        - "PublishingSite" (stsadm -o activatefeature -filename PublishingSite\feature.xml -url http://MyUrl)
        - "PublishingWeb" (stsadm -o activatefeature -filename PublishingWeb\feature.xml -url http://myurl/)

    After that, I could create pages under the top-level site, and the "Modify Navigation" link worked again.



    Wednesday, December 03, 2008 8:40 AM
  • NGDev,
    Your solution worked great! I had exactly the same problem and this fixed it.

    -Steve
    Thursday, December 11, 2008 7:07 PM
  • As I posted here: http://social.technet.microsoft.com/Forums/en-US/sharepointadmin/thread/b0a54b5f-a37f-4a4a-b15a-77ac17c69418 I get that error after activating CKS EBE, due to a HttpModule issue deployed by the solution. Try deactivating all 3rd party solutions and check HttpModules in web.config
    Blog de Barto Molina
    Microsoft MCP 6608632
    Saturday, February 07, 2009 2:32 PM
  • Worked for me!!!  Thank you so much!
    Keep the good work going.

    Tanuj
    Monday, April 27, 2009 11:11 AM
  • This post is useful. Thanks
    Thursday, November 12, 2009 1:41 PM
  • I had the same issue when activating the feature, and Chris' solution worked for activating it. I am, however, still getting the same exact exception when trying to access Edit Page > Page > Page Settings and Schedules. Any thoughts as to the root of the problem? I am not able to delete the site colection.
    Tuesday, December 29, 2009 2:47 PM
  • Thanks a lot Chris W. ...your suggestion worked like magic.
    you are a life saver indeed!!
    Kepp up the good work.
    Monday, January 25, 2010 5:51 PM
  • Hi chris,
    i tried stsadm -o activatefeature -filename publishing\feature.xml -url http://URL -force but i m getting failed to find XML file

    Tuesday, February 23, 2010 12:35 PM
  • Hi datke1. Have you tried cheking your HttpModules, as I suggested?
    Microsoft MCP 6608632
    Tuesday, February 23, 2010 1:31 PM
  • If you have CKS.EBE installed you will need to remove reference to the assembly and modules as noted by Bartomolina within your web.config file.

    After removing all references to CKS.EBE I can now cleanly activate Office SharePoint Server Publishing Infrastructure within the site collection settings.


    I am rock, nerf paper!
    Tuesday, June 29, 2010 4:18 AM
  • I was getting the same error message whenever I tried to edit webparts on a site which was based on a customized Publishing site definition. I finally noticed that the feature which contained the definition of my custom Publishing site was missing. In the log files I found a lot of errors about a particular feature guid which could not be accessed. After I reinstalled the feature, I was able to edit the webparts on the custom site without having to delete and recreate the whole site. It seems like one cause for this error is when the definition for something is corrupted or deleted. I would check to make sure that the feature or solution package containing the definitions of whatever site is causing the error is correctly deployed before deleting the entire site collection.
    Tuesday, August 10, 2010 2:35 PM
  • This happens when the SPWeb.Properties property bag gets corrupted, this happens often on large SharePoint Sites, specifically where content databases get moved around or content deployment jobs run (or any other type of replication). The property bag holds information regarding navigation and IDs of things like the Pages list for the site and other things the publishing infrustructure uses. I have written code that uses the property bag for it's own purposes, and have learnt that the property bags in SP can not be trusted... Why Microsoft used it for anything important is beyond me (in my opinion, they should rather use serialised objects with a persistance model similar to the timer jobs, and maybe some type of code access security)... When this property bag gets corrupted, you need to re-activate whatever feature added the missing properties to begin with.
    Tuesday, August 17, 2010 3:47 PM
  • Chris:

    Three years later, it still works 8-).

     

    Thanks very much.

    Josh

    Monday, November 21, 2011 2:37 PM
  • It didn't work for me either. I kept receiving the following error message: 

    The Web application at https://SharePointSite could not be found. Verify th
    at you have typed the URL correctly. If the URL should be serving existing conte
    nt, the system administrator may need to add a new request URL mapping to the in
    tended application.

    I then realized that I was logged on with my server admin account. I connected with my SharePoint Farm account, and then I was able to active the features.


    Tuesday, January 24, 2012 9:23 PM