none
Error: TypeError: Unable to get property 'replace' of undefined or null reference

    Question

  • All,

    on a list page, I am seeing the following error repeated multiple times and the list never displays:

    TypeError: Unable to get property 'replace' of undefined or null reference

    I can see the ribbon and the various formatting elements.

    I have discovered that if I use the ribbon to change to a view that isn't using a particular column, the error goes away.  the column giving me trouble is the title column when it is using the "linked to item with edit menu".

    I can change it to use the title with "linked to item" only and the error goes away.

    FYI, it was working when I left for the day but the next morning this error was occuring, so i'm super confused about any changes that may have caused it.

    any ideas what I may have done to cause this?

    Wednesday, January 13, 2016 5:50 PM

Answers

All replies

  • i forgot to mention this is happening on multiple lists in the same site.
    Wednesday, January 13, 2016 5:53 PM
  • Got the same issue. It looks like "Security Update for Microsoft SharePoint Foundation 2013 (KB3114503)  farm-deployment " to blame.

    kb3114497 (CU Jan 2016) helps:

    • kb3114497 (CU Jan 2016) after KB3114503 solves the problem
    • kb3114497 (CU Jan 2016) before KB3114503 leads to Windows doesn't require KB3114503

    Just another prove to
    a) test any patch/CU before production
    b) turn off automatic windows update

    Wednesday, January 13, 2016 6:52 PM
  • We are having the same issues. I verified the health of the sharepoint site. When looking at the changes to the system the SharePoint Foundation Security Update for Jan 2016 (KB3114503) (Released 1/12/2016) was installed this morning. https://blogs.technet.microsoft.com/stefan_gossner/2016/01/12/january-2016-cu-for-sharepoint-2013-product-family-is-available-for-download/ This update is unable to be removed after installation.
    Wednesday, January 13, 2016 6:55 PM
  • I am having this issue as well, and have that same patch installed :(
    Wednesday, January 13, 2016 7:00 PM
  • hmm, might be patch related.  I was having the issue starting early this morning.  i didn't install the patch until after I saw the error.

    but out of curiosity, did all of you have SP1 installed?  i saw a mention that the update will have issues if SP1 is not install first.

    Also, did anyone run psconfig after the update completed?  I am trying that now per the article timothy mentioned

    Wednesday, January 13, 2016 7:14 PM
  • We received the same error. I tried running the SharePoint configuration wizard and the psconfig command line utility with no change in error behavior. I decided to do a full server restore from backup. We are up and running again but I'm afraid to update the server now. Hopefully Microsoft pulls this bad patch from windows updates.    
    Wednesday, January 13, 2016 7:16 PM
  • I just confirmed that I already had SP1 installed, so that isn't my problem.  it's really shaping up to be a bad patch apparently
    Wednesday, January 13, 2016 7:20 PM
  • linking to others with the same issue:

    http://sharepoint.stackexchange.com/questions/167034/sharepoint-2013-jan-2016-updates

    Wednesday, January 13, 2016 7:41 PM
  • A workaround is to change views from Title (linked to Edit) to Title (Linked to Item)
    Wednesday, January 13, 2016 8:08 PM
  • We too had this issue.. I installed the Jan cumulative and the issue is now resolved. (we had the foundation update installed from yesterday too that caused the issue).. the JAN cumulative solved the unwanted behavior.

    https://support.microsoft.com/en-us/kb/3114492 

    Thanks

    Kent

    Wednesday, January 13, 2016 8:21 PM
  • We had the same issue, very slow sharepoint while showing lists with Hyperlinks. we also had the same errors. Error: TypeError: Unable to get property 'replace' of undefined or null reference. the search function was also broken.

    Cumulative update for SP Foundation 2013 janari 12 (KB3114492) did the trick!

    Thanks,

    Tim


    Wednesday, January 13, 2016 8:46 PM
  • I'm having the exact same problem described. I try and install the Jan update above and it tells me the expected version of the product was not found on my system! I have double and triple checked I have SP1 for SharePoint 2013 foundation installed!

    I'm going crazy. I have a call into microsoft, but they are taking forever.

    Wednesday, January 13, 2016 9:37 PM
  • Update: I re-ran the SP1 install. It went through super fast (~10 seconds) and said it succeeded. Now the Jan update is installing!
    Wednesday, January 13, 2016 9:54 PM
  • Apply the January 2016 Cumulative Update for SharePoint 2013 (Foundation, Server, or Project). This should resolve the issue.

    Trevor Seward

            

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.


    Wednesday, January 13, 2016 10:01 PM
    Moderator
  • Applied the January 2016 Cumulative Update for SharePoint 2013 (Foundation, Server, or Project) and all is well. Thanks everyone for your input....it is greatly appreciated.
    Wednesday, January 13, 2016 11:14 PM
  • Thank you so much Tim Borremans. I had a same problem with you and then it's gone
    Thursday, January 14, 2016 6:41 AM
  • a) test any patch/CU before production

    Wouldn't it be better and a better world if companies actually TESTED BEFORE RELEASING PATCHES?

    Thursday, January 14, 2016 4:27 PM
  • That does not 100% solve that problem. When you've a multilanguage farm - e.g. basic german SharePoint installation but additional languages (most English on our sites) - the list on the site with the basic language are repaired but on all other languages the lists are still crap.

    In this case on concerned systems an immense damage results from that.   

         
    Friday, January 15, 2016 11:19 AM
  • Hi Guys,

    here is a solution for the problem, released by MS

    h ttps://blogs.technet.microsoft.com/stefan_gossner/2016/01/15/solution-for-the-list-view-issue-with-ms16-004-january-2016-pu-for-sharepoint-2013/#comments

    sorry cant submit link

    Friday, January 15, 2016 12:34 PM
  • Hello, 

    I have installed KB3114503 and I have the "Error: TypeError: Unable to get property 'replace' of undefined or null reference" problem but i am not able to install the kb3114497 (CU Jan 2016), it says:

    "The expected version of the product was not found on the system"

    What can I do to be able to install the CU?

    P.S. I have SharePoint Server SP1 installed already.

    thank you.

    Friday, January 15, 2016 5:16 PM
  • Hello, how were you able to re-run the SP1 install? every time I try to do it, i get a message saying i have already installed it.
    Friday, January 15, 2016 5:19 PM
  • When you've installed language packages, remove them, install then the CU and as the last step is to reinstall the language packages again.

     
    Friday, January 15, 2016 5:20 PM
  • Hello All:

    Stefan has just updated the fix to this issue.  Basically some missing "localized msp file.".  See here https://blogs.technet.microsoft.com/stefan_gossner/2016/01/15/solution-for-the-list-view-issue-with-ms16-004-january-2016-pu-for-sharepoint-2013/. This saved us a lot of effort.  Cheers..AG


    Ashok

    Updated on 1/27/2016

    =============

    I installed the missing files released under KB 3114508 – Download location: https://www.microsoft.com/en-us/download/details.aspx?id=50667 and it fixed the issue.  Please note we are not using any language packs besides default English.

    Friday, January 15, 2016 8:44 PM
  • any update for Multilanguage farm?

    the KB3114508 solution just fixed English sites.


    ----

    « Accept Me as Me »

    Monday, January 18, 2016 8:39 AM
  • Hi everyone,

    After installing KB 3114503 for SharePoint Foundation 2013 or SharePoint Server 2013, list views in SharePoint may stop working.

    To resolve this issue, install KB 3114508.

    https://support.microsoft.com/en-us/kb/3114508

    Anahita

    Monday, January 18, 2016 10:18 PM
  • Just to let people know I have installed KB3114503  and it's fixed my list issue.

    It has also fixed my broken search crawler which was a result of recent windows patching.  I'm going to run some more tests now but things 'appear' to look ok now!  I also had a certificate trust issue which looks resolved by KB3114503.


    • Edited by MJ2012 Thursday, January 21, 2016 10:01 AM typo
    Thursday, January 21, 2016 10:00 AM
  • A workaround is to change views from Title (linked to Edit) to Title (Linked to Item)

    i am facing this issue today, i have an issue tracking list which use to work well,, but today i start having this problem.. so as a workaround and as @JRABEAK mentioned i changed the views columns from Title (linked to Edit) to Title (Linked to Item) and now the list is showing well... so not sure if this is a permanent fix ? or i need to install the latest CU ??
    Friday, January 22, 2016 2:49 AM
  • Hi John, did you try installing the January 12, 2016, update, (SharePoint Foundation 2013 (KB3114508)?
    • Proposed as answer by Jesper Arnecke Tuesday, January 26, 2016 11:55 AM
    Monday, January 25, 2016 7:07 PM
  • I have a polish version as default and english as language pack. After installing kb3114497 problem with lists is solved only in defalut (polish) version.

    I was able to install kb3114497 after deinstalling language pack as Guy Jascht has written.

    How to repair lists in english version?


    • Edited by MkCies Wednesday, January 27, 2016 10:17 AM
    Wednesday, January 27, 2016 10:17 AM
  • Cumulative update for SP Foundation 2013 janari 12 (KB3114492) did the trick!

    The January 2016 Cumulative Update for SharePoint 2013 (Foundation, Server, or Project). This should resolve the issue.

    • Proposed as answer by SP2013GK Tuesday, March 1, 2016 7:57 AM
    Wednesday, January 27, 2016 12:09 PM
  • I've read update from Stefan Goßner:

    [Update – January 25th, 2016] A couple of customers reported that the fix from 3114508 does not install or that the issue still occurs after installing it for some languages. Our analysis shows that in each of these cases SP1 was missing – either for the core product or for one of the language packs. You can use the following script to verify the patch baseline (means the installed service pack level): http://blogs.technet.com/b/stefan_gossner/archive/2015/04/20/powershell-script-to-display-version-info-for-sharepoint-product-and-language-packs.aspx

    It turned out that I hadn't had SP1 for language pack

    DisplayName    : Microsoft SharePoint Foundation 2013
    DisplayVersion : 15.0.4571.1502

    DisplayName    : Language Pack for SharePoint Foundation 2013  - English
    DisplayVersion : 15.0.4420.1017

    After installing SP1 to the language pack and then once again kb3114497 the problem is solved! :-) 


    • Edited by MkCies Wednesday, January 27, 2016 12:47 PM
    Wednesday, January 27, 2016 12:46 PM
  • @Anahita as you know that installing SharePoint updates need be carefully managed... and i i need to install it first on test server then test the whole functionalities , before applying the updates on live server.. and i do not see my self doing so at this stage ,,unless there is not any other way to get this solved,,, can you adivce on this please ? 
    Wednesday, January 27, 2016 4:16 PM
  • Hi all,

    I just installed 2016 January 12 (KB3114492) CU to my SharePoint Server 2013 SP1 and successfully ran the PSConfig. Then I verified the build number of my farm to be 15.0.4787.1000. However the issue is still there! When I create an OOTB SharePoint list with default 'Title' column (linked to item with edit menu), I still see:

    "TypeError: Unable to get property 'replace' of undefined or null reference  

    TypeError: Unable to get property 'replace' of undefined or null referenceTypeError: Unable to get property '_events' of undefined or null reference"

    Not using any language packs, just default English.

    WTF???

    EDIT: Fixed with KB 3114508 

     



    • Edited by Lukas_UK Friday, January 29, 2016 12:33 PM
    Friday, January 29, 2016 11:59 AM
  • Hello all,

    Installing January 2016 CU KB3114492 (https://support.microsoft.com/en-us/kb/3114492) resolved the issue.

    Thanks

    Friday, January 29, 2016 9:07 PM
  • Hi John, I know that it takes a lot of time and resources to test an update before deploying in the production environment, but it's still recommended to test before deploying. Please see this topic for more information:

    https://technet.microsoft.com/en-us/library/ff806329.aspx .

    Anahita


    Anahita Bahrami

    Wednesday, February 3, 2016 6:16 PM
  • This workaround worked for me, thanks.
    Monday, February 8, 2016 5:23 PM