none
Lync Control Panel Errors RRS feed

  • Question

  • So I finally got Lync installed on my server. And everything seems to be set up properly and I get the following error when I launch the Lync Control Panel

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Rtc.Server.WebInfrastructure, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Microsoft.Rtc.Server.WebInfrastructure, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' could not be loaded.

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    

    Stack Trace:

    [FileNotFoundException: Could not load file or assembly 'Microsoft.Rtc.Server.WebInfrastructure, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.]
      System.RuntimeTypeHandle._GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark, Boolean loadTypeFromPartialName) +0
      System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark) +64
      System.RuntimeType.PrivateGetType(String typeName, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark) +58
      System.Type.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase) +65
      System.Web.Compilation.BuildManager.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase) +342
      System.Web.Configuration.ConfigUtil.GetType(String typeName, String propertyName, ConfigurationElement configElement, XmlNode node, Boolean checkAptcaBit, Boolean ignoreCase) +52
    
    [ConfigurationErrorsException: Could not load file or assembly 'Microsoft.Rtc.Server.WebInfrastructure, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.]
      System.Web.Configuration.ConfigUtil.GetType(String typeName, String propertyName, ConfigurationElement configElement, XmlNode node, Boolean checkAptcaBit, Boolean ignoreCase) +351
      System.Web.Configuration.Common.ModulesEntry..ctor(String name, String typeName, String propertyName, ConfigurationElement configElement) +56
      System.Web.HttpApplication.BuildIntegratedModuleCollection(List`1 moduleList) +146
      System.Web.HttpApplication.GetModuleCollection(IntPtr appContext) +1219
      System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +97
      System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +188
      System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +295
      System.Web.HttpApplicationFactory.GetPipelineApplicationInstance(IntPtr appContext, HttpContext context) +56
      System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +231
    
    [HttpException (0x80004005): Could not load file or assembly 'Microsoft.Rtc.Server.WebInfrastructure, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.]
      System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +8901019
      System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +85
      System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +333
    


    Version Information: Microsoft .NET Framework Version:2.0.50727.4952; ASP.NET Version:2.0.50727.4955

     

    Please Help I have no idea what to do here.

    Server Error in '/cscp' Application.

    Could not load file or assembly 'Microsoft.Rtc.Server.WebInfrastructure, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

     

    Monday, January 24, 2011 9:59 PM

Answers

  • I had this exact same error the other day.  The issue for me was that I had IIS 32-Bit Worker processes enabled on 64-Bit IIS (I am running IIS 7.5 on Server 2008 R2).  The reason it was set that way was because of another web application on that same server that required that 32-bit setting to run.  So I reversed the process by doing this from the command line:

    cscript %SystemDrive%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 0 

    %SYSTEMROOT%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

    <note:  the 0 at the end disables it, to renable it change it to one>

    After that I did an IISreset and it started working again.  However, of course my other web application did not.  This setting above enables it globally for all application pools so I just went in to inetmgr>Application Pools>[name of application pool]>Advanced Settings.  I changed the value of the line "Enable 32-Bit Applications to True for this one isolated Application Pool, left the "Enable 32-Bit Applications to False on all the other Application Pools including the DefaultAppPool, and now both Lync Server Web Applications (and the control panel) and the other web application work fine now.

    Hope this helps.

    • Marked as answer by josh.scott Thursday, September 22, 2011 5:34 PM
    Tuesday, January 25, 2011 8:56 PM

All replies

  • Hi,

    Have you added your user into CSAdministrator's Group ?

     

    I think after that your problem will be resolved.

     

    Regards.

     

    Shafaquat Ali.


    M.C.I.T.P Exchange 2007/2010, M.C.I.T.P Windows Server 2008, M.C.T.S OCS Server 2007 R2, URL: http://blog.WhatDoUC.net Phone: +923008210320
    Tuesday, January 25, 2011 5:13 AM
  • You can also try to install these hotfixes:

    http://www.pro-exchange.be/blogs/ocs_wave_14/archive/2011/01/24/cumulative-update-package-for-lync-2010-january-2011.aspx


    Technical Specialist Microsoft OCS/Lync & UC Voice Specialisation - http://www.uwictpartner.be
    If you think my post is the answer to your question, please mark it as answer so future visitors can easily find it.
    Tuesday, January 25, 2011 8:07 AM
  • Yes my account is a member of the CSAdministrator's Group.
    Tuesday, January 25, 2011 1:14 PM
  • Aren't those for the Lync Client? I will give them a try but what does that have to do with the Lync server?
    Tuesday, January 25, 2011 1:15 PM
  • I had this exact same error the other day.  The issue for me was that I had IIS 32-Bit Worker processes enabled on 64-Bit IIS (I am running IIS 7.5 on Server 2008 R2).  The reason it was set that way was because of another web application on that same server that required that 32-bit setting to run.  So I reversed the process by doing this from the command line:

    cscript %SystemDrive%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 0 

    %SYSTEMROOT%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

    <note:  the 0 at the end disables it, to renable it change it to one>

    After that I did an IISreset and it started working again.  However, of course my other web application did not.  This setting above enables it globally for all application pools so I just went in to inetmgr>Application Pools>[name of application pool]>Advanced Settings.  I changed the value of the line "Enable 32-Bit Applications to True for this one isolated Application Pool, left the "Enable 32-Bit Applications to False on all the other Application Pools including the DefaultAppPool, and now both Lync Server Web Applications (and the control panel) and the other web application work fine now.

    Hope this helps.

    • Marked as answer by josh.scott Thursday, September 22, 2011 5:34 PM
    Tuesday, January 25, 2011 8:56 PM
  • Same error

    windows server 2012 r2  se

    lync 2010

    i just added http activation feature .net 3.5 and it works

    extra i have done (i think not necessary)

    iis manager - application pools - .net 4.5 - advanced settings - enable 32bit applications - true

    Sunday, November 15, 2015 3:23 AM
  • Hey Chad, 

    You saved me lots of efforts by your post! Thank you so much!

    I had other 32-bit apps installed previously on this server indeed.

    Alex

    Sunday, June 3, 2018 4:09 PM