none
Can't get Windows update to download updates for other MS products

    Question

  • Hi,

    Installed W7 Home Premium on a single system and for one or another reason I cannot get Windows Update to download updates for other Microsoft products. MS Office University 365, MS Visual Studio Pro 2013 and Microsoft Expression are also installed on this system.

    I click on Find Out More in the Windows Update page and IE 11 opens. It first goes to http://www.update.microsoft.com/microsoftupdate/v6/vistadefault.aspx?ln=en-au and then redirects to http://www.update.microsoft.com/windowsupdate/v6/thanks.aspx?ln=en&&thankspage=5 .

    Here is a picture of the page:


    As you can see there is no change settings button as described at http://windows.microsoft.com/en-au/windows/change-windows-update-installation-notification#1TC=windows-7 .There is no way I can change settings so updates for other MS products are also downloaded.

    Firefox is my default browser; even if I load the link in Firefox I get the same result.

    Thanks,

    Imran

    Friday, December 13, 2013 11:18 PM

Answers

All replies

  • 1. You should us Microsoft Update instead of Windows Update.

    2. Analyze WindowsUpdate.log

    3. Acces update from Control Panel (set small icons)

    HTH

    Milos

    Friday, December 13, 2013 11:38 PM
  • Don't use a web browser to do that. Since Vista, WindowsUpdates are no longer performed in a web browser, it's in Control Panel. (that's why the www.update.microsoft.com web page is telling you to check Start Menu")

    The Change Settings button, appears in the Windows Update applet in Control Panel.

    Click "Start", and in the search box, type in: Windows Update. Or, look on Start Menu. Or go to Control Panel/System&Security/WindowsUpdate.


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Friday, December 13, 2013 11:51 PM
  • Hi,

    I have also tried this. Here is the picture of the Change Settings screen which is showed after I click on Change Settings from Control Panel -> Windows Update (small icons):

    As you can see there is no option for Microsoft update.

    Not sure what I am doing wrong.

    Thanks for your replies,

    Imran

    Saturday, December 14, 2013 12:10 AM
  • Hmm, that's odd.

    maybe this article/script might help:
    http://myitforum.com/myitforumwp/2012/01/04/workaround-for-installing-office-updates-during-an-image-build/

    In case there is some mis-configuration on your machine, the WU troubleshooter might be able to correct it: http://windows.microsoft.com/en-au/windows7/open-the-windows-update-troubleshooter


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)


    • Edited by DonPick Saturday, December 14, 2013 5:40 AM
    Saturday, December 14, 2013 5:38 AM
  • I just found this, maybe related for you?

    http://social.technet.microsoft.com/Forums/en-US/68fc8092-8480-4c10-ba53-f1a2d23654b2/ie-11-blocks-access-to-quotmicrosoft-updatequot-service?forum=ieitprocurrentver


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    • Marked as answer by iraj1101 Saturday, December 14, 2013 12:57 PM
    Saturday, December 14, 2013 6:52 AM
  • Hi,

    Uninstalled the IE 11 update and now when I click on "Find out more" in Windows Update from IE 10, I get to a point where I can install MS Update.

    Thanks so much for your help :)

    Regards,

    Imran

    Saturday, December 14, 2013 12:58 PM
  • Better way than uninstall IE11 is:

    - add *.microsoft.com in Internet Explorer 11 to trusted sites

    - add microsoft.com in IE to compatibility view

    Apply, close IE then press once again Find out more.

    • Proposed as answer by DMY2000 Wednesday, December 3, 2014 11:42 AM
    Friday, August 29, 2014 7:57 AM
  • Better way than uninstall IE11 is:

    - add *.microsoft.com in Internet Explorer 11 to trusted sites

    - add microsoft.com in IE to compatibility view

    Apply, close IE then press once again Find out more.


    I just added *.Microsoft.com to compatibility view and it fixed mine. Thanks.
    • Proposed as answer by SMaxey Thursday, February 12, 2015 2:53 PM
    Tuesday, November 11, 2014 4:30 PM
  • Worked perfectly. I needed to do both trusted and compatibility. thanks because this is not always broken with IE11! I searched for this fix for sometime!

    SW

    • Proposed as answer by Hollisorama Monday, June 19, 2017 2:47 PM
    Monday, December 8, 2014 9:07 PM
  • Had the same issue, and this was exactly related for me. Thanks!

    Michal

    Wednesday, February 18, 2015 1:23 PM
  • Worked for me, thank you much!!! Pretty pathetic that Microsoft cannot even cooperate with its self...
    Monday, March 30, 2015 6:11 PM
  • Worked for me, thanks!
    Wednesday, August 26, 2015 1:27 PM
  • Worked for me when i added microsoft.com to compatibilité list,

    thanks


    El Khiyati

    Wednesday, September 2, 2015 11:29 AM
  • That just fixed my exact same problem.

    Thanks !!!

    Friday, February 19, 2016 5:00 AM
  • I add my thanks, too - fixed the same issue the same way. 

    --------------------

    Now, if only there was as easy an option to turn off everything to do with operating systems post Windows 7, dealing with which is how I got WU in a mess in the first place. 

    MY TABLET WILL NEVER RUN OS BEYOND WINDOWS 7 (and yes, I mean to shout!).  Barely enough resources for W7 and I plan hardware obsolescence the same way as software.  So where is the Off Switch for anything to do with Windows updates for W8, W10 and all paths in that direction.  Please!  I should not have to vet every update to see if it is marketing. 


    • Edited by Empty Boxes Wednesday, March 16, 2016 9:33 AM
    Wednesday, March 16, 2016 9:31 AM
  • you're a f*ing genius, it worked!! thanks :)
    Wednesday, April 6, 2016 10:19 AM
  • That worked for me (I did both, but one might be sufficient for some) Thanks!

    Wednesday, May 11, 2016 8:17 PM
  • After wasting hours trying Windows FixIt, Regedits, MS Office online repairs etc....finally tracked down this answer and it worked like a charm.  THANK YOU!
    Tuesday, May 24, 2016 9:08 PM
  • The suggestion from Sethiel worked for me, thanks, but I had to untick the box requiring server verification (https:) for all sites in the Trusted Zone since update.microsoft.com appears as http: rather than https:
    Friday, June 10, 2016 2:17 PM

  • I just added *.Microsoft.com to compatibility view and it fixed mine. Thanks.

    This.
    Tuesday, June 21, 2016 4:24 AM
  • That's great, it worked!

    Thanks.

    Thursday, July 14, 2016 3:10 AM
  • Just got this after installing my win 7 HP on a new computer.

    I sometimes wonder if Microsoft deliberately try to make things difficult for end users like us.

    Tuesday, July 26, 2016 2:06 PM
  • - add microsoft.com in IE to compatibility view

    This worked for me, didn't needed to add it to trusted sites.

    Thanks..

    Thursday, November 17, 2016 7:39 AM
  • Give that man a cigar, unless he doesn't smoke, in which case give him a breath-mint.

    Only needed to add the site to compatibility view, and it worked first time!

    Saturday, December 10, 2016 2:27 AM
  • Thank you, worked a treat!
    Friday, February 24, 2017 1:57 PM
  • Thanks, this works

    Mostafa Pazhang

    Thursday, April 20, 2017 4:03 PM
  • THANK YOU -- THIS FIXED THE ISSUE!!
    Friday, May 5, 2017 8:11 PM
  • The solution:

    https://www.microsoft.com/getsilverlight/get-started/install/default.aspx?reason=unsupportedbrowser&_helpmsg=ChromeVersionDoesNotSupportPlugins#

    Just Install. And it´s done.

    ;)

    Saturday, May 27, 2017 9:47 AM
  • This worked for me as well thank you very much!!
    Thursday, June 8, 2017 1:40 PM
  • Better way than uninstall IE11 is:

    - add *.microsoft.com in Internet Explorer 11 to trusted sites

    - add microsoft.com in IE to compatibility view

    Apply, close IE then press once again Find out more.


    You're a genius. Adding *.microsoft.com to IE11 compatibility list worked for me. Problem solved. Thanks.
    Wednesday, June 21, 2017 4:24 PM
  • Thanks, this worked!
    Friday, July 21, 2017 2:52 PM