locked
SyncStateStorage has an invalid name RRS feed

  • Question

  • I'm currently in the process of migrating our organization from Exchange 2007 Enterprise to Exchange 2010 Enterprise (on-premise). I've been able to migrate several accounts successfully and without incident. However, I am unable to manage mobile device partnerships on those accounts after they are moved to a 2010 database. Attempting to do so, either through the GUI console or PowerShell, results in the error "SyncStateStorage has an invalid name". The accounts can still receive mail via ActiveSync and appear otherwise healthy. This does not occur with new accounts that are created in 2010 -- I can manage their mobile device partnerships just fine.

    This leads me to believe that an attribute on the AD account in regards to Exchange is incorrect. But I have tried to compare two accounts using ADSIEdit, one that was migrated from 2007 and another created in 2010, and could not find any particular attribute that stood out as being different.

    Not finding a whole lot of info on this error anywhere so I'm a bit lost. Any help would be greatly appreciated.

    Thanks,

    Adam

    Thursday, June 4, 2015 12:47 PM

All replies

  • So after almost two years, I figured out the fix to this by chance. If you're running into this issue, it is caused by a leftover folder that I believe is used during account migration from Exchange 2007 to 2010.

    Use something like MFCMapi to delete: [user@domain.com] --> ExchangeSyncData --> MailboxLoggingTriggerFolder

    That's it!

    -Adam

    • Proposed as answer by luvfi Monday, May 8, 2017 1:33 AM
    Friday, February 17, 2017 2:23 PM
  • Thanks for the clue!! :)

    DIED HARD FI FAN

    Friday, May 5, 2017 2:37 AM