none
Outlook 2016 Very Slow Windows 10 PC RRS feed

  • Question

  • I have recently upgraded to Office 2016, and ever since Outlook has become painfully slow.

    When switching between emails, it can take 10 seconds to show them.

    I have a Lenovo Yoga ultrabook, i7 processor, 8GB RAM with an SSD Hard drive, so I don't believe the hardware should be an issue. Is this a known issue? If so, what can I do to resolve it?

    Thank you.

    Friday, October 16, 2015 3:08 PM

All replies

  • Hi,

    What type of email account are you using? If you are using an Exchange account, please make sure you have Cached Exchange Mode enabled and then check if Outlook will be faster.

    Please also go to File > Options > Advanced, scroll down to the Display heading, check the check box before "Disable hardware graphics acceleration" and click OK. Then, test if this issue persists.

    In addition, how large is your Outlook data file (.pst or .ost)? Please make sure your Outlook data file is not too large and is exceeding the limit. If this is the case, you may consider to remove unwanted emails and archive old items to local pst file to fix the issue.

    Regards,

    Steve Fan
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    • Proposed as answer by Damean Berry Thursday, October 29, 2015 12:37 PM
    Monday, October 19, 2015 7:52 AM
    Moderator
  • Hi Steve,

    Thank you for your reply.

    We are using an Exchange Account. My email account is set Cache the last 6 months of emails. I have disabled the hardware graphics acceleration and it has made no difference.

    My Outlook data file is 5,669,049 KB. I have set my account to archive everything over 6 months old, but this doesn't seem to make a difference.

    Regards,

    Jonathon Atkinson


    Monday, October 19, 2015 9:32 AM
  • Disabling the graphics acceleration did speed up things for me. Thanks
    Wednesday, October 28, 2015 4:35 PM
  • Even disabled the hardware graphics acceleration it has made no difference. Outlook 2016 too slow for me.
    Thursday, October 29, 2015 12:09 PM
  • I am seeing this issue also, Windows 10 Enterprise  Office 2016 MSO 16.0.6001.1038 64bit (I wonder if 64bit is the issue)

    1. Disabled Hardware Graphics Acceleration
    2. My OST file is only 912,264KB
    3. I have tried to do a clean boot, disable as much as I can, even Anti-Virus.

    It's like 2-3 seconds between clicking each e-mail.

    Performance is pretty bad. 

    Thursday, November 19, 2015 3:22 PM
  • Hi, I have the same problem! Having an exchange account, Windows 10 Pro and Outlook 2016 combination seems to make it extremely slow. We are talking over 30 seconds load up; switching between emails seem very slow.
    Thursday, December 3, 2015 2:20 PM
  • Hi Jona,
    i have a same issue. when i change between folders, outlook be freeze some seconds (10, 15), this is bad. The way i be solved, is disable the social connector add. When go disabled, the outlook have no more freeze.

    Best regards
    Gabriel
    Friday, December 11, 2015 2:32 AM
  • To Microsoft,

    Just purchased and installed outlook 2016, running with W7 professional.  Takes way to long to load! It seems to be a very common problem. I had been using outlook 2003 which opened fast. 

     Can I go back to my earlier 2003 version, and get my money back from Costco?  Unless, of course, Microsoft can provide a fix!

    Quite disappointed so far.

    Thank you

    Friday, December 11, 2015 2:38 AM
  • This does not fix the load time of Outlook 2016 but it certainly fixed the responsiveness of clicking through emails: 

    Enable "Use Cached Exchange Mode".

    Friday, December 11, 2015 11:16 AM
  • Hi

    I am having exactly the same problem - 2 - 3 seconds between changing folders or opening an email. Cached Exchange Mode is enabled and hardware graphics acceleration is disabled. Could it be some add-ins or Coms? How do I disable these in Outloook 2016?

    Please let me know if you have any ideas.

    Thaks

    Andrew

    Tuesday, December 29, 2015 1:04 AM
  • I discovered it was my add-in for AVG (anti-virus) that was causing the issues.

    Even though I had disabled email scanning, the Outlook "Add In" was still active.

    Everything went back to normal in Outlook once it was disabled/removed.

    • Proposed as answer by nirshiloni Wednesday, January 13, 2016 12:27 PM
    Tuesday, January 5, 2016 9:26 PM
  • Same issue for me and turned out to be the Nuance PDF Outlook Add-in. Disabled and switching emails almost instantaneous.

    However, MS really need better system for enabling/disabling COM Add-ins (such as keeping enable/disable window open) whilst you test disabling each of the add-ins.

    Friday, January 8, 2016 12:07 AM
  • Worked for me!
    Friday, January 22, 2016 6:56 PM
  • Disabling several add-ins made a noticeable difference for me too:

    (1) disabled the Microsoft SharePoint Server Colleague Import Addin; and

    (2) disabled the AVG Addin for MS Outlook

    Outlook 2016 is now running acceptably fast again.  I wonder if AVG will release an updated addin without this slowness issue, or whether the core of the problem is actually in how Outlook 2016 itself handles addins.

    This certainly wasn't an issue for me with Outlook 2007, 2010 or 2013.

    Saturday, January 23, 2016 10:14 PM
  • Thanks for this tip. This was my problem.  I just disabled the AVG add-in for email in Outlook and all is better.
    Tuesday, February 2, 2016 9:22 PM
  • This was my situation as well.

    I'd recommend checking out the Add-ins and disabling one-by-one until the problem goes away, or else there are no Add-ins left.


    • Proposed as answer by carterdawson Thursday, February 4, 2016 11:46 PM
    Thursday, February 4, 2016 11:46 PM
  • I also have the Outlook slowness problem. Opening an email and going from one email to the next is quick, snappy. But closing an email is very slow, like 30 seconds or a minute. Closing time varies. But is very slow. I'm not talking about closing Outlook. I'm talking about closing an email.

    I have Windows 10, 64-bit Professional, Outlook 2016 Professional


    Ron Lewis at Indinfer, Baltimore, Maryland United States


    • Edited by Indinfer Sunday, March 6, 2016 4:05 AM
    Sunday, March 6, 2016 4:04 AM
  • After disabling hardware acceleration as described in an earlier post, I think Outlook is a little faster. But it still seems slow at times. Sometimes it is okay. I don't know whether it is Outlook that is slow, or whether it might be Windows that slows down Outlook and some other applications such as QuickBooks and TurboTax, that also have slow, hanging behavior at times.

    Ron Lewis at Indinfer, Baltimore, Maryland United States

    Monday, March 7, 2016 4:40 PM
  • I resolved this issue by going into Control Panel > Mail > Show Profiles > Add new profile then set the new profile as active below.

    It will create an new ost file.  Turns out there was an issue with my profile that was not downloading mail locally.  This solved the issue.

    Wednesday, May 11, 2016 3:55 PM
  • Disabling Nuance PDF Outlook Add-In did it for me too.
    Sunday, May 22, 2016 10:11 PM
  • Hi All,

    I tried every single advice from this topic, but nothing helped.

    When I've launched Outlook in safemode for the first time, everything worked flawlessly. However when I open it 2nd and 3rd time it was sooo slow again - like in normal mode.

    I noticed that whenever Outlook is closed it create another "Interferences[long number].xml" file in the same folder where OST file lies (c:\users\%username%\AppData\Local\Microsoft\Outlook).

    I have removed all those files and everything was back to normal. I've launched Outlook few times after that and it is still OK.

    I hope this will help someone :)

    Regards

    Adrian



    • Edited by Chrustus Monday, June 27, 2016 12:47 PM
    Monday, June 27, 2016 12:45 PM
  • Hi, All

     If you are using an Exchange account, please make sure you have Cached Exchange Mode enabled and then check if Outlook will be faster.

    Please also go to File > Account setting> click on E-Mail , check the check box before "Use cached Exchange Mode" and click Next and Finish. Then, test if this issue persists

    In additions, you can Repair your E-Mail Account Please Go to file >Account setting > click on E-Mail then click Repair.


    It will definitely help you .

    Thanks and Regards

    Pawan singh

    Tuesday, June 28, 2016 7:52 AM
  • This solved my problem as well
    Thursday, June 30, 2016 9:18 AM
  • Disable hardware graphics acceleration:

     This seemed to have corrected my issue.... Thank you.

    Friday, July 8, 2016 12:55 PM
  • Disabling Nuance Power PDF made a big difference. Disabling graphic acceleration didn't help much.
    Wednesday, July 13, 2016 11:25 PM
  • same issue on my system. Disabled the Nuance PDF addin and problem has been corrected.
    Friday, July 15, 2016 4:06 PM
  • Hello,

    Would someone please step back a few steps, and explain to a NON-computer person how to correct this problem? I see "go to file" etc., but -- where am I starting? 

    My Outlook emails sucks beyond belief, starting about a week ago. I hate it. It barely functions. I have never had problems like this. I got Windows 10 last winter sometime and it has been okay, until now. I hate this and can hardly get through my inbox.

    If someone could please rephrase the above instructions and tell me where to BEGIN, I would greatly, greatly appreciate it. Thank you.

    Thursday, July 21, 2016 6:11 PM
  • Hello,

    Would someone please step back a few steps, and explain to a NON-computer person how to correct this problem? I see "go to file" etc., but -- where am I starting? 

    My Outlook emails sucks beyond belief, starting about a week ago. I hate it. It barely functions. I have never had problems like this. I got Windows 10 last winter sometime and it has been okay, until now. I hate this and can hardly get through my inbox.

    If someone could please rephrase the above instructions and tell me where to BEGIN, I would greatly, greatly appreciate it. Thank you.


    It's located at the top left of your screen. There's 'File' there.

    My outlook 2016 performance is getting slightly better with this workaround.

    • Edited by zeroxxx2 Tuesday, July 26, 2016 2:31 AM
    Tuesday, July 26, 2016 2:30 AM
  • Thank you so much! I got to the box after clicking "Email", however, none of these options is available there. I'm stuck. Does anyone know if there is a phone number for HELP with this issue? It is driving me crazy and I am giving up on even trying to read my mail. I work long shifts at night and there simply isn't enough time to fight with this. 

    Thank you for any help. I am discouraged. 

    Thursday, July 28, 2016 4:41 PM
  • very helpful. I have only the outlook live but checked all the advanced settings. I don't know about the .pst or .ocs? Do you have any more detailed checks or unchecks for the advanced settings. Most I don't understand.  Newbee to outlook eamil
    Saturday, August 20, 2016 7:35 PM
    • Left click the file tab
    • Left click Options
    • Left click advanced
    • Scroll down until you see "display" and check the box "Disable hardware graphics acceleration"
    • Click OK
    Friday, September 30, 2016 4:30 PM
  • Hello Jonathan,

    I noticed the same problems with Outlook and also with Excel. Some of my Excel files with VBA programming are suddenly not opening anymore when I activate macros. This is really annoying. I know that there are no corrupted files or wrong settings on my machine. Of course you can loose yourself in the jungle of possible reasons. I am pretty sure that this is just one of those probably sloppily tested background updates again which is unnoticedly pushed on your machine and slows it and costs you a lot of working time. It remembers me of my student times where one tested the faults in software routines with repetitive debugging in practice. However, at those time you just affected yourself not others by making a big public test.

    So just wait. The problem will suddenly disappear like your working time before.

    Have a good day

    Matthias

    Wednesday, October 26, 2016 7:01 AM
  • I had nothing but issues with 64bit Office suite on my personal computers. Even at work in our 64bit, controlled, virtualized, 64bit environment, we had a ton of issues that went away by reinstalling with 32bit architecture for the Office apps.
    Wednesday, November 23, 2016 5:00 PM
  • I have a Dell XP 9100, with Office 365 -2016 and I am having all the same problems with web based pictures loading very very slow.   Previously with Office - 2015 my email loaded instantly with no issues.   I have gone from Time Warner 50 Mbps internet to up to 200 Mbps speed and I don't believe my internet is the problem and I believe Microsoft has an issue with their Outlook 2016.   I have tried many of the suggestions I have seen on the blogs but nothing has fixed my slow opening of web based pictures.  I also use GMAIL and have no PST file.

    Bob Elliott

    Saturday, December 10, 2016 2:09 AM
  • I have a Dell XP 9100, with Office 365 -2016 and I am having all the same problems with web based pictures loading very very slow.   Previously with Office - 2015 my email loaded instantly with no issues.   I have gone from Time Warner 50 Mbps internet to up to 200 Mbps speed and I don't believe my internet is the problem and I believe Microsoft has an issue with their Outlook 2016.   I have tried many of the suggestions I have seen on the blogs but nothing has fixed my slow opening of web based pictures.  I also use GMAIL and have no PST file.

    Bob Elliott

    outlook 2016 - really a terrible stuff to be installed......
    Monday, December 19, 2016 2:53 PM
  • Have you solved this? I have the same computer and sometimes outlook makes the computer start the fans and the mouse ends up being unresponsive...
    Thursday, January 26, 2017 9:18 PM
  • Thanks Steve, disabling the haardware graphics accelerator solved my problem.
    • Proposed as answer by TomS64DK Thursday, March 2, 2017 8:44 PM
    • Unproposed as answer by TomS64DK Thursday, March 2, 2017 8:44 PM
    Tuesday, February 14, 2017 10:05 PM
  • Turning off a skype add-ins worked for me...
    Thursday, March 2, 2017 8:47 PM
  • Disabling the hardware graphics acceleration worked for me!  Thank you!!

    Wednesday, March 8, 2017 8:48 AM
  • This worked for me.. Additionally I had disabled antivirus add-in.
    Tuesday, April 11, 2017 7:28 AM
  • I have this same problem, but can't find the 'file' option anywhere ? I'm just using the free version of Outlook, is this the reason ? Thanks for any help !
    Saturday, April 29, 2017 1:45 PM
  • I´m currently going through all possible articles and hints and findings about slow typing in O365 product. Found in UserVoice, that MS has confirmed the slow behavior, and currently Office should be updated from Current channel to receive all latest updates.

    Please remember to mark my post as an answer, if I really helped you out, or vote if usefull. Thank you!

    Thursday, May 11, 2017 5:52 PM
  • Hi,

    I had the same issue where switching between emails took 5-10 seconds to show and my solution was enabling "Use cached Exchange mode" under offline setting of my account.

    File --> Account Settings --> E-mail tab --> double click on your email --> check "Use cached Exchange mode"

    Hopeful this will help resolving your problem.

    Regards,
    Abdulrahman

    Sunday, May 21, 2017 4:52 AM
  • Thanks for the advice. The Social Media addin kills the performance. I'm back to instant responses.
    Friday, June 2, 2017 5:32 PM
  • Thank you to everyone that posted! I have also observed this with Windows 7 Enterprise 64 bit and I had updated from Office 2013 to Office 2016 because I needed to use that version for compatibility reasons. Here is what I did to solve this issue which was literally bringing a very powerful laptop to it's knees whenever outlook is running (I have to have it running)

    1 - Disabled Nuance PDF add-in

    2 -Disabled Microsoft VBA add-in - I don't use macro's and I seem to remember (correct me if I'm wrong that this was a path that someone could utilize to give you a virus if you accidently ran something bad - so for security reasons I killed it.

    3 - Disabled Hardware acceleration

    I don't know which combination of the above three did it, but wow what a difference.  I already had cache mode enabled so that wasn't an issue for me.  I too have a very high speed internet connection from my provider and also outlook running from the web was working fine but it doesn't have all the features.

    Friday, June 9, 2017 5:35 AM
  • Hi 😊,

    => Did you try starting Outlook with /RPCDiag ?  This can show you attempts to server and fails, also shows response time.  This could illuminate what the issue is.

    => It could also be a large PST or OST file, those come along for the ride when you do an update of Office.

    => It could also be your Secure Hidden Cache.  It's hard to find unless you check the registry or know where to go.  This should get you close.  You'll want to move those files to another folder.  Microsoft says you can delete them but I've shown this to other people and they found things they lost.  I like to give people time to review the files.  There is a sub-folder or a couple in the Content.Outlook folder, that is where your files are.  Even if you have 1 tb free on your HD, this folder containing 200 mb will slow down your Outlook.  It also creates other problems.

    %userprofile%\AppData\Local\Microsoft\Windows\INetCache\Content.Outlook

    => Another thing is the "Hardware Acceleration", sometimes if you disable this it will speed up Office including Outlook.  File > Options > Advanced > "Disable hardware graphics acceleration", check the box and save changes.

    Cheers,

    Kevin


    Helpful nice guy

    Friday, June 9, 2017 7:17 AM
  • ...Disable hardware graphics acceleration worked on VMWare Workstation Pro \ Windows 10 VM.  Whodda thunk it, hardware graphics acceleration for e-mail?!??
    Tuesday, July 25, 2017 12:46 PM
  • Thanks Steve.
    It solved my loooooong pending problem.
    I just considered removing outlook and switching to Thunderbird just because it was performing tooo slowly.


    Amol Tarte

    Thursday, August 10, 2017 9:31 AM
  • Thanks Jona,

    Disabling the Social connector Add-inn worked.

    Regards,

    Sankara.

    Monday, August 21, 2017 7:05 AM
  • I have recently upgraded to Office 2016, and ever since Outlook has become painfully slow.

    When switching between emails, it can take 10 seconds to show them.

    I have a Lenovo Yoga ultrabook, i7 processor, 8GB RAM with an SSD Hard drive, so I don't believe the hardware should be an issue. Is this a known issue? If so, what can I do to resolve it?

    Thank you.

    I concur. Using the very latest office upgrade beta version and outlook 2016 became very slow to load over last few days. I guess since last update. Disabled all add-ins seemed to help with load time.

    Cheers

    Wednesday, September 13, 2017 10:17 PM
  • Same here. I found it was my Nuance plug in. You can also try setting the editor to HTML instead of word as the editor.

    thanks,

    Tuesday, October 17, 2017 3:58 PM
  • This is not easy.


    But after trying everything under the sun listed in this community and some other things, I found the fix.

    BACKUP YOUR REGISTRY AND SET A RESTORE POINT BEFORE YOU ATTEMPT THIS.

    I run in exchange mode (local cache turned on / M.2 SSD running 4 PCI-e channels) it is still just agonizingly slow.  I am now sure that it is waiting for communications with the server.  To minimize the delay, do what gamers do to increase network responsiveness.  Turn off Nagle's algorithm on all interface instances in the registry. 

    My goodness the difference in responsiveness is amazing.   I have listed several articles below that will help in turning off Nagle and why you should do it.

    https://answers.microsoft.com/en-us/windows/forum/windows_other-gaming/nagles-algorithm-how-can-i-fully-disable-it/67cb3be9-480f-4081-a545-8892ab50bbbd?auth=1

    https://www.back2gaming.com/guides/how-to-tweak-windows-10-for-gaming/

    • Proposed as answer by p.hurth Friday, July 13, 2018 3:25 PM
    Tuesday, December 19, 2017 7:36 PM
  • This. Outlook 2016 with O365 was extremely slow - just awful performance. Several seconds to switch messages of mailboxes. I'm amazed there hasn't been a revolt over this. The registry change to disable Nagel's algorithm was the fix.
    Friday, July 13, 2018 3:28 PM