content editor webpart error "cannot retrieve properties at this time"

All replies

  • Anybody have any more ideas?  Microsoft?  I'm having the exact same issue.
    Monday, September 08, 2008 8:25 PM
  • Same here.  I may have to open a MS Case.
    Monday, September 22, 2008 9:36 PM
  •  I would certainly like to know the answer to this one cause im experiencing the same problem.
    Thursday, September 25, 2008 1:45 PM
  • Did you check it after activateing Publishing Infrastructure feature at the site collection level?
    Thanks, Arpit
    Thursday, September 25, 2008 8:11 PM
  • We having a similar problem here.
    Anyone found a solution for this??
    Wednesday, October 22, 2008 1:26 AM
  • we have the same error and i have just opened a MS support case, i will let you know what we find.
    Wednesday, November 19, 2008 4:10 PM
  • hey guys
    we found that the error was related to ISA, since our SharePoint implementation was behind it.
    It wasn't configured properly, and the javascripts were not being loaded properly.
    Not sure if this is a similar problem to you guys

    other behaviours we noticed was the drop down in the DataSheet view were not working either.

    Wednesday, November 19, 2008 9:01 PM
  • Neo, was it an intermittent problem you were having, or constant?  Our implementation is behind an ISA server but the problem is only intermittent.


    Wednesday, November 19, 2008 9:04 PM
  • It was constant.
    Note that the problem was on IE since it tries to load the javascript resources for the default editor.
    It will work fine on FireFox, or if you using any other editors.

    Our ISA Team was able to fix the problem, i can ask for more details on how it was fixed if the problem is similar.
    Wednesday, November 19, 2008 9:07 PM
  • Okay, it must be a different issue.  Our problem is intermittent and seems to be caused by using a combination of host headers and SSL.  The problem is rectified by performing an iisreset but it's very annoying.


    Wednesday, November 19, 2008 9:18 PM
  • Neo,
    We are having the exact same problem.  consistently.  SSL thru ISA.  (when we are going directly at the server and not thru ISA/SSL we dont have the problem.
    Same 2 issues, including the datasheet view.
    Can you ask your ISA team what the fix was.  Thanks.
    Thursday, December 18, 2008 5:19 AM
  • Hi Neo,

    My organization is experiencing the same problem and have yet to find a solution.
    If you could post your ISA team's resolution, I'll lavish you with praise!  ;-)

    Thursday, February 12, 2009 4:12 PM
  • Hi Neo,
    My organization is also having the same issues with the CEWP and datasheet view.  We are also SSL thru an ISA server.  Could you post the details of the ISA team's fix?  thanks so much!!!

    Much appreciated,
    Tuesday, July 21, 2009 3:26 PM
  • Another call for Neo - or anyone else with the answer - to post any further details that can be shared along those lines. I've got the same issue here...
    Tuesday, August 04, 2009 8:35 PM
  • I'd be interested in an answer to this too.
    Friday, September 04, 2009 2:33 PM
  • My symptoms

    1.  CEWP & Sharepoint Designer could not retrieve data.

    2.  Event id 5000 "ulsexception12,p1 w3wp.exe ..."


    1. Upgraded Small Farm WSS and SPS 2007 to SP2.

    2. Unhandled exceptions and access denieds int the uls logs no specifics to run down.

    3. Crawl issues and had to reset the crawl index.


    1. ASPNet user account had certain rights stripped by gpo, check your permission with Tech Net "IIS and Built-in Accounts 6.0"  or I found a much easier product to use Mircrosofts "Authentication & Access Control Diagnostics 1.0"

    2. Ran the "stsadm -o sync -listolddatabases 0" to check for unsyn'd databases  then ran the "stsadm -o sync deleteolddatabases 0"  to clear those databases.

    Havn't seen any further issues, this was a tuff nut to crack hope this helps someone else.
    Friday, September 25, 2009 7:07 AM
  • Recycle the application pool worked for me!
    IIS -> right click on the app pool -> recycle
    Umakanth Nelige
    • Proposed as answer by Vargtas Tuesday, September 11, 2012 1:20 PM
    Wednesday, October 14, 2009 8:05 PM
  • Hi Umakanth

    currently site in LIVE, So I cannot recycle it . cud you please suggest me the best time to recycle the pool
    Wednesday, February 17, 2010 5:30 PM
  • Hi

    Even i have same issue, users when they try edit the rich text editor they get popup error

    "Cannot  retrieve properties at this time"

    by doing recycle the app pool it works but we cant do recyle every time i have the problem.

    Thursday, February 18, 2010 6:57 PM
  • Hi,
    Same issue.

    Can anyone else suggest anything else?

    Thank u.

    Rafik - Consultant Sharepoint
    Wednesday, February 24, 2010 6:52 PM
  • Hi Neo,
    Can u plz chare the fix did by your ISA TEAM.
    Thank u
    Rafik - Consultant Sharepoint
    Wednesday, February 24, 2010 6:53 PM
  • This issue was fixed for me by looking at old blogs from 2008 - by fixing the order of statements in the <httpHandlers> section of the web.config.  (We had a rogue WSP package mess it up)

    In the <httpHandlers> setion Move the <remove verb="*" path="*.asmx" /> to be above the <add verb="*" path"*.asmx" .... and you should be good to go.

    as per the solution from this blog: 



    Software Consultant - DWS

    • Proposed as answer by James Boman Tuesday, March 23, 2010 12:58 AM
    • Unproposed as answer by Mike Walsh FIN Tuesday, March 23, 2010 6:37 AM
    Tuesday, March 23, 2010 12:57 AM
  • James Boman:

    Please don't propose your own posts as answers. It isn't helpful.

    Propose the good answers of other people and wait for someone else to propose your posts.




    FAQ sites: (SP 2010); (v3) and (WSS 2.0)
    Complete Book Lists (incl. foreign language) on each site.
    Tuesday, March 23, 2010 6:38 AM
  • > Can u plz chare the fix did by your ISA TEAM.


    These are English language forums. Please use full English language words in them and avoid things like "u" and "plz".

    (Spelling mistakes like "chare" are OK because we know English isn't the native language of people posting. But "You" and "Please" are common words everyone posting here should be able to manage.)


    FAQ sites: (SP 2010); (v3) and (WSS 2.0)
    Complete Book Lists (incl. foreign language) on each site.
    Tuesday, March 23, 2010 6:40 AM
  • Notice this question was posted 2 years ago and has been dragging on since then. I found that recycling the application pool fixed it only sometimes and iisreset only fixed it sometimes. When neither worked rebooting the machine also changed this behaviour.

    It turns out that the problem is not actually Sharepoint at all. It's Internet Explorers javascript handling and if you use Firefox the problem goes away. Firefox is riddled with it's own problems and does a bad job of displaying Sharepoint sites in general so it's not a solution but it's an effective workaround for modifying CEWP

    It's fixed in IE8 Tools-->Compatibility-view-settings

    Try it from IE8 in this mode and the error disappears.

    Thursday, April 22, 2010 8:25 AM
  • Hi All

    I have the very same issue, but I seem to have resolved it by enabling the XML HTTP Request add-on in IE...


    Hope this helps...



    Monday, May 10, 2010 11:16 AM
  • We resolved this issue completly by opening the case with microsoft.

    We found the reason for this CEWP error as due to out of memory exception by using fiddler2 & our sharepoint farm was in 32 bit ,windows 2003 4gbRam. I observerd the worker process memory usage for that application crossing the 1Gb.

    So i change the no of worker process for that application pool from 1 to 4 & it saved us from webapplication getting saturated. But microsoft doesnt support changes in worker process number & they suggested to increase the RAM memory.

    So our organization planed migrating our windows 2003 servers,4 Gb ram webfront server to windows 2008 with almost 20 gb of Ram on them. Now i dont see a CEWP cannot save properties at this time & canot save properties at this time error any more.

    Before this changes, I use to manage the CEWP error by doing a recyle to application pool.




    Thursday, February 03, 2011 4:34 PM
  • HI Sam,

    Just recycle your site's application pool and you will find issue resolved.




    Tuesday, July 26, 2011 6:30 AM
  • Three year old issue without a resolution.   This is how I fixed my instance of it - tool a while to find it, so I figured I'd post in case other's had the same issue. 

    I was getting the error on a DEV site that had been copied to from the PROD server; however, it didn't appear to be perfectly copied and instead of: I had

    The extra slash was allowing everything else to work, but not edits to CEWP's.

    Hope that helps somebody.



    Tuesday, August 30, 2011 12:50 PM
  • Add the Site into Trusted Security Zone of Internet Explorer and It will solve the issue.

    1.Internet Explorer -> Internet Options -> Security -> Trusted Sites -> Sites
    2.Add the URL(s) of your SharePoint server(s).
    (if prompted a pop up: You would just need to uncheck the Checkbox saying "Require Server Verification (https:) for all sites in this zone" and follow the Step 2. Add the URL(s) of your SharePoint server(s).)
    3.Click OK
    4.Click Custom Level -> Scroll to the bottom -> User Authentication
    5.Ensure that it is set to Automatic logon with current user name and password

    Restart the browser and try to access again.

    • Proposed as answer by tunicious Monday, September 29, 2014 9:09 AM
    Monday, September 29, 2014 9:09 AM
  • Wow, 6 years later and why am I not surprised Msft can't be bothered to fix a glaring incompatibility between their products? Oh yeah, I know why - I come across a few of these unresolved problems that are ignored by Msft every day. So I'm used to it.

    None of the above worked for me  - some because I'm working on a company's ancient SP install, and I don't have server access so can't implement them.And I can't try Tunicious' idea because I have no idea what the server url is. The site urls were added, but that made no difference.

    Funnily enough, compatibility view to get back to IE7 seemed to work sort of. 

    Msft: if you listened to your users and fixed things that don't work, you could maybe begin a little culture change and not have such a tough time adapting to the modern world. 

    • Edited by webbrewer Thursday, November 06, 2014 4:11 AM
    Thursday, November 06, 2014 4:10 AM
  • Hi,
    Oh my God, 7 years without any solution!!
    I had the same issue and I solved it by using Google Chrome browser. Easy and quick solution without any restarting of the application pool or any other complex solutions.

    Good luck

    Thursday, December 17, 2015 8:45 AM