none
Content Type Description is not adding on list RRS feed

  • Question

  • Hello

    I have some custom content type on site level and each content type I have different description. When I add content type manually  in existing document library, description is also coming for added content type. But when I add content type programmatically, description not coming with content type it is coming as empty. I have used following MSDN article for adding content type.

    http://msdn.microsoft.com/en-us/library/office/aa543576(v=office.14).aspx

    Can one please let me know what am I missing here?

    Regards

    Avi

    Thursday, April 17, 2014 9:09 PM

Answers

  • Hi,

    According to your post, my understanding is that the description of the content type not displayed in the site while adding the content type programmatically.

    I had tested the code of the above link with a custom content type based on the Document content type, it worked without any issue.

    To narrow down the issue, you can check with the following steps.

    1. You can recreate a new content type then check whether it works.
    2. You can use other libraries to check whether it works.
    3. You can also check the event log and ULS log to see if anything unexpected occurred.

    To check event log, click the Start button and type “Event Viewer” in the Search box.

    For SharePoint 2010, by default, ULS log is at      

    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS

    Thanks & Regards,

    Jason

    Jason Guo
    TechNet Community Support

    • Marked as answer by Lindali Saturday, April 26, 2014 7:46 AM
    Friday, April 18, 2014 10:05 AM