none
Outlook 2010 and WIndows Search failing

    Question

  • The addin Windows Search Indexer is showing as disabled.
    If I enable it, the next time I launch Outlook, it becomes disabled again.
    I have also tried to rebuild the index but that does not help either.

    (I'm running Outlook 2010 RTM, x86 on Windows 7 x64)


    Michael Tissington
    Thursday, May 13, 2010 6:20 AM

All replies

  • Hi,

     

    We can try to create a new profile to test the issue.

     

    Here are the detailed steps on how to create a new profile to test this issue

    ==============

    1.    Exit Outlook.

    2.    Go to Start > Control Panel, click or double-click Mail.

     

    Mail appears in different Control Panel locations depending upon the version of the Microsoft Windows operating system, Control Panel view selected, and whether a 32- or 64-bit operating system or version of Outlook is installed.

     

    The easiest way to locate Mail is to open Control Panel in Windows, and then in the Search box at the top of window, type Mail. In Control Panel for Windows XP, type Mail in the Address box.

     

    Note    The Mail icon appears after Outlook starts for the first time.

     

    The title bar of the Mail Setup dialog box contains the name of the current profile. To select a different existing profile, click Show Profiles, select the profile name, and then click Properties.

     

    3.    Click Show Profiles. Choose Prompt for a profile to be used.

    4.    Click Add.

    5.    Type a name for the profile, and then click OK.

    6.    Start Outlook, and choose this new profile.

     

    If this problem does not occur in the new Outlook profile, the old Outlook is corrupted. We can delete that and use a new Outlook profile.

     

    Best Regards,

     

    Sally Tang

     

    Thursday, June 3, 2010 9:03 AM
  • I tried creating a new profile - that did not solve the problem for me.  Outlook 2010 is loaded, and the COM add-in mssphtb.dll is disabled.  Enabling it using the File/Options/Add-ins menu does not solve the problem - it disables itself immediately.  No email has been indexed since I upgraded to Outlook 2010.  windows search service is running.  My system is stuck at 175,000 unindexed entries - I tried leaving it on with Outlook open overnight and it didn't solve this issue.  Here are the com add-ins that are running:

    Autotask outlook extension (Enabled or disabled doesn't matter)

    Business Connectivity Services add-in (don't know what this does - have not disabled)

    MS Exchange add-in

    MS Outlook social connector add in

    MS Sharepoint server colleague import add in

    MS Sharepoint workspace p[roxy for outlook add in

    OneNote Notes about outlook items

    Send to bluetooth

    Inactive:

    Gotomeeting com add in

    MS Access outlook add in for data colleection/publishing

    MS VBA for outlook add in.

    Disabled:

    Windows search email indexer (cannot enable successfully).

     System config: Windows 7, 3gb ram, office 2010 enterprise full licensed version, 32 bit OS and App


    Lee Drake - www.os-cubed.com
    Tuesday, June 15, 2010 1:09 PM
  • I'm glad I found this because the same thing happens with me. I've been going crazy reading MS documentation on Outlook indexing-I have all the options enabled, tried all sorts of stuff then I saw that the add-in is disabled. When I enable it and restart Outlook it becomes disabled again.

     


    MCTS 70-620 Certified
    Thursday, June 17, 2010 7:37 PM
  • I may have a solution.

    1. Go to Programs and Features (Turn Windows features on or off) and UNCHECK Windows Search. I'm using Win7.
    2. Reboot
    3. Open Outlook and you should see Search is not available. Close Outlook.
    4. I rebooted here, but you may not need to.
    5. Go back to Programs.. and CHECK Windows Search.
    6. Reboot
    7. Open Outlook and see if it's working.

    In my case I have an Exchange account and an IMAP (with a password on the PST) and when Outlook opened on the Outlook Data File Password it froze. I waited 20 minutes then forced Outlook to close. Assuming you don't see the Password box, it may not freeze and the index will take a while to rebuild. When I opened Outlook, the Outlook Mail Search Add-In was still disabled. (????). I still can search, but it seems to take just as long to get results as when indexing isn't enabled.

    Not 100% guarantee-- HOWEVER when I look at the Indexing Options in the Control Panel, the Modify > Outlook shows my Exchange account - previously it was not. Also, my items indexed value is now 18K, before it was 5K (the missing Outlook items).

    Does Cached Mode HAVE to be enabled for indexing (searching in Outlook) to work properly?

    When my results are returned, the Refine toolbar options are greyed out.


    MCTS 70-620 Certified
    Thursday, June 17, 2010 8:10 PM
  • I am having the identical issue.
    Tuesday, June 22, 2010 5:57 PM
  • Same issue here. Win7 64 bit office pro plus 2010 64bit.

    Searching for anyone that has actually fixed this.

    It seems that the only solution is to never shutdown ;o)

    Friday, July 9, 2010 1:29 PM
  • Anyone solved this, Identical problem and can be replicated with a Windows 7 32 and 64bit installation.
    Tuesday, July 13, 2010 9:20 PM
  • I have found that the addin does not need to be working for full search to be working within Outlook.
    Michael Tissington
    Tuesday, July 13, 2010 9:29 PM
  • Anyone solved this, Identical problem and can be replicated with a Windows 7 32 and 64bit installation.
    Microsoft this needs to be fixed after reviewing 100's of threads all over the web this is a serious problem that needs to be fixed. It looks like installing 2010 on top of 2007 completely breaks Windows 7 searching of e-mail. I have tested on a new install of office 2007 with Windows 7 and upgraded to 2010 and the problem exists immediately. It is not a mail profile problem or a index problem but something else.
    Tuesday, July 13, 2010 11:18 PM
  • I would like to add a 'me too' to this list thread as well. Very annoying.

     

    Written about it on SuperUser as well.

    Wednesday, July 14, 2010 7:53 AM
  • Me: Windows 7 (64-bit), Office Professional 2010 (32-bit).

    Search in Outlook was working up until yesterday or the day before. Can't swear to it, but I think the problem started after Microsoft offered a Beta version of Live Messenger. I installed it, then uninstalled it. I think that is when the search function broke.

    I use Outlook's search extensively. This is a real big problem.

     

     

    Thursday, July 15, 2010 8:18 PM
  • I managed to get it to work for me again even though the DLL is still marked as disabled.

    See This post

    Friday, July 16, 2010 8:26 AM
  • Are you running Outlook with Administrator priviledges by any chance?

    I noticed that the 'Run As Administrator' check box ('General' tab > Advanced) was indeed checked. When I unchecked this and restarted Outlook, I no lnger received the 'Windows Search Is Disabled' message.

    It worked for me, I hope it works for you!

    Paul


    Paul
    Thursday, July 22, 2010 2:38 AM
  • SOLVED!

    I've been having the exact same issue with Outlook 2010 (running on Vista).  The following solved it for me:

    1) Go to Control Panel --> Programs and Feaures

    2) Click on "Turn Windows Features on or off"

    3) Place a tick against "Indexing Service" (mine was un-checked)

    4) Choose OK then wait several minutes (as prompted)

    Re-open Outlook 2010 and hey presto the search functionality works fine!

    In Outlook, you'll now be able to re-enable the Windows Search Email Indexer (mssphtb.dll) via Options->Add-ins

    Hope my solution helps others here :-)

    Good luck

    Adrian

     

    Thursday, July 22, 2010 6:35 PM
  • Sorry, did you just copy and re-write what I wrote?
    MCTS 70-620 Certified
    Thursday, July 22, 2010 6:52 PM
  • Sorry LDVG I didn't see your post, although my solution is slightly different to yours.  I didn't need to reboot as you suggest plus mssphtb.dll can be re-enabled from the Add-in options OK (don't think you suggested that either).

    I'm just providing what worked for me. 

    Update:

    Indexing Status: 0 items remaining to be indexed - hoorah!!!

    Thursday, July 22, 2010 7:06 PM
  • Cool, good work.

    For me I had to switch to cached (offline mode) in the end. It's still a mystery to me!


    MCTS 70-620 Certified
    Thursday, July 22, 2010 7:12 PM
  • I'm having the same or similar trouble. I tried the suggestions above (checking indexing service...) with no luck. Outlook 2010 beta worked fine, but now that I've upgraded to the "real" version, no go on indexing. (Seems like the full product ought to be less buggy then the beta, huh?). Indexing finds some entries (mostly recent ones) but not others. Mostly useless. Any other suggestions?

     

    thanks...

    Friday, August 27, 2010 6:21 AM

  • I may have a solution.

    1. Go to Programs and Features (Turn Windows features on or off) and UNCHECK Windows Search. I'm using Win7.
    2. Reboot
    3. Open Outlook and you should see Search is not available. Close Outlook.
    4. I rebooted here, but you may not need to.
    5. Go back to Programs.. and CHECK Windows Search.
    6. Reboot
    7. Open Outlook and see if it's working.

    In my case I have an Exchange account and an IMAP (with a password on the PST) and when Outlook opened on the Outlook Data File Password it froze. I waited 20 minutes then forced Outlook to close. Assuming you don't see the Password box, it may not freeze and the index will take a while to rebuild. When I opened Outlook, the Outlook Mail Search Add-In was still disabled. (????). I still can search, but it seems to take just as long to get results as when indexing isn't enabled.

    Not 100% guarantee-- HOWEVER when I look at the Indexing Options in the Control Panel, the Modify > Outlook shows my Exchange account - previously it was not. Also, my items indexed value is now 18K, before it was 5K (the missing Outlook items).

    Does Cached Mode HAVE to be enabled for indexing (searching in Outlook) to work properly?

    When my results are returned, the Refine toolbar options are greyed out.


    MCTS 70-620 Certified

    I did 1 to 7 mentioned in above and it solved my problem. Thanks a lot

    ;o) Jesper Kick

    Friday, October 15, 2010 5:16 AM
  • Jasper, LDVG. I have tried your solutions and it is still not working for me. I uses my search function quite alot and it is really an inconvenience that it is not working. I am running W7 Enterprise with outlook 2010 which was upgraded from 2007.

    Friday, October 15, 2010 7:17 AM
  • I have the same problem but running on XP (SP 3). I can't find the equivalent to 'Turn Windows Features on or off' in the control panel. Any help would be appreciated as I use search a lot and it has recently stopped working.

    Thanks.

    Wednesday, October 20, 2010 9:20 AM
  • I am also using Windows XP (SP3) and running Outlook 2010. I recently installed Outlook 2010 and used .pst files from outlook 2007. I used scanpst.exe to remove all errors as well. But indexing never indexes all the files within PST, it only indexes a few. Can anybody help here?

    Wednesday, October 27, 2010 8:20 AM
  • Add me to the list of users that experience outlook 2010 search crash on windows 7.
    • Proposed as answer by mcpram Saturday, November 20, 2010 9:04 PM
    Wednesday, November 17, 2010 3:28 PM
  • I went through all the different fixes that have worked for people - to no avail! as a last hope before a repair installation , i uninstalled bitdefender 2011 . Indexing instantly started . Problem Solved
    Saturday, November 20, 2010 9:07 PM
  • Are we sure the index add-in is supposed to be enabled?  My theory is that the add-in is used in Windows installations without a global search.  To that end, my search is working without the add-in enabled, at least for now.  Here's basically what I did.

    1.  At baseline, Outlook 2010 search was hung up with some 70,000 messages unindexed. 

    2.  Go to the global indexing (start -> type indexing...) -> advanced-> restore defaults -> ok -> modify -> show all locations -> uncheck everything but outlook -> OK -> advanced -> rebuild index -> indexing worked for outlook and indexed over 70,000 messages in about 4 hours or so -> back to indexing options -> turn on all other locations -> bed -> all indexed by am.

    3.  I then turned on the indexing add-in.  I ended up getting an error that the indexing service stopped working and the whole outlook index rebuilt itself again.  That's where I am right now.  If this doesn't work, it may be time for a full ground-up Windows reinstallation.

    Maybe we should look at "healthy" systems and see if the search add-in is running.Leave the add-in disabled. 

    I'm using Vista sp2 32 bit with outlook 2010 installed over outlook 2007.

    Friday, December 31, 2010 5:27 PM
  • Zippy From Rainbow's solution is quite different from yours. I tried yours it didn't help, because in my situation Indexing Service was disabled, not Windows Search.
    Sunday, January 2, 2011 5:19 PM
  • This help solve my disable add-in indexing problem  and a vba problem with Outlook 2010 starting up and disabling add-ins on Window 7 64-Bit system. My hope is that this is helpful information, it solved my problems.

    To enable the Developer tab

    1. On the File tab, choose Options to open the Outlook Options dialog box.

    2. Click Customize Ribbon on the left side of the dialog box.

    3. Under Choose commands from on the left side of the dialog box, select Popular Commands .

    4. Under Customize the ribbon on the right side of the dialog box, select Main tabs , and then select the Developer check box.

    5. Click OK .

    Additional instruction see the site listed below

    http://msdn.microsoft.com/en-us/library/ee814736.aspx
    • Proposed as answer by jdope Tuesday, January 4, 2011 5:11 PM
    Tuesday, January 4, 2011 5:11 PM
  • I have the same problem. Windows 7 64-bit with office 64-bit. I have gotten my outlook to start working again using the various methods provided here. However .... the indexing service seems to break and stop working about every month or so. I have to one by one try all these methods to get things going again.

    Just started happening to me again today. Indexer addin is disabled ... HOWEVER I can do a search and get results, it just wont search the last 5 days. Anything older than about 5 days ago comes up just fine in my search results!

    When I check the indexing status, it shows 0 items. Rebuild in all my past experience seems to be a waste of time.

    Here we go again!

    Tuesday, January 4, 2011 10:48 PM
  • I reinstalled Windows completely. 

    1.  I found a big slow down in indexing, and maybe a cause of some of these unstable indexing problems, is the PDF Ifilter from Nuance (PDF Converter Pro on my system).  In some ways it's a nice filter, but it's really slow because it does OCR on every single PDF file!  I uninstalled it and indexing is zipping along.  I instead installed the Foxit PDF Ifilter - a free download.  Of note, Foxit installation hangs on my system and I finally got a successful installation by using MSConfig -> diagnostic startup, but start the windows installer service.

    2.  The add-in for oulook is disabled w/ a clean installation. Conceivably, it's some other software conflict w/ something else, but not much else installed yet, and t's clearly not just a random fluke.  Can anyone confirm that the add-in works on any systems?

    Saturday, January 22, 2011 7:17 AM
  • I can report that after another almost 2 weeks after changing the pdf Ifilter from Nuance's to Foxit, indexing is running perfectly.  Also, the add-in for indexing in outlook remains disabled, which appears to be the normal state of affairs. 

    So if you are having problems with indexing, I strongly recommend as a trial to disable indexing of pdf files (indexing options -> advanced -> file types -> uncheck pdf if enabled).  If that resolves the problem, try the Foxit pdf Ifilter - it's the trial version, which is permanently free without any other pdf software. http://www.foxitsoftware.com/pdf/ifilter/

    Wednesday, February 2, 2011 11:55 AM
  • The Windows Search Email Indexer add-in is deprecated and disabled intentionally.  It used to be responsible for indexing online mode Exchange content.  It is not used at all by Outlook 2010.

    • Proposed as answer by Joe Tinney Thursday, March 31, 2011 2:36 PM
    Monday, February 14, 2011 10:43 PM
  • PROGRESS!  I'm using WinXP and Outlook 2010 Pro Plus x86.

    None of the indexing type of things has worked consistently and for no apparent reason starts all over again and takes two days to do its thing.

    I worked with the addins instead.  I unchecked all of the addins and it still did not fix the problem.

    If I run Outlook with the /safe:3 flag the search works!!!

    According to Microsoft, /safe:3 = Both native and managed Component Object Model (COM) addins are turned off.

    Now since I believe I turned off all of the "managed" COM addins manually and it didn't work, I am concluding that the problem is in the "native" COM addins.

    I don't know what these are and I don't know what I will be disabling by running with /safe:3

    ANYONE COMMENT ON THIS?

     

    Friday, March 11, 2011 12:46 AM
  • the solution is to enable the exchange cached mode on the outlook profile
    Tuesday, March 15, 2011 11:07 AM
  • the solution is to enable the exchange cached mode on the outlook profile

    I don't use exchange and problem exists so it nothing to do with that?
    problem exists for me using Outlook 2010 stand alone on Win7.   its a real pain as this is a critical feature I use day to day.  Stopped indexing a few days ago.  Items already indexed show up but NOT anything in the last 5 days. 

    I really hope somebody can find a solution  

    Thursday, March 17, 2011 11:58 PM
    • Proposed as answer by moore101 Monday, April 11, 2011 6:44 PM
    Thursday, March 31, 2011 3:51 PM
  • The Windows Search Email Indexer add-in is ... not used at all by Outlook 2010.


    Thank you! So much discussion about this add-in... and actually my question was, the add-in is disabled but my search works fine, why is it there?
    Tuesday, May 17, 2011 12:46 PM
  • I've also been expriencing this problem and did the following as suggested by LDVG

     

    I may have a solution.

    1. Go to Programs and Features (Turn Windows features on or off) and UNCHECK Windows Search. I'm using Win7.
    2. Reboot
    3. Open Outlook and you should see Search is not available. Close Outlook.
    4. I rebooted here, but you may not need to.
    5. Go back to Programs.. and CHECK Windows Search.
    6. Reboot
    7. Open Outlook and see if it's working.

     

    It didn't work and oulook still reported Windows Seach disabled. :(

    I then disabled People Pain (View > People Pain (drop down) > Off)

    Closed Outlook and re-opened (it briefly ran through an install screen) it works and indexing now!

    Hope this helps!

    Alex

     

    Tuesday, June 28, 2011 9:27 AM
  • Having tried all those suggestions above, none of them really worked with Windows 7 64-bit and Outlook 64-bit. However, what really fixed the problem:

    Service Pack 1 for Microsoft Office 2010 (KB2460049) 64-bit Edition
    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=26617

    Thereafter I rebuilt the indexes. Everything has been fine since yesterday (and I used Outlook most of the night with different Exchange 2010 accounts).


    MCTS: Messaging | MCSE: S+M
    Wednesday, June 29, 2011 6:00 AM
  • On a stand-alone PC, running Outlook 2010 as part of the Windows Office Professional Plus bundle.  The operating system is Windows 7, service pack 1.

    I have experienced the indexing problem and the search failure ever since I installed Outlook 2010.  The only solution that works for me has been to uninstall Outlook and let it re-index as part of its installation process.  This usually lasts for some 2 to 3 months and then suddenly I'll try a search and I'll have nothing found.

    When attempting to run "Rebuild" in the advanced tab of index option from within Outlook, it goes through the whole process of indexing 39930 items, reporting indexing complete and then when I attempt to conduct a search, it always returns nothing.

    The last time it happened is when Win7 service pack 1 was installed.

    This problem has been discussed on various forums.  I cannot understand how Microsoft can have this issue unresolved for so long.

    Please let me know if ever one of you finds a solution other than re-installing Outlook ever 2 months or so.

    Wednesday, June 29, 2011 11:08 PM
  • While I can't comment on the longevity of the solution. For me, Outlook 2010 SP1 in combination with rebuilding the index has solved the issue. Works fine with two separate Exchange 2010 accounts on Windows 7 SP1 (Outlook and Windows 64-bit).

    The search function in Outlook 2010 never worked before, while I never had any issues with my machine at work with the 32-bit versions of Windows 7 and Outlook 2010.


    MCTS: Messaging | MCSE: S+M
    Thursday, June 30, 2011 5:44 AM
  • This worked for me!  Thanks.
    Friday, August 5, 2011 3:00 PM
  • Dear Sally Tang,

    I have the  same problem on win7 x64 pro sp1/outlook 2010.

    I use your function try ti fix this issue, but it still could not.

    can anyone help me??

    thank you so much!!


    Michael
    Friday, September 2, 2011 8:48 AM
  • Alright,  So for me, the culprit was the windows search service.  I saw that it was enabled in the Add Programs/Add Windows Features,  I tried running as Administrator without any luck. SO i decided to see if the "Windows Search" Service was running.  So i opened a run prompt and typed in "services.msc" (you can get to services through the control panel) and then scrolled down to "windows search" and it was indeed disabled.  I double clicked it, Changed it from disabled to automatic (you can do manual if your worried about it for some reason) and then i was able to start the service.   i then clicked over in the search inbox folder and instantly was able to sift through my emails!

     

    Good luck

    Friday, October 28, 2011 5:02 PM
  • I'm running into similar issues with WinXP(x86) and Outlook 2010(x86). Exchange in cloud, cache activated, search in services activated, search in Outlook activated, windows search 4 installed indexing run and appropriate dotnet installed.

     

    Search works fine with everything other than Outlook where it cannot find .msg's.


    btw: Cannot use  /safe:3 flag due to 3rd party software.
    • Edited by Ami16th Monday, December 5, 2011 3:09 PM
    Friday, November 25, 2011 10:49 AM
  • As one of the guys pointed out, disabled windows search index add-in seems to be by design. I was facing this issue too. Read several posts and threads and tried many things. Nothing worked. But what worked for me seems too simple. What I did is I searched with a generic string in Outlook. It showed no results which was its normal behavior. Then I decided to click on Search Tools > Search Options. Selected All folders, Include messages from the Deleted items folder...... All Items. Finished up this then searched for a generic term again and BOOM. Began getting instant results and a message stating that Outlook still needs to index xxxxx number of items (which it did in a matter of seconds). 

    Hope this works for you guys too. But thanks for all the input. 
    Thursday, January 19, 2012 4:47 AM
  • Hi Maverick,

    at the time I first commented on this thread, I've also tried this without positive results. Out of the blue this morning, I checked the settings again and reapplied the radio button and check box. We then tested the search function and low and behold ... success.  :-)

     

    Thanks for your help Maverick, we were dumbfounded as to why search didn't work for this particular customer.

     

    Mark

    Thursday, January 19, 2012 9:06 AM
  • I also had the same problem with search. The reason why mssphtb.dll is constantly disabled is that outlook 2010 doesn't need it anymore. I tried all of the things from rebuilding index to removing and adding back Indexing service and Windows search. Nothing worked.

    Then I noticed on my Exchange 2010 SP1 server, an error in event viewer:

    Content Indexing function 'CISearch::EcGetRowsetAndAccessor' received an unusual and unexpected error code from MSSearch.
    Mailbox Database: {Database Name}
    Error Code: 0x80041606

    To solve this problem do the next steps on your Exchange Server:

    1. On the Microsoft Exchange Server type services.msc, then find Microsoft Exchange Search Indexer Service and stop it
    2. Navigate to the folder that holds the database in question.
    3. In this folder you will find a folder Catalog-Data.......something random. Delete this folder
    4. Start the Microsoft Exchange Search Indexer Service

    These steps will rebuild your Full Text Index Catalog. I recommend doing this in the off hours because it can use a lot of your CPU.

     

    PS: This didn't solve the error. I still get it but the search in Outlook is now working as charm :)

    • Edited by Darth Vlado Thursday, January 19, 2012 12:06 PM
    Thursday, January 19, 2012 12:00 PM
  • Thanks LDVG, finally a solution that worked
    Thursday, March 1, 2012 7:53 PM
  • As this is a highly-indexed "answer" to the question, I thought I'd post my experience here.

    I found this thread because Windows Search and Outlook Instant Search was failing.  I am using Outlook 2013 on Windows 8.

    I tried (with no success) the tips in this thread which include (to summarize for anyone who doesn't want to read the whole thread):

    • Resetting the Windows Search index(Control Panel -Indexing Options)
    • Removing and re-adding the Windows Search feature (Control Panel - Programs and Features)
    • NOTE: It is NOT necessary to enable the Windows Desktop Search "Add-in" for Outlook 2010 and later--this is outdated information in this thread.  The add-in is there for legacy reasons.  Don't remove it, but no need to enable it.
    • Creating a new profile.
    • Trying it under an entirely new user account (to remove the variable of any user-specific configuration problems)

    None of these things worked. Though I recommend trying them first, anyway--could be they will work for you.

    For ME, what fixed the problem was to run a REPAIR on Office 2013.  I did the "full repair" option.  Took a long time, but when it was done, and when Outlook finally indexed my mailbox, search finally started working as expected.

    • Edited by Dan Holme Monday, August 27, 2012 7:44 PM
    Monday, August 27, 2012 7:43 PM
  • I had the same problem with indexing in Outlook 2010 always saying that indexing was not complete. I tried "everything" - scanpst, repair Office, new profile, empty deleted items, re-run scanpst, etc. But - I found that the thing that fixed it was to turn off Nuance indexing. So - see if you have any other software that is also indexing. I have lots of Nuance products including PaperPort and it indexes, also. Once I turned that off and rebooted and made sure it was still off, I opened Outlook and all was well. Nuance has it's indexer shown in the notification area so it was easy to test. You might also check your start-up items for indexing software.
    • Proposed as answer by aputerlady Sunday, January 6, 2013 3:00 PM
    Sunday, January 6, 2013 3:00 PM
  • I can report that after another almost 2 weeks after changing the pdf Ifilter from Nuance's to Foxit, indexing is running perfectly.  Also, the add-in for indexing in outlook remains disabled, which appears to be the normal state of affairs. 

    So if you are having problems with indexing, I strongly recommend as a trial to disable indexing of pdf files (indexing options -> advanced -> file types -> uncheck pdf if enabled).  If that resolves the problem, try the Foxit pdf Ifilter - it's the trial version, which is permanently free without any other pdf software. http://www.foxitsoftware.com/pdf/ifilter/

    THANK YOU Yearn2Burn!  I've been fighting this issue for at least a month now.  I also probably have thousands of PDF attachments, and at some point I noticed it had started returning search results from the contents of PDF attachments, for reasons I did not know, but somehow didn't make the connection that the OCR process might be causing the indexing to go awry.

    Per your instructions, I deselected "PDF" from "File types".  The number of files to be indexed suddenly jumped from 8k to 45k as it started to rebuild the index, but started working downward from there faster than it had before.  Then I also hit Ctrl-Shift-Esc and ended the Process "PDFProFiltSrvPP.exe".  Now I'm down to 0 items remaining. 

    Here's hoping it sticks! 

    Wednesday, February 20, 2013 11:05 PM
  • This solved the problem for me also.
    Tuesday, October 21, 2014 7:40 PM
  • this also helped me successful.thanks
    • Proposed as answer by Gary_90 Monday, November 9, 2015 9:42 PM
    • Unproposed as answer by Gary_90 Monday, November 9, 2015 9:43 PM
    Tuesday, September 29, 2015 12:25 PM
  • Repairing Outlook worked for me.  I have Windows 7 and Office/Outlook 2010.  When searching from the "Search programs and files" I could see the Outlook messages but I could not open them. Other files worked fine. 

    Control Panel >> Programs and Features >> right click on "Outlook", then click "Change" and then select "Repair"

    Monday, November 9, 2015 9:50 PM