none
Retention policy Action skipped RRS feed

  • Question

  • I have a document library with around 80k emails in it. Now the business wants to have these emails send to an archive if the received date (date meta data field) is older than two years.
    So I have created a retention rule on that library:

    Received + 2 years,
    Transfer to another location,
    move,
    location: Drop off library

    The drop off library is configured in CA with the correct .asmx url. The drop off library should process the email further to the archive based on the existing content organizer rules.
    When starting the information management policy timerjob the expiration date is filled for all 80k emails. After they are filled I start the Expiration policy timerjob. This one starts running and I see in the uls log that it does check every file in the library, however no files are being send to the drop off library.
    At least 60k of the 80k files have an expiration date based on which the item should be processed by the expiration policy timerjob. Looking at the uls log all these files give the following error:
    Retention: Attempt to send file filename.msg within the same site http://sitename.net. Action skipped

    Does anyone know what is happening here?

    Thursday, May 30, 2013 2:01 PM

Answers

All replies

  • Hi,

    I understand that you want to move the documents using the document retention policy. Since there are 60k document that need to be moved to the drop off library, this skip can be caused by that the amount of the documents are too large. So you can create a retention policy on another library which contains a few documents to test whether the asms URL works as expected. If this service doesn’t work, you need to first check the content organizer rule settings.

    Thanks,

    Entan Ming


    Entan Ming
    TechNet Community Support

    Friday, May 31, 2013 11:24 AM
    Moderator
  • I did a test with only 4 emails in a seperate document library and the same retention rule. When i run the information management policy timer job all expiration dates get set. After that when i run the expiration policy timer job the expiration date gets cleared, but no documents are being moved to the drop off library. When i use the send to connection on a single document with send to the document is sended correctly to the drop off library.
    Tuesday, June 4, 2013 9:10 AM
  • I did some more research and found that more people encounter this problem. Transfer to another location does not seem to work in retention. See also http://social.msdn.microsoft.com/Forums/en-US/sharepointgeneralprevious/thread/5a919feb-493c-4ce9-b8fa-0e17cd309f03

    So i decided to go for a Designer workflow that does a copy and delete of the item. This works fine with retention.

    • Proposed as answer by Roger Beulen Tuesday, June 4, 2013 12:15 PM
    • Marked as answer by Ruud Hamers Tuesday, June 4, 2013 12:24 PM
    Tuesday, June 4, 2013 11:47 AM