none
Exchange 2010 Mail Archive Missing in Outlook 2010 - Shows in OWA

    Question

  • Outlook 2010 (Technet Pro Plus) on a 2003 Terminal Server
    Exchange 2010 SP1 (218.15) Enterprise
    Set up a second datastore for the archive
    Added archiving to test account (administrator)
    See the icon change in EMC, mailbox and archive database are listed in user properties

    Launch Outlook and the Online Archive mailbox is missing under Folder List. The Online Archive shows up in OWA

    Thursday, March 29, 2012 11:43 PM

Answers

  • Hello,

    From the above notes, I understand that the Online Archive mailbox is not showing up in Outlook on a Terminal Server Session. If we configure Outlook using the same user credentials on a standalone workstation we are able to see the Online Archive mailbox. You also have purchased Volume Licensing. Please correct me if I've got this wrong?

    Is this specific to the Terminal Sever Session? Is the issue seen when any user logs onto the Terminal Server? What we are trying to isolate is the Terminal Server.

    Can you please log on to the Terminal Server with the test account and follow the below steps to check for the Auto-Discover Services?
    1. Launch Outlook.
    2. Hold the Ctrl Button down on the keyboard and right click the Outlook Icon in the System Try.
    3. Select Test Email AutoConfiguration.
    4. Check AutoDiscover and hit Test. Do you see the below information?

    <AlternativeMailbox>
            <Type>Archive</Type>
            <DisplayName>Online Archive - ABC </DisplayName>
            <LegacyDN>
    </LegacyDN>
            <Server> </Server>
          </AlternativeMailbox>

    If you do see the above information, it means that the Auto Discover Services are brining the Online Archiving Info; however Outlook is unable to read it. If you are unable to see the above info, then we will have to engage the Exchange Team to help us.

    To investigate further; we will require to take few logs and analyze the same. Hence I suggest that you open a Phone Support case with Microsoft.

    Thank You.


    RKeith - [MSFT]

    Tuesday, April 17, 2012 4:02 PM
    Moderator

All replies

  • Hi,

    It might be caused by the Office version doesn’t meet the license requirement for Personal Archive feature. See the following article:

    http://office.microsoft.com/en-us/outlook-help/license-requirements-for-personal-archive-and-retention-policies-HA102576659.aspx

    To use the feature with Outlook volume licenses, Microsoft Office Professional Plus 2010 is required.


    Sincerely
    Rex Zhang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, March 30, 2012 6:52 AM
    Moderator
  • According to the list I have the correct software. I tried it on another machine and it works. The only difference is Windows 7.
    Friday, March 30, 2012 2:28 PM
  • Do you see it after recreating your mail profile via the Mail applet in Cotrol Panel?
    See; http://www.howto-outlook.com/faq/newprofile.htm



    Robert Sparnaaij [MVP-Outlook]
    Outlook guides and more: HowTo-Outlook.com
    Outlook Quick Tips: MSOutlook.info

    Friday, March 30, 2012 4:11 PM
  • Hi mvalpreda,

    Do you mean you have the Microsoft Office Professional Plus 2010 installed on both clients?

    Best regards,


    Rex Zhang

    TechNet Community Support

    Monday, April 2, 2012 1:34 AM
    Moderator
  • Does not show up when re-creating the profile.

    Using Office Professional Plus 2010 on both clients. The only difference is that one is a 2003 Terminal Server and the other is a Window 7 laptop. The Windows 7 machine works as expected.

    Monday, April 2, 2012 3:28 PM
  • Hi,

    In other words, the issue occurs on the Terminal Server but not Windows 7 clients. See if the following could be help:

    http://social.technet.microsoft.com/Forums/nl/outlook/thread/27d9ce81-7ba4-4271-93d1-f2b30638a58f

    Best regards,


    Rex Zhang

    TechNet Community Support

    • Marked as answer by Rex ZhangModerator Wednesday, April 11, 2012 1:25 AM
    • Unmarked as answer by mvalpreda Wednesday, April 11, 2012 4:33 PM
    Tuesday, April 3, 2012 4:34 AM
    Moderator
  • Hi,
     
    I am writing to see how everything is going with this issue. Is the problem resolved? If there is anything I can do for you, please feel free to let me know.
     
    Best Regards, 


    Rex Zhang


    Rex Zhang

    TechNet Community Support

    Friday, April 6, 2012 2:55 AM
    Moderator
  • Hi,
     
    As I have not heard from you for several days. I will go ahead and close this thread. If you have any questions, please feel free to reply to us and this thread will be re-opened.
     
    Best Regards, 
     
    Rex Zhang

    Rex Zhang

    TechNet Community Support

    Wednesday, April 11, 2012 1:24 AM
    Moderator
  • Autodiscover is functional on the terminal server. I was able to set up a new user on there that has archiving enabled with no issue but the Archive mailbox does not show up.
    • Edited by mvalpreda Wednesday, April 11, 2012 4:34 PM
    Wednesday, April 11, 2012 4:34 PM
  • Hello,

    From the above notes, I understand that the Online Archive mailbox is not showing up in Outlook on a Terminal Server Session. If we configure Outlook using the same user credentials on a standalone workstation we are able to see the Online Archive mailbox. You also have purchased Volume Licensing. Please correct me if I've got this wrong?

    Is this specific to the Terminal Sever Session? Is the issue seen when any user logs onto the Terminal Server? What we are trying to isolate is the Terminal Server.

    Can you please log on to the Terminal Server with the test account and follow the below steps to check for the Auto-Discover Services?
    1. Launch Outlook.
    2. Hold the Ctrl Button down on the keyboard and right click the Outlook Icon in the System Try.
    3. Select Test Email AutoConfiguration.
    4. Check AutoDiscover and hit Test. Do you see the below information?

    <AlternativeMailbox>
            <Type>Archive</Type>
            <DisplayName>Online Archive - ABC </DisplayName>
            <LegacyDN>
    </LegacyDN>
            <Server> </Server>
          </AlternativeMailbox>

    If you do see the above information, it means that the Auto Discover Services are brining the Online Archiving Info; however Outlook is unable to read it. If you are unable to see the above info, then we will have to engage the Exchange Team to help us.

    To investigate further; we will require to take few logs and analyze the same. Hence I suggest that you open a Phone Support case with Microsoft.

    Thank You.


    RKeith - [MSFT]

    Tuesday, April 17, 2012 4:02 PM
    Moderator
  • Thanks RKeith. This helped me to resolve the issue.

    I had the same issue. We moved our users to a new Terminal Server on the same domain.

    Frustrated and after much searching and trial and error, for us, it was indeed a mailbox permissions issue.

    I removed the "self" permissions from "Manage Full Access Permissions" and then re-added it.

    The mailbox may temporarily be duplicated but after closing Outlook and opening again you should be left with one mailbox and the much sought after Archive folder...

    Happy days...

    :)

    • Proposed as answer by ryryguy Sunday, January 27, 2013 11:19 PM
    Wednesday, September 26, 2012 3:55 AM
  • Thank you, this resolved my issue with the Online Archive not appearing in Outlook 2010, when Outlook client was the correct version compatible with the licensing requirements of Online Archive (Office Professional in my case).
    Sunday, January 27, 2013 11:25 PM
  • Hi. I've just had a really similar issue.

    Migrating PST files from "server1" to Exchange 2010 SP2.
    Using shell commands on exchange2010.
    Step1.
    (this enables the archive for that user)
    Enable-Mailbox -Identity user1 -Archive
    Step2.
    (to move the PST files)
    New-MailboxImportRequest -FilePath "\\server1\folder1\NameOfPstFile.pst" -Mailbox user1 -TargetRootFolder "FolderNameToAppearInTheArchive" -IsArchive

    (repeat Step2 if there is multiple pst files, and just give them a different name in the archives to separate them)

    You can check the status on the migration with:
    Get-MailboxImportRequest | Get-MailboxImportRequestStatistics

    Once this was done, I checked the users OWA account, and the archive was there.
    This just tells us that all was good, migration was a success.
    But then when you open Outlook 2010 (SP1) there is no Archive Directory.... ?

    You can still check to see if your outlook client can detect the Archive by Keep Ctrl+RightClick on the Outlook icon in the Taskbar, and select "Test Email AutoConfiguration" menu.
    Un-check "Use Guessmart" and "Secure Guessmart Authentication" (when your domain connected)
    Click "TEST" Go to the XML tab, down towards the end of the list you should see entries for your Archive.

    After searching on the internet, I found that it might be related to the NT AUTHORITY\SELF permission not working as it should. To fix this I run these power commands:
    Step 1: (check current settings)

    Get-MailboxPermission -identity user1@domainname.com | format-list
    (on top of the list)

    RunspaceId         : a9cd14ac-53e8-4bb8-xxxxx-xxxxxxxxxx

    AccessRights       : {SendAs, ReadPermission}               (note that it's missing the FullAccess here)

    Deny                      : False

    InheritanceType : All

    User                       : NT AUTHORITY\SELF

    Identity                : domainname.com/user1

    IsInherited           : False

    IsValid                    : True

    Step 2:

    Open the Mailbox GUI setting for User1 on Exchange.
    Right-Click on the mailbox, and select "Manage Full Access Permission"
    Remove the "NT AUTHORITY\SELF" entry, accept, and close the rest of the dialog boxes, and close the GUI.
    Make a coffee (or wait for about 5 min)

    Step 3:
    Run this command
    get-mailbox "user1" | Add-MailboxPermission  -User 'NT AUTHORITY\SELF' -InheritanceType 'All' -AccessRights 'FullAccess'

    (that will add the permission in again)

    Step 4:

    Check that the permission is correct now. With:
    Get-MailboxPermission -identity user1@domainname.com | format-list

    RunspaceId         : a9cd14ac-53e8-4bb8-xxxxx-xxxxxxxxxx

    AccessRights       : {FullAccess, SendAs, ReadPermission}               (note: FullAccess should be back now)

    Deny                      : False

    InheritanceType : All

    User                       : NT AUTHORITY\SELF

    Identity                : domainname.com/user1

    IsInherited           : False

    IsValid                    : True

    This should fix the Outlook 2010 not been able to open Archives Folder.
    So open Outlook with user1 account, and wait about a minute, then the archive should come up shortly.

    Worked for me.

    Thanks, and good luck.
    Fred.

    Friday, May 24, 2013 3:14 AM