none
"Because of an error in data encryption, this session will end"

    Question

  • All of a sudden my Windows 7 x64 computer is unable to connect to random Windows 2008 R2 servers via Remote Desktop.

    I can connect to the same servers from other Windows 7 machines.

    The only fix I've come across so far is this, except that key doesn't exist on either my machine or on the server(s):

    To resolve this issue, follow these steps:

    1. Start Registry Editor.
    2. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TermService\Parameters
    3. Under this registry subkey, delete the following values:
      • Certificate
      • X509 Certificate
      • X509 Certificate ID
    4. Quit Registry Editor, and then restart the server.

    Does anyone have any suggestions please as I'm at a total loss what is happening here.

    Thanks.

    Monday, December 3, 2012 8:38 AM

Answers

  • Hi,

    You can try to configure the target server NIC properties to see whether solve this issue.

    Local Area Connection -> Properties -> Configure -> Advanced -> IPv4 Large Send Offload =Disabled.

    If it doesn't solve this issue, you can open the regedit.exe on target server, and navigate to:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters

    After exporting this for safekeeping, then you can delete the Certificate keys. Reboot the target server to see whether the same issue still exists.

    Clarence


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, December 4, 2012 9:21 AM
    Moderator

All replies

  • Hi,

    You can try to configure the target server NIC properties to see whether solve this issue.

    Local Area Connection -> Properties -> Configure -> Advanced -> IPv4 Large Send Offload =Disabled.

    If it doesn't solve this issue, you can open the regedit.exe on target server, and navigate to:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters

    After exporting this for safekeeping, then you can delete the Certificate keys. Reboot the target server to see whether the same issue still exists.

    Clarence


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, December 4, 2012 9:21 AM
    Moderator
  • I know this is ancient, but I thought that I'd add what I found to be my solution after having the exact same issues as yourself, trying the suggested fixes without luck and just about pulling my hair out too:

    My Fix:  Simply uninstall the Link-Layer Topology (Mapper I/O Driver and Responder) protocols, as well as the QoS Packet Scheduler service (you can add them back again afterwards) in the Local Area Connection of the client machine (not the server/target).  You must uninstall, not simply remove the checkmark next to the protocol or service.


    This did the trick for me.
    • Proposed as answer by AirborneAgain Friday, May 31, 2013 8:58 PM
    Tuesday, March 12, 2013 4:22 PM
  • Ancient or not, it helped me today.  I am connecting over a VPN, and I suddenly started getting this message when connecting to 5 different servers.  I knew it was on my end, so all of these suggestions for server changes weren't helping.  This took care of it, though.  Thanks, Garth.
    Friday, May 31, 2013 9:01 PM
  • thanks ! it worked like a charm ! i searched for dam long before seeing your reply
    Monday, August 19, 2013 8:00 PM
  • I uninstalled the Sonicwall Global VPN client and the problem went away.  In fact the VNC issues cleared up as well.  Haven't heard back from Sonicwall on the issue.
    • Proposed as answer by Weeboo_TN Tuesday, November 4, 2014 4:17 PM
    Monday, September 9, 2013 1:03 PM
  • I uninstalled the Sonicwall Global VPN client and the problem went away.  In fact the VNC issues cleared up as well.  Haven't heard back from Sonicwall on the issue.
    This resolved my problem. Thanks for the suggestion.
    Tuesday, September 24, 2013 2:36 AM
  • I uninstalled the Sonicwall Global VPN client and the problem went away.  In fact the VNC issues cleared up as well.  Haven't heard back from Sonicwall on the issue.

    This fixed my issue, I'll have to find a work around to remote to my Sonic Wall network... Thank you Chris Kless


    • Edited by Puente23 Sunday, October 6, 2013 4:37 PM
    Sunday, October 6, 2013 4:36 PM
  • I uninstalled the Sonicwall Global VPN client and still had the issue.

    Finally, removing Citrix DNE Lightweight Filter service from my network adapter solved the problem for me.

    John

    • Proposed as answer by Simon Carroll Thursday, October 31, 2013 11:25 AM
    Tuesday, October 29, 2013 1:32 PM
  • I uninstalled the Sonicwall Global VPN client and still had the issue.

    Finally, removing Citrix DNE Lightweight Filter service from my network adapter solved the problem for me.

    John

    I'll second this, I connect to a couple of dozen different clients' servers using at least 10 different pieces of software; and I ripped out just about everything suggested here.  Only after uninstalling the Citrix DNE LightWeight Filter service from the network adaptor (and restarting) did the error go away.
    I'm not putting back the other stuff (SonicWall client, Link-Layer Topology (Mapper I/O Driver and Responder) and QoS Packet Scheduler service) until this job is finished tomorrow, but I'll test as I add things back in and report back here.  
    Thursday, October 31, 2013 11:25 AM
  • Thanks!  This worked for me too.  Server 2003, Windows 7 x64.
    Monday, December 30, 2013 2:52 PM
  • Simply running the Sonicwall client without actually connecting to any vpn actually resolved the issue for me.
    • Proposed as answer by KBert99 Monday, May 12, 2014 3:18 PM
    Thursday, January 23, 2014 11:26 PM
  • Yes... it wasn't the sonicwall client for me... it was the citrix DNE filter? Removing that allowed my sonicwall vpn to work again.
    Wednesday, January 29, 2014 4:34 AM
  • I uninstalled the Sonicwall Global VPN client and still had the issue.

    Finally, removing Citrix DNE Lightweight Filter service from my network adapter solved the problem for me.

    John

    I'll second this, I connect to a couple of dozen different clients' servers using at least 10 different pieces of software; and I ripped out just about everything suggested here.  Only after uninstalling the Citrix DNE LightWeight Filter service from the network adaptor (and restarting) did the error go away.
    I'm not putting back the other stuff (SonicWall client, Link-Layer Topology (Mapper I/O Driver and Responder) and QoS Packet Scheduler service) until this job is finished tomorrow, but I'll test as I add things back in and report back here.  

    I did this.  Removed the old Global VPN client and re-added everything back in and it works fine.  I had 2 systems displaying this issue that both ran the old client.  I took just the client off the 2nd system and it corrected the issue.  I also removed the Citrix Client but I did not have to do a restart on either system.  Didn't see a need for that filter anyway and I am running perfectly normal without it.

    I have had those Global VPN clients in place for quite some time even though I primarily utilize the SSL-VPN now.

    This issue has plagued me for a long while on one system and it never occurred to me that the old client (since it was not being used) could cause this.  Thanks for the help John and Simon.

    Thursday, February 20, 2014 12:53 PM
  • Simply running the Sonicwall client without actually connecting to any vpn actually resolved the issue for me.

    THIS WORKED! I have no idea why. I just turned on the client, and then was able to connect to RDP sessions via my standard windows PPTP vpn. What horrible sorcery is behind this client!?
    Thursday, March 13, 2014 5:11 PM
  • Thanks a ton for these simple and clear instructions that just work.  These days, with all the Microsoft bugs and crappy and failing software, it's nice to find friends and folks who simply find quick fixes that actually work.  So many times people make suggestions, but it's nice to find someone who bothered to take the time to help others solve theirs.  Thanks again Garth!
    Friday, March 14, 2014 4:04 PM
  • This also worked for me AMAZING -- I have tried just about everything in all other posts. In fact I was doing it and was able to use SSL VPN without knowing why. Today I tried it and this is definitely what results in me able to stably connect. I tried to connect to 5 different sonicwalls of different firmwares using 3 different versions of the NetExtender and only this solution of simply opening GVC worked for me. Thank you!!

    Monday, March 31, 2014 6:56 PM
  • Yup, this worked for me too.  Go figure.
    Tuesday, June 10, 2014 4:19 PM
  • Simply running the Sonicwall client without actually connecting to any vpn actually resolved the issue for me.
    worked for me.
    Friday, June 27, 2014 5:49 PM
  • This worked for me!... Thanks!
    Tuesday, July 1, 2014 8:30 PM
  • Confirmed running the Sonicwall VPN Client while connecting works for me too.

    And I'll add the I can connect to Win8.1 (from the same Win7 machine) without error without the VPN client running. Probably Microsoft added some way to encrypt RDP traffic that's not shared with Sonicwall's VPN client.

    Monday, July 21, 2014 1:07 AM
  • The Sonicwall Global VPN client started causing the error for me recently as well while trying to RDP into 2012r2 servers.  Removing the Sonicwall Global VPN client and rebooting did the trick. 

    Ironically, I am RDP'ing into a 2012r2 server over a Sonicwall NetExtender client now successfully.

    Tuesday, November 4, 2014 4:20 PM
  • Yes, just simply running the Sonicwall Global VPN client (without connecting anything) allowed me to then connect to any RDP that uses a VPN. Uninstalling Sonicwall did not solve the problem. I had to reinstall and then run Sonicwall.
    Tuesday, March 17, 2015 4:10 PM
  • This worked for me as well. Thanks.
    Thursday, March 19, 2015 4:35 PM
  • Hi,

    Issue resolved by Local Area Connection -> Properties -> Configure -> Advanced -> IPv4 Large Send Offload =Disabled.

    Thank you.

    Thursday, April 16, 2015 5:40 AM
  • Simply running the Sonicwall client without actually connecting to any vpn actually resolved the issue for me.
    This worked for me. Thanks!
    Wednesday, July 1, 2015 4:52 PM
  • Hi Garth, Thank you.It worked like a charm. Don't have to fiddle with the server. It is the issue in the client and you said it right.


    Hari Subu

    Wednesday, September 16, 2015 8:25 PM
  • It is not necessary ti uninstall the Sonicwall Global Client. Just running it without actually connecting to any VPN, resolved the issue.

    Thanks!!

    Monday, December 21, 2015 8:34 PM
  • This did it for me too but I also uninstalled Citrix DNE Lightweight Filter. Then I rebooted and reinstalled  the Link-Layer Topology (Mapper I/O Driver and Responder) protocols, as well as the QoS Packet Scheduler service.

    All my VPN problems seem to have gone away - I hope they stay away.

    Sunday, January 24, 2016 10:10 AM
  • Thank you it worked for me as well. This should be the main answer :-)


    BSOD Plague

    Wednesday, March 23, 2016 8:47 PM
  • Perfect solution .. resolved my issue as well

    Hany Elkady

    Infrastructure Consultant

    Friday, October 21, 2016 12:17 AM
  • Simply running the Sonicwall client without actually connecting to any vpn actually resolved the issue for me.
    A year of frustration resolved. Thanks! I was wondering why it seemed to work and then other days not.
    Wednesday, November 16, 2016 8:13 PM
  • As a non-geek, I have no idea what you just said.  Could you please explain this in English?
    Wednesday, November 23, 2016 2:28 AM
  • It looks SonicWALL Global VPN has conflicts with SonicWALL NetExtender VPN.

    After uninstall SonicWALL Global VPN, issue solved!

    Tuesday, December 6, 2016 2:43 AM
  • Regarding your commnt:  "My Fix:  Simply uninstall the Link-Layer Topology (Mapper I/O Driver and Responder) protocols, as well as the QoS Packet Scheduler service (you can add them back again afterwards) in the Local Area Connection of the client machine (not the server/target).  You must uninstall, not simply remove the checkmark next to the protocol or service."

    Could someone please explain this in a simple, step by step manner as I am not familiar at all with computers and I would not want to damage my computer by doing the wrong thing.  Thanks.

    Ed

    Thursday, December 8, 2016 10:14 PM
  • It's 2018, Windows 10 now. I still suddenly encountered this problem, IPv4 Large Send Offload =Disabled still works
    Saturday, March 17, 2018 3:39 AM