Sites and list, error


  • Hi all,

    I am creating a webpart that will access all the items in a site and its subsites if the items approval status is on pending.
    It was fully working when i was only checking it on the top level site, but when i entered the code to make it run on multiple sites i got this error:

    "Feature 'df31abb1-d432-4fa5-bdb1-25a2a5dd7e86' for list template '7655' is not installed in this farm.  The operation could not be completed."

    I installed the U2U Caml Query feature as a solution to what i found during research for this problem and them came across this problem:

    Feature '0561d315-d5db-4736-929e-26da142812c5' for list template '5001' is not installed in this farm.  The operation could not be completed.

    Can anyone please tell me what is wrong with this, or just point me in the right direction.

    Thursday, September 10, 2009 8:41 AM


All replies

  • Looks like some custom feature with Id '0561d315-d5db-4736-929e-26da142812c5' is being used and not being removed completely.
    I would suggest you try to use deactive and unistall feature from stmadm with guid '0561d315-d5db-4736-929e-26da142812c5'.

    Please mark if reply answers your query.
    Thursday, September 10, 2009 10:57 AM
  • Hi,

    It unistalls the feature that i am creating, can this be any other problem?

    Thank you
    Thursday, September 10, 2009 11:20 AM
  • This sounds like a site scoped feature.  Is the scope Site?  Check the properties of the feature.xml.
    You could have missing feature dependencies.  Find what features are for those GUIDs and see if they are activated on the subweb you are targeting.
    Thursday, September 10, 2009 12:13 PM
  • The scope is site, and i have tried dploying it on different levels of the structure.
    And it was working before i put the code in for it to read the different sites, that would make the feature.xml correct.

    any other ideas why i am getting this error?

    thank you
    Thursday, September 10, 2009 12:22 PM
  • How are you reading the different sites?  I'm assuming you wrote a query against a list?
    Thursday, September 10, 2009 1:06 PM
  •  SPWebApplication webApp = SPContext.Current.Site.WebApplication;
                SPSiteCollection sites = webApp.Sites;
                foreach (SPSite site in sites)
                     SPWebCollection webCol = site.AllWebs;
                     for (int k = 0; k < webCol.Count; k++)
                         SPListCollection lists = webCol[k].Lists;
                         int count = lists.Count;
                         SPList list1;
                         for (int kkk = 0; kkk < count; kkk++)
                             list1 = lists[kkk];
                             int count1 = list1.Items.Count;
                             for (int k1 = 0; k1 < count1; k1++)
                                 if (list1.Items[k1]["Approval Status"].ToString() == "2")
                                     row = new TableRow();
                                     cell = new TableCell();
                                     Label lbl2 = new Label();
                                     SPListItem spIDTest = list1.Items[k1];
                                     if (list1.BaseType == SPBaseType.DocumentLibrary)
                                         lbl2.Text = list1.Items[k1]["Name"].ToString();
                                         lbl2.Text = list1.Items[k1]["Title"].ToString();
                                     lbl2.ID = site.ID + ";" + list1.ID + ";lbl" + spIDTest.ID.ToString();
                                     cell2 = new TableCell();
                                     CheckBox chk = new CheckBox();
                                     chk.ID = site.ID + "#" + list1.ID + ";" + spIDTest.ID.ToString();
                                     IDs.Add("Not Pending");
                                     CheckBox con1 = new CheckBox();
                                     con1.ID = "Not Pending";
    Does that help at all?

    Thank you
    Thursday, September 10, 2009 1:10 PM
  • You might try this.  The source could at least give you ideas where you went wrong.  I don't see anything that jumps out at me immediately why you are getting some feature dependency error.

    • Marked as answer by Chengyi Wu Monday, September 14, 2009 12:44 AM
    Thursday, September 10, 2009 1:41 PM
  • Thank you for your help, i appreciate it.
    Thursday, September 10, 2009 1:44 PM
  • Hi Everybody,

    although this post might be a little bit of age, I just had the same error while trying to export a list using the Export-SPWeb cmdlet.

    The Feature with Id '0561d315-d5db-4736-929e-26da142812c5' belongs to Nintex

    PS C:\> Get-SPFeature -Identity 0561d315-d5db-4736-929e-26da142812c5
    DisplayName                    Id                                       Scope
    -----------                    --                                       -----
    NintexWorkflow                 0561d315-d5db-4736-929e-26da142812c5     Site

    In my case I have moved the site collection from a farm were Nintex was installed to a farm without it.

    Hope this will help somebody...



    • Proposed as answer by warkem Thursday, September 13, 2012 12:12 AM
    Thursday, April 12, 2012 12:23 PM
  • I get this error in my old test environment when I try to run SPMetal... 

    I tried this tool to clean-up Nintex but it didn't work:

    How do you purge Nintex altogether?

    Monday, May 06, 2013 5:38 AM