Topology - Unable to remove a PSTN gateway


  • I recently added a Survivable Branch Appliance to the Topology.  When I did the initial configuration, I used the same fqdn for the SBA and the PSTN gateway it connects to.  Afterwards, when PSTN testing showed the SBA did not work, I added another PSTN Gateway to the Topology, using the ip address for the name, rather than the fqdn.  That worked fine.  However, now I have the first PSTN Gateway in the Topology, which I can not delete.  Topology Builder will not let me.  It does not tell me why, but I suspect it is confused because the SBA and Mediation server in the Branch Site have the exact same name.

    Any suggestions on how I can remove this gateway from the Topology?

    Thursday, June 02, 2011 5:09 PM

All replies

  • John,

    I have experienced the exact same issue in my environment. The only way to fix the topology is to remove the SBA from the topology and add it back in. In my experience this was rather painless. 

    1) Download the current Topology into Topology Builder.

    2) Remove the SBA from the topology, this will remove the SBA and the PSTN Gateway of the same name.

    3) Publish the Topology.

    4) Add the SBA back in and re-associate the IP defined PSTN Gateway with the SBA.

    5) Publish the topology. Might have to re-run setup bootstrapper on the SBA. 


    I did not have any users homed to the SBA when I performed this procedure. You might want to move the users back to the Front End before performing this procedure.

    Hope that helps,

    Jamie Schwinn

    Thursday, June 02, 2011 6:17 PM
  • Thanks.

    Two issues:

    1.  When I tried those steps - Topology builder would not let me add the SBA fqdn back it.  If I use a different fqdn, it will accept it, but then that would be wrong.  I suspect if I published after deleting the original SBA, then add it, it would work, but I am scared of the consequences of that, since that SBA is fully configured now.

    2.  Also, I am not sure my Dialogic SBA has the bootstrapper.  When I try to run Lync configure on it, it tells me it does not.

    You did not run into these issues?


    Thursday, June 02, 2011 6:35 PM
  • Yes, I missed the step of publishing the topology in-between removing and adding it back in. My mistake.

    Can you be more specific about the configuration you are scared of losing? What configuration changes have you made that would be specific to the SBA?


    I can confirm that my DMG4000 does indeed have the setup bootstrapper:

    Start > Programs > Microsoft Lync Server 2010 > Lync Server Deployment Wizard > Install or Update Lync Server System > Setup or Remove Lync Server Components


    If you can't run it from the GUI for some reason, it can also be run from CMD prompt:



    C:\Program Files\Microsoft Lync Server 2010\Deployment>Bootstrapper.exe /?


      Install admin console               - Bootstrapper.exe /BootstrapCore

      Install local management store      - Bootstrapper.exe /BootstrapLocalMgmt

      Install roles specified in topology - Bootstrapper.exe

      Prepare SQL Express RTC instance    - Bootstrapper.exe /BootstrapSqlExpress

      Remove roles installed on machine   - Bootstrapper.exe /Scorch

    Additional parameters:

      Bypass checks for readiness         - /SkipPrepareCheck

      Set source directory of MSIs        - /SourceDirectory <directory>


    C:\Program Files\Microsoft Lync Server 2010\Deployment>



    Thursday, June 02, 2011 6:57 PM
  • "Can you be more specific about the configuration you are scared of losing? What configuration changes have you made that would be specific to the SBA?"

    Not really - just a general fear.  :-)  I had many problems getting the SBA installed.  Mostly because of the custom scripts that Dialogic wrote that failed.

    When I run bootstrapper.exe , I get "Bootstrapper is not suported on a Brach Office Appliance." - Hence, my concern.

    Thursday, June 02, 2011 10:32 PM
  • Hi,John,

    Would you please try to follow this document to remove PSTN gateway ?



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, June 07, 2011 9:27 AM
  • No Sharon, that does not work.  Please read my first post.
    Tuesday, June 07, 2011 5:53 PM