locked
OneNote 2013: Font changes when pressing Enter / Return key RRS feed

  • Question

  • Ok, so this same issue existed in 2010. If I have started a new page when the default font was set to Calibri, every time I hit the enter key to start a new paragraph the font changes back to Calibri. This occurs even through the default font has been changed to Arial.

    Is there still no way to stop this? A way to change the default font for a page without have to create a new page and reenter all of the data?

    Copying to a new page does not work either as it maintains the formatting from the origianal page.

    Wednesday, July 24, 2013 3:23 PM

Answers

  • This happened until I clicked in the ribbon Styles > Normal; it was set to Heading 1, and kept switching back to the Heading 1 format on return. I switched to Normal, and then it works fine.
    • Proposed as answer by gjmoran Wednesday, April 8, 2015 3:39 PM
    • Unproposed as answer by VanAwful Friday, June 9, 2017 1:42 PM
    • Marked as answer by VanAwful Friday, June 9, 2017 1:44 PM
    Thursday, July 31, 2014 2:55 PM
  • This happened until I clicked in the ribbon Styles > Normal; it was set to Heading 1, and kept switching back to the Heading 1 format on return. I switched to Normal, and then it works fine.

    This worked perfectly for me, thanks so much!

    Here's exactly what I did to make your suggestion work:

    1. Move cursor to end of the line which has the font I would like to keep using
    2. Click Styles > Normal
    3. Step 2 is tricky because when you select the "Styles" drop-down it will look like "Normal" is already selected. Go ahead and click "Normal" even if it looks like it is already selected.
    4. Press the Enter key
    5. Type some text

    LOL, I did step 5 several times and I was stoked that it kept working. Thanks again!

    Rant:

    How does a company with billions of dollars not have a way to fix something so simple? Imagine if Microsoft would employ someone who actually knows how to type coherent sentences, took time to understand the problem, and, after providing a fix, provided that answer back to the users experiencing the issue? I think that social.technet.microsoft.com would implode because, for once, an issue was raised for which a solution was provided by MICROSOFT and not other users. For what is Microsoft paying these "MVPs"?




    • Edited by cesthree Tuesday, December 8, 2015 12:47 PM
    • Marked as answer by VanAwful Friday, June 9, 2017 1:43 PM
    Tuesday, December 8, 2015 12:44 PM

All replies

  • Hi,

    I haven't noticed such behavior that font changes when hit the enter key, could you provide more detail information about how to reproduce this behavior? Such as the detail steps, the input method, etc.

    Even though, consider the following methods to avoid reentering the data:

    • Select all the text content in the page (by press Ctrl + A), and change the font for them;
    • When paste the text content, choose Keep Text Only from Paste Options, this will let the text content use the new font of the new page.

    Max Meng
    TechNet Community Support

    • Edited by Max Meng Thursday, July 25, 2013 8:32 AM typo
    • Marked as answer by Max Meng Tuesday, July 30, 2013 7:02 AM
    • Unmarked as answer by VanAwful Tuesday, July 30, 2013 1:31 PM
    Thursday, July 25, 2013 8:30 AM
  • Hi,

    Just checking to see how is everything going on?


    Max Meng
    TechNet Community Support

    Monday, July 29, 2013 9:48 AM
  • Hi,

    I've marked the reply as answer as there has been no update for a couple of days. Please let us know if you would like further assistance.


    Max Meng
    TechNet Community Support

    Tuesday, July 30, 2013 7:02 AM
  • Sorry for the delay in replying. Traveling with little access to internet.

    Your suggestion is not a solution. To re-produce the behavior:

    1. Start a new page.
    2. Enter a some text.
    3. Press enter to start a new paragraph and enter more text.
    4. Note the Font that is being used.
    5. Now go into OneNote Options and change the default font to something else.
    6. Go back to the page you were working on. From the last paragraph you were working on press enter to start a new paragraph.
    7. The font on this page will still be the original default, this is expected. Change it to match the new default font.
    8. Enter some text. It will have the new font.
    9. Now press enter. Note that it switches back to the original font. So you have to change the font every time you press enter to start a new paragraph.

    Your suggested solution only works for existing text. The first time you press enter in the text object it reverts back to the original default font.

    If I select the frame of the text object itself, not just highlighting the text, then it would be reasonable to think that changing the font should then set the default for that object to the newly selected font. It does not.

    Tuesday, July 30, 2013 1:30 PM
  • This problem happens to my 2013 OneNote too. When I keep typing in a textbox, the font will always change from my defaul Times New Roman to SimSun or Calibri.
    Thursday, October 31, 2013 8:46 PM
  • Good description - I can confirm that problem exists - and is very annoying. Pages generated in a OneNote with different font seemingly cannot be changed to the "local font" without manually copy and paste without formatting - which of course loses all the formatting.  

    I would love to see OneNote be able to display the control characters much like the paragraph marks and section breaks in MS Word which, when displayed, allow you to more easily deal with formatting issues.

    Wednesday, January 8, 2014 4:43 PM
  • I can also confirm this problem exists. In my situation, I had originally created a bunch of pages (~100 or so) with a default font of Times New Roman. Recently I decided I would rather have my notes in Calibri, so I changed my default font to Calibri. But every time I hit enter to make a new paragraph in an existing page (that was created when Times New Roman was the default font), it reverts the font to Times New Roman.

    I think this needs to be solved, the comment above is a good one: OneNote needs to have more of the same functionality as Word and PowerPoint. It could be a really powerful tool if it incorporated more formatting tools from Word and PowerPoint!

     
    Friday, January 24, 2014 3:20 PM
  • Agreed that this needs to be resolved. It appears that whatever the default font was when a page template was created is what it's always going to be. So, I "fixed" it by doing the following:

    1. Set the default font to my liking.
    2. Set the new page template to "No Default Template". (Insert tab -> Page Templates dropdown button -> Page Templates... -> set Always use a specific template dropdown to "No Default Template".)
    3. Create a new page (with no template).
    4. Set whatever template stuff you like.
    5. Then, click "Save current page as template" (in Templates window).

    The new template has the default font set correctly. Of course, if Microsoft doesn't fix this issue by the time you decide to switch default fonts, you get to repeat this process.


    • Edited by Corrbs Tuesday, May 20, 2014 8:48 PM
    Tuesday, May 20, 2014 8:48 PM
  • This is the single most frustrating problem I consistently face with OneNote 2013. I lose time and concentration every time OneNote changes my default font (Tahoma 14 pt) to Calibri 11 pt. I must stop my flow of concentration and reformat the text from Calibri to Tahoma. While this may seem to some to be an insignificant issue, to those of us who are visually-oriented (and troubled by poor vision) using the font we choose IS significant. Please resolve this issue soon.

    Wednesday, May 21, 2014 4:20 PM
  • One trick that has always worked for me when encountering "stuck" or hidden formatting issues in any of the Office components is to copy and paste the malfunctioning text into Notepad, save as a text file, and then copy and paste it back into a new document, spreadsheet, OneNote page, etc. This strips all the formatting off of the text in question so I can begin anew. Obviously this isn't the solution if the text in question has a bunch of formatting that I want to keep, but it sounded as if the only formatting issue in the case in this discussion had to do with font.

    On another note, is anyone else experiencing Word and Excel 2013 crashing all the time? This is with 8G of RAM, and the earlier versions never crashed. Incredibly frustrating - means I have to save my work every few words if I don't want to lose it instead of every few sentences or paragraph as I've done in the past. Reminds me of the craziness of Win95 back in the day. A huge step backward for these otherwise reliable programs.

    Monday, May 26, 2014 2:22 PM
  • I have just now encountered the same problem on OneNote 2013, it's terribly annoying.

    • Edited by Deltron Friday, May 30, 2014 11:22 AM
    Friday, May 30, 2014 11:22 AM
  • It is very annoying. I have found that hitting <ENTER> when at the beginning of a line, rather than the end, and then using the <UP> arrow to move to the new line will preserve the font.'

    Others may find this acceptable. I have moved my notes to the DavidRM Journal.


    Echo Train Nashville TN

    Wednesday, June 11, 2014 6:26 PM
  • Ugh, having the exactly same problem. It's been 1 years and guess it's not solved yet!!

    Monday, July 7, 2014 2:30 PM
  • This happened until I clicked in the ribbon Styles > Normal; it was set to Heading 1, and kept switching back to the Heading 1 format on return. I switched to Normal, and then it works fine.
    • Proposed as answer by gjmoran Wednesday, April 8, 2015 3:39 PM
    • Unproposed as answer by VanAwful Friday, June 9, 2017 1:42 PM
    • Marked as answer by VanAwful Friday, June 9, 2017 1:44 PM
    Thursday, July 31, 2014 2:55 PM
  • No, I'm sorry, the style was and still is set to Normal.

    Hitting Enter still reverts back to the original font, and does not carry the font of the preceding paragraph forward like Word does.

    Do the developers understand how annoying this problem is?

    When is this problem going to be fixed?

    • Proposed as answer by DannyQuah Tuesday, February 10, 2015 5:48 AM
    • Unproposed as answer by DannyQuah Tuesday, February 10, 2015 5:48 AM
    Tuesday, September 30, 2014 10:23 AM
  • The ribbon style trick worked for me. I'll have to see if it continues to work in other docs or was a fluke. I selected the entire note text and then clicked on Normal in the ribbon Styles. So far so good.
    Sunday, November 16, 2014 10:37 PM
  • When I hit a Return and the font switches back to what I don't want, backspace to go back up and then go to Styles.  It *looks* like it's set on Normal. But go ahead and mouse-click Normal anyway. Then hit return. The font no longer switches. Who knew.
    Monday, February 2, 2015 8:50 AM
  • I've experimented a little more with this now and "Styles/Normal"  step (I describe in response to a subquestion below) has fixed almost all the problems I'd encountered with the Font changes you describe.  Again, to be clear, when you first mouse over to Styles, it'll look like "Normal" has already been selected. I previously thought that too, but then the Font change kept recurring.  Ignore what you see and click "Normal" (even if it looks already selected) after you've done the "File/Options" change to the font you prefer.  On the page you're having issues with, if possible, select All and set "Styles/Normal"; if that's not feasible or desirable, just to go where you're having these Font change problems, and do it there.  Like I say, this has fixed pretty much all the Font change problems I'd previously had.

    Tuesday, February 10, 2015 5:50 AM
  • Thanks for the fix - the Calibri font switch after using the [Enter] key was driving me crazy. Selecting "Styles/Normal" seems to work though the action removes all my previous font selections (e.g., color, bold) and I have to implement the change on each page. Please let me know if there is a global fix or even by tab (versus each page).
    Friday, February 20, 2015 11:01 PM
  • This happened until I clicked in the ribbon Styles > Normal; it was set to Heading 1, and kept switching back to the Heading 1 format on return. I switched to Normal, and then it works fine.
    This worked for me, thank you very much. Why would MS make the other Style as default? So annoying!
    Wednesday, April 8, 2015 3:40 PM
  • I had this issue too.  I changed the default font and size in options, verified it was using the "Normal" style. The issue persisted.  My solution ended up being to create a new text field in the same OneNote page and copy and paste the text from the original text field.  From then on it worked properly - keeping the new default font and text size when pressing Enter.  It almost feels as though the original default font was locked to the text field since that was the default when the field was created.
    Tuesday, April 21, 2015 9:10 PM
  • I had experienced the same problem and here is what I found that was able to get rid of the problem.

    Select the entire text box with the font changing problem. Once the text box is selected, go to Styles in the ribbon, under the drop down, select Clear Formatting. 

    This should get rid of the weird font changing problem and reset the formatting back to whatever the default font was.

    Wednesday, April 29, 2015 2:42 PM
  • This happened until I clicked in the ribbon Styles > Normal; it was set to Heading 1, and kept switching back to the Heading 1 format on return. I switched to Normal, and then it works fine.

    This worked perfectly for me, thanks so much!

    Here's exactly what I did to make your suggestion work:

    1. Move cursor to end of the line which has the font I would like to keep using
    2. Click Styles > Normal
    3. Step 2 is tricky because when you select the "Styles" drop-down it will look like "Normal" is already selected. Go ahead and click "Normal" even if it looks like it is already selected.
    4. Press the Enter key
    5. Type some text

    LOL, I did step 5 several times and I was stoked that it kept working. Thanks again!

    Rant:

    How does a company with billions of dollars not have a way to fix something so simple? Imagine if Microsoft would employ someone who actually knows how to type coherent sentences, took time to understand the problem, and, after providing a fix, provided that answer back to the users experiencing the issue? I think that social.technet.microsoft.com would implode because, for once, an issue was raised for which a solution was provided by MICROSOFT and not other users. For what is Microsoft paying these "MVPs"?




    • Edited by cesthree Tuesday, December 8, 2015 12:47 PM
    • Marked as answer by VanAwful Friday, June 9, 2017 1:43 PM
    Tuesday, December 8, 2015 12:44 PM
  • I agree with the fact that this is a VERY annoying problem which microsoft should fix quickly. Switching to a computer with higher resolution triggered me to change my default font (rather than zooming all the time) and I do not want to reformat every single page!

    I did find a better solution! Copy the text with formatting to word. Paste it, select it again and copy it back. Presto! All formatting preserved. Still annoying though...

    Friday, February 19, 2016 2:24 PM
  • Amazing.... this thread is 3 years old and still no fix from MS.  Well I finally got frustrated enough to look for a solution.

    Thank you to all who have gone before me and found successful work arounds!

    And .... MicroSoft you should be ashamed of yourself for not fixing this by now!

    Monday, March 14, 2016 8:11 PM
  • This works BUT. It basically strips all your formatting, bold, underline, font size, highlighting etc. 

    To make this work you have to select ALL your text including 

    ctl-A does not work to select ALL your text you have to click the top frame in the text window.  

    Friday, March 18, 2016 2:41 PM
  • "This works BUT. It basically strips all your formatting, bold, underline, font size, highlighting etc."

    In other words, that works to fix some other problem, but it doesn't fix the problem we have here.

    1. We want to change the font, while preserving other formatting.

    2. We want to be able to do this globally for an entire notebook and globally for a section of a notebook -- our option at the time.

    A three year-old problem and still not fixed.

    The problem continues on in OneNote 2016.

    I suggest we try using Office's feedback tool, which you can add to your ribbon, and try reaching the developers that way.  Obviously forum posts are good for asking how to do something a product can do, but they are not a good way to ask developers for changes or fixes.
    • Edited by Keith2468 Friday, April 15, 2016 11:18 PM problem continues
    Friday, April 15, 2016 11:08 PM
  • And now the time is May 16th, 2016. This defect is still not fixed....Shame on MS.
    Monday, May 16, 2016 6:18 AM
  • I think I have discovered the root of the problem and workaround. At least for me, the problem occurs when I create a page with using a different default font/size (Calibri 10 pt) than the one currently set (Calibri 11pt). When I then set the font size to what my current default is, OneNote just thinks "oh, he is using the default settings" but looks to the page properties to find the old default settings. A simple, but still annoying, workaround is to select all text on the page and then alter the font size slightly so that it is not the default (e.g. "11" pt font to "11.5").  So far this has worked in preventing the reversion from occurring.

    This has been plaguing me in OneNote since its creation, and needs to be fixed. Hope this helps someone.

    Tuesday, October 18, 2016 4:05 PM
  • Yeahp struggling with this, found the 'resolution' by looking through the comments... You can change the default font/text in OneNote, but NONE OF YOUR EXISTING PAGES WILL GET THE TREATMENT, and changing them to match will still cause hitting 'enter' to revert to the previous style.

    Only NEW pages will reflect. If you copy/paste from one to another you have to be careful because if you copy too much (like an extra blank line that that used the previous font) then it will still attempt to revert the font style on hitting enter again. Very annoying.

    Wednesday, January 11, 2017 6:38 PM
  • This happened until I clicked in the ribbon Styles > Normal; it was set to Heading 1, and kept switching back to the Heading 1 format on return. I switched to Normal, and then it works fine.

    i have been having this issue for a really long time and came across this thread. The above suggested solution worked for me. I would add that you should select all on page (CTRL + A) & then select the Style as 'Normal' from ribbon. I also went ahead and updated/ran thru the same procedure on my templates, which ensured there were no lingering issues.

    Tuesday, May 23, 2017 10:24 AM
  • UPDATE: Yes, this is a very old thread. Hard to believe I started this one nearly four years ago and back three versions. As of June 2017, the workarounds that have worked for others are:

    • Selecting style 'Normal' - Thank you Tim Corder for sharing your find and cesthree for the clear steps. Both replies are marked as the answer.
    • Use ctrl-A to select all contents then perform a copy and paste into a new text field that already contains the default font you want. You can also paste text only into a word doc, or notepad, notepad++, etc. Then past the raw text back into OneNote. This works, but is not efficient. I also did this until learning about the normal style. At one point I stopped writing in OneNote and worked in MS Word, then inserted the Word doc into OneNote.

    Note that this issue still exist in 2016 and 365. Seems Microsoft has lost interest in making their products usable.

    Friday, June 9, 2017 1:59 PM
  • Very old problem indeed -- it's 2019 (5+ years from original post thread) and I am still experiencing this problem.

    I had noticed it throughout the years randomly, but now I have been experiencing it more and more in my daily notetaking in class after downloading and installing some templates from a classmate.

    When I hit the enter key, the font changes from Calibri (my default) to theirs (SimSun or something). Usually only the first (and capitalized) letter of the new line takes on the new font, but sometimes the whole line does.

    Changing all text to the "Normal" Style seems to temporarily work but is an annoying workaround that also eliminates other text formatting that I then have to re-apply.

    An annoying issue in class, and breaks concentration/flow up a bit when I have to deal with it.

    From looking at this post it's clear this is an issue Microsoft has not cared enough about to address in the last 5 years. Just FYI in case you're hoping to see a bug update on this soon.

    • Proposed as answer by williamsbir6 Thursday, February 14, 2019 4:52 AM
    • Unproposed as answer by williamsbir6 Thursday, February 14, 2019 4:52 AM
    Tuesday, February 5, 2019 9:38 PM
  • I think I may have figured out the problem. If the font keep going back to the default font and you are using bullet points when you press enter change the font back to the one that you want to use and click the bullet point icon. This fixed my problem. Hope this helps someone else. 
    Thursday, February 14, 2019 4:57 AM
  • Its unbelievable how long I've had to deal with this... Basically since I started using it in 2009... Is anyone at MS/Office actually using this product? It's SO easy to reproduce this common issue...
    Sunday, October 6, 2019 5:22 AM
  • If the Text Line above a box is a header with unique text characteristics, then those settings will revert on each "enter" key within the box. was driving me nuts as well. The solution was make sure there is a blank "enter" line separating the header and the box. Hope that makes sense.
    Wednesday, January 8, 2020 1:54 PM
  • This is my trying, And I just copy pasted the following texts from my OneNote.

    BTW:I set Microsoft YaHei UI as a defaut font.

    "

    Here by, I start a new page, it is Calibri.

    现在我开始输入中文,没有问题,它是微软雅黑。I keep typing English with my Chinese input methods, and they are still Microsoft YaHei UI, now I swtich to English, perfect, Microsoft YaHei UI.

    I start another line, oops, it changed!

     

    If I set a normal, it will be different?

    中文,here we go,中文English. Set normal.

    Try again…fail.

     

    This story tells us, don't trust the optional font that you set default!

    And don't switch input methods.

    No matter how, You will be sticked to Calibri foreeeeeeeeeever!

    "

    Friday, February 14, 2020 7:28 PM
  • Still happening April 2020 (Office 365). Grateful to find this thread and the Style workaround, even though it reset all my styling.
    Wednesday, April 1, 2020 5:07 PM
  • It's 2020 and I'm having this issue right now. Your suggestion works. However, am I supposed to click "Normal" every time before I hit enter? That's unfortunate.

    So basically, this is a bug that still isn't fixed by July 2020?

    Friday, July 17, 2020 2:18 PM