none
ProfileSynchronizationSetupJob will not be created RRS feed

  • Question

  • Hi,

    i have a problem with the "User Profile Application"-Service. I cannot start the service, always stucks at "Starting". I have all done the settings descripted in all the help-forums (e.q. https://blog.devoworx.net/2013/01/14/user-profile-sync-service-stuck-on-starting/ ). 

    There are no ULS entries to get some information what went wrong.

    For my understanding, as soon as i start the service, there should be a timerjob named "ProfileSynchronizationSetupJob" be created, to start the FIM-Services (which are both on status "Disabled").

    In my case, there is no such job created, no log entries (even when set to "Verbose") whatsoever.

    I dont know what i can do any further, i recreated the UPA several times, gave the service-accounts all the permissions,....

    Please Help !

    System: 1 WFE-Server, 1 APP-Server, 1 DB
    Latest CU installed.


    Thursday, November 30, 2017 3:37 PM

Answers

  • Hi,

    By service stuck at starting I am assuming User Profile Synchronization service is stuck at starting.

    If yes, then follow below steps:

    1. Open SharePoint 2010 Power shell and run the below command 

    2. Get-SPServiceInstance (Returns the services instance for a specific server or the entire farm) 

    3. Copy the ID for the User Profile Synchronization service. 

    4. Stop-SPServiceInstance –id 
    Where <id> is the GUID of the User Profile Synchronization service        

    5. Come back to the Central Administration Page – Manage Services on Server and you will notice that the User Profile Synchronization service should be stopped now. 

    6. Stop SharePoint timer and SharePoint admin service from services.msc 

    7. Clear the SharePoint Config cache by following the article 
    http://blogs.msdn.com/b/josrod/archive/2007/12/12/clear-the-sharepoint-configuration-cache-for-timer-job-and-psconfig-errors.aspx

    8. Run the below command 
    stsadm -o execadmsvcjobs

    9. Start the SharePoint timer and SharePoint Admin service from services.msc

    10. IIsreset

    11. On the SharePoint Server Click on Start -- Run -- MMC -- file -- add/ remove snap in -- select certificate. You will Find My user account | Service Account | Computer Account.

    12. Except service account added the other two accounts

    13. Clicked Ok.

    14. Delete all the certificated related to ForefrontIdentityManager from all the folders you see in the console. 
    (Note: DO NOT DELETE ANY OTHER CERTIFICATES EXCEPT THE ForefrontIdentityManager)

    15. Open regedit -- Hkey Local Machine -- System -- Current Control Set -- Service -- FimService and verify the database name is pointing to correct sync database name that is used with the User Profile Service Application. 
    NOTE: You need to check the same registry key under Control Set002 and Current Control Set001. If the sync database name is incorrect, then manually correct it use the database name which is being used by the User Profile Service Application. 

    16. Do an IISreset. 

    17. Then try starting the UPA sync service again.

    Mark as Answered if above is helpful.

    • Marked as answer by Thomas Stessl Friday, December 1, 2017 7:40 AM
    Thursday, November 30, 2017 5:00 PM
  • Hi Thomas Stessl,

    What's the version of the SQL server?

    If you use SQL server 2014, please install June 2015 Cumulative Update or latest Cumulative Update for SharePoint Server 2013.

    Refer to: https://blogs.msdn.microsoft.com/calvarro/2015/07/22/sharepoint-2013-sql-2014-issues-with-user-synchronization/

    Ensure the farm account has Log On Locally permission to the server on which you are trying to start the User Profile Synchronization service.

    In addition, check the certificate store to see if there are several ForefrontIdentityManager certificates. Each time stop the User Profile Sync Service and then start it or recreate, it will re-add the certificate to the certificate store. Remove all ForefrontIdentityManager certificates and compare the results.

    For this issue, you could also check the event logs to see if there is any error message.

    Here are some articles have good information about how to troubleshoot User Profile Synchronization Service start issue for your reference. The articles are for SharePoint 2010, but they still have good information.

    http://www.harbar.net/articles/sp2010ups2.aspx

    http://www.sharepointdiary.com/2012/09/user-profile-synchronization-service-stuck-at-starting.html

    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, December 1, 2017 6:49 AM
    Moderator

All replies

  • Hi,

    By service stuck at starting I am assuming User Profile Synchronization service is stuck at starting.

    If yes, then follow below steps:

    1. Open SharePoint 2010 Power shell and run the below command 

    2. Get-SPServiceInstance (Returns the services instance for a specific server or the entire farm) 

    3. Copy the ID for the User Profile Synchronization service. 

    4. Stop-SPServiceInstance –id 
    Where <id> is the GUID of the User Profile Synchronization service        

    5. Come back to the Central Administration Page – Manage Services on Server and you will notice that the User Profile Synchronization service should be stopped now. 

    6. Stop SharePoint timer and SharePoint admin service from services.msc 

    7. Clear the SharePoint Config cache by following the article 
    http://blogs.msdn.com/b/josrod/archive/2007/12/12/clear-the-sharepoint-configuration-cache-for-timer-job-and-psconfig-errors.aspx

    8. Run the below command 
    stsadm -o execadmsvcjobs

    9. Start the SharePoint timer and SharePoint Admin service from services.msc

    10. IIsreset

    11. On the SharePoint Server Click on Start -- Run -- MMC -- file -- add/ remove snap in -- select certificate. You will Find My user account | Service Account | Computer Account.

    12. Except service account added the other two accounts

    13. Clicked Ok.

    14. Delete all the certificated related to ForefrontIdentityManager from all the folders you see in the console. 
    (Note: DO NOT DELETE ANY OTHER CERTIFICATES EXCEPT THE ForefrontIdentityManager)

    15. Open regedit -- Hkey Local Machine -- System -- Current Control Set -- Service -- FimService and verify the database name is pointing to correct sync database name that is used with the User Profile Service Application. 
    NOTE: You need to check the same registry key under Control Set002 and Current Control Set001. If the sync database name is incorrect, then manually correct it use the database name which is being used by the User Profile Service Application. 

    16. Do an IISreset. 

    17. Then try starting the UPA sync service again.

    Mark as Answered if above is helpful.

    • Marked as answer by Thomas Stessl Friday, December 1, 2017 7:40 AM
    Thursday, November 30, 2017 5:00 PM
  • Hi,

    sadly not working either.

    7.) Config-cache cleared

    14.) Checked certificates -> none to delete

    15.) I think these changed with SP2013 and works on our PROD-System with these settings:

    DatabaseName: Provided by SettingsProvider.dll
    DatabaseServer: Provided by SettingsProvider.dll

    So i leave that.

    17.) Started service -> no timer job "ProfileSynchronizationSetupJob" created to initialize the FIMServices.

    I dont understand, why this job will not be created and why there are not log entries to pinpoint the problem.


    Friday, December 1, 2017 6:13 AM
  • I did a log file at the start of the service:

    Verbose Log File

    Eventually i am overlooking something.

    Friday, December 1, 2017 6:30 AM
  • Hi Thomas Stessl,

    What's the version of the SQL server?

    If you use SQL server 2014, please install June 2015 Cumulative Update or latest Cumulative Update for SharePoint Server 2013.

    Refer to: https://blogs.msdn.microsoft.com/calvarro/2015/07/22/sharepoint-2013-sql-2014-issues-with-user-synchronization/

    Ensure the farm account has Log On Locally permission to the server on which you are trying to start the User Profile Synchronization service.

    In addition, check the certificate store to see if there are several ForefrontIdentityManager certificates. Each time stop the User Profile Sync Service and then start it or recreate, it will re-add the certificate to the certificate store. Remove all ForefrontIdentityManager certificates and compare the results.

    For this issue, you could also check the event logs to see if there is any error message.

    Here are some articles have good information about how to troubleshoot User Profile Synchronization Service start issue for your reference. The articles are for SharePoint 2010, but they still have good information.

    http://www.harbar.net/articles/sp2010ups2.aspx

    http://www.sharepointdiary.com/2012/09/user-profile-synchronization-service-stuck-at-starting.html

    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, December 1, 2017 6:49 AM
    Moderator
  • Working now, but i am not sure what the fix was.

    I think i had a problem with the DNS.

    My setup was:

    1 WFE -> Computername = KNLEMOSSWEBTEST04
    1 APP -> Computername = KNLEMOSSAPPTEST04

    But in the farm setup the are entered as: KNLEMOSSWEBTEST and KNLEMOSSAPPTEST

    So i added KNLEMOSSWEBTEST to the HOST-file on KNLEMOSSAPPTEST and tried to ping the WFE with success.
    Prior to this setting the ping was not working.

    So i am not sure, if this was the problem, but the logging and tracing of SP is mostly confusing.



    Friday, December 1, 2017 7:21 AM