none
CAQuietExec: Error: Cannot create database.

    Question

  • Could not upgrade from Azure .NET SDK 2.2 to 2.3 (VS 2013) on Windows 8.1 x64. The Storage Emulator 3.0 setup is failing, even if launched manually. Do you have any tips?

    The logs of the WindowsAzureStorageEmulator install has the following lines just before initiating a rollback.

    MSI (s) (F4:D8) [08:18:27:340]: Source for file 'StartStorageEmulator.cmd' is compressed
    InstallFiles: File: StartStorageEmulator.cmd,  Directory: C:\Program Files (x86)\Microsoft SDKs\Windows Azure\Storage Emulator\,  Size: 64
    MSI (s) (F4:D8) [08:18:27:340]: Executing op: CacheSizeFlush(,)
    MSI (s) (F4:D8) [08:18:27:340]: Executing op: ActionStart(Name=RunInitialize,Description=Initializing the Storage Emulator,)
    Action 8:18:27: RunInitialize. Initializing the Storage Emulator
    MSI (s) (F4:D8) [08:18:27:340]: Executing op: CustomActionSchedule(Action=RunInitialize,ActionType=1025,Source=BinaryData,Target=CAQuietExec,CustomActionData="C:\Program Files (x86)\Microsoft SDKs\Windows Azure\Storage Emulator\WAStorageEmulator.exe" init -forcecreate -autodetect)
    MSI (s) (F4:F8) [08:18:27:371]: Invoking remote custom action. DLL: C:\Windows\Installer\MSIEAC9.tmp, Entrypoint: CAQuietExec
    MSI (s) (F4:C8) [08:18:27:371]: Generating random cookie.
    MSI (s) (F4:C8) [08:18:27:371]: Created Custom Action Server with PID 3640 (0xE38).
    MSI (s) (F4:48) [08:18:27:387]: Running as a service.
    MSI (s) (F4:48) [08:18:27:387]: Hello, I'm your 32bit Impersonated custom action server.
    CAQuietExec:  Windows Azure Storage Emulator 3.0.0.0 command line tool
    CAQuietExec:  Error: Cannot create database.
    CAQuietExec:  Error 0xfffffff3: Command line returned an error.
    CAQuietExec:  Error 0xfffffff3: CAQuietExec Failed
    CustomAction RunInitialize returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    Action ended 8:18:32: InstallFinalize. Return value 3.
    MSI (s) (F4:D8) [08:18:32:276]: Note: 1: 2265 2:  3: -2147287035
    MSI (s) (F4:D8) [08:18:32:276]: User policy value 'DisableRollback' is 0

    Friday, April 04, 2014 6:29 AM

Answers

  • I agree.  This (finally) took care of it!  Thanks to DixQuinze and Trent Swanson...

    sqllocaldb stop v11.0
    sqllocaldb delete v11.0
    delete C:\Users\MyAccount\WAStorageEmulatorDb30*.*
    sqllocaldb create v11.0

    Then try the install again!

    -Dave

    DixQuinze
    0 
    Tuesday, April 22, 2014 9:51 PM

All replies

  • Hi,

    This is an installation issue. I installed SDK2.3 on my PC correctly. I suggest you could remove all your azure sdk and use WPI to install it again. Please try it.

    Regards,

    Will


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, April 04, 2014 9:26 AM
    Moderator
  • Hi Will, I have uninstalled everything starting with "Windows Azure" and tried to install 2.3 once again, but it failed reporting the same error.

    Friday, April 04, 2014 11:32 AM
  • The same problem with the same error here.
    Friday, April 04, 2014 9:11 PM
  • Same error on my machine, unable to install Windows Azure Storage Emulator 3


    Saturday, April 05, 2014 2:37 PM
  • I am getting the same error as well.
    Sunday, April 06, 2014 3:36 AM
  • Another "me too." Seems awfully widespread to have made it through QA.
    Sunday, April 06, 2014 10:25 PM
  • This has happened on several separate Win 8.1 computers for me now.
    Sunday, April 06, 2014 10:41 PM
  • I have tried to delete the WAStorage30 database files in the user profile but the issue still remains.
    • Edited by MCCZ Monday, April 07, 2014 8:52 AM
    Monday, April 07, 2014 8:52 AM
  • No solutions yet? I'm experiencing this error on Windows 7.1.

    CAQuietExec:  Windows Azure Storage Emulator 3.0.0.0 command line tool
    CAQuietExec:  Error: Cannot create database.
    CAQuietExec:  Error 0xfffffff3: Command line returned an error.
    CAQuietExec:  Error 0xfffffff3: CAQuietExec Failed
    CustomAction RunInitialize returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)


    Monday, April 07, 2014 10:38 PM
  • hi all,
    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.
    Best Regards,

    Will


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, April 08, 2014 2:27 AM
    Moderator
  • Thanks, Will. Please keep us updated.
    Tuesday, April 08, 2014 11:28 AM
  • Thank you, Will. I can't run any of my solutions at work currently due to this error. If there are any thoughts or possible solutions, I will pursue anything at this point. Desperate.
    Tuesday, April 08, 2014 1:17 PM
  • I'd like to add that I am another user getting this error, either by installing through WebPI or standalone MSI.

    This is on a clean install of Windows 8.1. No previous versions of the SDK installed.

    • Edited by mattsharpe Tuesday, April 08, 2014 3:00 PM Added more info.
    Tuesday, April 08, 2014 2:52 PM
  • Is the only solution at this point to reformat? I have tried everything I can think of, to the point of uninstalling all of Azure SDK, IIS 8 Express, and VS2012, then reinstalling it all, even trying VS2013. Nothing works. ARGH.
    Tuesday, April 08, 2014 3:33 PM
  • I am having the same problem, and I am guessing that it has to do with the default SQL instance in wich the emulator installs the database. I do not use sqlexpress, instead have a SQL2012 developer, and with SDK 2.2, using the dbinit command initialized the DB correctly. I think that the installer for emulator 3.0 is missing an option to explicitly assign the DB instance to store the emulator database.  am I right? I really do not want to install SQL express just for this... Do the others have the same scenario without SQL express??

    • Edited by rgonzalezv Tuesday, April 08, 2014 6:01 PM
    Tuesday, April 08, 2014 5:59 PM
  • I'm getting the same thing even with SQL Express, and without (with no standalone SQL server at all).

    I have tried uninstalling everything with "azure" and "visual" in the name and starting from scratch, still not working. Win 8.1 x64

    • Edited by Matt Olenik Tuesday, April 08, 2014 6:20 PM
    Tuesday, April 08, 2014 6:18 PM
  • Had to perform a reformat. Couldn't do any work, right in the middle of a bunch of projects. Thanks for that, MS. After the reformat, everything installed normally, no issues. This is unbelievable.
    Tuesday, April 08, 2014 8:33 PM
  • Alright, I solved this on my machine. Lets see if this works for everyone else.  Turned out my automatic localdb instance -- (localdb)\v11.0 -- had a few issues.  Luckily I hadn't used it that much and it can recreate itself anyway so I opened the SQL Server Object Explorer in VS, connected to (localdb)\v11.0   then deleted the instance.

    To bring it back i just attempted to connect to it again -- (localdb)\v11.0 --  and it spun up a fresh instance.  My next attempt to update the Azure SDK worked flawlessly.

    if you prefer the cmd prompt these 2 statements should do it

    SqlLocalDB.exe s v11.0
    SqlLocalDB.exe d v11.0
    Wednesday, April 09, 2014 8:30 AM
  • Alright, I solved this on my machine. Lets see if this works for everyone else.  Turned out my automatic localdb instance -- (localdb)\v11.0 -- had a few issues.  Luckily I hadn't used it that much and it can recreate itself anyway so I opened the SQL Server Object Explorer in VS, connected to (localdb)\v11.0   then deleted the instance.

    To bring it back i just attempted to connect to it again -- (localdb)\v11.0 --  and it spun up a fresh instance.  My next attempt to update the Azure SDK worked flawlessly.
    Sounded promising, but this did not work for me.
    Wednesday, April 09, 2014 3:05 PM
  • Agree, sounded promising. Didn't work.
    • Proposed as answer by Mick123456 Saturday, November 19, 2016 6:47 PM
    • Unproposed as answer by Mick123456 Saturday, November 19, 2016 6:47 PM
    Wednesday, April 09, 2014 3:47 PM
  • Thanks man it really worked i just edited your commands to start v11.0 instance and then stop it so you can delete it

    Powershell prompt as administrator commands were:

    PS C:\Windows\system32> SqlLocalDB.exe s v11.0
    LocalDB instance "v11.0" started.
    PS C:\Windows\system32> SqlLocalDB.exe stop v11.0
    LocalDB instance "v11.0" stopped.
    PS C:\Windows\system32> SqlLocalDB.exe d v11.0
    LocalDB instance "v11.0" deleted.
    PS C:\Windows\system32> SqlLocalDB.exe s v11.0
    LocalDB instance "v11.0" started.
    
    Next attempt to simply install AzureSDK 2.3 went flawlessly for me too.


    Thursday, April 10, 2014 12:39 PM
  • Also didn't work for me, same error as before.

    Thursday, April 10, 2014 3:26 PM
  • yes, very promising.. didn't work for me either :(
    Thursday, April 10, 2014 11:38 PM
  • hi all,

    Please try to recreate the LocalDB instance fix the LocalDB issue.

    sqllocaldb delete “v11.0”
    sqllocaldb create “v11.0”

    If this doesn’t work, could you share the SQL Server logs for the “(localdb)\v11.0” instance during the time of installation? (See http://technet.microsoft.com/en-us/library/ms187109.aspx for how to get the logs.) There was a problem while creating the database or setting user permissions, and the SQL logs would be very helpful in tracking down this issue.

    Regards,

    Will


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, April 11, 2014 1:41 AM
    Moderator
  • Hi,

    That may not be sufficient.

    As far as I'm concerned, my first install attemp left some files in my c:\users\[user] directory :

    WAStorageEmulatorDb30.mdf
    WAStorageEmulatorDb30_log.ldf

    The sqllocaldb logs would mention these files still existed and it would not erase them.

    I just deleted them manually.
    Recreated the v11.0 (without the double quotes, please):

    sqllocaldb stop v11.0
    sqllocaldb delete v11.0
    sqllocaldb create v11.0

    And reinstalled...

    Hope it helps !

    OA

    • Proposed as answer by Winmetrics Thursday, August 07, 2014 4:39 AM
    Friday, April 11, 2014 8:25 AM
  • Stop/delete/create commands helped on my side. (I have deleted the database file during my previous elaboration, so not sure whether it was needed or not.)
    Friday, April 11, 2014 10:41 AM
  • This was not working for me either.  When I also deleted 'C:\Users\<User>\WAStorageEmulatorDb30.mdf' database file, and corresponding log file I was able to successfully install.

    • Proposed as answer by Dave McKinstry Tuesday, April 22, 2014 9:51 PM
    Friday, April 11, 2014 5:15 PM
  • Hi,


    From a support perspective this is really beyond what we can do here in the forums. If you cannot determine your answer here or on your own, consider opening a support case with us. Visit this link to see the various support options that are available to better meet your needs:  http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Jun Zh - MSFT Microsoft Online Community Support

    Monday, April 14, 2014 3:09 AM
  • I agree.  This (finally) took care of it!  Thanks to DixQuinze and Trent Swanson...

    sqllocaldb stop v11.0
    sqllocaldb delete v11.0
    delete C:\Users\MyAccount\WAStorageEmulatorDb30*.*
    sqllocaldb create v11.0

    Then try the install again!

    -Dave

    DixQuinze
    0 
    Tuesday, April 22, 2014 9:51 PM
  • This worked for me. The commands for powershell are summed up nicely in Dave's reply below except that instead of "delete" use "rm".
    Wednesday, April 23, 2014 10:41 AM
  • Following the steps outlined by Dave worked for me. I, too, had to use "rm" instead of "delete", though.
    Sunday, April 27, 2014 9:04 PM
  • I hope this helps..

    If you already tried and failed intallation perform:

         SQLLocalDB stop v11.0
         SQLLocalDB delete v11.0
         Delete all the files in C:\Users\<accontname>\WAStorageEmulatorDb* (usually one mdf and one ldf)
         Create a new account (I called it Azure, with administrative rights)
         Run again the installation
         Installation completed!

    For me this works... I had tried to format the PC before use this way. I supposte my problem is related to my username that contains "invalid" characters like Name 'NickName' Surname while the "Azure" account seems to be OK for him.

    I figure it out 'cause somewhere in the log I have a property destination path set to "C:\Users\Name$_" that is far away for the path of my user account folder.

    After that you can go on CMD.exe and prompt:

         control userpasswords2

    From the control you can delete the Azure login without delete the file folders!

    Hope it helps!

    Saturday, July 05, 2014 7:47 AM
  • Thanks, Dave. It worked for me perfectly.
    Wednesday, October 22, 2014 4:57 PM
  • This didn't work for me.  I'm using Parallels on OSX and have a "network profile" with a long path name. 

    Another solution that worked for me:

    - Manually download the MSI referenced in the error log

    - Create a new LOCAL username (not passport/LiveID connected) 

    - Install the MSI from C:\  NOT downloads (where Parallels is backing it as a UNC)

    I think it's hitting a 255 char limitation in Windows UNCs'

    Thursday, March 26, 2015 10:40 PM
  • Yes wasted 7 hours on this!

    if you're getting "CAQuietExec: Error: Cannot create database." check to see if you have Lavasoft Web Companion installed. I uninstall Lavasoft and then installed Azure Storage Emulator again.

    Worked for me


    Mick

    Saturday, November 19, 2016 6:50 PM