none
Bit Rate Throttling crashes my SP2010 web app RRS feed

  • Question

  • I've recently been trying to get the Bit Rate Throttling IIS.NET module to work with my SharePoint 2010 web application. It was working briefly for me in the past, but I've tried enabling it in three different environments recently and in each case the w3wp process for the SharePoint 2010 web application crashes as soon as I hit a page. It will serve a page or two once the w3wp starts up and then it will crash again. I've seen this problem mentioned on the IIS.NET forums but I've not seen any possible solutions. I'm posting the issue here since this could be an issue specific to SharePoint 2010 web applications.

    This is a WCM site with Output, Object and BLOB caching all enabled. Note that the problem occurs before I access any content that would be throttled by the module. These are the tests I've run:

    Test 1: BLOB Cache off, Bit Rate Throttling installed but disabled
    Works fine.
     
    Test 2: BLOB Cache on, Bit Rate Throttling installed but disabled
    Works fine.
     
    Test 3: BLOB Cache on, Bit Rate Throttling installed and enabled
    Faulting application name: w3wp.exe, version: 7.5.7600.16385, time stamp: 0x4a5bd0eb
    Faulting module name: bitratemodule.dll, version: 7.1.625.10, time stamp: 0x4aca8535
    Exception code: 0xc0000005
    Fault offset: 0x0000000000007669
    Faulting process id: 0x2140
    Faulting application start time: 0x01cb2cd16410dafa
    Faulting application path: c:\windows\system32\inetsrv\w3wp.exe
    Faulting module path: C:\Program Files\IIS\Media\bitratemodule.dll
    Report Id: e3004397-98c4-11df-91ae-00155d06ab22
    And…
    Fault bucket , type 0
    Event Name: APPCRASH
    Response: Not available
    Cab Id: 0
    Problem signature:
    P1: w3wp.exe
    P2: 7.5.7600.16385
    P3: 4a5bd0eb
    P4: bitratemodule.dll
    P5: 7.1.625.10
    P6: 4aca8535
    P7: c0000005
    P8: 0000000000007669
    P9:
    P10:
    Attached files:
    These files may be available here:
    Analysis symbol:
    Rechecking for solution: 0
    Report Id: e3004397-98c4-11df-91ae-00155d06ab22
    Report Status: 0
    Test 4: BLOB Cache off, Bit Rate Throttling installed and enabled
    Works fine.
     
    Test 5: BLOB Cache on, Bit Rate Throttling installed and re-enabled
    Breaks again, as in step 3.
     
    Test 6: BLOB Cache on, Bit Rate Throttling disabled
    Works fine.
    As I say, I've tried this in three SharePoint 2010 environments, from single-server w/local SQL to a four server farm + SQL. Each SharePoint server is running Windows Server 2008 R2 and SQL 2008 R2. I've also tried it in two different domains/forests. The only thing that looks remotely interesting to me is that the module is version 7.1.xxx and I'm using IIS 7.5, but the IIS.NET site suggests that it works with IIS 7.x.
    At one point I believe I fixed it by enabling/disabling BLOB caching (thus steps 4-6) but I've been unable to repeat that fix. Any ideas?
    Tuesday, July 27, 2010 2:47 PM

All replies

  • Hi Tristan,

    This is an interesting situation, w3wp is crashing and the faulting module is bitratemodule.dll. What happens with the BLOB Cache off and Bit-Rate Throttling on? Also, are you throttling anything beyond the default entries (for instance, did you make and entry for another file-type like .JPG or .CSS, for example)? If you added anything to be throttled, what are the throttle settings for that extension?

    Please let me know.

    Thanks!

    Tracy

    Thursday, August 12, 2010 10:54 PM
  • Hi Tracy,

    BLOB Caching is a requirement for Bit Rate Throttling SharePoint 2010 web applications, as I understand it, so I haven't tested the scenario where Bit Rate Throttling is turned on and BLOB Caching is turned off. I have just been using the default file types with default settings.

    Jackfree (also from MSFT I believe) has replied over on the IIS.NET thread, so I will try and capture the debug file for him and post it up over there.

    Cheers,

    Tristan

    Monday, August 16, 2010 1:19 PM
  • That sounds good to me, as IIS will have more experience with BitRate Throttling, as they are part of IIS's Media Services. Pity you can't post the answer here too. There's certainly nothing wrong with getting this information out.

    Thanks for letting me know, Tristan.

    Tracy

    Monday, August 16, 2010 8:14 PM
  • Will post a reply here if I ever hear back from the IIS team. All has gone quiet unfortunately.
    Friday, August 27, 2010 12:50 AM
  • Hi Tracy,

    Back on the originally-mentioned IIS.NET thread , the team there have posted that they are planning to release a fix for this "as part of IIS Media Services 4.0 which will be released in the very near future." Good news!

    Cheers,


    Tristan

    Wednesday, October 6, 2010 10:59 PM