none
Sharepoint 2016 DatePicker Error on farm with English setup and Norwegian language pack RRS feed

  • Question

  • Hi.  I have a farm with six members; App, Front End, Dist Cache, Search, DB and Office.  These servers are 2016 with English. Regional settings on servers are (now, not all at install time) Norwegian with Norwegian (nb-no) date formats.  

    When creating tasks, in a list view, with English language of display all dates from date picker are selected in European date format and then are changed to "today" with no other errors. When doing the same in Norwegian, all dates selected with date picker change to "i dag" (meaning "today"). After a day they change to "i går" (yesterday) and as time goes on they will appropriately count "6 dager siden" (six days ago) etc. As time goes on and the task ages, the due date will then read correctly so it appears that the calculating of a date as stored in the DB is working just fine. 

    Using the same date picker entering a task in the more complex mode which allows start date and end dates, in either language of display, gives a date error.   "You must specify a valid date within the range of 01.01.1900 and 31.12.8900." Manual dates entered in any format imaginable don't work. 

    When I enter a deliverable using the same datepicker all dates are fine.  

    My regional settings are:

    Timezone: +1

    Locale: Norwegian

    Sort Order; Danish/Norwegian

    Calendar: Gregiorian (tested with and without week numbers in the date navigator) 

    Alternate Calendar: None

    Week Definition: Tested with several options

    Timeformat: Tested with both 12 & 24, and remaining on 24.  

    From my perspective this looks like a customization error from something that was developed by a vendor, but I can be certain because I don't know where to go further with troubleshooting this.  Any ideas are appreciated! 

    JTSveigdalen


    Monday, February 6, 2017 9:17 AM

All replies

  • Hi,

    If I understand correctly, in the same site in your environment, different task lists make different results. One gives a date error one works fine, am I right?

    Does the problematical task list have any customizations? How was this task list created? By OOB way? Could you provide a screenshot about this issue in the problematical task list?

    I have tested in my environment and it works fine, shown as figure below.

    Best Regards,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, February 7, 2017 5:26 AM
    Moderator
  • Hi,

    Is there any update?

    Best Regards,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, February 13, 2017 11:07 AM
    Moderator
  • Hello, no update on the problem. I've tried to update language packs (jan-2017), but did not fix it. Here's a video of our problem: https://1drv.ms/v/s!AkLVDE9AnOnAkPcJhpwf_ZV_XrOaHw 
    Monday, February 20, 2017 9:54 AM
  • Hi,

    Just installed SharePoint 2016, With English install and Norwegian Language pack. I get the same error as you do, when I try to pick a date from a date column Field.

    When i Edit the list, and type in the grid view it Works.

    Wednesday, February 22, 2017 8:17 AM
  • Got it working, not 100% correct, but it is working for us Norwegians atleast. It may also apply to other Languages.

    I changed the region settings, from "Norwegian Bokmål" on the National settings, to "Norwegian nynorsk"
    - this only applies on how dates, time and numbers are shown, and Our two Languages are the same in that area.

    The datepicker now works as intended.

    Regards

    Aleksander.

    Wednesday, February 22, 2017 9:29 AM
  • Microsoft has confirmed the bug, and a patch is postponed to august 2017 due to delays.
    Thursday, May 4, 2017 5:25 AM
  • Was not solved in August 2017 CU.

    Same issue for Finnish language pack.


    Sorin Sandu

    • Proposed as answer by Øystein Brenna Thursday, November 23, 2017 11:58 AM
    • Unproposed as answer by Øystein Brenna Thursday, November 23, 2017 11:58 AM
    Thursday, August 10, 2017 5:55 AM
  • Hi 

    Any update on this, we too have the same issue.

    Please comment.

    Tuesday, October 10, 2017 12:32 PM
  • CU Jan 2018 doesn't fix the problem. Microsoft is investigating further.
    Tuesday, January 16, 2018 12:29 PM
  • On Finnish language we have now different error after CU Jan 2018.

    Error is : Index was outside the bounds of the array.

    But still not working.


    Wednesday, January 17, 2018 12:22 PM
  • SharePoint 2016 CU March 2018 fixes the timeseparator issue with DatePicker!

    When you use Norwegian (Bokmål) or any other locale that has the same separator for dates and times in Windows 2016, you receive the following error message when you verify the date and time fields:

    index was outside the bounds of the array 

    https://blogs.technet.microsoft.com/stefan_gossner/2018/03/13/march-2018-cu-for-sharepoint-server-2016-is-available-for-download/




    Wednesday, March 14, 2018 11:04 AM