none
Problem sending to yahoo just from exchange edge RRS feed

  • Question

  • Hi,

    a SMTP server gets emails from internal clients and then sends them to exchange edge, The SMTP server is allowed as an open-relay receiver (IP there, set to anonymous)

    Reverse is ok, SPF is ok, ports are good and sending to any domain works well except yahoo!

    When making the next hub after internal SMTP pointed to a Mdaemon server it is fixed and mails go to yahoo with no problem. Unfortunately nothing in exchange tracking logs

    Mails are stuck in queue as "active" or "ready" and this is what I see in text logs and also in GUI

    GUI: 10I: NTS:

    Text logs: 10I: NTS: ,Originating,,192.168.41.10,172.24.64.11,

    And last to say, I've no edge subscription. Hub sends to the mentioned SMTP server (to apply some policies) and SMTP sends to the edge and as I mentioned all domains working except Yahoo

    And there is no NDR from yahoo to dig it more


    I'm not sure but I think maybe the open relay from SMTP to edge server (although it is internal)  changes some properties of SMTP packets or mail which makes Yahoo not to accept it. I donno ...

    Any help appreciated.

     *** Update ***

    Emails are rec'd at yahoo but with a 3-4 hour delay !! Now what may be the problem?!





    • Edited by Mo.Gan Saturday, October 19, 2019 7:30 PM
    Saturday, October 19, 2019 9:21 AM

Answers

  • Yahoo didn't help and said you must pay for this and buy support.

    I changed the ISP and mails rushed to Yahoo. Confused of what can be the problem but anyway it is definitely something between Yahoo, us and the current Internet service provider (L3 probably)

    I cannot find out the problem exactly and why Mdaemon works but exchange edge doesn't

    • Marked as answer by Mo.Gan Wednesday, October 23, 2019 4:25 AM
    Tuesday, October 22, 2019 12:20 PM
  • Installed wireshark The stream of packets freeze when it reaches tls negotiation. seems like some sort of security guard, packets manipulation and filtering there

    • Marked as answer by Mo.Gan Wednesday, October 23, 2019 4:25 AM
    • Edited by Mo.Gan Wednesday, October 23, 2019 4:27 AM
    Tuesday, October 22, 2019 2:50 PM

All replies

  • Another interesting finding:

    If I send many emails with let's say 30 minutes intervals, they all get stuck in ready state in queue and with a 3-4 hour delay, all of them reach yahoo in the same time together.

    Seems Yahoo opens his gates to our server just once every 4 hour :)


    • Edited by Mo.Gan Sunday, October 20, 2019 5:41 AM
    Sunday, October 20, 2019 5:21 AM
  • And another finding ..

    The messages reach yahoo exactly after 4 hours. I sent messages at 1:00, 2:00, 3:30 ..

    All reached yahoo at 5:00

    Repeated this test and the same result.

    Sunday, October 20, 2019 11:36 AM
  • And another finding ..

    The messages reach yahoo exactly after 4 hours. I sent messages at 1:00, 2:00, 3:30 ..

    All reached yahoo at 5:00

    Repeated this test and the same result.

    You could run Get-Queue | Get-Message | fl to get the detailed info of every queued message.

    Besides, analyse the header of the message from the recipient side and find on which hop the message get stuck or delayed.

    By the way, we also suggest contacting Yahoo support since only mail to Yahoo with a 4 hour delay.

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, October 21, 2019 8:54 AM
    Moderator
  • Hi,

    Nothing in logs event with fl * and details

    Nothing at Yahoo side. Emails are received normally with no additional info or problem. But as I said they are received every 4 hour.

    I sent an email about the problem to Yahoo help central. Hope we can get somewhere.

    Monday, October 21, 2019 6:04 PM
  • Hi,

    Nothing in logs event with fl * and details

    Nothing at Yahoo side. Emails are received normally with no additional info or problem. But as I said they are received every 4 hour.

    I sent an email about the problem to Yahoo help central. Hope we can get somewhere.

    OK. Hope you could get some clues from Yahoo side. Meanwhile, if possible, also check the following:

    Besides, analyse the header of the message from the recipient side and find on which hop the message get stuck or delayed.

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, October 22, 2019 9:10 AM
    Moderator
  • Yahoo didn't help and said you must pay for this and buy support.

    I changed the ISP and mails rushed to Yahoo. Confused of what can be the problem but anyway it is definitely something between Yahoo, us and the current Internet service provider (L3 probably)

    I cannot find out the problem exactly and why Mdaemon works but exchange edge doesn't

    • Marked as answer by Mo.Gan Wednesday, October 23, 2019 4:25 AM
    Tuesday, October 22, 2019 12:20 PM
  • Installed wireshark The stream of packets freeze when it reaches tls negotiation. seems like some sort of security guard, packets manipulation and filtering there

    • Marked as answer by Mo.Gan Wednesday, October 23, 2019 4:25 AM
    • Edited by Mo.Gan Wednesday, October 23, 2019 4:27 AM
    Tuesday, October 22, 2019 2:50 PM