none
The following error occured attempting to join the domain

    Question

  • Hi,

    Our domain controller running on Windows Server 2008. Before this we are using single IP Address to access active directory server.

    Now our organization already change the network structure and using multiple VLAN.Our client using windows 7 Pro, cannot join to domain. error "The following error occurred attempting to join the domain "XXX.Local" The specified network name is no longer available.

    Below is my test:-

    1. Test ping server AD = Successful

    2. Test nslookup = Successful

         
    C:\>nslookup
    Default Server:  biru.itnmb.local
    Address:  192.168.42.4

    > itnmb.local
    Server:  biru.itnmb.local
    Address:  192.168.42.4

    Name:    itnmb.local
    Address:  192.168.42.4

    > 192.168.42.4
    Server:  biru.itnmb.local
    Address:  192.168.42.4

    Name:    biru.itnmb.local
    Address:  192.168.42.4

    3. Test running dcdiag = successful and passed test

    4. Telnet from client (all port required joining to domain) = Successful

    what can i do?

    Thanks,

    Ezzy


    Ezzy

    Friday, March 29, 2013 11:45 AM

Answers

All replies

  • If you are able to ping, I would assume that the routing is fine.

    Please check that needed ports for AD authentication are not blocked or filtered: http://technet.microsoft.com/en-gb/library/dd772723%28v=ws.10%29.aspx

    PortQryUI should be helpful here.

    More details if you check the ACLs with the networking team.


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Friday, March 29, 2013 12:41 PM
  • Hello,

    I would like to see an unedited ipconfig /all from the existing DC/DNS servers and also a client with problems joining the domain. As you are talking about VLAN, how exactly are the machines connected? Can you provide a small picture/drawing with routers/switches so we can understand the network setup?


    Best regards

    Meinolf Weber
    MVP, MCP, MCTS
    Microsoft MVP - Directory Services
    My Blog: http://msmvps.com/blogs/mweber/

    Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.

    Friday, March 29, 2013 12:48 PM
  • In addition temporarly disable antivirus and windows firewall and give a try.

    The following error occurred attempting to join the domain "crayveon.com": The specified network name is no longer available
    http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2virtualization/thread/3c329a3f-f80c-45b0-a0d3-ec61c0ea9843/
    http://support.microsoft.com/kb/961293

    Best Regards,

    Sandesh Dubey.

    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator | My Blog

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Saturday, March 30, 2013 8:24 AM
  • Yes Agreed with sandesh, try disabling the firewall and any Antivirus. Also check the DNS settings and verify that they are correct. Ports are also important to process the connection request successfully. As the ports are also working as per the you above mention then might need to disable the firewall.

    Ensure below some points for successful joining

    1) Firewall should be disable

    2) Ports should be open bi-directionaly on network devices

    3) If you are using windows Vista or 7 machine then check whether Netbios over TCP/IP is enable

    4) verify the DNS entered are correct.


    Thanks & Regards, Abhijit Deshpande This posting is provided "AS IS" with no warranties or guarantees , and confers no rights

    • Proposed as answer by Marius Sagen Friday, May 8, 2015 1:22 PM
    Saturday, March 30, 2013 10:23 AM
  • Hi,

    Please also check the Net Logon service and make sure it is started.

    Meanwhile, check this similar thread:

    error occurred attempting to join the domain

    http://social.technet.microsoft.com/Forums/en-US/winservergen/thread/65068d1e-d399-42f0-bf8a-dc92b9650245

    Hope this helps!

    Regards.


    Vivian Wang
    TechNet Community Support


    Monday, April 1, 2013 5:38 AM
    Moderator
  • Hi Mohd,

    For the issue "The specified network name is no longer available"

    Confirm the following

    1. DNS name resolution is working fine by running command nslookup domainname - make sure it resolves to all the valid ipaddress of the DC's in the domain

    2. Try PING domainname and confirm if resolve to valid DC ipaddress of the domain

    3. Try to access \\domainname and confirm you are able to access SYSVOL and Netlogon Share (from machine not part of domain it should prompt for credentials and should show shares once valid credentials are provided)

    4. All the required ports for domain authentication are allowed on the firewall

    Monday, April 1, 2013 7:49 AM
  • I just wanted to add my experience here for anyone who happens to come across.

    I was getting the same error. The cause was layer1 or Layer2 (Switch port or Cable) I was only connecting at 10Mbps. After switching to another cable and port on the same switch I was connected at 1Gbps. I was then able to join to the domain.

    -Hope this helps someone.

    Ryan Younker

    Wednesday, September 11, 2013 12:57 PM
  • Had the same issue, ping, nslookup correct, changed DNS server to DC all looked ok. Manually created computer account in AD and DNS record for the computer I wanted to join the domain. Disabled firewall and antivirus on both DC and client. Would get as far as being prompted for the join domain Administrative credentials then would fail with the same error as the person starting this post. I was connecting via WIFI, when I connected to the ethernet port it worked. Haven't investigated the WIFI issue further.
    Saturday, May 23, 2015 8:24 AM
  • [RESOLVED] If trying to Re-join to domain Re-image the PC, which I did in the past and it worked but this time just had to do a SYSTEM RESTORE to a restore point and that resolved the issue. Once restore is completed then Disjoin and Rejoin to the domain.

    Thursday, March 31, 2016 7:26 PM
  • Hey man, i thank you for this help. Congratulations

    My server is not stay with Primary PDC 

    • Edited by Fransuelo Friday, September 16, 2016 5:18 PM
    Friday, September 16, 2016 2:17 PM
  • I was getting this on a server with 2 network cards (NICs). I disabled 1 NIC and domain joining worked fine.
    Sunday, August 19, 2018 11:19 AM