none
Lync visual voicemail

    Question

  • Hello,

    I am running a Lync 2010 RC server in combination with Exchange 2010 SP1. UM works fine and so does IM integration in OWA.

    There is just one thing that doesn't seem to work. Internal users seem to have no issues logging in (while external users still get an error that the address book is unreachable, which is because I don't run a ISA server yet), and there are no exclamation marks for internal users. However, I do not see any information in the visual Voice Mail tab in the Lync Client. I have voice mail messages though, and I can just listen to them using Outlook 2010. So, for some reason the voicemails don't seem to be synchronizing properly to the Lync Client.

    I followed the deployment guide Microsoft released. Are there any other steps you need to perform to get visual voicemail working? Actually, where do all the blogposters get their information from, since there is nothing on TechNet yet?

    Ruud van Strijp


    Ruud van Strijp - Network Infrastructure Design in the Netherlands. MCSE: 70-270, 70-284, 70-290, 70-291, 70-294, 70-297. Cisco: CCNA, CCDA, CCNP, CCDP.
    • Moved by Ben-Shun Zhu Monday, October 4, 2010 7:35 AM better put here (From:UC Integration)
    Saturday, October 2, 2010 4:04 PM

Answers

  • I think I have the soltion:

    1) Wilcard Certificates are not supported with OCS/Lync Phone Edition on the Exchange server

    2) SHA256 Certificates are not supported (Out internal CA uses SHA256)

    3) To the Autodiscover Problem. The problem is the service handler for autodiscover.svc. We got everytime Error 405 Method not allowed. On the CAS IIS I saw that .svc extension is allowed BUT the GUI seems to lie. Please take alook at yout applicationhost.config (just an extract):

    <location path="Default Web Site/Autodiscover">

            <system.webServer>

                <directoryBrowse enabled="false" showFlags="Date, Size, Extension, LongDate" />

                <handlers accessPolicy="Read, Script">

                    <clear />

                                    <add name="HttpRemotingHandlerFactory-soap-Integrated" path="*.soap" verb="GET,HEAD,POST,DEBUG" type="System.Runtime.Remoting.Channels.Http.HttpRemotingHandlerFactory, System.Runtime.Remoting, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" preCondition="integratedMode" />

                    <add name="svc-Integrated" path="*.svc" verb="*" type="System.ServiceModel.Activation.HttpHandler, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" preCondition="integratedMode" />

                    <add name="AboMapperCustom-59812" path="*.xml" verb="POST,GET" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll" requireAccess="Script" responseBufferLimit="0" />

                    <add name="TRACEVerbHandler" path="*" verb="TRACE" modules="ProtocolSupportModule" requireAccess="None" />

                               </handlers>

    You must add the yellow line to support the .svc request. After an iisreset everythink is working!

    Please tell me if this solution also fix your problems.

    KR, Jens

    • Proposed as answer by Eniac Blast Saturday, November 27, 2010 4:58 PM
    • Marked as answer by Ruud van Strijp Thursday, December 2, 2010 9:08 AM
    Saturday, November 27, 2010 4:58 PM

All replies

  • Hi Ruud,

    Do you have autodiscover and the DNS records configured for your Exchange 2010 environment? 

     

    Please have a look at these:

    http://technet.microsoft.com/en-us/library/bb201695.aspx

    http://technet.microsoft.com/en-us/library/bb124251.aspx

     

    Hope this helps!

    -kp


    Kevin Peters blog: www.ocsguy.com MCITP: Enterprise Administration | MCTS:OCS | MCSE | MCSA | CCNA
    Saturday, October 2, 2010 7:30 PM
  • I too am having this issue.  I am running a lab environment with AD 2008 R2, Exchange 2010 SP1, and Lync RC.  I haven't setup any external access for Lync or Exchange, therefore I don't have an external DNS to configure Autodiscover.  Is this required to get Visual Voicemail working?  It is the only component that I don't have working at this point.

    I too second the thought that it is really hard to find help on deploying this RC.

    Thanks for any info,
    Jeff

    Tuesday, October 5, 2010 2:30 PM
  • Lync is using autodiscover to find the exchange webservices. Please check the lync client connectivity. Its the same function like in outlook "strg" and with the right mouse click on the Lync icon in the taskbar. The configuration info should sho EWS are used.

    Do you have a DNS entry for autodiscover, because Lync didn't use the servicepointer from the AD.


    regards

    Holger

    Technical Specialist UC

    Tuesday, October 5, 2010 6:53 PM
  • Thanks for the tip about the Configuration Right Click.  I do see the issue...

    MAPI Information;MAPI Status OK;MAPI Status OK;
    EWS Information;--;EWS not deployed;
    UCS Connectivity State;Exchange connection Down;--;

    It looks as though something is not deployed correctly on the Exchange side.  I have created the SRV DNS record for Autodiscover and ran the three Exchange Powershell commands to enable it to work correctly.  I have OWA working 100% with the Communicator 2007 R2 add-in.  How do I deploy EWS correctly?

    Tuesday, October 5, 2010 8:02 PM
  • I have the same things as Jeffrey Kelso describes. Lync Client says EWS not deployed.

    So, I started sniffing some packets. Here I found that Lync was trying to access my autodiscover URL through http instead of https. Because I don't know how to force Lync to use https, I just allowed http access to the Exchange Autodiscover folder in IIS. Now I get the following error:

     

    181 9:27:37 AM 10/6/2010 10.9858456 communicator.exe dcex.lync.test CLIENT1 HTTP HTTP:Response, HTTP/1.1, Status: Unauthorized, URL: /autodiscover/autodiscover.xml Using Multiple Authetication Methods, see frame details {HTTP:20, TCP:19, IPv4:7}

    When I look into how it's trying to authenticate, I see it's trying to authenticate in two different ways. First through NTLM, but I cannot see which credentials it's using. The other authentication is basic, but it's trying to authenticate to the realm autodiscover.sipdomain.net instead of using the internal lync.test domain. When I use a browser to go to http://autodiscover.sipdomain.net/autodiscover/autodiscover.xml, I get a loginscreen. When I fill in my domain credentials (Lync\Test1 username and my password) I can access the website "600Invalid Request" (which I probably get because I didn't give any parameters in the URL). So the IIS part seems to be configured properly.

    I am sure I am doing something wrong, but what? My Outlook 2010 clients just work right away so autodiscovery seems to work fine.

     


    Ruud van Strijp - Network Infrastructure Design in the Netherlands. MCSE: 70-270, 70-284, 70-290, 70-291, 70-294, 70-297. Cisco: CCNA, CCDA, CCNP, CCDP.
    Wednesday, October 6, 2010 7:45 AM
  • Okay, I've made progress.  I had the autodiscover SRV entry in DNS, but I also added a CNAME record that points Autodiscover.FQDN to my Mailserver.FQDN.  I also went in to the Autodiscover part in IIS and removed "Require SSL".  I then was able to get to the http://autodiscover.FQDN/autodiscover/autodiscover.xml address with both http and https.  Although, I noticed that the certficiate was now wrong because I was hitting the mail server with the Autodiscover name.  I then went into the Exchange management console and requested a new certficiate, this time marking the certficiate request as a Wildcard.  I had my local CA sign it and completed the request.  I then assigned it to IIS.  I went ahead and rebooted the mail server.  My Lync client now says that EWS status is okay.  However, the UCS Connectivity State still shows Exchange Connection Down.  I also still do not have Visual Voicemail.  Any ideas?
    Wednesday, October 6, 2010 1:52 PM
  • I am in a similar situation.  I have UM integration set up, and also get missed call and voicemail messages in Outlook.

    But Lync does not show me missed calls OR voicemails.

    I also have EWS not deployed and UCS connectivity state Exchange connection Down.

    Jeffrey I can't imagine that your solution, as clever as it is, is the way this needs to be done.

    Where the heck is the documentation?

    Friday, October 8, 2010 3:44 AM
  • I would tend to agree with you.  If you have to do all of that, then it should be documented somewhere.  Maybe the Visual Voicemail issue is a bug in the RC.  If anyone has Visual Voicemail working in Lync RC, please post.
    Wednesday, October 13, 2010 1:29 PM
  • bizzump
    Friday, October 15, 2010 3:23 PM
  • I have the same problem with Exchange EWS...
    Friday, October 15, 2010 4:24 PM
  • Bump
    Jeffrey Kelso, Enterprise Communications Specialist - CCNA
    Monday, October 18, 2010 3:08 PM
  • It's working in my Lab deployment. As far as I remember a wildcard certificate on Exchange side did not work so I used a SAN certificate.

     


    Johann Deutinger | MCTS Exchange 2007 / OCS 2007
    Wednesday, October 20, 2010 9:46 PM
  • I use a wildcard certificate. I try now a SAN...
    Thursday, October 21, 2010 10:10 AM
  • Did you use a self signed cert or did you get it from digicert or verisign or someone like that?
    cwl
    Thursday, October 21, 2010 1:38 PM
  • It's an official one.
    Thursday, October 21, 2010 2:12 PM
  • My UM server has a single-name cert (lum.lab.local) issues by my enterprise ca (domain controller).  Why should we have to use an external 3rd party cert for internal communication?  Doesn't make any sense.
    Thursday, October 21, 2010 3:56 PM
  • Hi

    I faced the same issue: Lync 2010 RC, Exchange 2010 SP1. Internal PKI for certificates, autodiscover record in DNS, everything seems to bo ok.

    I had this behaviour (no voicemail in Lync tab) on one testing client, but not on a second one: for the moment difference I can see is on the Outlook folders:

    The one which is not working properly has folders in non english language. The other one, working one, has english folder names, but not all the folders (no voicemail view for example, I don't know why for the moment).

    I think this has maybe a link, or the issue is linked to the profile ?

    Thursday, October 21, 2010 4:41 PM
  • Everything we do is in English and we have no voicemail in Lync.
    Thursday, October 21, 2010 5:02 PM
  • I changed the language to English, reset the folder names, still the same. I recreate the outlook profile, the same. Now the two PC looks the same, same Outlook patch update. If I log the same account, I've got visual voicemail on the working PC, and nothing on the non working PC: so it must be a local issue ? can't be profile, as I created a new one (user never logged on the working PC) Edit: what about the installation order ? I think I installed Lync first, Outlook second on the working PC. Maybe not on the first one. It used to have issues about order on OCS...
    Thursday, October 21, 2010 6:15 PM
  • Hi

    Any progress on this isssue ? My voicemail behaviour is erratic, in fact I have received some voicemail in Lync (now in cache in the Lync profile user folder) but it does not receive or synchronize anymore (read/unread status for example). I don't see any exchange in Lync client log file on this subject.

    Tuesday, October 26, 2010 8:18 AM
  • Hi

    Solved for me: I forgot the autodiscover record in the DNS zone associated to my SIP domain, different from the AD DNS zone.

    I also activate in Exchange shell EWS (via set-organizationconfig)

     

    Wednesday, October 27, 2010 9:18 AM
  • Can you explain in a little more detail what is required nkv?
    Wednesday, October 27, 2010 4:25 PM
  • Ok:

    Let's say my SIP domain was ucdom.com: my Lync clients were configured for automatic logon, so they were trying to find Exchange servers via autodiscover.ucdom.com DNS record, which was missing.

    I also check Exchange config via shell, get-organizationconfig: have a look at ews<...> parameters, I enable this:

    set-organizationConfig -EwsEnabled $true - EwsApplicationAccessPolicy EnforceBlockList

    with an empty EwsBlockList, so all applications are allowed to access EWS.

    I think it should work directly with only the autodiscover record, try the shell command after to check if it is necessary.

    Thursday, October 28, 2010 6:29 AM
  • Awesome, once i got the autodiscover SRV record created it worked.  Thanks!
    Thursday, October 28, 2010 10:20 PM
  • I still didn't find any procedure how to configure Lync/Exchange for Exchange UM features like voicemail through EWS. For some reason I was able to configure one client in my testenvironment to use EWS, however a popup with credentials for web services just popped up out of nowhere when I was surfing for any clues regarding Lync, EWS and exchange. I didn't made any changes to any of the servers for about half an hour when this popup popped out. I still have no idea how to configure it. Tried an other workstation, with no luck.

    The strange thing I noticed is that when I right-click my outlook icon and choose to test my e-mail configuration it just nicely tells me the EWS URLs. Also when trying to browse to both the internal and external URLs for EWS (https://fqdn/EWS/exchange.asmx) I get a login prompt, and with proper credentials it just gives me output. Looks like everything is working, however as if Lync just doesn't see it. I don't know how to test autodiscover to see if it publishes EWS services right. As far as my Outlook e-mailconfiguration test tells me, EWS works through autodiscover.

    If anybody knows the exact procedure he did to enable EWS/voicemail, let us know. As far as I get it's:
    - Make sure Autodiscover is running on your exchange server.
    - Make sure you have an autodiscover SRV record in your DNS server for the primary SIP domain.
    - Make sure EWS is running, however as far as I know this is enabled by default

    Wednesday, November 10, 2010 8:34 PM
  • getting the same issue, on the client - for me i have no restrictions - in the function - but if i use a aastra 6725ip and likt to check the calendar then i get a error message "connection to microsoft exchange is unavailable" i think because of the missing EWS internal URL and EWS external URL (in the configuration information page of the LYNC client)

     

    Monday, November 15, 2010 3:13 PM
  • I was getting the same error but after about 15 minutes the calendar information trickled in although the unavailable error was still there.  It took another 5 minutes for that to go away  and i was able to see/join meetings.  Just seems slow, I also created a test meeting in Outlook and with the Polycom CX600 untethered it took about 15 minutes to get to the phone.

    Monday, November 15, 2010 5:57 PM
  • Hi, I will create a MS Support Case! Nothing seems to work. I will post the solution here....
    Thursday, November 18, 2010 8:12 AM
  • I am working with MS on this issue. I will come back (hopefully with a solution)....
    Monday, November 22, 2010 6:42 PM
  • Hello Eniac,

    Did you hear anything about this yet? I just finished setting up my RTM demo environment, and now I'm running into the exact same problem. I got the proper autodiscovery domain in my DNS, and I can just log in to https://autodiscover.internalFQDN.local/autodiscover/autodiscover.xml without certificate errors.

    Is there something else we have to configure? My Exchange autodiscovery seems to work just fine, when I log in for the first time with Outlook I get all settings for my email.

    Ruud van Strijp


    Ruud van Strijp - Network Infrastructure Design in the Netherlands. MCSE: 70-270, 70-284, 70-290, 70-291, 70-294, 70-297. Cisco: CCNA, CCDA, CCNP, CCDP.
    Wednesday, November 24, 2010 2:51 PM
  • Hi everybody,

    you are not alone.. I've the same problem, Lync is not connecting against Exchange using EWS. Both internal and external. But Outlook 2010 is working fine, Autodiscover is working. Tested with Outlook and with www.testexchangeconnectivity.com.

    What i found: Outlook is talking to autodiscover.xml - first with a GET then doing the POST.
    But Lync is doing the initial GET against the autodiscover.xml and then trying a POST against autodiscover.svc. This is rejected by IIS as a unsupported Action. If I change the Handlermapping for .svc to allow POST nothing changes:

    2010-11-26 21:05:54 192.168.x.y GET /autodiscover/autodiscover.xml - 80 - 77.47.5.11 OC/4.0.7577.0+(Microsoft+Lync+2010) 401 0 0 46
    2010-11-26 21:05:54 192.168.x.y POST /autodiscover/autodiscover.svc - 80 - 77.47.5.11 OC/4.0.7577.0+(Microsoft+Lync+2010) 405 0 1 0

    Also, there is NO authentication, which is quite confusing to me.

    While writing this, I've changed the authentication setting on the autodiscover.svc file not accepting anonymous access, now the POST is being authenticated successfully.

    Now it's looking like this:

    2010-11-26 21:52:47 192.168.30.28 GET /autodiscover/autodiscover.xml - 80 - 93.104.97.13 OC/4.0.7577.0+(Microsoft+Lync+2010) 401 0 0 187
    2010-11-26 21:52:47 192.168.30.28 POST /autodiscover/autodiscover.svc - 80 - 93.104.97.13 OC/4.0.7577.0+(Microsoft+Lync+2010) 401 1 2148074254 62
    2010-11-26 21:52:47 192.168.30.28 POST /autodiscover/autodiscover.svc - 80 - 93.104.97.13 OC/4.0.7577.0+(Microsoft+Lync+2010) 401 1 2148074254 62
    2010-11-26 21:52:47 192.168.30.28 POST /autodiscover/autodiscover.svc - 80 domain\user 93.104.97.13 OC/4.0.7577.0+(Microsoft+Lync+2010) 302 0 0 31

    Right after the POST the client is redirected (302) to another URL (/autodiscover/services.wsdl). But there is no such request afterwards.

    Can somebody with a working integration into the EWS please take a look to the IIS log to see which files are beeing accessed? If the POST ist against the .xml or the .svc? or even the .wsdl or whatever?

    Maybe this helps us a little to get rid of this thing..

    Cheers,
    Martin.

     

     

    Friday, November 26, 2010 10:02 PM
  • Hi,

    we have got the same problem in our production environment since RC. The funny thing is, that it does work in all our test environments. So I traced it down to this:

    Production Env (not working):

    Request:

    POST /autodiscover/autodiscover.svc HTTP/1.1
    Accept: text/xml, application/soap+xml, application/octet-stream
    SOAPAction: "http://schemas.microsoft.com/exchange/2010/Autodiscover/Autodiscover/GetUserSettings"
    Cache-Control: no-cache, no-store
    Content-Type: text/xml; charset=utf-8
    Pragma: no-cache
    User-Agent: OC/4.0.7577.0 (Microsoft Lync 2010)
    Content-Length: 1115
    Connection: Keep-Alive
    Host: exchange.company.de:443

    <soap:Envelope xmlns:a="http://schemas.microsoft.com/exchange/2010/Autodiscover" xmlns:wsa="http://www.w3.org/2005/08/addressing" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
                    <soap:Header>
                                   <a:RequestedServerVersion>Exchange2010</a:RequestedServerVersion>
                                    <wsa:Action>http://schemas.microsoft.com/exchange/2010/Autodiscover/Autodiscover/GetUserSettings</wsa:Action>
                                   <wsa:To>https:// exchange.company.de /autodiscover/autodiscover.svc</wsa:To>
                    </soap:Header>
                    <soap:Body>
                                   <a:GetUserSettingsRequestMessage xmlns:a="http://schemas.microsoft.com/exchange/2010/Autodiscover">
                                                   <a:Request>
                                                                   <a:Users>
                                                                                  <a:User>
                                                                                                  <a:Mailbox>user@company.de</a:Mailbox>
                                                                                  </a:User>
                                                                   </a:Users>
                                                                   <a:RequestedSettings>
                                                                                  <a:Setting>InternalEwsUrl</a:Setting>
                                                                                  <a:Setting>ExternalEwsUrl</a:Setting>
                                                                                  <a:Setting>InternalEcpVoicemailUrl</a:Setting>
                                                                                  <a:Setting>ExternalEcpVoicemailUrl</a:Setting>
                                                                   </a:RequestedSettings>
                                                   </a:Request>
                                   </a:GetUserSettingsRequestMessage>
                    </soap:Body></soap:Envelope>


    Response:

    HTTP/1.1 405 Method Not Allowed
    Allow: GET, HEAD, OPTIONS, TRACE
    Content-Type: text/html
    Server: Microsoft-IIS/7.5
    X-Powered-By: ASP.NET
    Date: Thu, 25 Nov 2010 16:53:45 GMT
    Content-Length: 101

    The page you are looking for cannot be displayed because an invalid method (HTTP verb) is being used.

    -----

    Test Environment (working):

    1. Request:

    POST /autodiscover/autodiscover.svc HTTP/1.1
    Accept: text/xml, application/soap+xml, application/octet-stream
    SOAPAction: "http://schemas.microsoft.com/exchange/2010/Autodiscover/Autodiscover/GetUserSettings"
    Cache-Control: no-cache, no-store
    Content-Type: text/xml; charset=utf-8
    Pragma: no-cache
    User-Agent: OC/4.0.7577.0 (Microsoft Lync 2010)
    Content-Length: 1118
    Connection: Keep-Alive
    Cookie: exchangecookie=7248dbe3c6c04a2c8765ddf3f5a5008f
    Host: exchange.company.de:443

    <soap:Envelope xmlns:a="http://schemas.microsoft.com/exchange/2010/Autodiscover" xmlns:wsa="http://www.w3.org/2005/08/addressing" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
                    <soap:Header>
                                   <a:RequestedServerVersion>Exchange2010</a:RequestedServerVersion>
                                    <wsa:Action>http://schemas.microsoft.com/exchange/2010/Autodiscover/Autodiscover/GetUserSettings</wsa:Action>
                                   <wsa:To>https://exchange.company.de/autodiscover/autodiscover.svc</wsa:To>
                    </soap:Header>
                    <soap:Body>
                                   <a:GetUserSettingsRequestMessage xmlns:a="http://schemas.microsoft.com/exchange/2010/Autodiscover">
                                                   <a:Request>
                                                                   <a:Users>
                                                                                  <a:User>
                                                                                                  <a:Mailbox> user@company.de</a:Mailbox>
                                                                                  </a:User>
                                                                   </a:Users>
                                                                   <a:RequestedSettings>
                                                                                  <a:Setting>InternalEwsUrl</a:Setting>
                                                                                  <a:Setting>ExternalEwsUrl</a:Setting>
                                                                                  <a:Setting>InternalEcpVoicemailUrl</a:Setting>
                                                                                  <a:Setting>ExternalEcpVoicemailUrl</a:Setting>
                                                                   </a:RequestedSettings>
                                                   </a:Request>
                                   </a:GetUserSettingsRequestMessage>
                    </soap:Body></soap:Envelope>

    1. Response:

    HTTP/1.1 401 Unauthorized
    Cache-Control: private
    Server: Microsoft-IIS/7.5
    X-AspNet-Version: 2.0.50727
    WWW-Authenticate: Negotiate
    WWW-Authenticate: NTLM
    WWW-Authenticate: Basic realm="exchange.company.de"
    X-Powered-By: ASP.NET
    Date: Thu, 25 Nov 2010 17:06:54 GMT
    Content-Length: 0

    2. Request:

    POST /autodiscover/autodiscover.svc HTTP/1.1
    Accept: text/xml, application/soap+xml, application/octet-stream
    SOAPAction: "http://schemas.microsoft.com/exchange/2010/Autodiscover/Autodiscover/GetUserSettings"
    Cache-Control: no-cache, no-store
    Content-Type: text/xml; charset=utf-8
    Pragma: no-cache
    User-Agent: OC/4.0.7577.0 (Microsoft Lync 2010)
    Connection: Keep-Alive
    Cookie: exchangecookie=7248dbe3c6c04a2c8765ddf3f5a5008f
    Authorization: Negotiate TlRMTVNTUAABAAAAl4II4gAAAAAXXXXXXXXXXXXXXXXXXXXXXXXXXXXX==
    Content-Length: 0
    Host: exchange.company.de:443

    2. Response:

    HTTP/1.1 401 Unauthorized
    Content-Type: text/html
    Server: Microsoft-IIS/7.5
    WWW-Authenticate: Negotiate TlRMTVNTUAACAAAAFAHHHHH88888ExxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxEEAQgBTAAIAFABOAFQARQBBAE0ALQBMAEEAQgBTAAEADgBTAFYATgBFAFgAMAAyAAQAGgBsAGEAYgBzAC4AbgB0AGUAYQBtAC4AZABlAAMAKgBTAFYATgBFAFgAMAAyAC4AbABhAGIAcwAuAG4AdABlAGEAbQAuAGQxxxxxxxxx
    WWW-Authenticate: NTLM
    WWW-Authenticate: Basic realm="exchange.company.de"
    X-Powered-By: ASP.NET
    Date: Thu, 25 Nov 2010 17:06:54 GMT
    Content-Length: 58

    You do not have permission to view this directory or page.

    3. Request:

    POST /autodiscover/autodiscover.svc HTTP/1.1
    Accept: text/xml, application/soap+xml, application/octet-stream
    SOAPAction: "http://schemas.microsoft.com/exchange/2010/Autodiscover/Autodiscover/GetUserSettings"
    Cache-Control: no-cache, no-store
    Content-Type: text/xml; charset=utf-8
    Pragma: no-cache
    User-Agent: OC/4.0.7577.0 (Microsoft Lync 2010)
    Cookie: exchangecookie=7248dbe3c6c04a2c8765ddf3f5a5008f
    Connection: Keep-Alive
    Authorization: Negotiate TlRMTVNTUAACAAAAFAHHHHH88888ExxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxEEAQgBTAAIAFABOAFQARQBBAE0ALQBMAEEAQgBTAAEADgBTAFYATgBFAFgAMAAyAAQAGgBsAGEAYgBzAC4AbgB0AGUAYQBtAC4AZABlAAMAKgBTAFYATgBFAFgAMAAyAC4AbABhAGIAcwAuAG4AdABlAGEAbQAuAGQxxxxxxxxx
    Content-Length: 1118
    Host: exchange.company.de:443

    <soap:Envelope xmlns:a="http://schemas.microsoft.com/exchange/2010/Autodiscover" xmlns:wsa="http://www.w3.org/2005/08/addressing" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
                    <soap:Header>
                                   <a:RequestedServerVersion>Exchange2010</a:RequestedServerVersion>
                                    <wsa:Action>http://schemas.microsoft.com/exchange/2010/Autodiscover/Autodiscover/GetUserSettings</wsa:Action>
                                   <wsa:To>https://exchange.company.de/autodiscover/autodiscover.svc</wsa:To>
                    </soap:Header>
                    <soap:Body>
                                   <a:GetUserSettingsRequestMessage xmlns:a="http://schemas.microsoft.com/exchange/2010/Autodiscover">
                                                   <a:Request>
                                                                   <a:Users>
                                                                                  <a:User>
                                                                                                  <a:Mailbox>user@company.de</a:Mailbox>
                                                                                  </a:User>
                                                                   </a:Users>
                                                                   <a:RequestedSettings>
                                                                                  <a:Setting>InternalEwsUrl</a:Setting>
                                                                                  <a:Setting>ExternalEwsUrl</a:Setting>
                                                                                  <a:Setting>InternalEcpVoicemailUrl</a:Setting>
                                                                                  <a:Setting>ExternalEcpVoicemailUrl</a:Setting>
                                                                   </a:RequestedSettings>
                                                   </a:Request>
                                   </a:GetUserSettingsRequestMessage>
                    </soap:Body></soap:Envelope>

    3. Response:

    HTTP/1.1 200 OK
    Cache-Control: private
    Transfer-Encoding: chunked
    Content-Type: text/xml; charset=utf-8
    Server: Microsoft-IIS/7.5
    X-AspNet-Version: 2.0.50727
    Persistent-Auth: true
    X-Powered-By: ASP.NET
    Date: Thu, 25 Nov 2010 17:06:54 GMT

    <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" xmlns:a="http://www.w3.org/2005/08/addressing"><s:Header><a:Action s:mustUnderstand="1">http://schemas.microsoft.com/exchange/2010/Autodiscover/Autodiscover/GetUserSettingsResponse</a:Action><h:ServerVersionInfo xmlns:h="http://schemas.microsoft.com/exchange/2010/Autodiscover" xmlns:i="http://www.w3.org/2001/XMLSchema-instance"><h:MajorVersion>14</h:MajorVersion><h:MinorVersion>1</h:MinorVersion><h:MajorBuildNumber>218</h:MajorBuildNumber><h:MinorBuildNumber>12</h:MinorBuildNumber><h:Version>Exchange2010_SP1</h:Version></h:ServerVersionInfo></s:Header><s:Body><GetUserSettingsResponseMessage xmlns="http://schemas.microsoft.com/exchange/2010/Autodiscover"><Response xmlns:i="http://www.w3.org/2001/XMLSchema-instance"><ErrorCode>NoError</ErrorCode><ErrorMessage/><UserResponses><UserResponse><ErrorCode>NoError</ErrorCode><ErrorMessage>No error.</ErrorMessage><RedirectTarget i:nil="true"/><UserSettingErrors/><UserSettings><UserSetting i:type="StringSetting"><Name>InternalEcpVoicemailUrl</Name><Value>https://exchange.company.de/ecp/?p=customize/voicemail.aspx&amp;exsvurl=1</Value></UserSetting><UserSetting i:type="StringSetting"><Name>InternalEwsUrl</Name><Value>https://exchange.company.de/EWS/Exchange.asmx</Value></UserSetting></UserSettings></UserResponse></UserResponses></Response></GetUserSettingsResponseMessage></s:Body></s:Envelope>

     

    And then it switches over to EWS.

    I have no idea yet, why "Method not allowed" occurs in the production environment.

    Regards

    Daniel

     

    Saturday, November 27, 2010 2:56 PM
  • I think I have the soltion:

    1) Wilcard Certificates are not supported with OCS/Lync Phone Edition on the Exchange server

    2) SHA256 Certificates are not supported (Out internal CA uses SHA256)

    3) To the Autodiscover Problem. The problem is the service handler for autodiscover.svc. We got everytime Error 405 Method not allowed. On the CAS IIS I saw that .svc extension is allowed BUT the GUI seems to lie. Please take alook at yout applicationhost.config (just an extract):

    <location path="Default Web Site/Autodiscover">

            <system.webServer>

                <directoryBrowse enabled="false" showFlags="Date, Size, Extension, LongDate" />

                <handlers accessPolicy="Read, Script">

                    <clear />

                                    <add name="HttpRemotingHandlerFactory-soap-Integrated" path="*.soap" verb="GET,HEAD,POST,DEBUG" type="System.Runtime.Remoting.Channels.Http.HttpRemotingHandlerFactory, System.Runtime.Remoting, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" preCondition="integratedMode" />

                    <add name="svc-Integrated" path="*.svc" verb="*" type="System.ServiceModel.Activation.HttpHandler, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" preCondition="integratedMode" />

                    <add name="AboMapperCustom-59812" path="*.xml" verb="POST,GET" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll" requireAccess="Script" responseBufferLimit="0" />

                    <add name="TRACEVerbHandler" path="*" verb="TRACE" modules="ProtocolSupportModule" requireAccess="None" />

                               </handlers>

    You must add the yellow line to support the .svc request. After an iisreset everythink is working!

    Please tell me if this solution also fix your problems.

    KR, Jens

    • Proposed as answer by Eniac Blast Saturday, November 27, 2010 4:58 PM
    • Marked as answer by Ruud van Strijp Thursday, December 2, 2010 9:08 AM
    Saturday, November 27, 2010 4:58 PM
  • Great, autodiscoer and EWS are working now - I added the mentioned line. Lync can now access call log and voice mails.

    Regards

    Daniel

     

     

    Saturday, November 27, 2010 7:26 PM
  • YES!

    Adding the svc-integrated got this stuff running, thank you!

    Lync is now discovering and connecting against my EWS, Visual Voicemail and Conversation History is working.

    If you ever get to munich let me know ;)

    Saturday, November 27, 2010 10:29 PM
  • It made the trick for me too. 

    Thank you, you saved my week end.

    Sunday, November 28, 2010 8:32 PM
  • Did you guys do anything else than adding that line to C:\Windows\System32\inetsrv\config\applicationHost.config on the Exchange machine? For me it's still not working, I still get the message 'EWS not deployed' in the Lync client.

    I am using SHA1 certificates, no wildcards and I have autodiscover.internaldomain.local and autodiscover.externaldomain.nl in the certificate.


    Ruud van Strijp - Network Infrastructure Design in the Netherlands. MCSE: 70-270, 70-284, 70-290, 70-291, 70-294, 70-297. Cisco: CCNA, CCDA, CCNP, CCDP.
    Monday, November 29, 2010 9:39 AM
  • :-) Thanks a lot! It did the trick!
    Monday, November 29, 2010 1:57 PM
  • Eniac, did you get this fix from Microsoft PSS?  Does this mean the Lync RTM code is broken?
    Tuesday, November 30, 2010 8:39 AM
  • The above correction is done on the Exchange server! In my case (Exchange 2010 SP1) it was already there.
    Johann Deutinger | MCTS Exchange 2007/2010 / OCS 2007
    Tuesday, November 30, 2010 8:43 AM
  • I assume this is done on the CAS server(s).

    I am running 2010 SP1 and the code addition did not exist on my CAS servers.

    Adding it now and doing an iisreset and we'll see...

    Tuesday, November 30, 2010 8:45 AM
  • Well it sort of seems to have helped...  At least now I can see the voicemails in the Lync client.

    However I still don't get anything under the missed call area - I've tried calling and ignoring calls, and also calling while Lync client is shut down.  If you leave a voicemail, does it not bother to log it as a missed call? EDIT: that appears to be the case

    Tuesday, November 30, 2010 8:51 AM
  • Did you guys do anything else than adding that line to C:\Windows\System32\inetsrv\configapplicationHost.config on the Exchange machine? For me it's still not working, I still get the message 'EWS not deployed' in the Lync client.

    I am using SHA1 certificates, no wildcards and I have autodiscover.internaldomain.local and autodiscover.externaldomain.nl in the certificate.


    Ruud van Strijp - Network Infrastructure Design in the Netherlands. MCSE: 70-270, 70-284, 70-290, 70-291, 70-294, 70-297. Cisco: CCNA, CCDA, CCNP, CCDP.

    For some reason, I get an Error 500 when I try to access https://FQDN/autodiscover/autodiscover.svc. Is anyone familiar with that problem?

    Edit: I ran these commands:

    Get-AutodiscoverVirtualDirectory | Remove-AutodiscoverVirtualDirectory

    New-AutodiscoverVirtualDirectory

    Set-ClientAccessServer -Identity <computername> -AutoDiscoverServiceInternalUri https://autodiscover.internaldomain.local

    And now visual voicemail works perfectly for me! Thanks a lot for giving us that line, Eniac. That did the trick!


    Ruud van Strijp - Network Infrastructure Design in the Netherlands. MCSE: 70-270, 70-284, 70-290, 70-291, 70-294, 70-297. Cisco: CCNA, CCDA, CCNP, CCDP.
    Wednesday, December 1, 2010 11:09 AM
  • I have done the manual editing of the Exchange 2010 SP1 CAS applicationhost.config file (I have separate CAS and UM server), run "iisreset", I still see error 405 in IIS log for "https://CAS_FQDN/autodiscover/autodiscover.svc" requests.

    Any other idea? I am even not sure how to check if EWS is healthy in my deployment, or not?

    With OCS 2007 R2 there was no problem seeing the call history or the voicemessage list in tanjay. Autodiscover A-record (not SRV record) is there since ages. With

    Ps. I just missed the details: EWS status: not deployed, UCS connectivity state: Exchange connection down, EWS internal/external URL: <empty>. MAPI status is OK however. I cannot see Exchange integration error in Lync UI, but the call lists, visual voicemail notification is empty.

    Pa2: LOL, Lync Configuration information is not refreshed if you click the Refresh button. You have to close the window and re-open. Tada.wav!
    Wednesday, December 8, 2010 4:39 PM
  • We haven't deployed Enterprise Voice, but we are unable to get Outlook conversation history and presence information from the calendar in Lync and Communicator.  I figured this would be a fix for me as well.  However that line is already in my applicationhost.config file.  I don't see any events in my IIS logs on my exchange CAS. 

    How can I verify that EWS is deployed and working correctly?

    Friday, December 17, 2010 9:19 PM
  • I'm still having the same issue as the rest of you - Exchange Connection Down.  I attempted to add the svc-integrated line to my config file and it did not help.  I already had this line in my file:

    <add name="svc-Integrated-4.0" path="*.svc" verb="*" type="System.ServiceModel.Activation.ServiceHttpHandlerFactory, System.ServiceModel.Activation, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode,runtimeVersionv4.0" />

    It is slightly different than the one listed here that works for everyone else.  Does anyone have any suggestions?

    Thanks for the help,
    Jeff


    Jeffrey Kelso, Enterprise Communications Specialist - CCNA
    • Edited by Jeffrey Kelso Sunday, December 19, 2010 10:14 PM typo
    Sunday, December 19, 2010 10:13 PM
  • Jeff,

    I also have the same version 4.0 reference and the subsequent EWS issue. Our nearest maintenance window isn't until this coming weekend, but so long as I remember, I'll see how it goes with backdating the reference to the above version 3.0 example (though I will be rolling that back after brief testing with Lync).

    For reference, we're on Exchange 2010, but not with SP1.

    Cheers,
    Lain

    Thursday, January 6, 2011 3:02 AM
  • Hi!

    I also have the problem, that I don't have (missed) calls in Lync. The above mentioned solution from Jens is already in our  applicationhost.config. We have 401s for autodiscover.xml requests. We're on Exchange 2010 SP1, UR2.

    We have this problem only for external users which connect via ISA 2006 SP1 - Autodiscover for Outlook etc. works perfect with FBA, Authentication Validation Method is LDAP; Authentication is Basic. https://www.testexchangeconnectivity.com/ is green.

    Lync Configuration status shows, that it doesn't have any EWS information.

    Just found this from Elan Shudnow: http://www.shudnow.net/2009/08/05/publishing-exchange-2007-autodisover-in-isa-2006-part-2/ 

    Can someone confirm, that integrated authentication is still needed for EWS on Exchange 2010 through ISA 2006?

    Or has anyone any hints for me?

    Regards,

    Jens

    Thursday, January 6, 2011 10:55 AM
  • One thing to note on the visual voicemail issue.  I had it working on some clients, but not on mine.  Make sure that you go into your Lync Client settings and check to see if your Personal Information Manager is set; for some reason, mine was not.  It's under the Personal section of the settings.

    Also know that my Configuration Information still states that my UCS Connectivity State is Exchange Connection Down.  Everything works still works though.

    -Jeff


    Jeffrey Kelso, Enterprise Communications Specialist - CCNA
    Monday, January 24, 2011 1:37 PM
  • One thing to note on the visual voicemail issue.  I had it working on some clients, but not on mine.  Make sure that you go into your Lync Client settings and check to see if your Personal Information Manager is set; for some reason, mine was not.  It's under the Personal section of the settings.

    Also know that my Configuration Information still states that my UCS Connectivity State is Exchange Connection Down.  Everything works still works though.

    -Jeff


    Jeffrey Kelso, Enterprise Communications Specialist - CCNA
    Monday, January 24, 2011 1:37 PM
  • Hey guys, I just posted an article relating to this last night. Can you please review and see if this solves the problem for anyone else? http://www.confusedamused.com/notebook/lync-claims-ews-not-deployed/

    FYI - UCS is a feature dropped from RTM. I wouldn't worry about the configuration window complaining the connection is done. Focus on the EWS and MAPI status instead.

    Thursday, January 27, 2011 3:28 PM
  • Anyone else have any other suggestions for this? I tried everything on this forum and still no resolution.

    Monday, February 28, 2011 10:38 PM
  • The other thing I noticed, Tom Pacyk, on your aritlce you state that there are a bunch of registry settings in HKCU\Software\Microsoft\Communicator\<SIP URI>\Autodiscovery. The problem is I do not even have the Autodiscovery key located at that path.. You would mind posting all the registry values that should be there with an example on some of the non-general ones such as cacheVersion, UsedWSSSecurity, etc.. I am thinking about manually creating them to see if that resolves the issue.

    Thanks

    Tuesday, March 1, 2011 7:03 PM
  • Update, after some more research I changed my default email address to the same as my sip domain and it works. For example, the sip domain I am using to log onto lync is username@test.net, my default email alias is username@test.com. Changed it to username@test.net, everything works fine. Anyone have any suggestions on how to get around this?
    Tuesday, March 1, 2011 11:12 PM
  • Got everything working, as far as EWS goes on the lync client. For me this turned out to be an underlying autodiscover misconfiguration. Plus with the above service handler issue fix, everyting is working. As well, to get around the issue with Lync using your default email address, you can disable this by setting the DisableEmailComparisonCheck to True in the Client Policy via the management shell. http://technet.microsoft.com/en-us/library/gg398300.aspx I did notice that after changing this setting it took a little while to take affect.

    This also has some great info on communicator and exchange: http://communicatorteam.com/archive/2008/01/29/54.aspx

    Thanks

    Thursday, March 17, 2011 1:03 PM
  • Thank you Eniac Blast - worked for me!
    Friday, November 11, 2011 10:01 PM
  • Hi Eniac,

     

    I was having issues at a client site where the Lync client would report "EWS not deployed", although EWS was in fact deployed and accessible via Outlook. A wireshark trace showed the same error you were seeing (405 Method Not Allowed).

    Checking the applicationhost.config file, I also noted that the "svc-integrated" entry was missing. After adding this and restarting IIS EWS status for Lync users instantly displayed as ok with EWS website details now visible from Lync configuration information.

    Thanks for the info.

    Damo.

    Monday, December 19, 2011 10:22 PM
  • Hi Guys,

    In My case, I was getting following in one CAS1 server and Lync client was getting EWS not deployed message when connected to this server,

    GET /autodiscover/autodiscover.xml - 443 - 1.2.3.4 OC/4.0.7577.4061+(Microsoft+Lync+2010) 401 0 0 16027
    POST /autodiscover/autodiscover.svc - 443 - 1.2.3.4 OC/4.0.7577.4061+(Microsoft+Lync+2010) 401 0 0 0
    POST /autodiscover/autodiscover.svc - 443 - 1.2.3.4 OC/4.0.7577.4061+(Microsoft+Lync+2010) 401 1 2148074254 15
    POST /autodiscover/autodiscover.svc - 443 domain\user 1.2.3.4 OC/4.0.7577.4061+(Microsoft+Lync+2010) 302 0 0 218
    GET /autodiscover/autodiscover.xml - 80 - 1.2.3.4 OC/4.0.7577.4061+(Microsoft+Lync+2010) 403 4 5 218

    On the other server (CAS2) where EWS and voice mail is fine,

    GET /autodiscover/autodiscover.xml - 443 - 1.2.3.4 OC/4.0.7577.4061+(Microsoft+Lync+2010) 401 0 0 0
    POST /autodiscover/autodiscover.svc - 443 - 1.2.3.4 OC/4.0.7577.4061+(Microsoft+Lync+2010) 401 0 0 0
    POST /autodiscover/autodiscover.svc - 443 - 1.2.3.4 OC/4.0.7577.4061+(Microsoft+Lync+2010) 401 1 2148074254 15
    POST /autodiscover/autodiscover.svc - 443 domain\user 1.2.3.4 OC/4.0.7577.4061+(Microsoft+Lync+2010) 200 0 0 78

    I then compared IIS handler mappings for both servers and found that for CAS1, in AutoDiscoveryHandler Request Restriction verbs was set as "POST" whereas in CAS2 it was "GET". I set the same setting in CAS1 (Request Restriction verbs was set as "GET") and it started working fine.

    This is strange !!

    Hope this helps for anyone who faces this problem...

    Monday, April 23, 2012 7:44 AM
  • Hi Eniac

    I didn't believed it's the solution

    but it works fine

    Thanks a lot for your answer 

    Wednesday, July 4, 2012 12:56 PM
  • The information contained in this thread had been very helpful, however, my specific problem was rooted in the certificate.  I deleted all exchange certificates to understand what was needed to get Exchange UM voice mail to work. (Exchange UM service needs a certificate issued from the same CA that issued the Lync certificate). After I fixed this I finally got UM voice mail working. The next issue I was faced with was EWS not configured (hold CTRL and left click on the LYNC icon in the notifcation area) . Again what led me it been a certificate issue is, I read about Exchange PS command Test-OutlookWebServices -ClientAccessServer "exchange", however, when I ran this command I got and error ".....error....Failed to find a mailbox....” I found this Exchange PS command [PS] C:\program files\microsoft\exchange server\v14\scripts>.\new-testcasconnectivityuser.ps1. This is where I got my clue that I should recreate the certificate, here's the error I got -

    Test-OutlookWebServices -ClientAccessServer "exchange

    RunspaceId : 13091c60-a148-4042-974a-d7c3ef27e624
    Id         : 1004
    Type       : Error
    Message    : The certificate for the (external) URL https://mail.name.com/ews/exchange.asmx is incorrect. For SSL to work,
                  the certificate needs to have a subject of mail.name.com, but the subject that was found is (internal)EXCHA
                 NGE.name.com. Consider correcting service discovery, or installing a correct SSL certificate.

    I requested a new certificate and made sure to expand all the service options and when the request was sent create it had the external URL in SAN. I used AD CA web services to request the certificate and when I applied it, BINGO!, it all started working again.

    I hope this helps

    Tuesday, September 11, 2012 4:49 AM
  • The problem in my implementation:

    Missed calls and conversation history appears in outlook for all users but:

    1. for some users data in outlook appears with delay,

    2. for some users missed calls, call logs do not appear in lync client.

    All users got the same setting in lync and in exchange (and so network ones). Lync server and lync client are upgraded to the last patch. 

    Any ideas what I missed?

    Sunday, December 2, 2012 12:14 PM
  • Lync use the Exchange EWS for Missed conversation and the info about missed conversation will be send from the Echange Um server to the users mailbox.

    If you have delay for some users, you should check the message transfer from UM to the users mailbox and the connection to the EWS.

    For the users which did not receive any notification, check the outlook/lync integration. Also if the users have not more than 1000 folders in her mailbox, because EWS search only a maximum at 1000 folders by defaul configuration.


    regards Holger Technical Specialist UC

    Sunday, December 2, 2012 1:21 PM
  • New update:

    1. Data in outlook appears without delay - I guess this issue is solved,

    2. For some users in lync, I do not see ONLY the missed calls (conversations and made calls are in lync),

    EWS Settings are correct. I excluded the network issues (logged users on end stations and so on server). 


    Monday, December 3, 2012 1:52 PM
  • New update:

    1. Person who do not have problems with missed calls in lync client logged on the computer of the user, who problem got - Missed calls are working properly

    2. Person who have problems with missed calls in lync logged on the computer of the user, who problems has not - Missed calls are not working properly.

    It means there is something wrong with the account. What can I change to make it working?

    Friday, December 7, 2012 1:26 PM
  • Has anyone encountered the same error?
    Monday, December 10, 2012 1:14 PM
  • New update:

    - wenn I deleted the outlook profile (added to get access to Exchange UM), the lync client began to work properly.

    What could be wring in adding data to outlook?

    Friday, December 14, 2012 2:55 PM
  • when I run "set-organizationConfig -EwsEnabled $true - EwsApplicationAccessPolicy EnforceBlockList" it's telling me that "a parameter cannot be found that matches parameter name 'EwsEnabled' " why pls help me ,ty
    Friday, September 20, 2013 2:13 PM
  • this did the trick for us on Lync 2013 server & Exchnage 2010. 

    our internal clients were reporting that EWS was not deployed, after adding this & rebooting (exchange & the lync client) everything is working as deisgned in lync client for the internal people. 

    external is still broken (EWS not deployed) so no conversation history or missed calls...etc....

    i think it has to do with our TMG server & or certs.

    Wednesday, December 11, 2013 7:57 PM
  • you have a "space"
    between your "-" & "EWSApplicationAccessPolciy"
    Wednesday, December 11, 2013 7:58 PM
  • Thanks, worked for me. Looked for a week, had everything in place and correct.
    Friday, April 1, 2016 2:01 PM