none
Username won't appear in sharepoint.

    Question

  • Hello,  I have an issue with a specific user that sharepoint doesn't show his name. 

    For instance, if this user creates or edits an item in sharepoint, the value for "created/modify by" is alwayse empty.  

    Any idea where the issue comes from ?

    Friday, November 10, 2017 4:12 PM

All replies

  • Hi Mak- I suggest re-creating his account.

    cameron rautmann

    Friday, November 10, 2017 9:51 PM
  • Please check this below

    https://social.technet.microsoft.com/Forums/sharepoint/en-US/5e50fa8a-08f4-444b-baed-7e42b6142651/created-by-and-modified-by-fields-empty-across-entire-sharepoint-site?forum=sharepointgenerallegacy


    Please remember to click Mark as Answer on the answer if it helps you

    Friday, November 10, 2017 10:51 PM
  • Hi,

    There are some PowerShell commands which do this easily:

    Set-SPUser -Identity "i:0#.w|domain\user" -DisplayName "SP User Guy" –Web http://micorosoft.com

    Alternatively you can change this using the User Profile Application.

    Please let me know if you need additional help.

    Thanks

    Please rate this post if this information was useful

    Saturday, November 11, 2017 6:25 AM
  • Try below code, if it fix your issue

    $login= "i:0#.w|dev\TestUser1"
    $site= "http://intranet.contoso.com/sites/abcsite" 
    Set-SPUser -Identity $login -web $site -SyncFromAD

    Check below blog for more troubleshooting 

    https://blogs.technet.microsoft.com/marj/2016/03/14/what-is-hidden-user-information-userinfo-list-in-sharepoint-20102013-and-how-to-fix-when-it-causes-a-site-collection-to-show-old-user-metadata-properties-in-people-picker-control-or-in-a-person-or/

    Regards

    Prasad Tandel

    Saturday, November 11, 2017 10:22 AM
    1. Contact your sysadmins and request that they verify that the user's domain account Display Name property has been entered correctly.
    2. Trigger user profile to run a full update
    3. Launch a full crawl of user profile
    Saturday, November 11, 2017 7:34 PM
  • Hi Mak222,

    As others mentioned above, please navigate to the User Information List and check if the user is in the list.

    The path of User Information List is: http://sp/sites/<site>/_layouts/15/people.aspx?MembershipGroupId=0

    Besides, ensure the User Information List is set to show items "Read all items" and "Create and edit all items".

    On the User Information List, click Settings > List Settings > Advanced settings.


    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, November 13, 2017 7:19 AM
    Moderator
  • Hi Mak222,

    Is there any update?

    Have you resolved the issue?

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, November 17, 2017 9:21 AM
    Moderator