locked
Uls Unhealthy RRS feed

  • Question

  • Hi,

    My Office Online 2016 is unhealthy, because ULS is unhealthy. After some debugging I found out that UlsControllerWatchdog.exe is digging through ULS logs looking for a line containing "ULS Controller Watchdog canary.". This line mush have "Hosted Services Infrastructure" in the Area column, while my log files have "Services Infrastructure". This results in log messages such as:

    Trace string was successfully found in MACHINE-20160531-1523.log!
    Format validation failed in MACHINE-20160531-1523.log and invalid message is : The following fields has the wrong format or content: [ Area ]!
    Trace string is found but not correct!
    UlsControllerWatchdog says that health status for the UlsController agent on machine MACHINE (category = Verify Trace Logging) is Error

    Is there anything I can do about it?

    Tuesday, May 31, 2016 2:02 PM

All replies

  • Same here:

    <?xml version="1.0" encoding="utf-16"?><HealthReport xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <HealthMessage>UlsControllerWatchdog reported status for UlsController in category 'Verify Trace Logging'. Reported status: Trace string is found but the format is not correct in C:\ProgramData\Microsoft\OfficeWebApps\Data\Logs\ULS.</HealthMessage>
      <Severity xsi:nil="true" />
    </HealthReport>

    resulting in:

    <?xml version="1.0" encoding="utf-16"?><HealthReport xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <HealthMessage>AgentManagerWatchdog reported status for AgentManagerWatchdog in category 'Recent Watchdog Reports'. Reported status: Machine health is Unhealthy</HealthMessage>
      <Severity xsi:nil="true" />
    </HealthReport>

    Tuesday, June 7, 2016 8:57 AM
  • I have got the same message error with error ID 1672 / 2672

    Has anyone a solution ?

    Thursday, June 9, 2016 2:08 PM
  • Same error here, tried below fix setting to Medium or Verbose

    https://wespoint.wordpress.com/2014/04/07/office-web-apps-server-unhealthy-status/

    Still the error remains.

    can;t believe this product is RTM, full of bugs and 2 articles on technet with different prereqs.

    Thursday, June 23, 2016 1:31 PM
  • Will there be an update for this product ?

    I have still the same error. Reinstall everything from scratch, in English, in French, with a wildcard, with a SAN...

    And the farm is still unhealthy and the error are always the same 1672:

    <HealthMessage>UlsControllerWatchdog reported status for UlsController in category 'Verify Trace Logging'. Reported status: Trace string is found but the format is not correct in C:\ProgramData\Microsoft\OfficeWebApps\Data\Logs\ULS.</HealthMessage>

    Hope we will receive an answer soon

    Sunday, June 26, 2016 8:21 AM
  • Same problem here... when will this be updated?
    Thursday, June 30, 2016 12:28 PM
  • The Product Team has published a blog post about this - https://blogs.technet.microsoft.com/office_web_apps_server_2013_support_blog/2016/10/26/oos-unhealthy/

    "The OOS product team is in the process of correcting the health checks in an upcoming patch for OOS. We do not have a timeline on when this will be released, but this blog will be updated when the patch is available"

    They also state that "The healthStatus message should not be a indication of functionality of a OOS farm".

    I suggest everyone who wants the health status fixed to follow that blog.

    Thursday, October 27, 2016 6:49 AM
  • Hello,

    I've installed November 2016 update for OOS and receiving below error message :

      <HealthMessage>UlsControllerWatchdog reported status for UlsController in category 'Verify Trace Logging'. Reported status: Likely caused by shipping osipartner outputs from somewhere other than a devmain checkpoint. Trace string is found but the format is not correct in C:\ProgramData\Microsoft\OfficeWebApps\Data\Logs\ULS. The following fields has the wrong format or content: [ Timestamp ].</HealthMessage>

    Is this error wrongly reported, a bug in this release?

    BR, Sarath

    Monday, December 19, 2016 12:09 PM
  • Hi

    A few month back I had a similar problem, it was related to the certificate and to a missing feature (Add-WindowsFeature windows-identity-foundation). Have you tried all the steps from this Troubleshooting Website:

    http://www.wictorwilen.se/office-web-apps-server-2013---machines-are-always-reported-as-unhealthy



    Monday, December 19, 2016 12:36 PM
  • Yes, this feature is installed in my environments and certificate have needed FQDNs added under SAN.

    Also, I m also seeing this error in a dev environment where HTTP is used.

    BR, Sarath

    Monday, December 19, 2016 1:59 PM
  • Hello,

    I've installed November 2016 update for OOS and receiving below error message :

      <HealthMessage>UlsControllerWatchdog reported status for UlsController in category 'Verify Trace Logging'. Reported status: Likely caused by shipping osipartner outputs from somewhere other than a devmain checkpoint. Trace string is found but the format is not correct in C:\ProgramData\Microsoft\OfficeWebApps\Data\Logs\ULS. The following fields has the wrong format or content: [ Timestamp ].</HealthMessage>

    Is this error wrongly reported, a bug in this release?

    BR, Sarath


    Try set English formats (date, time or number) to system accounts.
    Wednesday, March 22, 2017 5:35 AM
  • Hi,

    I had the same problem, how I fixed that :

    On all your OOS servers : Go to Control Panel - Region. In the Formats tab you need to have "English (United States)" in Format section.

    Then in Administrative tab click on "Copy settings...", check "Welcome screen and systems accounts", you need to have "English (United States)" in Format section, then click OK.

    Execute this PS command on all OOS servers : Restart-Service WACSM

    Wait 10/15 minutes and check with this command : (Get-OfficeWebAppsFarm).Machines

    Friday, August 17, 2018 8:22 AM