locked
Excel associates .xlsx as ".xlsx files" RRS feed

  • Question

  • I have two users and they have windows 7 and office 2010. When they receive any xlsx files either via e-mail or sharepoint the files are seen as ".xlsx files" and do not open unless you have excel open and go to file > open. I've unchecked the ignore DDE and I've checked the registry and its correct. 
    Wednesday, December 22, 2010 10:21 PM

Answers

  • Actually nothing suggested above worked. Unfortunately, you might need another working computer with Windows 7 and Office 2010 that can open it correctly. I have not tested it without importing a reg from a working computer. Someone can test it out and reply to help others if it does works, What else do you have to lose?  What I ended up doing was going to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExt and deleting ".xlsx" reg file because it kept treating them like "xlsx file". Before deleting anything back up you entire registry not just the node! Also I suggest googling for "unassociate" and use it to unassociate ".xlsx" files on your computer and do not hit anything else. So after deleting the reg file and unassociating it import the working reg file by going to search bar and typing "regedit" then you can File(top left hand corner)-->Import, then it browse will let you find it and import it (also put it somewhere easy found and not somewhere wher you have to dig for it)  

    1) Download Unassociate & obtain a reg ".xlsx" file from the same location (see above if you don't have another working comp with the requested reg file)

    2) Set restore point(to be safe) and back up entire registry

    3) Go to HKEY_CURRENT_USER\Software\Microsoft\CurrentVersion\Explorer\FileExt and find ".xlsx" and delete it

    4) Unassociate ".xlsx" file

    5) Import the reg from the working comp (Skip if don't have reg file)

    6) Double click any ".xlsx" file and the computer should ask you "What program do you want to open this with ?" Click Excel 2010 and make sure click the box that says "Always use this program for this kid of file", if not you and right click and go to "open with" and it will bring you through the same process.    

    • Marked as answer by eddiero Monday, February 7, 2011 9:02 PM
    Monday, February 7, 2011 9:02 PM

All replies

  • Hi,

    First, try to hold on ctrl key while double click xlsx file to see if it can open in safe mode.

    If it works, try to disable add-ins in Excel 2010.

    Click the File menu –> Options –> Navigate to Add-Ins options.

    Select Disabled Items in the Manage dropdown and click the Go button. This would display the following Disabled Items window using which you can see and also re-enable the disabled add-in. You can select the ones you wish to re-enable and click the Enable button.

     

    Second, right click on an .xlsx excel file

    - Select "Open with..."
    - Then pick (or browse to) the loction for the Excel 2010  (e.g. C:\Program Files\Microsoft Office\Office14\EXCEL.EXE)

    or do it via control panel

    Control Panel -> All Control Panel Items -> Default Programs -> Set Associations

    Third, check this registry:

    • First open Registry Editor (Go to Start -> Run -> regedit.exe)
    • Navigate to HKEY_CURRENT_USER\SOFTWARE\MICROSOFT\OFFICE\14.0\EXCEL\SECURITY
    • Right click in the right window and choose New -> DWORD
    • Type “ExtensionHardening” as the name (without the quotes)
    • Verify that the data has the value “0″
    • Marked as answer by Jennifer Zhan Friday, December 31, 2010 5:50 AM
    • Unmarked as answer by eddiero Thursday, January 6, 2011 9:29 PM
    Monday, December 27, 2010 1:58 AM
  • I am yet to try this the users were on vacation. I will repy back with results, ASAP.

    Thursday, January 6, 2011 9:29 PM
  • Actually nothing suggested above worked. Unfortunately, you might need another working computer with Windows 7 and Office 2010 that can open it correctly. I have not tested it without importing a reg from a working computer. Someone can test it out and reply to help others if it does works, What else do you have to lose?  What I ended up doing was going to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExt and deleting ".xlsx" reg file because it kept treating them like "xlsx file". Before deleting anything back up you entire registry not just the node! Also I suggest googling for "unassociate" and use it to unassociate ".xlsx" files on your computer and do not hit anything else. So after deleting the reg file and unassociating it import the working reg file by going to search bar and typing "regedit" then you can File(top left hand corner)-->Import, then it browse will let you find it and import it (also put it somewhere easy found and not somewhere wher you have to dig for it)  

    1) Download Unassociate & obtain a reg ".xlsx" file from the same location (see above if you don't have another working comp with the requested reg file)

    2) Set restore point(to be safe) and back up entire registry

    3) Go to HKEY_CURRENT_USER\Software\Microsoft\CurrentVersion\Explorer\FileExt and find ".xlsx" and delete it

    4) Unassociate ".xlsx" file

    5) Import the reg from the working comp (Skip if don't have reg file)

    6) Double click any ".xlsx" file and the computer should ask you "What program do you want to open this with ?" Click Excel 2010 and make sure click the box that says "Always use this program for this kid of file", if not you and right click and go to "open with" and it will bring you through the same process.    

    • Marked as answer by eddiero Monday, February 7, 2011 9:02 PM
    Monday, February 7, 2011 9:02 PM