none
Export-SPWeb and Import-SPWeb problem RRS feed

  • Question

  • Here's the error message:  Import-SPWeb : Cannot import site. The exported site is based on the template SPSREPORTCENTER#0 but the destination site is based on the template BICenterSite#0  [I'm 99% sure it said BICenterSite#0]

    The background is:

    • I migrated a site from SharePoint 2007 to SharePoint 2010
    • I ran Export-SPWeb from the migrated SharePoint 2010 site
    • I ran Import-SPWeb from the previous export and got the error message above

    In short, nothing that I can now create in SharePoint 2010 seems to match the exported "SPSREPORTCENTER#0" template.

    So the question is, how can I export and then import to a different location?  Thanks.

    Wednesday, September 4, 2013 6:29 PM

Answers

  • Hi,

    When exporting imported sites to SharePoint 2010 they have to have the same template.

    When i ran to this before my solution was to create a site with the same template to the target site, then do the export and move the sites manually. Or if you don't have the same template available, create a site which is available in both sites and move the sites under that site.

    If you are exporting/importing a whole site collection, your solution is to create site collection with the option to select the template later and then do the import.


    • Edited by Miksteri Wednesday, September 4, 2013 6:47 PM typo
    • Marked as answer by Bob Harford Wednesday, September 4, 2013 7:56 PM
    Wednesday, September 4, 2013 6:47 PM

All replies

  • Hi,

    When exporting imported sites to SharePoint 2010 they have to have the same template.

    When i ran to this before my solution was to create a site with the same template to the target site, then do the export and move the sites manually. Or if you don't have the same template available, create a site which is available in both sites and move the sites under that site.

    If you are exporting/importing a whole site collection, your solution is to create site collection with the option to select the template later and then do the import.


    • Edited by Miksteri Wednesday, September 4, 2013 6:47 PM typo
    • Marked as answer by Bob Harford Wednesday, September 4, 2013 7:56 PM
    Wednesday, September 4, 2013 6:47 PM
  • can you try just doing new-spweb and giving it a url and owner only? I think this way your import & export will works. i cross my fingers.

    thanks

    -WS


    Thanks -WS SharePoint administrator, MCITP(SharePoint 2010)

    Wednesday, September 4, 2013 7:55 PM
    Moderator
  • <<If you are exporting/importing a whole site collection, your solution is to create site collection with the option to select the template later and then do the import.>>

    That is what worked for me, thanks Miksteri.


    • Edited by Bob Harford Wednesday, September 4, 2013 7:57 PM typo
    Wednesday, September 4, 2013 7:57 PM