locked
Hyper-V host disk usage at 100% RRS feed

  • Question

  • Greetings all,

    I'm stumped. I have a Windows 8 Pro Hyper-V host running a Windows 7 Pro VM. When I start the VM, the disk usage on the disk that it is stored on goes to 100% (on the host). All disk, RAM, & CPU usage looks normal on the host. The only symptom on the host is extreme latency when I click things (!).

    As I said before, the host is running Windows 8 Pro. It has three physical disks--one SSD that the OS installed on, and two RAID arrays totaling 18TB each. It has one physical processor, 6 cores w/hyper-threading. 32GB of RAM.

    The VM is the only VM, and I've allocated 16GB of RAM w/dynamic RAM enabled. I've allocated 8 cores to it. The OS is installed on a 500GB virtual disk. I had hooked up a second 4TB (GPT) virtual disk, but it is currently disconnected. I was thinking that maybe it was the problem, but the disk usage is still maxed out at the present time. The only other thing I tried, admittedly as a long-shot, was to change the paging location to the other empty disk (on the host). That hasn't had an effect, either, and I'll likely put it back when I can. As I type this, the VM is rebooting after having installed the Hyper-V integration services and a Windows Update (including SP1). This will likely take a while...

    Any thoughts are appreciated!


    • Edited by Jspartacus Thursday, May 7, 2015 8:21 PM
    Thursday, May 7, 2015 8:16 PM

Answers

  • Set the "Automatic Stop Action" setting of the VM to anything except "Save".

    Setting the stop action to Save causes Hyper-V to reserve a page out file equivalent to the RAM of the VM.  thus consuming this much disk space.

    Everything beyond that is disk IO of the VM affecting the host - assuming the VM virtual disk is on the Windows 8 OS disk.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    • Marked as answer by Bruce Wooding Thursday, May 14, 2015 7:30 PM
    Thursday, May 7, 2015 8:44 PM

All replies

  • Set the "Automatic Stop Action" setting of the VM to anything except "Save".

    Setting the stop action to Save causes Hyper-V to reserve a page out file equivalent to the RAM of the VM.  thus consuming this much disk space.

    Everything beyond that is disk IO of the VM affecting the host - assuming the VM virtual disk is on the Windows 8 OS disk.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    • Marked as answer by Bruce Wooding Thursday, May 14, 2015 7:30 PM
    Thursday, May 7, 2015 8:44 PM
  • problem solved partially, it is not showing 100% use every time, but at the startup time of main PC both main and Hyper-v pc makes computer called "Dead"
    Tuesday, September 5, 2017 5:56 AM