locked
IISRESET fails with an error message "Restart attempt failed..." RRS feed

  • Question

  • Hi,

    I’m having problem restarting IIS through the command prompt – it fails every time with the following error message:

    "Restart attempt failed.
    The IIS Admin Service or the World Wide Web Publishing Service, or a service dep
    endent on them failed to start.  The service, or dependent services, may had an
    error during its startup or may be disabled."

    Once this happens - I would see (from the Services page) both IIS Admin and World Wide Publishing Service are stopped. I can start these services manually no problem.  Also I can restart IIS admin / W3 Service from the UI.   

    This is a Windows Server 2008 R2 and I've MOSS 2007 SP2 installed. The account I’m using for the IISRESET is a local admin and I also tried with different accounts – results are the same.

    Any suggestions would be appreciated.

    Many thanks in advanced!


    BlueSky2010

    • Edited by BlueSky2010 Wednesday, March 2, 2011 7:29 PM Rephrased the posting emphasizing this is an IISRESET issue
    Tuesday, March 1, 2011 7:56 PM

Answers

All replies

  • Hi,

    Could you please check Event viewer for more error

    Please refer

    http://answers.microsoft.com/en-us/windows/forum/windows_7-system/cant-restart-iis/00f2e484-5187-46af-89f5-97b2741d97a6

    http://forums.iis.net/p/1134427/1849117.aspx

    Please let us know if this will be helpful


    Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Wednesday, March 2, 2011 3:25 PM
  • Hi Pratik,

    Thank you for your response - it does not log anything in the Windows Events log unfortunately (when IISRESET fails).

    I've also checked the links you forwarded but they are not related to my situation.

    I appreicate any help!

     


    BlueSky2010
    Wednesday, March 2, 2011 7:31 PM
  • Did you recently make any edits to your registry on the server?
    Wednesday, March 2, 2011 8:01 PM
  • I had the same issue on server 2k8 R2. The problem is windows process activation service does not start.

    http://support.microsoft.com/kb/975443

    Install this hotfix and it should fix it for u.

    • Marked as answer by BlueSky2010 Wednesday, March 2, 2011 10:19 PM
    Wednesday, March 2, 2011 9:18 PM
  • Hi,

     

    According to your description, World Wide Web Publishing Services is set to start automatically, but that led to all of your IIS Web Sites being stopped. In my opinion, World Wide Web Publishing Services(W3SVC) or IIS Administrative Service causes all the site down. Please check SharePoint Server Event Viewer Log. I guess it is Error 1053: the service did not respond to the start or control request in a timely.

    After you reset IIS and receive the error, I suggest that you should find which Services fails to start.

    Finally, check out the service account you used. Are you system administrators? Local system? A domain user with administrator right?

    For more information, you can check the following link:

    http://social.msdn.microsoft.com/Forums/en/sqlkjpowerpointforsharepoint/thread/c0e8c18b-063e-4974-98fe-d75bb91835e5

     

     
    Best regards
    David Hu

     

    Thursday, March 3, 2011 1:09 AM
  • I had the same issue. In windows 7 PC iis not started.

    I gone to windows services. Started Remote Procedure call . Then started IIS Admin Service .. Everything worked fine now.

    Thanks

    Tuesday, February 7, 2012 7:08 AM