none
2146827284Microsoft Excel cannot open or save any more documents because there is not enough available memory or disk space RRS feed

  • Question

  • Hi Experts,

    I am getting below error when Exporting data from my one web application to the Excel 2010 on Windows Server 2008 R2 ,

    02/29/2012 18:54:50
    Type : System.Exception, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b11a5c481859e569
    Message : -2146827284Microsoft Excel cannot open or save any more documents because there is not enough available memory or disk space.

    • To make more memory available, close workbooks or programs you no longer need.

    • To free disk space, delete files you no longer need from the disk you are saving to.

    The disk space is 30 GB free, I have cleared all the temp files, increased the virtual memory & internet temp files size to max but no luck

    Wednesday, May 2, 2012 8:57 AM

Answers

  • I have resolved this.

    step1 :  Go to run type dcomcnfg
    Step2:   Click >Component services >Computes >My Computer>Dcom config> and select micro soft Excel Application>
    Step3:   Right Click on Microsoft Excel Application>Properties>Give Asp.net Permissions
    Step 4: Select Identity table >Select interactive user >select ok

    • Marked as answer by VLCC Thursday, May 3, 2012 4:01 AM
    Thursday, May 3, 2012 4:01 AM
  • If you're running 64-bit Windows you have to run Component Services in 32-bit mode before you can see Microsoft Excel Application to modify its properties.  

    You can run Component Services in 32-bit mode two ways: 

    1.  dcomcnfg -32 

    2.  MMC comexp.msc /32


    Thursday, June 14, 2012 4:44 PM

All replies

  • I have resolved this.

    step1 :  Go to run type dcomcnfg
    Step2:   Click >Component services >Computes >My Computer>Dcom config> and select micro soft Excel Application>
    Step3:   Right Click on Microsoft Excel Application>Properties>Give Asp.net Permissions
    Step 4: Select Identity table >Select interactive user >select ok

    • Marked as answer by VLCC Thursday, May 3, 2012 4:01 AM
    Thursday, May 3, 2012 4:01 AM
  • If you're running 64-bit Windows you have to run Component Services in 32-bit mode before you can see Microsoft Excel Application to modify its properties.  

    You can run Component Services in 32-bit mode two ways: 

    1.  dcomcnfg -32 

    2.  MMC comexp.msc /32


    Thursday, June 14, 2012 4:44 PM
  • Hi,

    Thank you for your sharing, it will help someone who meets the same issue.


    Jaynet Zhang

    TechNet Community Support

    Friday, June 15, 2012 1:05 AM
    Moderator
  • sometimes, you create new application pool and cann't solve it via DCOMCNFG.

    then there is another method to do:

    set the identity (Model Name) of application pool to "LocalSystem"

    I don't know the root cause, but it could solve some problems.

    Sunday, July 15, 2012 3:58 PM
  • Disregard my comment below, the problem reoccured.  

    This is the most awesome thread I have seen all month!  Thanks to you guys for this helpful, concise information.  Just to mention, I did not see an option "Give Asp.net Permissions."  However I went to the Security tab and customized the permissions to allow Full Control to everyone.  (This is a single-person computer).

    • Edited by laurelii Tuesday, August 21, 2012 7:38 PM
    Friday, August 17, 2012 4:52 PM
  • I ran dcomcnfg -32 still cannot  see "micro soft Excel Application" in the decom CNFG.  My computer is Win7 64bits.  Can you shed the light?
    Saturday, August 25, 2012 7:15 PM
  • Windows 8: Excel 2013: right click, unlock file.
    • Proposed as answer by AymanMaher Wednesday, April 15, 2015 10:53 AM
    Thursday, January 17, 2013 2:14 AM
  • You want to use this one here - MMC comexp.msc /32

    THAT will launch the MMC process as 32 bit then you'll the Microsoft Excel Application.

    Right Click -> Properties.
    What I did at this point was to select the Identity tab and then select "The Interactive User" (the default was "The launching user").  My app pool was already running as "LocalSystem".  I believe by running it as the Interactive User now that it has the right permissions to save workbooks.

    Everything worked after this.

    This was a tough one!


    R. Matt Sampson

    Thursday, May 30, 2013 2:53 PM
  • *unblock* file... but yes and thanks!!
    Wednesday, September 4, 2013 5:47 PM
  • thanks you .. its working well
    Thursday, December 19, 2013 5:08 AM
  • i have done step 1/2 & 4 but stuck in step no 3...where i will get this Asp.net permission option ? 
    Friday, February 28, 2014 8:40 AM
  • Thanks. I had tried it out and it solved my issue.

    Angie

    Tuesday, June 3, 2014 2:49 AM
  • Thanks. This is the best and simplest solution for working as well as.

    Thanks

    Friday, October 31, 2014 4:25 AM
  • Unblocking the file by right clicking on it worked for me.  I had, as it said, downloaded the file from another computer.  Thanks panikfan!
    Tuesday, November 18, 2014 9:35 PM
  • Problem with this:

    Have Component Services open and goto Microsoft Excel Application and right-click and Goto properties sheet.

    I do not see an item labeled "Give Asp.net Permissions"?  Where is this?

    Thursday, April 9, 2015 10:23 PM
  • THANK YOU
    Wednesday, April 15, 2015 10:53 AM