none
Windows 7 - User needs to login again in sharepoint RRS feed

  • Question

  • Hi there,

    i hope this is the correct forum for this question. I need help with this issue:

    Every Morning, a user [Windows 7/Office 2007/IE 8] needs to authenticate again when he opens sharepoint for the first time.

    In the IE-Settings i tried to put the the sharepoint site to the trusted sites and set the authentication to automatic authentication with current user and password.
    That did not help. I also tried to put the sharepoint site to intranetzone  aswell but that did not help either (automatic authentication enabled).

    When i set these settings for a Win XP-User, it works like a charm - no extra authentication for the sharepoint will pop up. So i think its something with windows 7.
    I've heard about some registry values to be set. But to hack something into the registry of a customer pc seems to me like the last exit.

    Are there any other (better) solutions/settings which i can try ?

    Friday, October 22, 2010 10:17 AM

Answers

  • Is the Windows 7 PC a member of the same domain or forest as the SharePoint server?  If not, then that is the problem and there is no workaround.  If it is in the same domain then putting the server address in Trusted Sites and modifying the security of that zone should take care of it as long as the user is logging into Windows 7 with the same domain credentials they use on SharePoint.  Those settings simply pass the domain, userId, and password from the OS to SharePoint when challenged.  All three must be the same as SharePoint credentials or it won't work.  So if the PC isn't a member of the domain then the domain being passed won't match the credentials of the user.
    Paul Stork SharePoint Server MVP
    Friday, October 22, 2010 11:03 AM