none
SOLVED: "Your automatic reply settings cannot be displayed because the server is currently unavailable. Try again later" RRS feed

  • Question

  • This solution works for Exchange 2010 and Exchange 2007, but probably also works for Exchange 2013 and 2016. One caveat: This was done with an Exchange server that had a valid authoritative certificate from a commercial provider. I am not sure how a self-signed or expired certificate may affect this process. 

    The problem is that your user opens Outlook, and goes to the file tab, and clicks on the "Automatic Replies (Out of Office)" button, and he gets this error: "Your automatic reply settings cannot be displayed because the server is currently unavailable. Try again later."

    You probably have this error for every user you try, and if not, you probably have a different permissions issue related to a specific user or group, but the information below will still point you in the right direction (see comments in the last step).

    1. First, we need some information: On one of the Outlook clients in question, go to the System Tray, and hold the CTRL button down while right clicking on the Outlook icon to get the "Test Email Autoconfiguration...." button. You may need to do this twice before it comes up if you don't click it quite right. Run the test with the user's email you are trying to fix. Once it returns the results, you are looking for the URL that is listed for "OOF" under both RPC and HTTP (If you are reading this for some Exchange 2013 installations and all Exchange 2016 installations, you may not see RPC as that has been phased out as of Exchange 2016). They should be the same, and read something like this: https://mail.yourdomain/ews/exchange.asmx
    2. Take that URL and paste it into a browser. If it comes back with "This page cannot be displayed", continue with the next step. It is comes back with "403 Forbidden - The website declined to show this webpage", proceed to the last step.
    3. If the page cannot be displayed, it is often because it is your external .com-type URL, and you are inside your .local-type network. Go to your DNS server, and add the mail. (or whatever sub-domain it was from your test) part of that URL to your internal DNS pointing to the internal IP address. Now, when you try to go to https://mail.yourdomain/ews/exchange.asmx, you may already be working and get an authentication pop-up box so go test your Outlook Out of Office again, or at worst, you now get the "403 Forbidden - The website declined to show this webpage" error, but you are making progress.
    4. This assumes IIS 7.0, but if not, you can figure out your equivalent: Lastly, go into IIS, and expand the site with the EWS directory, and click on the EWS directory. Double-click on the Authentications icon, and make sure that ONLY "Windows Authentication" is enabled. Now try your https://mail.yourdomain/ews/exchange.asmx URL once more, and it should pop up an authentication box. If it does, you can now try your Outlook client again, and it should work provided you do not also have directory security issues too. This probably won't be the case, but if your Out-of-Office still does not work for some reason, make sure the user has permissions to the actual directory on the server.
    Saturday, October 29, 2016 11:32 AM

Answers

  • Incidentally, I have read a lot of the "solutions" regarding this problem, and one reason I posted is that this method is very methodical and not intrusive, so you can roll it back easily should you ultimately have a different problem. I also wanted to say that a lot of the other "solutions" have you changing a lot of permissions in IIS, so before you do that, I got my permissions from this Microsoft document:

    https://technet.microsoft.com/en-us/library/gg263433(v=exchg.80).aspx

    • Proposed as answer by David Wang_ Monday, October 31, 2016 2:21 AM
    • Marked as answer by David Wang_ Thursday, November 3, 2016 8:26 AM
    Saturday, October 29, 2016 11:44 AM

All replies

  • Incidentally, I have read a lot of the "solutions" regarding this problem, and one reason I posted is that this method is very methodical and not intrusive, so you can roll it back easily should you ultimately have a different problem. I also wanted to say that a lot of the other "solutions" have you changing a lot of permissions in IIS, so before you do that, I got my permissions from this Microsoft document:

    https://technet.microsoft.com/en-us/library/gg263433(v=exchg.80).aspx

    • Proposed as answer by David Wang_ Monday, October 31, 2016 2:21 AM
    • Marked as answer by David Wang_ Thursday, November 3, 2016 8:26 AM
    Saturday, October 29, 2016 11:44 AM
  • Hi,

    Thank you for generous sharing.

    Hope the post is helpful to persons who have the OOF issue.

    Regards,


    David Wang
    TechNet Community Support


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 31, 2016 2:21 AM
  • THANK YOU!!!! :)
    Saturday, June 23, 2018 9:19 PM
  • I am seeing "Your automatic reply settings cannot be displayed because the server is currently unavailable. Try again later" at our organization but the ews page is not showing any errors. Can anyone confirm if the page below is what should be seen for the /ews/exchange.asmx location?


    • Edited by dogness Thursday, June 28, 2018 1:13 PM Added picture for more information.
    Thursday, June 28, 2018 1:06 PM
  • I am having the same issue.  A user first reported it last week.  I tested with a user that reported it today and he is able to access https://mail.server.com/ews/exchange.asmx and he is prompted to sign in and when he does he gets xml....so permissions do not seem to be the issue.  What did you have to do to get yours working?
    Tuesday, August 27, 2019 4:05 PM
  • I have this same exact issue.  User can access xml after logging into with creds. 

    Did you ever find a solution?

     
    Wednesday, October 23, 2019 3:20 PM